nvidia-graphics-drivers-430 430.26-0ubuntu0.18.04.2 source package in Ubuntu

Changelog

nvidia-graphics-drivers-430 (430.26-0ubuntu0.18.04.2) bionic; urgency=medium

  [ Alberto Milone ]
  * debian/rules.defs:
    - Add alternate dependency on xserver-xorg-core-hwe-18.04.
      This fixes a compatibility issue with the hwe stack (LP: #1834603).

  [ Kai-Heng Feng ]
  * debian/71-nvidia.rules:
    - Make sure each rule is comma seperated.
    - Use DEVPATH=="/bus/pci/drivers/nvidia", which is added after nvidia
      driver probes and binds to the device, to prevent any race condition.
      (LP: #1834603).
    - Use TAG+="systemd" and ENV{SYSTEMD_WANTS} to let systemd manage the
      service.
  * debian/templates/nvidia-compute-utils-flavour.nvidia-persistenced.service.in:
    - Now systemd knows the persistenced service depends on
      sys-bus-pci-drivers-nvidia.device, we can use StopWhenUnneeded=true to
      let systemd stop the service once sys-bus-pci-drivers-nvidia.device
      disappears.

nvidia-graphics-drivers-430 (430.26-0ubuntu0.18.04.1) bionic; urgency=medium

  * Initial release (LP: #1834603):
    - Added support for the following GPUs:
        Quadro P520
        Quadro RTX 3000
        Quadro T1000
        Quadro T2000
    - Fixed a bug, introduced in 415.13, that caused audio over
      DisplayPort to not work in some configurations.
  * debian/templates/control.in:
    - Specify multiarch for transitional packages.
    - Add transitional packages for 418.
    - Add dependency on libnvidia-cfg1-#FLAVOUR# to nvidia-headless-no-dkms-#FLAVOUR#
      nvidia-persistenced depends on it.
  * debian/71-nvidia.rules:
    - Remove nvidia-smi from run list.
      nvidia-smi was previously used for creating device nodes when nvidia
      kernel module is being loaded. This is no longer mandatory as the device
      nodes (nvidia0 & nvidiactl) will be created by any other process linking
      to libnvidia-ml.so, e.g. nvidia-settings, when necessary.

 -- Alberto Milone <email address hidden>  Tue, 09 Jul 2019 16:11:02 +0200

Upload details

Uploaded by:
Alberto Milone on 2019-07-09
Uploaded to:
Bionic
Original maintainer:
Ubuntu Developers
Architectures:
amd64 i386 all
Section:
libs
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section
Bionic proposed on 2019-07-09 multiverse libs

Builds

Bionic: [FULLYBUILT] amd64 [FULLYBUILT] i386

Downloads

File Size SHA-256 Checksum
nvidia-graphics-drivers-430_430.26.orig-amd64.tar.gz 105.5 MiB 14317497652db070f8ef6c43c15616725273fa8f4622882c2736b4439a4a9695
nvidia-graphics-drivers-430_430.26.orig.tar.gz 135 bytes 4ecf67a5a98fb9c2ec2bd397d74bff902fdfe24191c86debe0dc12b29862a4ed
nvidia-graphics-drivers-430_430.26-0ubuntu0.18.04.2.debian.tar.xz 35.0 KiB 7c54d525d6d30dfb8f941720d0b68af1c9ee85daa239d49df1b166a1277eed2d
nvidia-graphics-drivers-430_430.26-0ubuntu0.18.04.2.dsc 5.3 KiB f82a1fdfb6b8e2ff2bee70cc6f7231211de30e7859634afd7d9971b82984f1d5

View changes file

Binary packages built by this source

libnvidia-cfg1-418: Transitional package for libnvidia-cfg1-430

 This is a transitional package for libnvidia-cfg1-430, and can be
 safely removed after the installation is complete.

libnvidia-cfg1-430: NVIDIA binary OpenGL/GLX configuration library

 The NVIDIA binary driver provides optimized hardware acceleration of
 OpenGL/GLX/EGL/GLES applications via a direct-rendering X Server
 for graphics cards using NVIDIA chip sets.
 .
 This package contains the libnvidia-cfg.so.1 runtime library.

libnvidia-common-418: Transitional package for libnvidia-common-430

 This is a transitional package for libnvidia-common-430, and can be
 safely removed after the installation is complete.

libnvidia-common-430: Shared files used by the NVIDIA libraries

 This package provides a set of files that are required by the NVIDIA
 libraries.

libnvidia-compute-418: Transitional package for libnvidia-compute-430

 This is a transitional package for libnvidia-compute-430, and can be
 safely removed after the installation is complete.

libnvidia-compute-430: NVIDIA libcompute package

 This package provides a set of libraries which enable the NVIDIA driver
 to use GPUs for parallel general purpose computation through CUDA and
 OpenCL.

libnvidia-decode-418: Transitional package for libnvidia-decode-430

 This is a transitional package for libnvidia-decode-430, and can be
 safely removed after the installation is complete.

libnvidia-decode-430: NVIDIA Video Decoding runtime libraries

 This package includes the NVIDIA CUDA Video Decoder (NVCUVID) library which
 provides an interface to hardware video decoding capabilities on NVIDIA GPUs with CUDA.
 .
 The package also provides a VDPAU (Video Decode and Presentation API for Unix-like
 systems) library for the NVIDIA vendor implementation.

libnvidia-encode-418: Transitional package for libnvidia-encode-430

 This is a transitional package for libnvidia-encode-430, and can be
 safely removed after the installation is complete.

libnvidia-encode-430: NVENC Video Encoding runtime library

 The NVENC Video Encoding library provides an interface to video encoder
 hardware on supported NVIDIA GPUs.
 .
 This package contains the nvidia-encode runtime library.

libnvidia-fbc1-418: Transitional package for libnvidia-fbc1-430

 This is a transitional package for libnvidia-fbc1-430, and can be
 safely removed after the installation is complete.

libnvidia-fbc1-430: NVIDIA OpenGL-based Framebuffer Capture runtime library

 The NVIDIA OpenGL-based Framebuffer Capture (NvFBCOpenGL) library provides
 a high performance, low latency interface to capture and optionally encode an
 OpenGL framebuffer. NvFBCOpenGL is a private API that is only available to
 approved partners for use in remote graphics scenarios.
 .
 This package contains the NvFBCOpenGL runtime library.

libnvidia-gl-418: Transitional package for libnvidia-gl-430

 This is a transitional package for libnvidia-gl-430, and can be
 safely removed after the installation is complete.

libnvidia-gl-430: NVIDIA OpenGL/GLX/EGL/GLES GLVND libraries and Vulkan ICD

 This package provides the NVIDIA OpenGL/GLX/EGL/GLES libraries and the
 Vulkan ICD.

libnvidia-ifr1-418: Transitional package for libnvidia-ifr1-430

 This is a transitional package for libnvidia-ifr1-430, and can be
 safely removed after the installation is complete.

libnvidia-ifr1-430: NVIDIA OpenGL-based Inband Frame Readback runtime library

 The NVIDIA OpenGL-based Inband Frame Readback (NvIFROpenGL) library provides
 a high performance, low latency interface to capture and optionally encode an
 OpenGL framebuffer. NvIFROpenGL is a private API that is only available to
 approved partners for use in remote graphics scenarios.
 .
 This package contains the NvIFROpenGL runtime library.

nvidia-compute-utils-418: Transitional package for nvidia-compute-utils-430

 This is a transitional package for nvidia-compute-utils-430, and can be
 safely removed after the installation is complete.

nvidia-compute-utils-430: NVIDIA compute utilities

 This package provides utility binaries for paraller general purpose
 computing use cases with the NVIDIA driver.
 .
 CUDA MPS is a feature that allows multiple CUDA processes to share a single
 GPU context. CUDA MPS should be transparent to CUDA programs.
 .
 CUDA MPS requires a device that supports Unified Virtual Address (UVA) and
 has compute capability SM 3.5 or higher.
 Pre-CUDA 4.0 APIs are not supported under CUDA MPS.

nvidia-dkms-418: Transitional package for nvidia-dkms-430

 This is a transitional package for nvidia-dkms-430, and can be
 safely removed after the installation is complete.

nvidia-dkms-430: NVIDIA DKMS package

 This package builds the NVIDIA kernel module needed by the userspace
 driver, using DKMS.
 Provided that you have the kernel header packages installed, the kernel
 module will be built for your running kernel, and automatically rebuilt for
 any new kernel headers that are installed.

nvidia-driver-418: Transitional package for nvidia-driver-430

 This is a transitional package for nvidia-driver-430, and can be
 safely removed after the installation is complete.

nvidia-driver-430: NVIDIA driver metapackage

 This metapackage depends on the NVIDIA binary driver and on all of its libraries,
 to provide hardware acceleration for OpenGL/GLX/EGL/GLES/Vulkan
 applications on either X11 or on Wayland.
 .
 See /usr/share/doc/nvidia-driver-430/README.txt.gz
 for a complete list of supported GPUs and PCI IDs.

nvidia-headless-418: Transitional package for nvidia-headless-430

 This is a transitional package for nvidia-headless-430, and can be
 safely removed after the installation is complete.

nvidia-headless-430: NVIDIA headless metapackage

 This metapackage installs the NVIDIA driver and the libraries that enable
 parallel general purpose computation through CUDA and
 OpenCL.
 .
 Install this package if you do not need X11 or Wayland support, which is
 provided by the nvidia-driver-430 metapackage.

nvidia-headless-no-dkms-418: Transitional package for nvidia-headless-no-dkms-430

 This is a transitional package for nvidia-headless-no-dkms-430, and can be
 safely removed after the installation is complete.

nvidia-headless-no-dkms-430: NVIDIA headless metapackage - no DKMS

 This metapackage installs the NVIDIA driver and the libraries that enable
 parallel general purpose computation through CUDA and
 OpenCL. DKMS will not be installed, and, therefore, the kernel module
 will not be built.
 .
 Install this package if you do not need X11 or Wayland support, which is
 provided by the nvidia-driver-430 metapackage.

nvidia-kernel-common-418: Transitional package for nvidia-kernel-common-430

 This is a transitional package for nvidia-kernel-common-430, and can be
 safely removed after the installation is complete.

nvidia-kernel-common-430: Shared files used with the kernel module

 This package installs all the optional accessory files for the NVIDIA
 kernel module.
 .
 Install this package if you want to blacklist any conflicting kernel
 modules, and if you want udev to load the the NVIDIA kernel modules,
 and to create the uvm devices automatically.

nvidia-kernel-source-418: Transitional package for nvidia-kernel-source-430

 This is a transitional package for nvidia-kernel-source-430, and can be
 safely removed after the installation is complete.

nvidia-kernel-source-430: NVIDIA kernel source package

 This package provides the NVIDIA kernel source needed by the userspace
 driver.

nvidia-utils-418: Transitional package for nvidia-utils-430

 This is a transitional package for nvidia-utils-430, and can be
 safely removed after the installation is complete.

nvidia-utils-430: NVIDIA driver support binaries

 This package contains supporting binaries for the NVIDIA driver.

xserver-xorg-video-nvidia-418: Transitional package for xserver-xorg-video-nvidia-430

 This is a transitional package for xserver-xorg-video-nvidia-430, and can be
 safely removed after the installation is complete.

xserver-xorg-video-nvidia-430: NVIDIA binary Xorg driver

 The NVIDIA binary driver provides optimized hardware acceleration of
 OpenGL/GLX/EGL/GLES applications via a direct-rendering X Server
 for graphics cards using NVIDIA chip sets.
 .
 See /usr/share/doc/nvidia-driver-430/README.txt.gz
 for a complete list of supported GPUs and PCI IDs.