Change log for ocaml-tools package in Ubuntu

121 of 21 results
Published in hirsute-release on 2020-11-19
Deleted in hirsute-proposed (Reason: moved to Release)
ocaml-tools (20120103-7build1) hirsute; urgency=medium

  * No-change rebuild for ocaml abi changes.

 -- Matthias Klose <email address hidden>  Mon, 02 Nov 2020 13:56:41 +0100
Superseded in hirsute-release on 2020-11-19
Deleted in hirsute-proposed on 2020-11-21 (Reason: moved to Release)
ocaml-tools (20120103-7) unstable; urgency=medium

  [ Stéphane Glondu ]
  * Team upload
  * Recompile with OCaml 4.11.1
  * Bump debhelper compat level to 13
  * Bump Standards-Version to 4.5.0
  * Add Rules-Requires-Root: no

  [ Debian Janitor ]
  * Trim trailing whitespace.
  * debian/rules: Use dh_prep rather than "dh_clean -k".
  * Set debhelper-compat version in Build-Depends.

 -- Stéphane Glondu <email address hidden>  Tue, 13 Oct 2020 09:19:09 +0200
Superseded in hirsute-release on 2020-10-29
Published in groovy-release on 2020-04-24
Published in focal-release on 2020-02-28
Deleted in focal-proposed (Reason: moved to Release)
ocaml-tools (20120103-6build1) focal; urgency=medium

  * No change rebuild against new ocaml ABI

 -- Dimitri John Ledkov <email address hidden>  Thu, 20 Feb 2020 22:44:24 +0000
Superseded in focal-release on 2020-02-28
Deleted in focal-proposed on 2020-02-29 (Reason: moved to Release)
ocaml-tools (20120103-6) unstable; urgency=medium

  * Team upload
  * Recompile with OCaml 4.08.1
  * Update Vcs-*
  * Remove Samuel from Uploaders

 -- Stéphane Glondu <email address hidden>  Tue, 05 Nov 2019 09:37:36 +0100

Available diffs

Superseded in bionic-proposed on 2017-10-27
ocaml-tools (20120103-4build3) bionic; urgency=high

  * No change rebuild against ocaml 4.05.

 -- Dimitri John Ledkov <email address hidden>  Thu, 26 Oct 2017 23:54:44 +0100
Superseded in focal-release on 2019-11-05
Published in eoan-release on 2019-04-18
Obsolete in disco-release on 2020-07-14
Obsolete in cosmic-release on 2020-07-13
Published in bionic-release on 2017-11-05
Deleted in bionic-proposed (Reason: moved to release)
ocaml-tools (20120103-5) unstable; urgency=medium

  * DH compat level 10
  * Drop obsolete version constraint on build-dependency dh-ocaml
  * Standards-version 4.1.0:
    - d/copyright: use https in copyright-format URL

 -- Ralf Treinen <email address hidden>  Wed, 20 Sep 2017 08:41:40 +0200
Superseded in bionic-release on 2017-11-05
Obsolete in artful-release on 2020-07-10
Deleted in artful-proposed on 2020-07-10 (Reason: moved to release)
ocaml-tools (20120103-4build2) artful; urgency=high

  * No change rebuild against ocaml 4.04 transition.

 -- Dimitri John Ledkov <email address hidden>  Mon, 26 Jun 2017 22:49:19 +0100
Superseded in artful-release on 2017-07-18
Obsolete in zesty-release on 2018-06-22
Obsolete in yakkety-release on 2018-01-23
Published in xenial-release on 2015-11-13
Deleted in xenial-proposed (Reason: moved to release)
ocaml-tools (20120103-4build1) xenial; urgency=medium

  * No-change rebuild against ocaml 4.02.

 -- Łukasz 'sil2100' Zemczak <email address hidden>  Mon, 02 Nov 2015 15:10:01 -0500
Superseded in xenial-release on 2015-11-13
Deleted in xenial-proposed on 2015-11-14 (Reason: moved to release)
ocaml-tools (20120103-4) unstable; urgency=medium

  * Team upload
  * Recompile with OCaml 4.02.3

 -- Stéphane Glondu <email address hidden>  Sat, 10 Oct 2015 07:43:49 +0200
Superseded in xenial-release on 2015-10-24
Obsolete in wily-release on 2018-01-22
Obsolete in vivid-release on 2018-01-18
Obsolete in utopic-release on 2016-11-03
Published in trusty-release on 2013-12-24
Deleted in trusty-proposed (Reason: moved to release)
ocaml-tools (20120103-3build1) trusty; urgency=medium

  * Rebuild for ocaml-4.01.
 -- Matthias Klose <email address hidden>   Mon, 23 Dec 2013 12:11:35 +0000
Superseded in trusty-release on 2013-12-24
Deleted in trusty-proposed on 2013-12-25 (Reason: moved to release)
ocaml-tools (20120103-3) unstable; urgency=low


  [ Stéphane Glondu ]
  * Team upload
  * Recompile with OCaml 4.01.0

  [ Ralf Treinen ]
  * debian/copyright: migrate to machine-readable format 1.0

 -- Stéphane Glondu <email address hidden>  Fri, 06 Dec 2013 08:45:23 +0100

Available diffs

Superseded in trusty-release on 2013-12-06
Obsolete in saucy-release on 2015-04-24
Obsolete in raring-release on 2015-04-24
Obsolete in quantal-release on 2015-04-24
ocaml-tools (20120103-2) unstable; urgency=low


  * Fix debian/rules targets to call install before binary-indep
    (Closes: #656330)

 -- Mehdi Dogguy <email address hidden>  Wed, 18 Jan 2012 15:28:07 +0100
Superseded in quantal-release on 2012-04-30
Published in precise-release on 2011-10-13
Obsolete in oneiric-release on 2015-04-24
Obsolete in natty-release on 2013-06-04
Obsolete in maverick-release on 2013-03-05
Obsolete in lucid-release on 2016-10-26
ocaml-tools (20090719-1) unstable; urgency=low

  [ Stefano Zacchiroli ]
  * add ocaml-autoconf: autoconf macros for OCaml
    - upstream git snapshot, commit: d0ad968
  * fix vcs-svn field to point just above the debian/ dir
  * debian/control:
    - bump Standards-Version to 3.8.2 (no changes needed)
    - clean up inactive maintainers from Uploaders
    - revamp short and long descriptions
  * debian/copyright:
    - add copyright info for ocaml-autoconf
    - fix path pointing to GPL-2 (omlet's license)
    - change encoding to UTF-8
  * debian/compat: bump to 5 (minimum, non deprecated level)
  * debian/rules:
    - delegate file installation do appropriate dh_*
    - use dh_lintian to install lintian overrides

  [ Ralf Treinen ]
  * changed section to ocaml
 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  06 Nov 2009 08:56:48 +0000

Available diffs

Superseded in lucid-release on 2009-11-06
Obsolete in karmic-release on 2013-03-04
Obsolete in jaunty-release on 2013-02-28
Obsolete in intrepid-release on 2013-02-20
Obsolete in hardy-release on 2015-04-24
ocaml-tools (2007.06.24-2) unstable; urgency=low

  * Comply to the new vim policy for omlet: recommend vim-addon-manager,
    updated README.Debian, removed the debconf template, added a yaml file,
    closes: #432519.

Superseded in hardy-release on 2007-10-23
Obsolete in gutsy-release on 2011-09-16
ocaml-tools (2007.02.04-2) unstable; urgency=low

  * Added German debconf translation (thanks Stefan Bauer), closes: #410547.
  * Added Japanese debconf translation (thanks Kobayashi Noritada),
    closes: #413005.
  * Added Dutch debconf translation (thanks Bart Cornelis), closes: #418394.

Superseded in gutsy-release on 2007-04-27
Obsolete in feisty-release on 2009-08-20
Obsolete in edgy-release on 2008-06-19
ocaml-tools (2006.05.15-1) unstable; urgency=low

  * New upstream release of ocaml-make: 6.21.2.
  * Rebuild with OCaml 3.09.2.
  * Updated standards version to 3.7.2, no changes needed.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Thu,  15 Jun 2006 15:12:06 +0100
Superseded in edgy-release on 2006-06-15
Obsolete in dapper-release on 2011-09-06
Superseded in dapper-release on 2006-02-03
ocaml-tools (2005.29.04-5) unstable; urgency=low


  * Rebuild with OCaml 3.09.1.
  * Packaging is now automagically handling OCaml's ABI changes.

 -- Samuel Mimram <email address hidden>  Sun,  8 Jan 2006 18:27:00 +0100
Superseded in dapper-release on 2006-01-31
ocaml-tools (2005.29.04-4) unstable; urgency=low


  * Added Swedish debconf translation (thanks Daniel Nylander),
    closes: #331484. 
  * Bumped (build-)dependency on ocaml-* to 3.09.0.
  * Lintian override for upstream changelog: drop filename.

 -- Ralf Treinen <email address hidden>  Mon,  7 Nov 2005 22:44:26 +0100
Obsolete in breezy-release on 2008-03-25
ocaml-tools (2005.29.04-2) unstable; urgency=low


  * Added a french translation of the debconf messages (thanks Steve),
    closes: #309743.

 -- Samuel Mimram <email address hidden>  Thu, 19 May 2005 18:45:13 +0200
Obsolete in hoary-release on 2008-03-19
ocaml-tools (2004.08.22-1) unstable; urgency=low


  * New upstream version 6.18.0 of OcamlMakefile. This upstream release
    fixes a bug concerning the use of the CPPFLAGS variable. Thanks to
    Julien Cristau for the patch! (closes: #264413)
  * Install gtk example.
  * Removed useless patch 02_ocamlmake-incpath

 -- Ralf Treinen <email address hidden>  Sun, 22 Aug 2004 17:07:20 +0200
Obsolete in warty-release on 2008-01-09
ocaml-tools (2004.04.27-1) unstable; urgency=low


  * New upstream version 6.7.0 of OcamlMakefile. This upstream version
    - uses -fPIC -DPIC for compilation of C programs for inclusion in
      shared libraries (closes: #245171).
    - fixes a bug with "-passopt" which occured with the pabc target
      (closes: #242968).

 -- Ralf Treinen <email address hidden>  Tue, 27 Apr 2004 20:02:43 +0200
121 of 21 results