Change log for ocaml package in Ubuntu

155 of 55 results
Published in eoan-release on 2019-04-18
Published in disco-release on 2018-10-30
Published in cosmic-release on 2018-05-04
Deleted in cosmic-proposed (Reason: moved to release)
ocaml (4.05.0-10ubuntu2) cosmic; urgency=medium

  * No-change rebuild for ncurses soname changes.

 -- Matthias Klose <email address hidden>  Thu, 03 May 2018 14:17:33 +0000
Superseded in cosmic-release on 2018-05-04
Published in bionic-release on 2017-11-05
Deleted in bionic-proposed (Reason: moved to release)
ocaml (4.05.0-10ubuntu1) bionic; urgency=medium

  * Merge with Debian unstable:
    - Pass --hash-style=both --as-needed --build-id to the linker.
    - Keep -fPIC patch.

Available diffs

Superseded in bionic-release on 2017-11-05
Published in artful-release on 2017-10-10
Deleted in artful-proposed (Reason: moved to release)
ocaml (4.04.0-2ubuntu4) artful; urgency=medium

  * SECURITY UPDATE: Privilege escalation
    - debian/patches/CVE-2017-9772.patch: Fix using secure_getenv in
    setuid binaries
    - CVE-2017-9772

 -- Dimitri John Ledkov <email address hidden>  Mon, 09 Oct 2017 10:06:24 +0100
Superseded in artful-release on 2017-10-10
Deleted in artful-proposed on 2017-10-11 (Reason: moved to release)
ocaml (4.04.0-2ubuntu3) artful; urgency=medium

  * Mark certain symbols as .hidden in arm64 codegen, fixing FTBFS with
    binutils 2.29. (Closes: #868860). LP: #1704399.

 -- Matthias Klose <email address hidden>  Mon, 31 Jul 2017 12:41:45 +0200
Superseded in artful-release on 2017-07-31
Deleted in artful-proposed on 2017-08-01 (Reason: moved to release)
ocaml (4.04.0-2ubuntu2) artful; urgency=medium

  * Cherrypick upstream fix for a regression in 4.04 on s390x.

 -- Dimitri John Ledkov <email address hidden>  Fri, 14 Jul 2017 16:10:15 +0100
Superseded in artful-proposed on 2017-07-14
ocaml (4.04.0-2ubuntu1) artful; urgency=medium

  * Merge with Debian experimental:
    - Pass --hash-style=both --as-needed --build-id to the linker.
    - Keep -fPIC patch.

Superseded in artful-release on 2017-07-18
Deleted in artful-proposed on 2017-08-11 (Reason: moved to release)
ocaml (4.02.3-9ubuntu3) artful; urgency=medium

  * No-change rebuild to pick up -fPIE compiler default in static
    libraries

 -- Steve Langasek <email address hidden>  Fri, 02 Jun 2017 22:31:38 +0000

Available diffs

Superseded in artful-release on 2017-06-05
Deleted in artful-proposed on 2017-06-06 (Reason: moved to release)
ocaml (4.02.3-9ubuntu2) artful; urgency=medium

  * Re-enable pic patch.

 -- Gianfranco Costamagna <email address hidden>  Sun, 30 Apr 2017 00:22:58 +0200
Superseded in artful-proposed on 2017-04-29
ocaml (4.02.3-9ubuntu1) artful; urgency=low

  * Merge from Debian unstable.  Remaining changes:
    - Pass --hash-style=both --as-needed --build-id to the linker.
    - drop pic patch, enabled by default now

 -- Gianfranco Costamagna <email address hidden>  Fri, 28 Apr 2017 23:01:50 +0200
Published in trusty-updates on 2017-10-03
Published in trusty-security on 2017-10-03
ocaml (4.01.0-3ubuntu3.1) trusty-security; urgency=medium

  * SECURITY UPDATE: buffer overflow and information leak
    - debian/patches/CVE-2015-8869.patch: fix misuse of Int_val in
      byterun/alloc.c, byterun/str.c.
    - CVE-2015-8869

 -- Marc Deslauriers <email address hidden>  Thu, 05 May 2016 15:22:03 -0400
Superseded in artful-release on 2017-04-30
Obsolete in zesty-release on 2018-06-22
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed on 2018-06-22 (Reason: moved to release)
ocaml (4.02.3-6ubuntu2) yakkety; urgency=medium

  * Build with -fPIC on amd64.

 -- Matthias Klose <email address hidden>  Mon, 25 Apr 2016 16:26:32 +0200
Superseded in yakkety-proposed on 2016-04-25
ocaml (4.02.3-6ubuntu1) yakkety; urgency=medium

  * Merge with Debian; remaining changes:
    - Pass --hash-style=both --as-needed --build-id to the linker.

Superseded in yakkety-release on 2016-04-26
Published in xenial-release on 2016-04-08
Superseded in xenial-release on 2016-04-08
Deleted in xenial-proposed (Reason: moved to release)
ocaml (4.02.3-5ubuntu2) xenial; urgency=medium

  * No-change rebuild for ncurses6 transition.

 -- Matthias Klose <email address hidden>  Sun, 07 Feb 2016 09:44:25 +0000

Available diffs

Superseded in xenial-release on 2016-02-08
Deleted in xenial-proposed on 2016-02-09 (Reason: moved to release)
ocaml (4.02.3-5ubuntu1) xenial; urgency=low

  * Merge from Debian unstable.  Remaining changes:
    - Pass --hash-style=both --as-needed --build-id to the linker.

Superseded in xenial-release on 2015-11-13
Obsolete in wily-release on 2018-01-22
Obsolete in vivid-release on 2018-01-18
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed on 2018-01-22 (Reason: moved to release)
ocaml (4.01.0-4ubuntu1) utopic; urgency=medium

  * Merge with Debian; remaining changes:
    - Pass --hash-style=both --as-needed --build-id to the linker.

Superseded in utopic-release on 2014-08-15
Published in trusty-release on 2014-01-02
Deleted in trusty-proposed (Reason: moved to release)
ocaml (4.01.0-3ubuntu3) trusty; urgency=medium

  * Rebuild for Tcl/Tk 8.6.
 -- Matthias Klose <email address hidden>   Thu, 02 Jan 2014 20:05:45 +0100

Available diffs

Superseded in trusty-release on 2014-01-02
Deleted in trusty-proposed on 2014-01-04 (Reason: moved to release)
ocaml (4.01.0-3ubuntu2) trusty; urgency=medium

  * Disable the testsocket test, trying to reach the net.
 -- Matthias Klose <email address hidden>   Mon, 23 Dec 2013 00:07:52 +0100
Superseded in trusty-proposed on 2013-12-22
ocaml (4.01.0-3ubuntu1) trusty; urgency=low

  * Merge with Debian; remaining changes:
    - Pass --hash-style=both --as-needed --build-id to the linker.

Superseded in trusty-release on 2013-12-24
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed on 2015-04-28 (Reason: moved to release)
ocaml (3.12.1-4ubuntu1) saucy; urgency=low

  * Merge from Debian unstable.  Remaining changes:
    - Pass --hash-style=both --as-needed --build-id to the linker.
    - Add armhf to the ocaml-native-compilers architectures list.
 -- Adam Conrad <email address hidden>   Sat, 27 Apr 2013 12:45:36 -0600
Superseded in saucy-release on 2013-04-27
Obsolete in raring-release on 2015-04-24
Obsolete in quantal-release on 2015-04-24
ocaml (3.12.1-2ubuntu3) quantal; urgency=low

  * No-change rebuild against latest armel toolchain.
 -- Adam Conrad <email address hidden>   Fri, 27 Apr 2012 07:35:22 -0600

Available diffs

Superseded in quantal-release on 2012-04-27
Published in precise-release on 2011-12-05
ocaml (3.12.1-2ubuntu2) precise; urgency=low

  * Build ocaml-native-compilers for armhf.
 -- Matthias Klose <email address hidden>   Mon, 05 Dec 2011 17:09:44 +0100

Available diffs

Superseded in precise-release on 2011-12-05
ocaml (3.12.1-2ubuntu1) precise; urgency=low

  * Merge with Debian; remaining changes:
    - Pass --hash-style=both --as-needed --build-id to the linker.

Available diffs

Superseded in precise-release on 2011-11-18
Obsolete in oneiric-release on 2015-04-24
ocaml (3.12.0-7ubuntu2) oneiric; urgency=low

  * Pass --hash-style=both --no-copy-dt-needed-entries --as-needed to the linker.
 -- Matthias Klose <email address hidden>   Mon, 15 Aug 2011 12:17:36 +0200
Superseded in oneiric-release on 2011-08-16
ocaml (3.12.0-7ubuntu1) oneiric; urgency=low

  * ocamlopt/arm: Add .type directive for code symbols. LP: #810402.
 -- Matthias Klose <email address hidden>   Sat, 13 Aug 2011 08:59:40 +0200
Superseded in oneiric-release on 2011-08-13
ocaml (3.12.0-7build1) oneiric; urgency=low

  * Rebuild with GCC-4.6.
 -- Matthias Klose <email address hidden>   Thu, 14 Jul 2011 14:56:21 +0200

Available diffs

Superseded in oneiric-release on 2011-07-14
ocaml (3.12.0-7) unstable; urgency=low

  * Force aligned access for double and int64 on mips*
 -- Ubuntu Archive Auto-Sync <email address hidden>   Sun,  29 May 2011 08:08:44 +0000

Available diffs

Superseded in oneiric-release on 2011-05-29
ocaml (3.12.0-6) unstable; urgency=low

  * Provide a way to use legacy custom linking (Closes: #627761)
  * Document Debian-specific -custom behaviour in README.Debian
  * Properly initialize executable name in caml_startup_code
    (Closes: #627756)
 -- Ubuntu Archive Auto-Sync <email address hidden>   Wed,  25 May 2011 15:11:19 +0000

Available diffs

Superseded in oneiric-release on 2011-05-25
ocaml (3.12.0-5) unstable; urgency=low

  * Fixes related to -output-obj with g++ (in debian/patches):
    - add Declare-primitive-name-table-as-const-char
    - add Avoid-multiple-declarations-in-generated-.c-files-in
    - fix Embed-bytecode-in-C-object-when-using-custom: the closing
      brace for extern "C" { ... } was missing in some cases

Available diffs

Superseded in oneiric-release on 2011-05-04
Obsolete in natty-release on 2013-06-04
ocaml (3.11.2-4ubuntu1) natty; urgency=low

  * debian/rules: fix build failure when libX11 is in a multiarch directory;
    unlike other library checks, libX11 gets probed for directly rather than
    asking the compiler.  Closes: #619344.
  * debian/control: add build-depends on dpkg-dev (>= 1.16.0~ubuntu4) for the
    necessary dpkg-architecture support.

Available diffs

Superseded in natty-release on 2011-03-23
ocaml (3.11.2-2) unstable; urgency=low

  * debian/ocaml-mode.emacs-install: do not byte-compile camldebug.el
    and inf-caml.el for xemacs21 (Closes: #508813, LP: #464587).
 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  15 Oct 2010 09:51:01 +0000

Available diffs

Superseded in natty-release on 2010-10-15
Obsolete in maverick-release on 2013-03-05
Obsolete in lucid-release on 2016-10-26
ocaml (3.11.2-1) unstable; urgency=low

  [ Stéphane Glondu ]
  * New upstream release
  * Bump Standards-Version to 3.8.4 (no changes)

  [ Mehdi Dogguy ]
  * camlp4-extra:
    - Add cma files back into the package (Requested by users).
    - Don't install a manpage for camlp4boot (which is not installed).
  * debian/rules:
    - Do not compute dependencies for camlp4-extra
  * debian/control:
    - Make camlp4-extra depend on ocaml-base-nox

  [ Ralf Treinen ]
  * debian/control.in: bump dependency of ocaml-mode on emacs22 to emacs23.

Available diffs

Superseded in lucid-release on 2010-02-15
ocaml (3.11.1-4ubuntu1) lucid; urgency=low

  * debian/patches/0007-disable-specific-registers-for-thumb: (LP: #503011)
    - Resolve an FTBFS on armel caused by specifying specific registers for
      counters in the interpreter. This patch causes the compiler to determine
      what registers to use automatically for __thumb__ instead of hardcoding a
      specific set of registers. An upstream bug has been filed at
      http://caml.inria.fr/mantis/view.php?id=4953
 -- Michael Casadevall <email address hidden>   Mon, 04 Jan 2010 10:13:29 -0500

Available diffs

Superseded in lucid-release on 2010-01-04
ocaml (3.11.1-4) unstable; urgency=low

  * Exclude compiler-libs from exported modules (Closes: #554871)
 -- Ubuntu Archive Auto-Sync <email address hidden>   Tue,  17 Nov 2009 17:46:42 +0000

Available diffs

Superseded in lucid-release on 2009-11-17
ocaml (3.11.1-3) unstable; urgency=low

  [ Mehdi Dogguy ]
  * Add two tools:
    - ocamlbyteinfo to read content of bytecode binaries
    - ocamlplugininfo to read content of shared object files (.cmxs)
  * Move some files from ocaml-interp to ocaml-nox and ocaml-base-nox
  * Synchronize debian/control and debian/control.in
  * Remove cma files shipped in camlp4 package and camlp4boot since
    they are not used
  * Add myself to Uploaders and update Stéphane's address
  * Remove DMUA
  * Use dh-ocaml (>= 0.9)

  [ Stéphane Glondu ]
  * Add build-dependency to autotools-dev (for up-to-date config.*)
  * Maintainer scripts:
    - explicitly use set -e
    - remove references to ocaml-md5sums, as its jobs is handled by
      dh_ocaml, now
  * Remove all debian/*.dirs* files to avoid empty directories
  * Update Standards-Version to 3.8.3 (no changes)
 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  06 Nov 2009 08:56:35 +0000

Available diffs

Superseded in lucid-release on 2009-11-06
Obsolete in karmic-release on 2013-03-04
ocaml (3.11.1-2) unstable; urgency=low

  * Remove build-dependency to docbook-* (not needed anymore, since
    policy has been moved to dh-ocaml)

Available diffs

Superseded in karmic-release on 2009-07-24
ocaml (3.11.0-5) unstable; urgency=low

  * Uploading to unstable
  * debian/control: bump dh-ocaml to (>= 0.4) to avoid buggy ocamlinit.mk

Available diffs

Superseded in karmic-release on 2009-04-30
Obsolete in jaunty-release on 2013-02-28
Obsolete in intrepid-release on 2013-02-20
ocaml (3.10.2-3ubuntu1) intrepid; urgency=low

  * Build ocaml-native-compilers on lpia (restoring change from hardy).

 -- Colin Watson <email address hidden>   Sun, 15 Jun 2008 13:35:02 +0100

Available diffs

Superseded in intrepid-release on 2008-06-15
ocaml (3.10.2-3) unstable; urgency=low

  [ Stefano Zacchiroli ]
  * debian/rules: force using gcc-4.2 on arm (fix FTBFS on arm)

  [ Ralf Treinen ]
  * Added myself to uploaders.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Thu,  22 May 2008 08:20:08 +0100
Superseded in intrepid-release on 2008-05-22
ocaml (3.10.2-2) unstable; urgency=low

  [ Stefano Zacchiroli ]
  * releasing to unstable
  * fix "OCaml" spelling errors in package descriptions (thanks lintian!)

  [ Romain Beauxis ]
  * removed virtual package from internal dependencies in favour of strict
    versioned dependencies. Prevents build failures under some situations.

  [ Sylvain Le Gall ]
  * changing doc-base section of generated documentation to Programming/OCaml
    (Closes: #476647)
  * OCaml Packaging Policy:
    - update camlp4/camlp5 policy chapter
    - register policy in doc-base

  [ Ralf Treinen ]
  * OCaml Packaging Policy:
    - update OCaml version to 3.10.2
    - add a section on where to register documentation with doc-base.

Superseded in intrepid-release on 2008-05-19
ocaml (3.10.1-1) unstable; urgency=low

  [ Samuel Mimram ]
  * New upstream release.
  * Removed arm_ccheckbound_typo.dpatch, integrated upstream.

  [ Stefano Zacchiroli ]
  * fix vcs-svn field to point just above the debian/ dir

  [ Ralf Treinen ]
  * Policy: add section on correct spelling OCaml, bump version to 0.7.2

  [ Julien Cristau ]
  * Add ${shlibs:Depends} and ${misc:Depends} to all packages.

Superseded in intrepid-release on 2008-05-03
Obsolete in hardy-release on 2015-04-24
ocaml (3.10.0-8) unstable; urgency=low

  [ Stefano Zacchiroli ]
  * CDBS class
    - invoke ocamldoc after dh_install has been run (otherwise ocamldoc is
      likely to generate empty API references ...)
    - add support for automatic generation of doc-base entries for ocamldoc
      generated API reference
    - better test for package membership to OCAML_OCAMLDOC_PACKAGES
  * debian/ocaml-base-nox.README.Debian
    - add an entry describing the requirement for compiling ocamldoc-generated
      LaTeX documentation (closes: #420782)

Superseded in hardy-release on 2007-11-23
Obsolete in gutsy-release on 2011-09-16
ocaml (3.09.2-9ubuntu1) gutsy; urgency=low

  * Build ocaml-native-compilers on lpia.
  * Set Ubuntu maintainer address.

 -- Matthias Klose <email address hidden>   Tue, 07 Aug 2007 17:24:04 +0000
Superseded in gutsy-release on 2007-08-07
ocaml (3.09.2-9) unstable; urgency=low

  * Add Replaces: ocaml-nox (<< 3.09.2-8) to the ocaml package because of the
    ocamlbrowser move.
  * Sync debian/control.in with debian/control.

Superseded in gutsy-release on 2007-04-27
Obsolete in feisty-release on 2009-08-20
ocaml (3.09.2-7build1) feisty; urgency=low

  * Rebuild for changes in the amd64 toolchain.

 -- Matthias Klose <email address hidden>   Mon,  5 Mar 2007 01:23:27 +0000
Superseded in feisty-release on 2007-03-07
ocaml (3.09.2-7) unstable; urgency=low

  [ Julien Cristau ]
  * Fix typo in ocaml-base description (Closes: #390224).

  [ Stefano Zacchiroli ]
  * debian/control
    - added XS-Vcs-Svn field to let users know where our svn repository is
  * Added .txt suffix to the textual version of the policy
  * Ship CDBS class for building OCaml related packages in
    /usr/share/cdbs/1/; permission granted by the CDBS maintainers to
    ship files there, see #387299. (Closes: #387299).
  * Updated policy (now at version 0.7.1); changes:
    - added a best-practice section about using the XS-Vcs-Svn field in
      debian/control of OCaml related packages
    - fixed typo in the suggested debian/rules line to fill the OFILES
      variable

  [ Samuel Mimram ]
  * Updated policy (section 2.3) to explain how to add a conditional
    dependency on ocaml-base-nox-VERSION for native/bytecode packages.

Superseded in feisty-release on 2006-11-08
Obsolete in edgy-release on 2008-06-19
ocaml (3.09.2-5) unstable; urgency=low

  * Added a missing dependency on docbook-xml, closes: #373996.

Superseded in edgy-release on 2006-06-19
ocaml (3.09.2-3) unstable; urgency=low

  * Uploading to unstable.

Superseded in edgy-release on 2006-06-15
Obsolete in dapper-release on 2011-09-06
Superseded in dapper-release on 2006-02-03
ocaml (3.09.1-2) unstable; urgency=low


  [ Samuel Mimram ]
  * Cleaning ocaml-md5sums, closes: #346279.

  [ Julien Cristau ]
  * build-arch is a phony target.
  * Add patch to make ocamlopt -output-obj and ocamlopt -pack call the linker
    via gcc instead of directly, which allows us to pass the same linking
    options in these cases and in the common case (where ocamlopt already used
    gcc). This should unbreak ocamlopt -pack on alpha, and thus fix the build
    failure of camomile.

 -- Julien Cristau <email address hidden>  Thu, 12 Jan 2006 15:33:00 +0100
Superseded in dapper-release on 2006-01-31
ocaml (3.09.1-1) unstable; urgency=low


  [ Samuel Mimram ]
  * Removing possibly leftover /usr/lib/ocaml/ld.conf, closes: #300846.
  * Updated objinfo.dpatch.
  * Added dumpobj.dpatch to install ocamldumpobj.
  * Added a rule in rules to generate (manually) ocaml-source.files and
    updated ocaml-source.files.
  * Added a watch file.

  [ Julien Cristau ]
  * New upstream release
    + sparc is correctly detected and alignment of doubles and 64-bit ints on
      double-word boundaries is forced (Closes: #344615).
  * Remove Suggests on xlibs-dev which doesn't exist anymore.

 -- Samuel Mimram <email address hidden>  Wed,  4 Jan 2006 20:32:13 +0100
Superseded in dapper-release on 2006-01-31
ocaml (3.09.0-4) unstable; urgency=low


  [ Julien Cristau ]
  * debian/rules: the abi-sed rule is phony, we don't want to run configure
    twice.
  * Stop building the native compilers on hppa, they are buggy and upstream
    considers this port dead (see bug#342704).

  [ Samuel Mimram ]
  * Added for_pack_static.dpatch (from CVS) to correct a bug when linking,
    disabled for now though.
  * Added myself to uploaders.

  [ Julien Cristau ]
  * Install the list of architectures with native compilers in the ocaml-nox
    package.

  [ Sven Luther ]
  * This version should make it into testing, so let's (Closes: #338435).

 -- Sven Luther <email address hidden>  Mon, 19 Dec 2005 13:36:31 +0000
Superseded in dapper-release on 2006-01-31
ocaml (3.09.0-1) unstable; urgency=low


  * New upstream release.
    - self references are now ruled out (Closes: #263163, #294753)
    - better escaping in manpages generated by ocamldoc (Closes: #301046)
    - typo fixed in ocamldoc.1 (Closes: #304360)
    - argument order changed in Map.fold (Closes: #327211)

  [ Julien Cristau ]
  * Cleanup debian/control: remove redundant Depends.
  * Update location of ocaml-md5sums stuff.
  * Build-Depend on chrpath and delete rpath from DLLs.
  * Various lintian warnings fixed, and overrides cleaned up.

  [ Sven Luther ]
  * Updated to new upstream release.
  * Modified the packaging ifrastructure to not use hard-coded abi number
    except in the head of debian/rules. All else is sed'ed from #OcamlABI#
    (and #OcamlMAJOR# for the debian/copyright file and the upstream url).

 -- Debian OCaml Maintainers <email address hidden>  Mon, 07 Nov 2005 10:56:49 +0100
Superseded in dapper-release on 2006-01-31
ocaml (3.09.0-3) unstable; urgency=low


  * Fix build on non-native arches which was broken by the changes to
    debian/rules in the previous release. Sorry for this :(

 -- Julien Cristau <email address hidden>  Fri,  9 Dec 2005 11:01:06 +0100
Obsolete in breezy-release on 2008-03-25
ocaml (3.08.3-3ubuntu5) breezy; urgency=low


  * Add PreDepend on emacsen-common to fix ubuntu #13748 (debian #312618)
    The debian team plans to split out the emacs bits into it's own binary
    package. This dependency can be dropped once this is done.

 -- Michael Vogt <email address hidden>  Wed, 24 Aug 2005 12:11:22 +0200
Obsolete in hoary-release on 2008-03-19
ocaml (3.08.2-1) unstable; urgency=low


  * new upstream stable release.

 -- Sven Luther <email address hidden>  Sat, 27 Nov 2004 12:25:08 +0100
Obsolete in warty-release on 2008-01-09
ocaml (3.07.2a-2ubuntu1) warty; urgency=low


  * Add amd64 support.

 -- LaMont Jones <email address hidden>  Mon, 12 Jul 2004 20:47:13 +0100
155 of 55 results