[SRU] Rebuild octplot to fix UNMETDEPS

Bug #70789 reported by Michael Bienia
4
Affects Status Importance Assigned to Milestone
Edgy Backports
Fix Released
Undecided
Unassigned
octplot (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

Original bug report: bug 65398

The current package in edgy (octplot 0.3.5-2ubuntu1) fails to install:

The following packages have unmet dependencies.
  octplot: Depends: libhdf5-serial-1.6.4-0c2 but it is not installableor
                    libhdf5-1.6.4-0c2 but it is not installable
E: Broken packages

Rebuilding the packages fixes it. The Depends line after the rebuild:

Depends: atlas3-base | lapack3 | liblapack.so.3, atlas3-base | refblas3 | libblas.so.3, fftw3, libc6 (>= 2.4-1), libfltk1.1 (>= 1.1.7-2), libfreetype6 (>= 2.2), libgcc1 (>= 1:4.1.1-12), libgfortran1 (>= 4.1.1-12), libgl1-mesa-glx | libgl1, libglu1-mesa | libglu1, libhdf5-serial-1.6.5-0 | libhdf5-1.6.5-0, libncurses5 (>= 5.4-5), libreadline5 (>= 5.1), libstdc++6 (>= 4.1.1-12), libx11-6, libxft2 (>> 2.1.1), libxinerama1, zlib1g (>= 1:1.2.1), octave-forge (>= 2004.07.07)

Revision history for this message
Michael Bienia (geser) wrote :
Changed in octplot:
assignee: nobody → motu-sru
Revision history for this message
StefanPotyra (sistpoty) wrote :

Hi Micheal,

did you also test that the package works after rebuilding?

If so, I don't see much problem with this SRU and thus +1 from me.

Cheers,
   Stefan.

Revision history for this message
Michael Bienia (geser) wrote :

I just tested the rebuild package. Installation works fine. But as I don't use this package I can't test it really.

I've tried to run the examples from the README but get a "std::bad_alloc" error when something should be plotted :( (I've tested in a chroot on an AMD64).
So it seems the package is still broken.

I've also tested octplot 0.3.9 (rebuild from Debian unstable) which works better but is not target of this SRU request.

Revision history for this message
Jonh Wendell (wendell) wrote :

It would be nice if new version from debian (0.3.9) enter instead of that rebuilt package. (bug 70750)

Revision history for this message
StefanPotyra (sistpoty) wrote :

Ok, then I'm inclined to reject this request, since there is still the (very small) chance that it might be a regression, if s.o. has the old version installed and the libraries held back.

Cheers,
     Stefan.

Revision history for this message
StefanPotyra (sistpoty) wrote :

Setting this to needs info, in case you want to bring in the new upstream version.

Changed in octplot:
status: Unconfirmed → Needs Info
Revision history for this message
Michael Bienia (geser) wrote :

For those who are still interested in testing the packages, I've put debs for i386 and AMD on http://members.ping.de/~mb/octplot/

Revision history for this message
Tormod Volden (tormodvolden) wrote :

I have tested your octplot_0.3.9-1_i386.deb on Edgy and it works fine. I would also prefer this newer version rather than the old version that nobody was able to use anyway.

Revision history for this message
StefanPotyra (sistpoty) wrote :

Hi,

in case the newer package can be backported, edgy-backports might also be an option to bring the new upstream version in.

I'm unassigning this bug from motu-sru. In case you have a debdiff which will fix the current package in edgy, please subscribe motu-sru.

Cheers,
      Stefan.

Changed in octplot:
assignee: motu-sru → nobody
Revision history for this message
Tormod Volden (tormodvolden) wrote :

I rebuilt the feisty 0.3.9-2ubuntu1 (without changes) on edgy, and it worked fine. Should we open a new bug for requesting a backport, or can we just add the target to this one?

Revision history for this message
Martin Meredith (mez) wrote :

leave this one

Revision history for this message
Martin Meredith (mez) wrote :

prevu builds it fine... installs fine

+1 from me
John?

Revision history for this message
zenrox (kergan) wrote :

b/i/r(no major testing but works )
+1 edgy

Changed in edgy-backports:
status: Unconfirmed → Confirmed
Revision history for this message
John Dong (jdong) wrote :

Approving backport. SRU evaluated and users prefer the new upstream version instead.

Changed in edgy-backports:
status: Confirmed → In Progress
Revision history for this message
Sebastien Bacher (seb128) wrote :

 * Trying to backport octplot...
  - <octplot_0.3.9.orig.tar.gz: downloading from librarian>
  - <octplot_0.3.9-2ubuntu1.diff.gz: downloading from librarian>
  - <octplot_0.3.9-2ubuntu1.dsc: downloading from librarian>
I: Extracting octplot_0.3.9-2ubuntu1.dsc ... done.
I: Building backport of octplot-0.3.9 as 0.3.9-2ubuntu1~edgy1 ... done.

Changed in edgy-backports:
status: In Progress → Fix Released
Revision history for this message
William Grant (wgrant) wrote :

Michael, are you happy to close the bug now?

Changed in octplot:
status: Needs Info → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Patches