Change log for openexr package in Ubuntu

136 of 36 results
Published in eoan-release on 2019-04-18
Published in disco-release on 2019-04-11
Deleted in disco-proposed (Reason: moved to release)
openexr (2.2.1-4.1) unstable; urgency=medium

  * Non-maintainer upload.
  * bug909865.patch: Add -ffloat-store when compiling tests, to fix test
    failures on i386. Patch backported from experimental. (Closes: #909865)

 -- Steinar H. Gunderson <email address hidden>  Wed, 20 Mar 2019 22:40:43 +0100
Superseded in disco-release on 2019-04-11
Published in cosmic-release on 2018-07-06
Deleted in cosmic-proposed (Reason: moved to release)
openexr (2.2.1-4build1) cosmic; urgency=medium

  * No-change rebuild against latest ilmbase

 -- Rik Mills <email address hidden>  Thu, 24 May 2018 16:03:33 +0100
Superseded in cosmic-proposed on 2018-05-24
openexr (2.2.1-4) unstable; urgency=medium

  * Upload to unstable

 -- Matteo F. Vescovi <email address hidden>  Sun, 11 Mar 2018 14:10:23 +0100
Superseded in cosmic-release on 2018-07-06
Published in bionic-release on 2018-01-27
Deleted in bionic-proposed (Reason: moved to release)
openexr (2.2.0-11.1ubuntu1) bionic; urgency=medium

  * Merge with Debian unstable (LP: #1742243). Remaining changes:
    - Add ppc64el to the archs where to ignore test results.

Superseded in bionic-release on 2018-01-27
Published in artful-release on 2017-04-20
Obsolete in zesty-release on 2018-06-22
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed (Reason: moved to release)
openexr (2.2.0-11ubuntu1) yakkety; urgency=medium

  * Merge with Debian unstable (LP: #1628583). Remaining changes:
    - Add ppc64el to the archs where to ignore test results.
  * Drop:
    - Mark as optional symbols that aren't exported when building with
      -O3.
      [ symbols filed dropped in 2.2.0-11 ]

 -- Nishanth Aravamudan <email address hidden>  Wed, 28 Sep 2016 09:06:18 -0700
Superseded in yakkety-release on 2016-09-30
Published in xenial-release on 2016-04-17
Deleted in xenial-proposed (Reason: moved to release)
openexr (2.2.0-10ubuntu2) xenial; urgency=medium

  * Add ppc64el to the archs where to ignore test results.

 -- Matthias Klose <email address hidden>  Sun, 17 Apr 2016 20:13:32 +0200
Superseded in xenial-proposed on 2016-04-17
openexr (2.2.0-10ubuntu1) xenial; urgency=medium

  * Merge with Debian; remaining changes:

Superseded in xenial-release on 2016-04-17
Deleted in xenial-proposed on 2016-04-19 (Reason: moved to release)
openexr (2.2.0-9ubuntu1) xenial; urgency=low

  * Merge from Debian unstable.  Remaining changes:
    - Mark as optional symbols that aren't exported when building with -O3.

Available diffs

Superseded in xenial-release on 2016-02-02
Deleted in xenial-proposed on 2016-02-03 (Reason: moved to release)
openexr (2.2.0-7ubuntu1) xenial; urgency=medium

  * Mark as optional symbols that aren't exported when building with -O3.

 -- Steve Langasek <email address hidden>  Sat, 05 Dec 2015 00:12:51 +0000
Superseded in xenial-proposed on 2015-12-05
openexr (2.2.0-7) experimental; urgency=medium

  * Fix symbols on armel/powerpc/armhf

 -- Mathieu Malaterre <email address hidden>  Mon, 19 Oct 2015 14:47:28 +0200
Superseded in xenial-release on 2015-12-05
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed on 2018-01-22 (Reason: moved to release)
openexr (2.2.0-1ubuntu3) wily; urgency=medium

  * Fix tests on big endian targets (taken from Fedora).
  * Ignore test results on 32bit archs.

 -- Matthias Klose <email address hidden>  Thu, 06 Aug 2015 00:23:37 +0200
Superseded in wily-proposed on 2015-08-05
openexr (2.2.0-1ubuntu2) wily; urgency=medium

  * Re-enable dh-autoreconf (don't run autoheader).
  * Disable the symbols file for now. New soname, and needs updates
    for the new libstdc++6 ABI.

Available diffs

Superseded in wily-proposed on 2015-08-05
openexr (2.2.0-1ubuntu1) wily; urgency=medium

  * Re-enable dh-autoreconf.
  * Disable the symbols file for now. New soname, and needs updates
    for the new libstdc++6 ABI.

Superseded in wily-release on 2015-08-16
Obsolete in vivid-release on 2018-01-18
Deleted in vivid-proposed on 2018-01-19 (Reason: moved to release)
openexr (1.6.1-8) unstable; urgency=medium


  * QA upload.
  * Orphan package, set maintainer to QA.
  * Add 20_autoreconf.diff by Andreas Barth to let autoreconf run successfully
    and use dh-autoreconf. Closes: #759719
  * Point Vcs-* to anonscm.debian.org.

 -- Andreas Metzler <email address hidden>  Sun, 31 Aug 2014 07:56:20 +0200
Superseded in vivid-release on 2014-11-03
Obsolete in utopic-release on 2016-11-03
Published in trusty-release on 2013-12-15
Deleted in trusty-proposed (Reason: moved to release)
openexr (1.6.1-7ubuntu1) trusty; urgency=medium

  * Build using dh-autoreconf.
  * Update for recent autoconf/autoheader.
 -- Matthias Klose <email address hidden>   Sun, 15 Dec 2013 15:23:25 +0100
Superseded in trusty-release on 2013-12-15
Obsolete in saucy-release on 2015-04-24
Obsolete in raring-release on 2015-04-24
Deleted in raring-proposed on 2015-04-27 (Reason: moved to release)
openexr (1.6.1-7) unstable; urgency=low


  * Convert to multi-arch.
    + Use debhelper v9 compat, bump build-dep. Drop unneeded invocation of
      dpkg-buildflags.
    + Update *.install.
    + Add Pre-Depends: ${misc:Pre-Depends}.
    + Runtime library is Multi-Arch: same, cmd-line utils Multi-Arch: foreign.

 -- Andreas Metzler <email address hidden>  Sat, 08 Dec 2012 14:23:33 +0100

Available diffs

Superseded in raring-release on 2012-12-08
Obsolete in quantal-release on 2015-04-24
openexr (1.6.1-6) unstable; urgency=low


  * nonlinuxlargestack.diff Fix FTBFS when large stacks are disabled.
    Bug-report, diagnosis and patch by Pino Toscano. Closes: #680509

 -- Andreas Metzler <email address hidden>  Sat, 07 Jul 2012 08:58:08 +0200

Available diffs

Superseded in quantal-release on 2012-08-08
openexr (1.6.1-5) unstable; urgency=low


  * Update package short description, openexr does not contain a viewer.
    Closes: #471783
  * Use 3.0 (quilt) source format.
  * Re-enable doc-base support. At least dhelp works without problems.
  * Use dh $@ --with autotools_dev. Version autotools-dev b-d.
  * The latter three changes add support for build-arch target, fixing FTBFS.
    Closes: #666297
  * Change override_dh_auto_test target to invoke dh_auto_test, otherwise the
    testsuite is run twice. (Once for build and binary).
  * Add myself to uploaders, remove Cyril. (Thanks for you work!)
  * Empty dependency_libs in libtool la file.
  * Fix doc-base ids. (lowercase, no underscore.)
  * Drop Section: graphics from binary package stanza in debian/control.
  * Fix typo mutiple in exrmaketiled.1.
  * Use 'dpkg-buildflags --export=configure' to get hardening-flags. (Thanks,
    Moritz Muehlenhoff). Add required b-d on dpkg-dev (>= 1.16.1). 
    Closes: #656506

 -- Andreas Metzler <email address hidden>  Sun, 01 Apr 2012 08:45:13 +0200

Available diffs

Superseded in quantal-release on 2012-04-30
Published in precise-release on 2011-10-13
Obsolete in oneiric-release on 2015-04-24
Obsolete in natty-release on 2013-06-04
Obsolete in maverick-release on 2013-03-05
Obsolete in lucid-release on 2016-10-26
openexr (1.6.1-4.1) unstable; urgency=high

  * Non-maintainer upload by the Security Team.
  * Fixed CVE-2009-1720: Integer overflows in Imf::PreviewImage::PreviewImage
    and integer overflows in compressor constructors
  * Fixed CVE-2009-1721: uninitialized pointers in Imf::hufUncompress
  * Patch stolen from stable-security, thanks to Cyril Brulebois
    (Closes: #550424)
 -- Lo?c Minier <email address hidden>   Mon,  23 Nov 2009 22:28:51 +0000

Available diffs

Superseded in lucid-release on 2009-11-23
Obsolete in karmic-release on 2013-03-04
openexr (1.6.1-4ubuntu3) karmic; urgency=low

  * No change rebuild to fix misbuilt binaries on armel.

 -- Loic Minier <email address hidden>   Wed, 21 Oct 2009 14:47:13 +0200

Available diffs

Superseded in karmic-release on 2009-10-22
openexr (1.6.1-4ubuntu2) karmic; urgency=low

  * SECURITY UPDATE: denial of service and possible code execution via
    multiple integer overflows
    - debian/patches/security_CVE-2009-1720.diff: make sure we don't
      overflow INT_MAX in IlmImf/{ImfPizCompressor,ImfPreviewImage,
      ImfPxr24Compressor,ImfRleCompressor,ImfZipCompressor}.cpp.
    - CVE-2009-1720
  * SECURITY UPDATE: denial of service and possible code execution via
    uninitialized pointer free in Imf::hufUncompress
    - debian/patches/security_CVE-2009-1721.diff: introduce
      hufClearDecTable function and use it to clear out hdec in
      IlmImf/ImfHuf.cpp.
    - CVE-2009-1721

 -- Marc Deslauriers <email address hidden>   Mon, 14 Sep 2009 14:35:41 -0400

Available diffs

Obsolete in jaunty-updates on 2013-02-28
Obsolete in jaunty-security on 2013-02-28
openexr (1.6.1-3ubuntu1.9.04.1) jaunty-security; urgency=low

  * SECURITY UPDATE: denial of service and possible code execution via
    multiple integer overflows
    - debian/patches/security_CVE-2009-1720.diff: make sure we don't
      overflow INT_MAX in IlmImf/{ImfPizCompressor,ImfPreviewImage,
      ImfPxr24Compressor,ImfRleCompressor,ImfZipCompressor}.cpp.
    - CVE-2009-1720
  * SECURITY UPDATE: denial of service and possible code execution via
    uninitialized pointer free in Imf::hufUncompress
    - debian/patches/security_CVE-2009-1721.diff: introduce
      hufClearDecTable function and use it to clear out hdec in
      IlmImf/ImfHuf.cpp.
    - CVE-2009-1721

 -- Marc Deslauriers <email address hidden>   Thu, 10 Sep 2009 08:18:39 -0400
Obsolete in intrepid-updates on 2013-02-20
Obsolete in intrepid-security on 2013-02-20
openexr (1.6.1-3ubuntu1.8.10.1) intrepid-security; urgency=low

  * SECURITY UPDATE: denial of service and possible code execution via
    multiple integer overflows
    - debian/patches/security_CVE-2009-1720.diff: make sure we don't
      overflow INT_MAX in IlmImf/{ImfPizCompressor,ImfPreviewImage,
      ImfPxr24Compressor,ImfRleCompressor,ImfZipCompressor}.cpp.
    - CVE-2009-1720
  * SECURITY UPDATE: denial of service and possible code execution via
    uninitialized pointer free in Imf::hufUncompress
    - debian/patches/security_CVE-2009-1721.diff: introduce
      hufClearDecTable function and use it to clear out hdec in
      IlmImf/ImfHuf.cpp.
    - CVE-2009-1721

 -- Marc Deslauriers <email address hidden>   Thu, 10 Sep 2009 08:23:06 -0400
Obsolete in hardy-updates on 2015-04-24
Obsolete in hardy-security on 2015-04-24
openexr (1.2.2-4.4ubuntu1.1) hardy-security; urgency=low

  * SECURITY UPDATE: denial of service and possible code execution via
    multiple integer overflows
    - debian/patches/02-security-CVE-2009-1720.patch: make sure we don't
      overflow INT_MAX in IlmImf/{ImfPizCompressor,ImfPreviewImage,
      ImfPxr24Compressor,ImfRleCompressor,ImfZipCompressor}.cpp.
    - CVE-2009-1720
  * SECURITY UPDATE: denial of service and possible code execution via
    uninitialized pointer free in Imf::hufUncompress
    - debian/patches/03-security-CVE-2009-1721.patch: introduce
      hufClearDecTable function and use it to clear out hdec, add error
      checking to IlmImf/ImfHuf.cpp.
    - CVE-2009-1721
  * SECURITY UPDATE: denial of service and possible code execution via
    buffer overflow in the compression implementation
    - debian/patches/04-security-CVE-2009-1722.patch: validate maximum
      image and tile sizes in IlmImf/ImfHeader.cpp, IlmImf/ImfHeader.h,
      IlmImf/ImfPizCompressor.cpp.
    - CVE-2009-1722

 -- Marc Deslauriers <email address hidden>   Thu, 10 Sep 2009 08:24:15 -0400
Superseded in karmic-release on 2009-09-15
openexr (1.6.1-4ubuntu1) karmic; urgency=low

  * Merge from debian unstable, remaining changes: (LP: #372112)
    - Added hppa to NO_MAKE_CHECK_ARCHES
    - This change can be dropped when the kernel for the HPPA buildds is
      updated with the latest NTPL fixes

Available diffs

Superseded in karmic-release on 2009-05-18
Obsolete in jaunty-release on 2013-02-28
Obsolete in intrepid-release on 2013-02-20
openexr (1.6.1-3ubuntu1) intrepid; urgency=low

  * Disabled test suite on HPPA to resolve FTBFS
    - Test suite disabled due to threading failures
      due to NPTL on HPPA. Can be re-enabled after
      NPTL in glibc is more stable

 -- Michael Casadevall <email address hidden>   Sat, 11 Oct 2008 01:54:37 -0400

Available diffs

Superseded in intrepid-release on 2008-10-11
openexr (1.6.1-3) unstable; urgency=medium

  * Disable (hopefully temporarily) the test suite on arm and ia64.

Available diffs

Superseded in intrepid-release on 2008-06-24
Obsolete in hardy-release on 2015-04-24
openexr (1.2.2-4.4ubuntu1) hardy; urgency=low

  * Merge with Debian; remaining changes:
    - Fix build failure with g++-4.3.
    - Adjust preferred libgl-dev/libglu-dev alternatives for Ubuntu.
  * Link using -Bsymbolic-functions.

Superseded in hardy-release on 2007-12-07
Obsolete in gutsy-release on 2011-09-16
openexr (1.2.2-4.3ubuntu2) gutsy; urgency=low

  * Fix build failure with g++-4.3.

 -- Matthias Klose <email address hidden>   Mon, 10 Sep 2007 13:09:28 +0000
Superseded in gutsy-release on 2007-09-10
Obsolete in feisty-release on 2009-08-20
openexr (1.2.2-4.3ubuntu1) feisty; urgency=low

  * Adjust preferred libgl-dev/libglu-dev alternatives for Ubuntu.

 -- Colin Watson <email address hidden>   Fri, 16 Feb 2007 10:53:02 +0000
Superseded in feisty-release on 2007-02-16
openexr (1.2.2-4.3build1) feisty; urgency=low

  * Rebuild for ldbl128 change on powerpc and sparc.

 -- Matthias Klose <email address hidden>   Thu,  2 Nov 2006 10:00:05 +0000
Superseded in feisty-release on 2006-11-03
Obsolete in edgy-release on 2008-06-19
openexr (1.2.2-4.3) unstable; urgency=medium

  * Non-maintainer upload.
  * Fix build system not to create libraries with undefined symbols. Added
    patch 01-libadd_to_prevent_undef_syms to properly define libImath_la_LIBADD
    and libIlmImf_la_LIBADD in Makefile.am.  (Closes: #370193)

Superseded in edgy-release on 2006-07-06
Obsolete in dapper-release on 2011-09-06
Superseded in dapper-release on 2006-02-03
openexr (1.2.2-4ubuntu2) dapper; urgency=low


  * Rename libopenexr2c2 to libopenexr2c2a (libstdc++ allocator change).

 -- Matthias Klose <email address hidden>  Wed, 23 Nov 2005 20:27:39 +0100
Obsolete in breezy-release on 2008-03-25
openexr (1.2.2-3ubuntu1) breezy; urgency=low


  * Update {build-,}depends for the xorg -> mesa transition.

 -- Adam Conrad <email address hidden>  Fri, 19 Aug 2005 00:01:46 +1000
Obsolete in hoary-release on 2008-03-19
openexr (1.2.1-2) unstable; urgency=medium


  * Correct libopenexr-dev's dependency on libopenexr0 to libopenexr2.

 -- Andrew Lau <email address hidden>  Tue, 17 Aug 2004 14:32:17 +1000
Obsolete in warty-release on 2008-01-09
openexr (1.1.1-1) unstable; urgency=low


  * New upstream release.
    - Builds on 64-bit architectures.
      (closes: #239732)
    - Note that this is a development release and the tiled file format has
      changed. See the ReleaseNotes file for more details.
    
 -- Andrew Lau <email address hidden>  Wed, 31 Mar 2004 12:17:48 +1000
136 of 36 results