OOo won't start after showing splash screen

Bug #42711 reported by Stefano Costa on 2006-05-03
16
Affects Status Importance Assigned to Milestone
linux-restricted-modules-2.6.17 (Ubuntu)
Undecided
Unassigned
openoffice.org (Ubuntu)
Medium
Matthias Klose

Bug Description

Binary package hint: openoffice.org

On Ubuntu Dapper 6.06, OOo (2.0.2-2ubuntu5) apps don't start after showing the
usual splash screen, which stays on top of the desktop

if started from the CLI, no error message will come out

here's ps aux

steko@cycnus:~$ ps aux | grep openoff
steko 19553 0.1 0.1 3404 1364 ? S 09:21 0:00
/usr/lib/openoffice/program/ooqstart
steko 19555 0.0 0.1 4188 1684 ? S 09:21 0:00 /bin/sh
/usr/lib/openoffice/program/soffice -draw -splash-pipe=6
steko 19568 5.8 3.4 97464 35756 ? SLl 09:21 0:00
/usr/lib/openoffice/program/soffice.bin -draw -splash-pipe=6

this has been filed here too http://www.openoffice.org/issues/show_bug.cgi?id=64984
I have to kill them if I want to stop the process.

Stefano Costa (steko) wrote :

since this morning OOo is working again. I can't understand what was wrong, and what got it to work, as there were no updates on the package since my 1st report.

Yichuan Wang (yichuan1118) wrote :

I got exactly the same problem, and I didn't have the luck to bring it back to life.

here is my original discription of the bug on the ubuntu forum: ( I am thinking java? )

After I installed Ubuntu Dapper beta2 the OOo seems worked.

But after a while( upgrade several times, changed java to sun's ), it stops to work.

After I clicked the icon, the splash screen shows, but the progress bar in the splash screen did show up.

There is 3 process in the system moniter, soffice soffice.bin ooqstart.

I tried to change the java back to gij, and reinstall the OOo, doesnt work.....

And if I run soffice/soffice.bin from the terminal, it show's no feedbacks, and the programm still won't start up, the progress bar sometimes shows up, up freeze there.

kevinz (klzhao) wrote :

I have exactly the same problem. I don't know if it is related to the Chinese environment I set up for dapper beta. It once works. But now it is the same as the problem statement.

Yichuan Wang (yichuan1118) wrote :

I figured it out.

There's a mysterious bug when fglrx, scim and OOo( or acroread ) works together. Change the ~/.xinput.d/zh_CN as following ( create if needed )

XIM=SCIM
XIM_PROGRAM=/usr/bin/scim
XIM_ARGS="-d"
GTK_IM_MODULE=xim
QT_IM_MODULE=xim
DEPENDS="scim,scim-gtk2-immodule | scim-qtimm"

kevinz (klzhao) wrote :

Thank you so much.

BTW, it is ok to set the two variable "GTK_IM_MODULE" and "QT_IM_MODULE" to "xim" before running OO programs. But what is the consequence of changing them to "xim"?

Do as I writed, the SCIM can still be used. Everything seems the same.

Weird...

On 5/17/06, kevinz <email address hidden> wrote:
>
> Thank you so much.
>
> BTW, it is ok to set the two variable "GTK_IM_MODULE" and "QT_IM_MODULE"
> to "xim" before running OO programs. But what is the consequence of
> changing them to "xim"?
>
> --
> OOo won't start after showing splash screen
> https://launchpad.net/bugs/42711
>

Well, at least on my machine, this seems to have nothing to do with
SCIM.

I solved this disabling the OOo autostart option. It seemed to work,
indeed. Or at least this worked yesterday. After today's update,
everything is the same.

But I can't explain why OOo starts without any problem if I login as
another user on this same machine.

--
Stefano Costa
http://www.iosa.it Software Open Source per l'Archeologia
Jabber: <email address hidden>
GnuPG Key ID 1024D/0xD0D30245
Linux Registered User #385969 counter.li.org

DarkMageZ (darkmagez) on 2006-05-24
Changed in openoffice.org:
assignee: nobody → desktop-bugs
DarkMageZ (darkmagez) wrote :

this bug doesn't replicate on every system, removing .openoffice.org2 doesn't fix this issue...

Changed in openoffice.org:
assignee: desktop-bugs → doko
LimSweeTat (st-lim) wrote :

I have this same problem. According to the strace, something is dying causing the program to wait for a reply that does not exist.

Trying to add the .xinput.d/zh_CN file does not seem to work for me.

Running the program "oowriter" as root works.

STRACE BELOW:

write(4, "\20\1\t\0\32\0\300\1_NET_WM_WINDOW_TYPE_SPLA"..., 36) = 36
read(4, "\0010\16\0\0\0\0\0\25\1\0\0\1\0\0\0\0\0\0\0$\0\0\0$\0\0"..., 32) = 32
write(4, "\22\0\7\0\1\0\300\1\365\0\0\0\4\0\0\0 IND\1\0\0\0\25\1"..., 52) = 52
read(4, "\0010\20\0\0\0\0\0\371\0\0\0\0\0\0\0\0\0\0\0\30\0\0\0\30"..., 32) = 32
mmap2(NULL, 503808, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0xb7c01000
writev(4, [{"\22\0\v\0\1\0\300\1\371\0\0\0\371\0\0\0 IND\5\0\0\0\17"..., 100}, {"III\0III\0III\0III\0III\0III\0III\0III\0"..., 260480}], 2) = 260580
writev(4, [{"H\0026\355\3\0\300\1\4\0\300\1\270\1\212\0\0\0\224\0\0"..., 24}, {"III\0\265\265\265\0\266\266\266\0\266\266\266\0\266\266"..., 242880}], 2) = 242904
munmap(0xb7c01000, 503808) = 0
write(4, "\2\2\4\0\1\0\300\1\1\0\0\0\3\0\300\1<\0\2\0\4\0\300\001"..., 112) = 112
ioctl(4, FIONREAD, [0]) = 0
access("/proc/version", F_OK) = 0
pipe([5, 6]) = 0
fstat64(5, {st_mode=S_IFIFO|0600, st_size=0, ...}) = 0
fcntl64(5, F_GETFL) = 0 (flags O_RDONLY)
pipe([7, 8]) = 0
pipe([9, 10]) = 0
clone(child_stack=0, flags=CLONE_CHILD_CLEARTID|CLONE_CHILD_SETTID|SIGCHLD, child_tidptr=0xb7cd9928) = 2070
--- SIGCHLD (Child exited) @ 0 (0) ---
close(8) = 0
close(10) = 0
waitpid(2070, [{WIFEXITED(s) && WEXITSTATUS(s) == 0}], 0) = 2070
read(7, "", 8) = 0
read(9, "\27\10\0\0", 4) = 4
read(9, "", 0) = 0
close(7) = 0
close(9) = 0
close(6) = 0
write(4, "C\2\5\0\1\0\300\1\2\0\300\1\f\0\f\1\240\1\6\0F\0\5\0\1"..., 40) = 40
ioctl(4, FIONREAD, [0]) = 0
poll([{fd=5, events=POLLIN|POLLPRI}], 1, 0) = 0
nanosleep({0, 20000000}, NULL) = 0
write(4, "C\2\5\0\1\0\300\1\2\0\300\1\f\0\f\1\240\1\6\0F\0\5\0\1"..., 40) = 40
ioctl(4, FIONREAD, [0]) = 0
poll([{fd=5, events=POLLIN|POLLPRI}], 1, 0) = 0
nanosleep({0, 20000000}, NULL) = 0

Stefano Costa (steko) wrote :

just to add some piece of info:

I think this could be related in some way to fglrx. briefly, here's why.

the hibernate function on my laptop doesn't work very well, most of the times it won't enable me to restore my session (and this is another bug ;) but in those rare cases when it does, for some reason it doesn't load the fglrx kernel module (and thus DRI and the like are not working).
But in such a situation, OOo started nicely for 2/2 times.

I can't understand why other users on the same machine have no problems using OOo, but running as root doesn't work as well: "sudo ooffice" or "sudo su" then "ooffice" aren't working. hope this gets fixed soon, obviously willful to help!

Stefano Costa (steko) wrote :

here's some "strace ooffice" results:

* my user (where OOo doesn't work) : http://steko.iosa.it/openoffice/opofsteko

* the "guest" user (where it works): http://steko.iosa.it/openoffice/opofguest

* my user after deleting the ~/.openoffice.org2 directory (doesn't work) http://steko.iosa.it/openoffice/opofsteko2

* the "guest" user after deleting the ~/.openoffice.org2 directory
http://steko.iosa.it/openoffice/opofguest2

Another thing I noticed is that on other users the "ooqstart" process doesn't show up in the process list, while I've got it running when the starting process fails. I haven't got the "quickstart" option on (and it isn't in the gnome-session-properties list), but could this be related ?

Stefano Costa (steko) wrote :

double checked, and now I'm 99% sure it's caused someway by fglrx. If I run without it, OOo starts nicely.

http://steko.iosa.it/openoffice/fglrx-off

here's the strace for a working session. I'm not able to understand it in a useful way, but I put it here so if someone can unserstand what's going on..

Pavel Mlčoch (pavkamlc) wrote :

Because ATI doesnt support graphics cards <= Radeon 9250
https://a248.e.akamai.net/f/674/9206/0/www2.ati.com/drivers/linux/linux_8.29.6.html#173867
I think, this bug may be closed :(

Oddly enough it worked just a few months ago. I would suggest
reverting to the last known release, unless you just want to throw
away r200 users as well.

Don.

On 9/22/06, Pavel Mlčoch <email address hidden> wrote:
> *** This bug is a duplicate of bug 47371 ***
>
> Because ATI doesnt support graphics cards <= Radeon 9250
> https://a248.e.akamai.net/f/674/9206/0/www2.ati.com/drivers/linux/linux_8.29.6.html#173867
> I think, this bug may be closed :(
>
> --
> OOo won't start after showing splash screen
> https://launchpad.net/bugs/42711
>

Jone Marius Vignes (inful) wrote :

It did work under breezy for me as well ( ATI Technologies Inc Radeon R250 Lf [FireGL 9000] (rev 01))

Yajun Wang (yalding) wrote :

I never had OO running in my Dapper box ever. The /home/yalding/.xinput.d/zh_CN is a link other than a file there.

My graphic card is: 0000:01:00.0 VGA compatible controller: ATI Technologies Inc RV370 5B60 [Radeon X300 (PCIE)]

I am using the official fglrx package in Dapper.

$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON X300/X550 Series Generic
OpenGL version string: 2.0.5814 (8.25.18)

Any suggestion to bring OO to life (except upgrading which once broke my machine)?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers