Ubuntu

[Edgy MoM] Please sync openscenegraph 1.0.0-9 from Debian Sid (main)

Reported by Daniel T Chen on 2006-08-19
4
Affects Status Importance Assigned to Milestone
openscenegraph (Ubuntu)
Undecided
Unassigned

Bug Description

Daniel T Chen (crimsun) wrote :

Including relevant details per new sync policy.

New Debian changes:

 openscenegraph (1.0.0-9) unstable; urgency=low
 .
   * Depend on gdal 1.3.2 (closes: #383141)

 openscenegraph (1.0.0-8) unstable; urgency=low
 .
   * add missing dependency to libproducer-dev package (libgl1-mesa-dev)

Old Ubuntu changes, marked by a leading hyphen, that can be overridden (each followed by rationale, marked by a leading asterisk):

- libopenscenegraph-dev depends on libproducer-dev. (Malone: #3995)
* In debian/control: Depends: libopenthreads-dev, libproducer-dev, libopenscenegraph2 (= ${Source-Version})

- Fix libopenscenegraph-dev's Depends to align with Ubuntu's GL transition.
* No longer relevant, as there are no explicit GL{,u} dependencies listed for libopenscenegraph-dev in debian/control. Likewise, Debian's Depends for libproducer-dev contains the correct GL dependency.

- Make openscenegraph Build-Depend on the proper libgdal1-dev (not libgdal-dev, which is no longer available in Dapper).
* libgdal1-1.3.1-dev is now used

- Rebuild against new libxine-main1
* (No changes)

- Fix FTBFS caused by new handling of escaped newlines in make by adding spaces where needed
[&&]
- Fix the missed Makefiles too
* New Debian revision compiles in an Edgy pbuilder.

[Updating] openscenegraph (0.9.9-7ubuntu5 [Ubuntu] < 1.0.0-9 [Debian])
 * Trying to add openscenegraph...
  - <openscenegraph_1.0.0-9.dsc: downloading from http://ftp.debian.org/debian/> - <openscenegraph_1.0.0.orig.tar.gz: downloading from http://ftp.debian.org/debian/>
  - <openscenegraph_1.0.0-9.diff.gz: downloading from http://ftp.debian.org/debian/>
I: openscenegraph [universe] -> libproducer-dev_0.9.9-7ubuntu5 [universe].
I: openscenegraph [universe] -> openscenegraph_0.9.9-7ubuntu5 [universe].
I: openscenegraph [universe] -> libopenscenegraph-dev_0.9.9-7ubuntu5 [universe].I: openscenegraph [universe] -> openscenegraph-doc_0.9.9-7ubuntu5 [universe].
I: openscenegraph [universe] -> producer-doc_0.9.9-7ubuntu5 [universe].
I: openscenegraph [universe] -> openthreads-doc_0.9.9-7ubuntu5 [universe].
I: openscenegraph [universe] -> libopenthreads-dev_0.9.9-7ubuntu5 [universe].

Changed in openscenegraph:
status: Unconfirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers