openssl 1.0.1e-3ubuntu1.4 source package in Ubuntu

Changelog

openssl (1.0.1e-3ubuntu1.4) saucy-security; urgency=medium

  * SECURITY UPDATE: arbitrary code execution via DTLS invalid fragment
    - debian/patches/CVE-2014-0195.patch: add consistency check for DTLS
      fragments in ssl/d1_both.c.
    - CVE-2014-0195
  * SECURITY UPDATE: denial of service via DTLS recursion flaw
    - debian/patches/CVE-2014-0221.patch: handle DTLS hello request without
      recursion in ssl/d1_both.c.
    - CVE-2014-0221
  * SECURITY UPDATE: MITM via change cipher spec
    - debian/patches/CVE-2014-0224-1.patch: only accept change cipher spec
      when it is expected in ssl/s3_clnt.c, ssl/s3_pkt.c, ssl/s3_srvr.c,
      ssl/ssl3.h.
    - debian/patches/CVE-2014-0224-2.patch: don't accept zero length master
      secrets in ssl/s3_pkt.c.
    - debian/patches/CVE-2014-0224-3.patch: allow CCS after resumption in
      ssl/s3_clnt.c.
    - CVE-2014-0224
  * SECURITY UPDATE: denial of service via ECDH null session cert
    - debian/patches/CVE-2014-3470.patch: check session_cert is not NULL
      before dereferencing it in ssl/s3_clnt.c.
    - CVE-2014-3470
 -- Marc Deslauriers <email address hidden>   Mon, 02 Jun 2014 14:04:18 -0400

Upload details

Uploaded by:
Marc Deslauriers on 2014-06-02
Uploaded to:
Saucy
Original maintainer:
Ubuntu Developers
Architectures:
any all
Section:
utils
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size SHA-256 Checksum
openssl_1.0.1e.orig.tar.gz 4.3 MiB f74f15e8c8ff11aa3d5bb5f276d202ec18d7246e95f961db76054199c69c1ae3
openssl_1.0.1e-3ubuntu1.4.debian.tar.gz 113.0 KiB dc8590feda733e3590775060c3b91fcd403c7d96de86827522e3d71c6987792d
openssl_1.0.1e-3ubuntu1.4.dsc 2.3 KiB 32ac7aa55e47277c2feb6064bf0891a87b3b8ecf400a1d6833a81c15b7707466

View changes file

Binary packages built by this source

libcrypto1.0.0-udeb: No summary available for libcrypto1.0.0-udeb in ubuntu saucy.

No description available for libcrypto1.0.0-udeb in ubuntu saucy.

libssl-dev: No summary available for libssl-dev in ubuntu saucy.

No description available for libssl-dev in ubuntu saucy.

libssl-doc: No summary available for libssl-doc in ubuntu saucy.

No description available for libssl-doc in ubuntu saucy.

libssl1.0.0: No summary available for libssl1.0.0 in ubuntu saucy.

No description available for libssl1.0.0 in ubuntu saucy.

libssl1.0.0-dbg: No summary available for libssl1.0.0-dbg in ubuntu saucy.

No description available for libssl1.0.0-dbg in ubuntu saucy.

libssl1.0.0-udeb: No summary available for libssl1.0.0-udeb in ubuntu saucy.

No description available for libssl1.0.0-udeb in ubuntu saucy.

openssl: No summary available for openssl in ubuntu saucy.

No description available for openssl in ubuntu saucy.