pam 1.1.8-3.1ubuntu3.1 source package in Ubuntu

Changelog

pam (1.1.8-3.1ubuntu3.1) wily-security; urgency=medium

  * SECURITY UPDATE: username enumeration via large passwords
    - debian/patches-applied/cve-2015-3238.patch: limit password size to
      prevent a helper function hang in modules/pam_exec/pam_exec.8.xml,
      modules/pam_exec/pam_exec.c, modules/pam_unix/pam_unix.8.xml,
      modules/pam_unix/pam_unix_passwd.c, modules/pam_unix/passverify.c,
      modules/pam_unix/passverify.h, modules/pam_unix/support.c.
    - CVE-2015-3238

 -- Marc Deslauriers <email address hidden>  Tue, 15 Mar 2016 14:40:16 -0400

Upload details

Uploaded by:
Marc Deslauriers on 2016-03-15
Uploaded to:
Wily
Original maintainer:
Ubuntu Developers
Architectures:
any all
Section:
libs
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size SHA-256 Checksum
pam_1.1.8.orig.tar.gz 1.8 MiB 4183409a450708a976eca5af561dbf4f0490141a08e86e4a1e649c7c1b094876
pam_1.1.8-3.1ubuntu3.1.diff.gz 194.4 KiB 7665c0d5d4a55e690c2f67704426bc7b362a1e1da8f44a9dacbbd0bba29fcbc8
pam_1.1.8-3.1ubuntu3.1.dsc 2.5 KiB f1d150113634a29141b27e57bb82a1425c596d2460a2486c3e5e46e186ebd003

View changes file

Binary packages built by this source

libpam-cracklib: No summary available for libpam-cracklib in ubuntu wily.

No description available for libpam-cracklib in ubuntu wily.

libpam-cracklib-dbgsym: No summary available for libpam-cracklib-dbgsym in ubuntu wily.

No description available for libpam-cracklib-dbgsym in ubuntu wily.

libpam-doc: No summary available for libpam-doc in ubuntu wily.

No description available for libpam-doc in ubuntu wily.

libpam-modules: No summary available for libpam-modules in ubuntu wily.

No description available for libpam-modules in ubuntu wily.

libpam-modules-bin: No summary available for libpam-modules-bin in ubuntu wily.

No description available for libpam-modules-bin in ubuntu wily.

libpam-modules-bin-dbgsym: No summary available for libpam-modules-bin-dbgsym in ubuntu wily.

No description available for libpam-modules-bin-dbgsym in ubuntu wily.

libpam-modules-dbgsym: No summary available for libpam-modules-dbgsym in ubuntu wily.

No description available for libpam-modules-dbgsym in ubuntu wily.

libpam-runtime: No summary available for libpam-runtime in ubuntu wily.

No description available for libpam-runtime in ubuntu wily.

libpam0g: No summary available for libpam0g in ubuntu wily.

No description available for libpam0g in ubuntu wily.

libpam0g-dbgsym: No summary available for libpam0g-dbgsym in ubuntu wily.

No description available for libpam0g-dbgsym in ubuntu wily.

libpam0g-dev: No summary available for libpam0g-dev in ubuntu wily.

No description available for libpam0g-dev in ubuntu wily.