Change log for pandoc package in Ubuntu

175 of 87 results
Published in eoan-release on 2019-04-18
Published in disco-release on 2019-01-02
Deleted in disco-proposed (Reason: moved to release)
pandoc (2.2.1-3build1) disco; urgency=medium

  * Rebuild against new GHC ABI.

 -- Gianfranco Costamagna <email address hidden>  Tue, 01 Jan 2019 15:37:28 +0100
Superseded in disco-release on 2019-01-02
Deleted in disco-proposed on 2019-01-03 (Reason: moved to release)
pandoc (2.2.1-3) unstable; urgency=medium

  * Add patch cherry-picked upstream to allow tasty 1.1.
    Thanks to Ilias Tsitsimpis.
  * Set Rules-Requires-Root: no.
  * Declare compliance with Debian Policy 4.2.1.
  * Update package relations:
    + Relax GHC upper bounds for tasty.
    + Fix relax GHC upper bounds for tasty-quickcheck.

 -- Jonas Smedegaard <email address hidden>  Wed, 24 Oct 2018 10:25:47 +0200
Superseded in disco-release on 2018-12-20
Published in cosmic-release on 2018-07-06
Deleted in cosmic-proposed (Reason: moved to release)
pandoc (2.2.1-2build2) cosmic; urgency=medium

  * Rebuild against new GHC ABI.

 -- Gianfranco Costamagna <email address hidden>  Wed, 04 Jul 2018 16:25:54 +0200

Available diffs

Superseded in cosmic-release on 2018-07-06
Deleted in cosmic-proposed on 2018-07-07 (Reason: moved to release)
pandoc (2.2.1-2build1) cosmic; urgency=medium

  * Rebuild against new GHC ABI.

 -- Gianfranco Costamagna <email address hidden>  Mon, 25 Jun 2018 15:58:03 +0200
Superseded in cosmic-proposed on 2018-06-25
pandoc (2.2.1-2) unstable; urgency=medium

  * Fix potential privacy breaches in templates:
    + Add patch 2001 to replace CDN URLs with local paths.
    + Add README.Debian note about Debian packaging favoring locally
      installed resources over network resources for so-called
      standalone documents.
    + Add TODO note about slidy format needing privacy breach fix.
    + Suggest packages libjs-mathjax node-katex, and mention their use
      in long description.
    Closes: Bug#901373. Thanks to Sean Whitton.
  * Mark binary package pandoc-data as Multi-Arch: foreign.

 -- Jonas Smedegaard <email address hidden>  Tue, 12 Jun 2018 15:33:38 +0200

Available diffs

Superseded in cosmic-proposed on 2018-06-12
pandoc (2.2.1-1) unstable; urgency=medium

  [ upstream ]
  * New release.

  [ Jonas Smedegaard ]
  * Update watch file:
    + Fix typo in usage comment.
    + Mention gbp option --upstream-vcs-tag in usage comment.
  * Update package relations: Relax GHC upper bounds for texmath.

 -- Jonas Smedegaard <email address hidden>  Fri, 01 Jun 2018 09:49:39 +0200

Available diffs

Superseded in cosmic-proposed on 2018-06-01
pandoc (2.2-1) unstable; urgency=medium

  [ upstream ]
  * New release(s).

  [ Jonas Smedegaard ]
  * Suppress lintian overrides regarding License-Reference for GPL-2.
  * Update Maintainer email address.
  * Declare compliance with Debian Policy 4.1.4.
  * Fix update -doc build-dependencies.
  * Stop repackage upstream source: No longer contains non-DFSG files.
  * Drop all patches: Applied/obsoleted upstream.
  * Update copyright info:
    + Extend coverage for main upstream authors.
    + Sort main upstream authors.
  * Update long descriptions:
    + Add new readers: EPUB, FictionBook2.
    + Simplify documenting suggested package requirements.
    + Mention use of ghc nodejs php perl python ruby r-base-core as
      filter interpreters.
  * Update package relations:
    + Tighten GHC lower bounds for pandoc-types.
    + Relax GHC upper bounds for exceptions aeson skylighting temporary
      haddock-library.
    + Fix suggest filter interpreters: ghc nodejs php perl python ruby
      r-base-core.

 -- Jonas Smedegaard <email address hidden>  Sun, 29 Apr 2018 15:25:44 +0200
Superseded in cosmic-release on 2018-06-27
Published in bionic-release on 2018-02-01
Deleted in bionic-proposed (Reason: moved to release)
pandoc (1.19.2.4~dfsg-1build4) bionic; urgency=medium

  * Rebuild against new GHC ABI.

 -- Gianfranco Costamagna <email address hidden>  Fri, 26 Jan 2018 13:52:22 +0100
Superseded in bionic-release on 2018-02-01
Deleted in bionic-proposed on 2018-02-02 (Reason: moved to release)
pandoc (1.19.2.4~dfsg-1build3) bionic; urgency=medium

  * Rebuild against new GHC ABI.

 -- Gianfranco Costamagna <email address hidden>  Wed, 20 Dec 2017 22:53:53 +0100
Superseded in bionic-release on 2017-12-21
Deleted in bionic-proposed on 2017-12-22 (Reason: moved to release)
pandoc (1.19.2.4~dfsg-1build2) bionic; urgency=medium

  * Rebuild against new GHC ABI.

 -- Gianfranco Costamagna <email address hidden>  Sun, 26 Nov 2017 18:03:55 +0100
Superseded in bionic-release on 2017-11-27
Deleted in bionic-proposed on 2017-11-28 (Reason: moved to release)
pandoc (1.19.2.4~dfsg-1build1) bionic; urgency=medium

  * No-change rebuild for new GHC ABIs

 -- Steve Langasek <email address hidden>  Mon, 06 Nov 2017 21:41:31 -0800
Superseded in bionic-proposed on 2017-11-07
pandoc (1.19.2.4~dfsg-1) unstable; urgency=medium

  [ upstream ]
  * New release(s).
    + Fix build with GHC 8.2.1.
    + Add CPP to Setup.hs so it works with Cabal >= 2 and < 2.

  [ Jonas Smedegaard ]
  * Fix suggest context. Improve long description to mention its use.
  * Generate and install bash-completion snippet.
    Build-depend on bash-completion.
  * Declare compliance with Debian Policy 4.1.1.
  * Fix update README.Debian to cover current needs for suggested
    packages.
  * Tighten lintian overrides regarding License-Reference.
  * Enable testsuite.
  * Drop no longer relevant TODO notes.
  * Update package relations:
    + Fix relax GHC upper bounds for diff (as done upstream since 1.11).
    + Relax GHC upper bounds for syb aeson quickcheck2 hunit
      ansi-terminal.
    + Tighten GHC upper bounds for pandoc-types.
  * Refresh and extend patches.
  * Fix repackage upstream source, stripping LaTeXMathML.js:
    Accidentally released 1.19.2.1.0 without stripping.
  * Update copyright info: Use https protocol in file format URL.
  * Use https protocol in homepage URL.
  * Update watch file: Use substitution strings. Tighten dversionmangle.

 -- Jonas Smedegaard <email address hidden>  Fri, 27 Oct 2017 14:04:20 +0200
Superseded in bionic-release on 2017-11-22
Published in artful-release on 2017-08-05
Deleted in artful-proposed (Reason: moved to release)
pandoc (1.19.2.1.0-1) unstable; urgency=medium

  [ upstream ]
  * New release(s).
    + Fixes lang-Variable collision between pandoc-citeproc and Babel.
      Closes: Bug#870248. Thanks to Claus-Michael.

  [ Jonas Smedegaard ]
  * Update package relations:
    + Add GHC for skylighting (replacing highlighting-kate).
    + Relax GHC upper bounds for aeson blaze-html blaze-markup vector.
  * Update copyright info: Extend coverage for main authors.
  * Drop patch 2003 (relax GHC upper bounds for directory): Relaxed
    upstream now.
  * Unfuzz patches.
  * Add patches cherry-picked upstream to use newer skylighting and
    mention skylighting (not highlighting-kate) in manpage.

 -- Jonas Smedegaard <email address hidden>  Tue, 01 Aug 2017 12:33:19 -0400
Superseded in artful-release on 2017-08-05
Deleted in artful-proposed on 2017-08-06 (Reason: moved to release)
pandoc (1.19.2.1~dfsg+really1.19.1-1) unstable; urgency=medium

  * Revert to upstream release 1.19.1: Avoid broken skylighting.

 -- Jonas Smedegaard <email address hidden>  Wed, 26 Jul 2017 16:20:44 +0000
Superseded in artful-proposed on 2017-07-26
pandoc (1.19.2.1~dfsg-1) unstable; urgency=medium

  [ upstream ]
  * New release(s).

  [ Jonas Smedegaard ]
  * Update package relations:
    + Add GHC for skylighting (replacing highlighting-kate).
    + Relax GHC upper bounds for aeson blaze-html blaze-markup vector.
  * Update copyright info:
    + Extend coverage for main authors.
  * Drop patch 2003: Upstream now relax GHC upper bounds for directory.
  * Unfuzz patches, and advertise DEP3 format.

 -- Jonas Smedegaard <email address hidden>  Tue, 25 Jul 2017 23:01:48 +0000

Available diffs

Superseded in artful-release on 2017-07-28
Deleted in artful-proposed on 2017-07-29 (Reason: moved to release)
pandoc (1.19.1~dfsg-1) unstable; urgency=medium

  [ upstream ]
  * New release.

  [ Jonas Smedegaard ]
  * Update package relations:
    + Add GHC for doctemplates.
    + Tighten GHC lower bounds for mtl.
    + Shift GHC bounds for texmath pandoc-types.
    + Drop GHC lower bounds for network-uri zip-archive tagsoup
      blaze-html yaml vector sha cmark http-types.
    + Drop GHC lower bounds for diff (but unused as testsuite skipped).
    + Relax to build-depend unversioned on haskell-devscripts.
    + Relax to suggest unversioned texlive-latex-extra: Needed versions
      satisfied even in oldsable.
    + Relax GHC upper bounds for aeson.
    + Relax GHC upper bounds for hunit (but unused as testsuite is
      skipped).
  * Stop override lintian for
    package-needs-versioned-debhelper-build-depends: Fixed in lintian.
  * Update copyright info: Add and tidy some copyright holders.
  * Modernize cdbs:
    + Check copyright in maintainer script (not during build).
    + Stop build-Depend on licensecheck libregexp-assemble-perl
      libimage-exiftool-perl libfont-ttf-perl.
    + Relax to build-depend unversioned on cdbs.
  + Update patches:
    + Drop patch 2002: Upstream relaxed GHC lower bounds for http-client
      http-client-tls.
    + Unfuzz patches.
  * Install README.md.
  * Modernize Vcs-Browser field: Use git (not cgit) in path.
  * Declare compliance with Debian Policy 4.0.0.

 -- Jonas Smedegaard <email address hidden>  Fri, 21 Jul 2017 20:12:57 +0200
Superseded in artful-proposed on 2017-07-21
pandoc (1.17.2~dfsg-4build2) artful; urgency=medium

  * Rebuild against new GHC ABI.

 -- Gianfranco Costamagna <email address hidden>  Thu, 20 Jul 2017 16:43:56 +0200
Superseded in artful-release on 2017-07-22
Deleted in artful-proposed on 2017-07-23 (Reason: moved to release)
pandoc (1.17.2~dfsg-4build1) artful; urgency=medium

  * Rebuild against new GHC ABI.

 -- Gianfranco Costamagna <email address hidden>  Thu, 22 Jun 2017 19:56:15 +0200
Superseded in artful-proposed on 2017-06-22
pandoc (1.17.2~dfsg-4) unstable; urgency=medium

  * Team upload.
  * Bump directory bounds on buildds.

 -- Gianfranco Costamagna <email address hidden>  Wed, 21 Jun 2017 08:53:51 +0200
Superseded in artful-proposed on 2017-06-21
pandoc (1.17.2~dfsg-3build2) artful; urgency=medium

  * No-change rebuild for new GHC ABIs

 -- Steve Langasek <email address hidden>  Wed, 21 Jun 2017 05:19:13 +0000
Superseded in artful-release on 2017-06-24
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed on 2018-06-22 (Reason: moved to release)
pandoc (1.17.2~dfsg-3build1) zesty; urgency=medium

  * Bump directory bounds on buildds.

 -- Bhavani Shankar <email address hidden>  Mon, 30 Jan 2017 18:10:50 +0530
Superseded in zesty-release on 2017-01-31
Deleted in zesty-proposed on 2017-02-01 (Reason: moved to release)
pandoc (1.17.2~dfsg-3) unstable; urgency=medium

  * Reduce compile-time memory utilization on mips and mipsel.

 -- Clint Adams <email address hidden>  Fri, 11 Nov 2016 22:46:37 -0500
Superseded in zesty-release on 2016-11-15
Deleted in zesty-proposed on 2016-11-16 (Reason: moved to release)
pandoc (1.17.2~dfsg-1build4) zesty; urgency=medium

  * No-change rebuild for new GHC ABIs

 -- Steve Langasek <email address hidden>  Mon, 24 Oct 2016 20:30:00 -0700
Superseded in zesty-proposed on 2016-10-25
pandoc (1.17.2~dfsg-1build3) zesty; urgency=medium

  * No-change rebuild for new GHC ABIs

 -- Steve Langasek <email address hidden>  Mon, 24 Oct 2016 00:40:30 -0700
Superseded in zesty-proposed on 2016-10-24
pandoc (1.17.2~dfsg-1build2) zesty; urgency=medium

  * No-change rebuild for new GHC ABIs

 -- Steve Langasek <email address hidden>  Sun, 23 Oct 2016 00:38:26 +0000
Superseded in zesty-release on 2016-10-26
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed on 2018-01-23 (Reason: moved to release)
pandoc (1.17.2~dfsg-1build1) yakkety; urgency=medium

  * Rebuild against new GHC ABI.

 -- Gianfranco Costamagna <email address hidden>  Fri, 02 Sep 2016 18:14:44 +0200
Superseded in yakkety-proposed on 2016-09-03
pandoc (1.17.2~dfsg-1) unstable; urgency=medium

  [ upstream ]
  * New release.
    + Fix links with no explicit link text.
      Closes: Bug#828167.

  [ Jonas Smedegaard ]
  * Update long descriptions to (almost) sync with upstream cabal file:
    + Mention new writer for ZimWiki.
    + Mention reader for TWiki markup.
    + Mention explicitly each of readers XHTML and HTML 5.
  * Update package relations:
    + Relax GHC upper bounds for tagsoup http-client http-client-tls
      quickcheck2.
    + Tighten GHC lower bounds for texmath.
  * Add patch 2002 to revert recent seemingly unneeded build-dependency
    tightening for http-client and http-client-tls.
  * Unfuzz patches.
  * Modernize CDBS: Build-depend on licensecheck (not devscripts).

 -- Jonas Smedegaard <email address hidden>  Fri, 26 Aug 2016 12:49:00 +0200
Superseded in yakkety-release on 2016-09-04
Deleted in yakkety-proposed on 2016-09-05 (Reason: moved to release)
pandoc (1.17.0.3~dfsg-2build4) yakkety; urgency=medium

  * Rebuild against new GHC ABI.

 -- Gianfranco Costamagna <email address hidden>  Sun, 21 Aug 2016 20:27:42 +0200
Superseded in yakkety-proposed on 2016-08-21
pandoc (1.17.0.3~dfsg-2build3) yakkety; urgency=medium

  * Rebuild against new GHC ABI.

 -- Gianfranco Costamagna <email address hidden>  Fri, 05 Aug 2016 20:59:02 +0200
Superseded in yakkety-proposed on 2016-08-05
pandoc (1.17.0.3~dfsg-2build2) yakkety; urgency=medium

  * No-change rebuild against libghc-unordered-containers-dev-0.2.7.1

 -- Steve Langasek <email address hidden>  Fri, 15 Jul 2016 06:59:06 +0000
Superseded in yakkety-proposed on 2016-07-15
pandoc (1.17.0.3~dfsg-2build1) yakkety; urgency=medium

  * No-change rebuild against libghc-scientific-dev-0.3.4.8

 -- Steve Langasek <email address hidden>  Fri, 15 Jul 2016 06:40:31 +0000
Superseded in yakkety-release on 2016-08-22
Deleted in yakkety-proposed on 2016-08-24 (Reason: moved to release)
pandoc (1.17.0.3~dfsg-2) unstable; urgency=medium

  * Fix pandoc dependency on pandoc-doc.
    Closes: Bug#826537. Thanks to Simon McVittie.

 -- Jonas Smedegaard <email address hidden>  Mon, 06 Jun 2016 20:36:14 +0200
Superseded in yakkety-proposed on 2016-06-07
pandoc (1.17.0.3~dfsg-1) unstable; urgency=medium

  [ upstream ]
  * New release(s).

  [ Jonas Smedegaard ]
  * Update watch file:
    + Add usage comment.
    + Bump to version 4.
    + Add repacksuffix option.
    + Use substitution variables.
  * Drop CDBS get-orig-source target: Use "gbp import-orig --uscan"
    instead.
  * Update copyright info:
    + Extend coverage for upstream authors to include current year.
    + Extend coverage of packaging to include current year.
  * Update long descriptions to mention new writer TEI Simple.
  * Declare compliance with Debian Policy 3.9.8.
  * Use https protocol in Vcs-Git URL.
  * Modernize git-buildpackage config:
    + Drop git- prefix.
    + Ignore anything .git*.
  * Unfuzz patches.
  * Modernize copyright-check.
  * Update package relations:
    + Relax GHC upper bounds for zip-archive aeson.
    + Tighten GHC lower bounds for tagsoup.
    + Tighten to build-depend versioned on cdbs: Needed for improved
      copyright-check.

 -- Jonas Smedegaard <email address hidden>  Wed, 01 Jun 2016 16:21:34 +0200
Superseded in yakkety-release on 2016-07-03
Published in xenial-release on 2016-02-25
Deleted in xenial-proposed (Reason: moved to release)
pandoc (1.16.0.2~dfsg-1) unstable; urgency=medium

  [ upstream ]
  * New release(s).
    + Fix regression in latex smart quote parsing.
      Closes: Bug#810981. Thanks to Paul Menzel.

  [ Jonas Smedegaard ]
  * Update package relations:
    + Suggest wkhtmltopdf, and document its use in long description.
    + Relax GHC upper bounds for http.
    + Tighten GHC lower bounds for texmath highlighting-kate.
    + Shift GHC bounds for pandoc-types cmark.
    + Stop GHC for deepseq-generics.
  * Sync long description with upstream description.
  * Exclude in repackaged upstream tarball yet another docx file lacking
    license.
  * Drop upstream cherry-picked patch now applied.
  * Unfuzz patches.
  * Fix (re)install man page.
    Closes: Bug#797469. Thanks to Alexander Kurtz and others.
  * Stop provide symlink for command hsmarkdown: No longer supported
    upstream.
  * Mark pandoc Multi-Arch:foreign, to ease bootstrapping new archs.
    Closes: bug#787894. Thanks to Johannes Schauer.
  * Fix tighten pandoc dependency on pandoc-data.
    Closes: bug#800935. Thanks to Oleksandr Gavenko.

 -- Jonas Smedegaard <email address hidden>  Fri, 19 Feb 2016 16:02:48 +0100
Superseded in xenial-proposed on 2016-02-22
pandoc (1.15.1.1~dfsg-2build2) xenial; urgency=medium

  * Rebuild for new GHC ABIs.

 -- Colin Watson <email address hidden>  Thu, 18 Feb 2016 16:39:32 +0000
Superseded in xenial-release on 2016-02-25
Deleted in xenial-proposed on 2016-02-26 (Reason: moved to release)
pandoc (1.15.1.1~dfsg-2build1) xenial; urgency=medium

  * Rebuild for new GHC ABIs.

 -- Colin Watson <email address hidden>  Wed, 27 Jan 2016 16:32:00 +0000
Superseded in xenial-release on 2016-02-10
Deleted in xenial-proposed on 2016-02-11 (Reason: moved to release)
pandoc (1.15.1.1~dfsg-2) unstable; urgency=medium

  * Upload to unstable.

 -- Clint Adams <email address hidden>  Sun, 06 Dec 2015 18:24:16 -0500
Superseded in xenial-release on 2015-12-20
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed on 2018-01-22 (Reason: moved to release)
pandoc (1.13.2.1~dfsg-1build6) wily; urgency=medium

  * Rebuild for new GHC ABIs.

 -- Colin Watson <email address hidden>  Mon, 17 Aug 2015 12:41:52 +0100
Superseded in wily-release on 2015-08-17
Deleted in wily-proposed on 2015-08-19 (Reason: moved to release)
pandoc (1.13.2.1~dfsg-1build5) wily; urgency=medium

  * Rebuild for new GHC ABIs.

 -- Colin Watson <email address hidden>  Wed, 05 Aug 2015 18:54:49 +0100
Superseded in wily-proposed on 2015-08-05
pandoc (1.13.2.1~dfsg-1build4) wily; urgency=medium

  * Rebuild for new GHC ABIs.

 -- Colin Watson <email address hidden>  Thu, 23 Jul 2015 20:28:14 +0100
Superseded in wily-proposed on 2015-07-23
pandoc (1.13.2.1~dfsg-1build3) wily; urgency=medium

  * Rebuild for new GHC ABIs.

 -- Colin Watson <email address hidden>  Thu, 23 Jul 2015 09:52:34 +0100
Superseded in wily-release on 2015-08-12
Deleted in wily-proposed on 2015-08-13 (Reason: moved to release)
pandoc (1.13.2.1~dfsg-1build2) wily; urgency=medium

  * Rebuild for new GHC ABIs.

 -- Colin Watson <email address hidden>  Mon, 06 Jul 2015 10:21:41 +0100
Superseded in wily-release on 2015-07-10
Deleted in wily-proposed on 2015-07-11 (Reason: moved to release)
pandoc (1.13.2.1~dfsg-1build1) wily; urgency=medium

  * Rebuild for new GHC ABIs.

 -- Colin Watson <email address hidden>  Tue, 23 Jun 2015 20:27:06 +0100
Superseded in wily-proposed on 2015-06-23
pandoc (1.13.2.1~dfsg-1) unstable; urgency=medium

  [ upstream ]
  * New release.
    + Update to build with ghc 7.10.1.
    + Bump package upper bounds for filepath, blaze-html, blaze-markup.

  [ Jonas Smedegaard ]
  * Fix really enable network-uri as intended in 1.13.2~dfsg-2 (not only
    add needed package relations, but also drop negating build option).
  * Update package relations:
    + Fix tighten build-dependency on haskell-devscripts to versions
      using unversioned datadir.
    + Relax GHC upper bounds for blaze-html.
    + Relax to drop GHC lower bounds for text data-default scientific
      haddock-library deepseq-generics juicypixels quickcheck2: Needed
      versions satisfied even in oldstable.
    + Revert to build-depend unversioned on haskell-devscripts (was
      needed only for experimental builds).
  * Update copyright info:
    + Extend coverage for myself.
    + Merge identically licensed Flies-sections.
  * Bump debhelper compatibility level to 9.
  * Move packaging to pkg-haskell Alioth group.
  * Declare compliance with Debian Policy 3.9.6.

 -- Jonas Smedegaard <email address hidden>  Wed, 29 Apr 2015 11:45:35 +0200
Superseded in wily-release on 2015-06-24
Obsolete in vivid-release on 2018-01-18
Deleted in vivid-proposed on 2018-01-19 (Reason: moved to release)
pandoc (1.12.4.2~dfsg-1build5) vivid; urgency=medium

  * Rebuild for new GHC ABIs.
 -- Colin Watson <email address hidden>   Sat, 01 Nov 2014 09:49:18 +0000
Superseded in vivid-release on 2014-11-03
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed on 2016-11-03 (Reason: moved to release)
pandoc (1.12.4.2~dfsg-1build4) utopic; urgency=medium

  * Rebuild for new GHC ABIs.
 -- Colin Watson <email address hidden>   Tue, 12 Aug 2014 11:27:14 +0100
Superseded in utopic-release on 2014-08-13
Deleted in utopic-proposed on 2014-08-14 (Reason: moved to release)
pandoc (1.12.4.2~dfsg-1build3) utopic; urgency=medium

  * Rebuild for new GHC ABIs.
 -- Colin Watson <email address hidden>   Fri, 18 Jul 2014 14:45:11 +0100
Superseded in utopic-release on 2014-07-18
Deleted in utopic-proposed on 2014-07-20 (Reason: moved to release)
pandoc (1.12.4.2~dfsg-1build2) utopic; urgency=medium

  * Rebuild for new GHC ABIs.
 -- Colin Watson <email address hidden>   Sat, 05 Jul 2014 20:46:53 +0100
Superseded in utopic-release on 2014-07-05
Deleted in utopic-proposed on 2014-07-07 (Reason: moved to release)
pandoc (1.12.4.2~dfsg-1build1) utopic; urgency=medium

  * Rebuild for new GHC ABIs.
 -- Colin Watson <email address hidden>   Tue, 24 Jun 2014 13:52:50 +0100
Superseded in utopic-proposed on 2014-06-24
pandoc (1.12.4.2~dfsg-1) unstable; urgency=medium


  [ upstream ]
  * New release.

  [ Jonas Smedegaard ]
  * Update long descriptions:
    + Rewrap using Semantic Linefeeds.
    + Mention new reader Emacs Org-mode, and new writer InDesign ICML.
  * Update package relations:
    + Fix tighten GHC (build-)dependencies on quickcheck2 (although
      currently unused: testsuite is disabled).
    + Tighten GHC (build-)dependencies on texmath, pandoc-types, aeson,
      tagsoup, highlighting-kate and yaml.
    + Relax GHC (build-)dependencies on mtl, network and http-conduit.
    + Add GHC (build-)dependencies on scientific.
  * Update copyright info:
    + Extend coverage for upstream authors.
    + Fix double-indent subsequent copyright holders.
    + Extend packaging to cover recent years.
    + Bump licensing of packaging to GPL-3+.
    + Add GPL boilerplate to rules file.

 -- Jonas Smedegaard <email address hidden>  Sun, 22 Jun 2014 09:25:54 +0200
Superseded in utopic-proposed on 2014-06-22
pandoc (1.12.3.3~dfsg-1build2) utopic; urgency=medium

  * Rebuild for new GHC ABIs.
 -- Colin Watson <email address hidden>   Wed, 18 Jun 2014 23:55:43 +0100
Superseded in utopic-release on 2014-07-04
Deleted in utopic-proposed on 2014-07-05 (Reason: moved to release)
pandoc (1.12.3.3~dfsg-1build1) utopic; urgency=medium

  * Rebuild for new GHC ABIs.
 -- Colin Watson <email address hidden>   Tue, 13 May 2014 11:19:42 +0100
Superseded in utopic-release on 2014-05-13
Deleted in utopic-proposed on 2014-05-14 (Reason: moved to release)
pandoc (1.12.3.3~dfsg-1) unstable; urgency=medium


  [ upstream ]
  * New release.
    Closes: bug#738633.

  [ Jonas Smedegaard ]
  * Update package relations:
    + Tighten GHC (build-)dependencies on texmath, highlighting-kate.
    + Relax GHC (build-)dependencies on text, zip-archive, aeson,
      temporary, attoparsec, http-conduit, blaze-html, blaze-markup.
  * Suggest etoolbox, and clarify in long description when it is needed
    (PDF output of content with YAML metadata).
    Closes: bug#740099. Thanks to Michael D Johnson.
  * Unfuzz patch 1001.

 -- Jonas Smedegaard <email address hidden>  Sat, 08 Mar 2014 15:57:19 +0100
Superseded in utopic-release on 2014-05-06
Published in trusty-release on 2014-02-07
Deleted in trusty-proposed (Reason: moved to release)
pandoc (1.12.2.1-1build2) trusty; urgency=medium

  * Rebuild for new GHC ABIs.
 -- Colin Watson <email address hidden>   Thu, 06 Feb 2014 15:03:58 +0000
Superseded in trusty-release on 2014-02-07
Deleted in trusty-proposed on 2014-02-09 (Reason: moved to release)
pandoc (1.12.2.1-1build1) trusty; urgency=medium

  * Rebuild for new GHC ABIs.
 -- Colin Watson <email address hidden>   Wed, 01 Jan 2014 15:07:41 +0000
Superseded in trusty-release on 2014-01-02
Deleted in trusty-proposed on 2014-01-03 (Reason: moved to release)
pandoc (1.12.2.1-1) unstable; urgency=low


  [ upstream ]
  * New release.
    Closes: bug#724636, #731391.

  [ Jonas Smedegaard ]
  * Fix use relative symlink to S5 data files.
  * Update upstream source URL and use TLS (https), in watch file,
    copyright file and CDBS hints in rules file.
    Mangle ~dfsg suffix in watch file.
  * Update long description based on upstream cabal file (seems more
    accurate than upstream README), additionally mentioning PDF
    renderings of LaTeX and GNU Texinfo writer.
  * Add NEWS file with entry on behavior changes, referring to upstream
    changelog for details.
  * Update package relations:
    + Build-depend on alex and happy.
    + Suggest (not yet packaged) pandoc-citeproc.
    + Stop depending on libghc-citeproc-hs-data.
    + Add GHC (build-)dependencies on unordered-containers, aeson (and
      not json), attoparsec, yaml, hslua, http-conduit, http-types and
      text.
    + Tighten GHC (build-)dependencies on texmath, pandoc-types, tagsoup
      and highlighting-kate.
    + Drop GHC (build-)dependencies on citeproc-hs.
  * Repackage upstream source to avoid minified LaTeXMathML.js code.
    Closes: bug#721417. Thanks to Luca Falavigna.
  * Add patch 1001 to use online LaTeXMathML.js by default.
  * Add patch 2001 to avoid dropped files during build.
  * Update copyright file:
    + Stop covering slide show and LaTeXMathML Javascript code: No
      longer shipped.
    + Cover new Haddock reader: partly BSD-2-clause partly GPL-2+
      licensed.

 -- Jonas Smedegaard <email address hidden>  Mon, 30 Dec 2013 14:10:47 +0100

Available diffs

Superseded in trusty-release on 2013-12-31
Deleted in trusty-proposed on 2014-01-02 (Reason: moved to release)
pandoc (1.11.1-5) unstable; urgency=low


  * Have pandoc depend on (not recommend) pandoc-data.
    Closes: bug#724102. Thanks to David Suárez and others involved.
  * Drop bogus note for backporters in changelog entry for 1.11.1-4.
    (note to self: never write notes here, always use README.Debian!).
  * Have pandoc-data symlink and depend on separately packaged S5.
    Closes: bug#631848. Thanks to Clint Adams.
  * Bump standards-version to 3.9.5.
  * Update copyright file to document how Slidy is covered only by W3C
    software license (not also document license).
    Closes: bug#722134. Thanks to Francesco Poli.

 -- Jonas Smedegaard <email address hidden>  Sat, 02 Nov 2013 16:09:01 +0100

Available diffs

Superseded in trusty-release on 2013-11-03
Deleted in trusty-proposed on 2013-11-04 (Reason: moved to release)
pandoc (1.11.1-4) unstable; urgency=low


  * Drop superfluous control file Section declaration.
  * Fix reference to GHC 6 in long description.
  * Introduce new binary-all package pandoc-data.
    Closes: bug#697306. Thanks to Joachim Breitner.
  * Add symlink to unversioned datadir when versioned, to ease
    backporting. Reverse dependencies are recommended to use
      Depends: pandoc-data (<= 1.11.1-4~)
    for a smoothest ride.

 -- Jonas Smedegaard <email address hidden>  Thu, 29 Aug 2013 22:29:13 +0200
Superseded in trusty-release on 2013-10-28
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed on 2015-04-28 (Reason: moved to release)
pandoc (1.11.1-2build2) saucy; urgency=low

  * Rebuild for new GHC ABIs.
 -- Colin Watson <email address hidden>   Mon, 17 Jun 2013 21:03:32 +0100

Available diffs

Superseded in saucy-release on 2013-06-19
Deleted in saucy-proposed on 2013-06-20 (Reason: moved to release)
pandoc (1.11.1-2build1) saucy; urgency=low

  * Rebuild for new GHC ABIs.
 -- Colin Watson <email address hidden>   Thu, 30 May 2013 14:52:29 +0100
Superseded in saucy-proposed on 2013-05-30
pandoc (1.11.1-2) unstable; urgency=low


  * Upload to unstable 

 -- Joachim Breitner <email address hidden>  Sat, 25 May 2013 00:41:12 +0200
Superseded in saucy-release on 2013-05-31
Deleted in saucy-proposed on 2013-06-01 (Reason: moved to release)
pandoc (1.10.1-1build1) saucy; urgency=low

  * Rebuild for new GHC ABIs.
 -- Colin Watson <email address hidden>   Wed, 01 May 2013 00:35:51 -0700
Superseded in saucy-release on 2013-05-03
Obsolete in raring-release on 2015-04-24
Deleted in raring-proposed on 2015-04-27 (Reason: moved to release)
pandoc (1.10.1-1) experimental; urgency=low


  [ upstream ]
  * New release.

  [ Jonas Smedegaard ]
  * Update copyright file:
    + Fix syntax for public-domain files.
    + Fix drop Files section for no longer shipped BSD-3-clause licensed
      files.
    + Extend coverage of main copyright holder.
  * Drop patches: All applied upstream.
  * Update long descriptions base on upstream README.
  * Drop configure flag blaze_html_0_5: Now enabled dy default.
  * Reorder *-doc build-dependencies to match *-dev ones.
  * Update package relations:
    + (Build-)depend on GHC packages data-default and (not only *-doc)
      text: Needed since 1.10.
    + Stop (build-)depending on GHC packages utf8-string: Unneeded since
      1.10.
    + Tighten build-dependencies on GHC packages citeproc-hs,
      pandoc-types, diff, test-framework, test-framework-hunit,
      test-framework-quickcheck2 and template-haskell: Needed since
      1.10.
    + Stop build-depending on GHC -doc package xhtml: Unused since
      1.9.1.1.
    + Stop build-depending on GHC -doc package diff: Seemingly never
      actually used.
    + Build-depend on GHC -doc packages rts and utf8-string: Seemingly
      needed (even if undeclared).
    + Relax (build-dependencies on GHC packages ansi-terminal: Changed
      since 1.10.1.
  * Shrink README.source to simply reference wiki page about used
    packaging style.
  * Suppress dist/ dir in gpb.conf, as workaround for upstream shipping
    dirty build dir.

 -- Jonas Smedegaard <email address hidden>  Sun, 17 Feb 2013 12:55:18 +0100
Superseded in raring-release on 2013-04-15
Obsolete in quantal-release on 2015-04-24
pandoc (1.9.4.2-2build1) quantal; urgency=low

  * No-change rebuild for GHC 7.4.2
 -- Iain Lane <email address hidden>   Sun, 26 Aug 2012 09:11:58 +0000
Superseded in quantal-release on 2012-08-26
pandoc (1.9.4.2-2) unstable; urgency=low


  * Cherry-pick patch from upstream to not build with the threaded runtime.
    It has a performance penalty and is not supported on multiple Debian
    architectures, leading to build failures there. (Closes: #682433)

 -- Iain Lane <email address hidden>  Mon, 23 Jul 2012 20:48:54 +0100

Available diffs

Superseded in quantal-release on 2012-07-24
pandoc (1.9.4.2-1) unstable; urgency=low


  * New upstream version, fixing non-ASCII filenames.
  * Add Recommends on libghc-citeproc-hs-data (for --bibliography).

 -- Clint Adams <email address hidden>  Sat, 30 Jun 2012 07:14:43 -0400

Available diffs

Superseded in quantal-release on 2012-07-01
pandoc (1.9.4.1-1) unstable; urgency=low


  * New upstream release.

  * Update long description to mention new Slideous output format.
  * Tighten (build-)dependencies for highlighting-kate-* packages,
    reflecting upstream change.
  * Drop patch: Adopted upstream.
  * Drop NEWS file: contents relevant only for transisitions from Lenny
    (now oldstable).

 -- Jonas Smedegaard <email address hidden>  Wed, 20 Jun 2012 23:12:23 +0200

Available diffs

Superseded in quantal-release on 2012-06-22
pandoc (1.9.3-1) unstable; urgency=low


  * New upstream release.

  * (Build-)depend on GHC -doc and -prof packages of blaze-builder
    hs-bibutils random and text: Indirectly needed (at least for -doc
    packages) but not pulled in.
  * Update package relations:
    + Fix have pandoc package recommend libghc-citeproc-hs-data.
      Closes: bug#645530.
    + Fix tighten dependencies needed since 1.8.0.1:
      - libghc-utf8-string-*
      - libghc-syb-*
    + Fix drop dependencies unused since 1.9.1.1:
      - libghc-xhtml-*
      - libghc-dlist-*
    + Fix drop dependencies apparently never used:
      - libghc-testpack-*
      - hscolour
    + Fix drop dependencies apparently used only for testsuite (which
      fails currently so is not enabled):
      - diff
      - test-framework-dev
      - test-framework-hunit-dev
      - test-framework-quickcheck2-dev
      - quickcheck-dev
      - hunit-dev
      - template-haskell-dev
      - ansi-terminal-dev
    + Fix exclude upper bound of libghc-zlib-* versioning (<< not <=).
    + Fix have libghc-* packages depend on ${haskell:Extra-Depends}, as
      suggested in bug#645530.
    + Tighten dependencies needed since 1.9.3:
      - libghc-mtl-*
    + Generally relax to drop lower bound of versionings: Satisfied in
      Wheezy and unavailable in Squeeze or Lenny (libghc-* naming was
      introduced post-Squeeze).
    + Build-depend only on libghc-*-prof packages explicitly declared in
      upstream cabal file (only include libghc-*-doc packages when
      Haddock complains).
    + Sort package relations.
  * Extend long description to mention newly added support for reading
    (not only writing) DocBook XML.
  * Add patch 1001 to support setting language in slidy output.
  * Update copyright file: Extend copyright years.

 -- Jonas Smedegaard <email address hidden>  Sun, 20 May 2012 21:34:54 +0200

Available diffs

Superseded in quantal-release on 2012-05-24
Published in precise-release on 2012-03-16
pandoc (1.9.1.1-1) unstable; urgency=low


  * New upstream release.

  [ Kiwamu Okabe ]
  * Allow DM uploads.
  * New debian/watch file to scan pandoc 1.9
  * Bump standards-version to 3.9.3.
  * Move maintenance to Haskell team, with Jonas and Kiwamu as
    uploaders.
  * Add new (build-)dependencies:
    + libghc-blaze-html-*
    + libghc-temporary-*
    + libghc-zlib-*
    Drop obsolete (build-)dependency:
    + libghc-deepseq-*
    Tighten build-dependencies:
    + libghc-http-dev
    + libghc-texmath-dev
    + libghc-pandoc-types-dev
    + libghc-json-dev
    + libghc-highlighting-kate-dev

  [ Jonas Smedegaard ]
  * Newline-delimit uploaders field.
  * Update copyright file:
    + Extend copyright years.
    + Adapt a Files section.
    + Bump copyright format to final version 1.0.
  * Update long descriptions:
    + Mention newly supported output formats:
      - Word Docx
      - AsciiDoc
      - DZSlides.
    + Explicitly mention output formats XHTML and HTML 5.
    + Explicitly mention out put (sub)format LaTeX beamer.
    + No longer mention markdown2pdf: Dropped upstream.

  [ Clint Adams ]
  * Move -doc build dependencies to Build-Depends-Indep.

 -- Clint Adams <email address hidden>  Sun, 04 Mar 2012 20:35:25 -0500
Superseded in precise-release on 2012-03-16
pandoc (1.8.2.1-2build1) precise; urgency=low

  * No change rebuild for new libghc-http-dev
 -- Micah Gersten <email address hidden>   Mon, 26 Dec 2011 00:29:50 -0600
Superseded in precise-release on 2011-12-12
pandoc (1.8.1.1-1ubuntu3) precise; urgency=low

  * Rebuild for new GHC ABIs.
 -- Colin Watson <email address hidden>   Sat, 12 Nov 2011 10:59:10 +0000
Superseded in precise-release on 2011-12-26
pandoc (1.8.2.1-2) unstable; urgency=low


  * Bump debhelper compatibility level to 7.
  * Update package relations:
    + Fix stop bogusly depending on libghc-rts-doc or libghc-rts-prof.
    + Build-depend-indep on ghc-haddock (not on virtual haddock).
    + Add ${haskell:Depends} ${haskell:Recommends} ${haskell:Suggests}
      and ${haskell:Provides}, and stop explicitly suggesting *-doc
      packages.
      This fixes: bug#640963. Thanks to Clint Adams.
    + Fix depend on ${shlibs:Depends}.
    + Relax to build-depend unversioned on devscripts and debhelper:
      Needed version satisfied even in oldstable.

 -- Jonas Smedegaard <email address hidden>  Thu, 29 Sep 2011 16:36:16 +0200
Superseded in precise-release on 2011-11-12
Obsolete in oneiric-release on 2015-04-24
pandoc (1.8.1.1-1ubuntu2) oneiric; urgency=low

  * No change rebuild against new GHC ABIs
 -- Iain Lane <email address hidden>   Thu, 09 Jun 2011 09:23:08 +0100
Superseded in oneiric-release on 2011-06-09
pandoc (1.8.1.1-1ubuntu1) oneiric; urgency=low

  * Change BDI to ghc-haddock explicitly. Can go away once ghc6 is removed and
    there is only one package providing haddock again.

Superseded in oneiric-release on 2011-05-29
Obsolete in natty-release on 2013-06-04
pandoc (1.5.1.1-5ubuntu1) natty; urgency=low

  * d/control: Add missing utf8-string BDs
 -- Iain Lane <email address hidden>   Wed, 16 Feb 2011 13:27:19 +0000
175 of 87 results