parrot 1.0.0-1ubuntu1 source package in Ubuntu

Changelog

parrot (1.0.0-1ubuntu1) karmic; urgency=low

  [ Allison Randal ]
  * Merge from Debian unstable.
  * Ubuntu remaining changes:
   - Add 01-lpia-FTBFS.path : from upstream, fix FTBFS for lpia.

  [ Julien Lavergne ]
   - Add quilt support for the patch :
    + debian/control.in : Add quilt as build-depends.
    + debian/rules : Add quilt support.

parrot (1.0.0-1) unstable; urgency=low

  * New upstream release
  * debian/control.in:
    - Updated Description of all packages.
    - Bumped Standards-Version to 3.8.1
    - Add new packages parrot-minimal and parrot-devel
  * debian/rules:
    - Integrate Ubuntu packaging changes to automatically generate
      debian/control.
    - Re-order dh_installdeb in binary-arch to run after dh_makeshlibs and
      shlibdeps so that the library gets installed properly (patch from David
      Nusinow)
    - Move manpage generation to new packages. Rename parrot-debugger.1 to
      parrot_debugger.1 to match executable name. Generate parrot_config
      manpage from .pir source files (patch from David Nusinow)
  * parrot.install.in, parrot-doc.install.in, libparrot.install.in,
    libparrot-dev.install.in
    - Added template files, replace parrot.install, parrot-doc.install,
      libparrot.install, and libparrot-dev.install
  * parrot-minimal.install.in, parrot-devel.install.in
    - Added template files for new packages
  * parrot-doc.docs, libparrot-dev.dirs
    - Removed
  * libparrot.postinst
    - Added so ldconfig gets called properly by dh_makeshlibs (patch from
      David Nusinow)
  * debian/copyright:
    - Changed copyright holder to Parrot Foundation, reflecting change in
      distribution.
    - Removed copyright info for files no longer in distribution.

parrot (0.9.0-1) unstable; urgency=low

  * New upstream release
  * debian/control.in:
    - Build-Depends removed optional library libicu-dev.
      Removed optional library libgmp3-dev.
    - Depends for libparrot-dev removed optional library
      libicu-dev.
  * debian/rules
    - Removed --optimize flag from configure, known problems
      on 64-bit architectures.
    - Changed 'reallyinstall' target to 'install', matching
      change in source makefile.
  * debian/parrot-doc.docs
    - Updated to sync with doc files in distribution.
  * debian/copyright:
    - Updated copyright years.

parrot (0.7.0-1) unstable; urgency=low

  * New upstream release

parrot (0.6.4-1) unstable; urgency=low

  * New upstream release
  * debian/copyright:
    - Added license link.
    - Updated copyright years.
    - Removed copyright info for files no longer in distribution.

parrot (0.5.1-1) unstable; urgency=low

  * New upstream release (Closes: #444707).
  * debian/control.in:
    - Build-Depends updated to libicu-dev from libicu36-dev
      (Closes: #456835).
    - Depends for libparrot-dev updated to libicu-dev from
      libicu34-dev (Closes: #431289).
    - New maintainer: Parrot Debian Maintainers
      (Closes: #444708)
    - New uploaders: Allison Randal, Nuno Carvalho,
      Patrick Michaud
    - Updated long and short package descriptions.
  * debian/rules
    - Removed install of install_config.o file, no longer in
      distribution.
  * debian/libparrot0.4.12.install
    - Deleted, replaced by debian/libparrot.install.
  * debian/parrot-doc.docs
    - Updated to sync with doc files in distribution.
    - Sorted for easier diffs between generated file lists.
  * debian/copyright:
    - Added license link.
    - Updated copyright years.
    - Removed copyright info for files no longer in distribution.

 -- Julien Lavergne <email address hidden>   Fri, 29 May 2009 01:34:42 +0200

Upload details

Uploaded by:
Julien Lavergne
Sponsored by:
Colin Watson
Uploaded to:
Karmic
Original maintainer:
Ubuntu Development Team
Architectures:
any
Section:
interpreters
Urgency:
Low Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size SHA-256 Checksum
parrot_1.0.0.orig.tar.gz 3.7 MiB f81b44b769fc043ad5cbb2cc015953b5be4eb9290dfa4076ef88d4b395429c9c
parrot_1.0.0-1ubuntu1.diff.gz 13.2 KiB d82cea5e39ee1833d4a078f08625de50d1b4d3ca9e9705b0ebcccce98338b8e8
parrot_1.0.0-1ubuntu1.dsc 1.4 KiB 01c793bca61e292e8d3444338316c27a3bc8dd477dc890e019d23e103e4ccf5b

View changes file

Binary packages built by this source

libparrot-dev: No summary available for libparrot-dev in ubuntu karmic.

No description available for libparrot-dev in ubuntu karmic.

libparrot1.0.0: No summary available for libparrot1.0.0 in ubuntu karmic.

No description available for libparrot1.0.0 in ubuntu karmic.

parrot: No summary available for parrot in ubuntu karmic.

No description available for parrot in ubuntu karmic.

parrot-devel: No summary available for parrot-devel in ubuntu karmic.

No description available for parrot-devel in ubuntu karmic.

parrot-doc: No summary available for parrot-doc in ubuntu karmic.

No description available for parrot-doc in ubuntu karmic.

parrot-minimal: No summary available for parrot-minimal in ubuntu karmic.

No description available for parrot-minimal in ubuntu karmic.