Change log for pcsc-lite package in Ubuntu

156 of 56 results
Published in bionic-release on 2018-02-02
Deleted in bionic-proposed (Reason: moved to release)
pcsc-lite (1.8.23-1) unstable; urgency=medium

  * New upstream version 1.8.23
  * Migrate the Debian packging from SVN to GIT
  * Check upstream tarball signature
  * Add .symbols file for libpcscspy
  * Build-Depends: add libsystemd-dev
  * Do not provide libpcscspy.so anymore
  * Add documentation to the systemd file
  * Update debian/compat from 9 to 10

 -- Ludovic Rousseau <email address hidden>  Tue, 19 Dec 2017 15:40:12 +0100
Superseded in bionic-release on 2018-02-02
Published in artful-release on 2017-08-23
Deleted in artful-proposed (Reason: moved to release)
pcsc-lite (1.8.22-1ubuntu1) artful; urgency=medium

  * Merge new upstream release from Debian Unstable.
    - debian/rules: Move runtime libraries to /lib, for the benefit of
      wpasupplicant. (See Debian #531592)

Superseded in artful-release on 2017-08-23
Deleted in artful-proposed on 2017-08-25 (Reason: moved to release)
pcsc-lite (1.8.21-1ubuntu1) artful; urgency=medium

  * Merge new upstream release from Debian Unstable.
    - debian/rules: Move runtime libraries to /lib, for the benefit of
      wpasupplicant. (See Debian #531592)

Superseded in artful-release on 2017-06-16
Deleted in artful-proposed on 2017-06-17 (Reason: moved to release)
pcsc-lite (1.8.20-1ubuntu1) artful; urgency=medium

  * Merge new upstream release from Debian Unstable.
    - debian/rules: Move runtime libraries to /lib, for the benefit of
      wpasupplicant. (See Debian #531592)

Available diffs

Superseded in artful-release on 2017-05-03
Published in zesty-release on 2017-03-10
Deleted in zesty-proposed (Reason: moved to release)
pcsc-lite (1.8.14-1ubuntu2) zesty; urgency=medium

  * SECURITY UPDATE: denial of service and possible code execution via
    cardsList use-after-free
    - debian/patches/CVE-2016-10109-1.patch: prevent use-after-free of
      cardsList in src/winscard_svc.c.
    - debian/patches/CVE-2016-10109-2.patch: check for a valid hContext
      handles in src/winscard_svc.c.
    - CVE-2016-10109

 -- Marc Deslauriers <email address hidden>  Mon, 23 Jan 2017 13:43:41 -0500
Published in precise-updates on 2017-01-23
Published in precise-security on 2017-01-23
pcsc-lite (1.7.4-2ubuntu2.1) precise-security; urgency=medium

  * SECURITY UPDATE: denial of service and possible code execution via
    cardsList use-after-free
    - debian/patches/CVE-2016-10109-1.patch: prevent use-after-free of
      cardsList in src/winscard_svc.c.
    - debian/patches/CVE-2016-10109-2.patch: check for a valid hContext
      handles in src/winscard_svc.c.
    - CVE-2016-10109

 -- Marc Deslauriers <email address hidden>  Fri, 06 Jan 2017 10:36:30 -0500
Published in trusty-updates on 2017-01-23
Published in trusty-security on 2017-01-23
pcsc-lite (1.8.10-1ubuntu1.1) trusty-security; urgency=medium

  * SECURITY UPDATE: denial of service and possible code execution via
    cardsList use-after-free
    - debian/patches/CVE-2016-10109-1.patch: prevent use-after-free of
      cardsList in src/winscard_svc.c.
    - debian/patches/CVE-2016-10109-2.patch: check for a valid hContext
      handles in src/winscard_svc.c.
    - CVE-2016-10109

 -- Marc Deslauriers <email address hidden>  Fri, 06 Jan 2017 10:33:14 -0500
Published in xenial-updates on 2017-01-23
Published in xenial-security on 2017-01-23
pcsc-lite (1.8.14-1ubuntu1.16.04.1) xenial-security; urgency=medium

  * SECURITY UPDATE: denial of service and possible code execution via
    cardsList use-after-free
    - debian/patches/CVE-2016-10109-1.patch: prevent use-after-free of
      cardsList in src/winscard_svc.c.
    - debian/patches/CVE-2016-10109-2.patch: check for a valid hContext
      handles in src/winscard_svc.c.
    - CVE-2016-10109

 -- Marc Deslauriers <email address hidden>  Fri, 06 Jan 2017 10:09:59 -0500
Obsolete in yakkety-updates on 2018-01-23
Obsolete in yakkety-security on 2018-01-23
pcsc-lite (1.8.14-1ubuntu1.16.10.1) yakkety-security; urgency=medium

  * SECURITY UPDATE: denial of service and possible code execution via
    cardsList use-after-free
    - debian/patches/CVE-2016-10109-1.patch: prevent use-after-free of
      cardsList in src/winscard_svc.c.
    - debian/patches/CVE-2016-10109-2.patch: check for a valid hContext
      handles in src/winscard_svc.c.
    - CVE-2016-10109

 -- Marc Deslauriers <email address hidden>  Fri, 06 Jan 2017 10:09:59 -0500
Superseded in zesty-release on 2017-03-10
Obsolete in yakkety-release on 2018-01-23
Published in xenial-release on 2015-10-22
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed (Reason: moved to release)
pcsc-lite (1.8.14-1ubuntu1) wily; urgency=medium

  * Merge new upstream release from Debian Unstable (LP: #1483750).
    - debian/rules: Move runtime libraries to /lib, for the benefit of
      wpasupplicant. (See Debian #531592)

Available diffs

Superseded in wily-release on 2015-08-12
Obsolete in vivid-release on 2018-01-18
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed on 2018-01-19 (Reason: moved to release)
pcsc-lite (1.8.11-3ubuntu1) utopic; urgency=medium

  * Merge with Debian; remaining changes:
    - debian/rules: Move runtime libraries to /lib, for the benefit of
      wpasupplicant. (See Debian #531592)

Superseded in utopic-release on 2014-08-05
Published in trusty-release on 2014-01-06
Deleted in trusty-proposed (Reason: moved to release)
pcsc-lite (1.8.10-1ubuntu1) trusty; urgency=medium

  * Merge with Debian; remaining changes:
    - Build using dh-autoreconf.
    - debian/rules: Move runtime libraries to /lib, for the benefit of
      wpasupplicant. (See Debian #531592)

Available diffs

Superseded in trusty-release on 2014-01-06
Deleted in trusty-proposed on 2014-01-08 (Reason: moved to release)
pcsc-lite (1.8.6-3ubuntu2) trusty; urgency=medium

  * Build using dh-autoreconf.
 -- Matthias Klose <email address hidden>   Mon, 16 Dec 2013 23:48:08 +0100

Available diffs

Superseded in trusty-release on 2013-12-17
Obsolete in saucy-release on 2015-04-24
Obsolete in raring-release on 2015-04-24
Deleted in raring-proposed on 2015-04-27 (Reason: moved to release)
pcsc-lite (1.8.6-3ubuntu1b1) raring; urgency=low

  * No-change rebuild against libudev1
 -- Martin Pitt <email address hidden>   Wed, 13 Mar 2013 07:08:03 +0000

Available diffs

Superseded in raring-release on 2013-03-15
Deleted in raring-proposed on 2013-03-16 (Reason: moved to release)
pcsc-lite (1.8.6-3ubuntu1) raring; urgency=low

  * Merge with Debian
    Remaining Ubuntu changes:
    - debian/rules: Move runtime libraries to /lib, for the benefit of
      wpasupplicant. (See Debian #531592)

Available diffs

Superseded in raring-release on 2012-11-13
Obsolete in quantal-release on 2015-04-24
pcsc-lite (1.8.5-1ubuntu1) quantal; urgency=low

  * Merge with Debian
    Remaining Ubuntu changes:
    - debian/rules: Move runtime libraries to /lib, for the benefit of
      wpasupplicant. (See Debian #531592)

Available diffs

Superseded in quantal-release on 2012-08-06
pcsc-lite (1.8.4-1ubuntu1) quantal; urgency=low

  * Merge with Debian
    Remaining Ubuntu changes:
    - debian/rules: Move runtime libraries to /lib, for the benefit of
      wpasupplicant. (See Debian #531592)

Available diffs

Superseded in quantal-release on 2012-08-03
pcsc-lite (1.8.3-3ubuntu1) quantal; urgency=low

  * Merge with Debian unstable (lp: #1001775). Remaining Ubuntu changes:
    - debian/rules: Move runtime libraries to /lib, for the benefit of
      wpasupplicant. (See Debian #531592)

Available diffs

Superseded in quantal-release on 2012-05-21
Published in precise-release on 2012-04-04
pcsc-lite (1.7.4-2ubuntu2) precise; urgency=low

  * Install into multiarch locations. LP: #949912.
 -- Matthias Klose <email address hidden>   Wed, 04 Apr 2012 10:00:42 +0200

Available diffs

Superseded in precise-release on 2012-04-04
pcsc-lite (1.7.4-2ubuntu1) precise; urgency=low

  * Merge with Debian testing. Remaining Ubuntu changes:
    - debian/rules: Move runtime libraries to /lib, for the benefit of
      wpasupplicant. (See Debian #531592)

Available diffs

Superseded in precise-release on 2011-10-19
Obsolete in oneiric-release on 2015-04-24
pcsc-lite (1.7.2-2ubuntu2) oneiric; urgency=low

  * debian/rules: Ensure that debian/libpcsclite1/lib/ actually exists.
 -- Martin Pitt <email address hidden>   Tue, 03 May 2011 10:53:11 +0200

Available diffs

Superseded in oneiric-release on 2011-05-03
pcsc-lite (1.7.2-2ubuntu1) oneiric; urgency=low

  * Merge with Debian unstable. Remaining Ubuntu changes:
    - debian/rules: Move runtime libraries to /lib, for the benefit of
      wpasupplicant. (See Debian #531592)

Available diffs

Obsolete in karmic-updates on 2013-03-04
Obsolete in karmic-security on 2013-03-04
pcsc-lite (1.5.3-1ubuntu1.2) karmic-security; urgency=low

  * SECURITY UPDATE: arbitrary code execution via long attribute value
    - src/atrhandler.c: verify against maximum attribute size.
    - http://lists.alioth.debian.org/pipermail/pcsclite-cvs-commit/2010-November/004923.html
    - CVE-2010-4531
 -- Marc Deslauriers <email address hidden>   Thu, 14 Apr 2011 09:39:10 -0400
Obsolete in lucid-updates on 2016-10-26
Obsolete in lucid-security on 2016-10-26
pcsc-lite (1.5.3-1ubuntu4.2) lucid-security; urgency=low

  * SECURITY UPDATE: arbitrary code execution via long attribute value
    - src/atrhandler.c: verify against maximum attribute size.
    - http://lists.alioth.debian.org/pipermail/pcsclite-cvs-commit/2010-November/004923.html
    - CVE-2010-4531
 -- Marc Deslauriers <email address hidden>   Thu, 14 Apr 2011 09:38:09 -0400
Obsolete in maverick-updates on 2013-03-05
Obsolete in maverick-security on 2013-03-05
pcsc-lite (1.5.5-3ubuntu2.1) maverick-security; urgency=low

  * SECURITY UPDATE: arbitrary code execution via long attribute value
    - src/atrhandler.c: verify against maximum attribute size.
    - http://lists.alioth.debian.org/pipermail/pcsclite-cvs-commit/2010-November/004923.html
    - CVE-2010-4531
 -- Marc Deslauriers <email address hidden>   Thu, 14 Apr 2011 09:13:24 -0400
Superseded in oneiric-release on 2011-05-03
Obsolete in natty-release on 2013-06-04
pcsc-lite (1.7.0-2ubuntu2) natty; urgency=low

  * debian/control: Drop pcscd Recommends to Suggests:, as pcscd (and its
    dependencies) is in universe.
 -- Martin Pitt <email address hidden>   Tue, 22 Mar 2011 20:09:23 +0100

Available diffs

Superseded in natty-release on 2011-03-22
pcsc-lite (1.7.0-2ubuntu1) natty; urgency=low

  * Merge from Debian Unstable (FFe LP: #723016).  Remaining changes:
  * debian/rules: Keep moving runtime libraries to /lib, for the benefit of
    wpasupplicant.

Available diffs

Superseded in natty-release on 2011-03-21
pcsc-lite (1.5.5-4ubuntu1) natty; urgency=low

  * Merge from debian unstable.  Remaining changes:
    - Move runtime libraries to /lib, for the benefit of wpasupplicant.
    - disable hal support. LP: #506908
    - add build-dep on libusb-dev, fixes FTBFS
  * debian/control: Drop libhal-dev build dependency, as we already configure
    with --disable-libhal. Using libusb instead.

Available diffs

Obsolete in jaunty-updates on 2013-02-28
Obsolete in jaunty-security on 2013-02-28
pcsc-lite (1.4.102-1ubuntu2.1) jaunty-security; urgency=low

  * SECURITY UPDATE: fix buffer overflows (LP: #603657)
  - modified src/winscard_svc.c: Fix buffer overflows which allow local users to
     to gain privileges via crafted message data, which is improperly
     demarshalled. Patch provided by Debian in Lenny. (DSA-2059-1)
  - CVE-2010-0407
 -- Brian Thomason <email address hidden>   Fri, 09 Jul 2010 12:05:26 -0400
Superseded in karmic-updates on 2011-04-27
Superseded in karmic-security on 2011-04-27
pcsc-lite (1.5.3-1ubuntu1.1) karmic-security; urgency=low

  * SECURITY UPDATE: fix buffer overflows (LP: #603657)
    - modified src/winscard_svc.c: Fix buffer overflows which allow local
      users to to gain privileges via crafted message data, which is
      improperly demarshalled. Patch provided by Debian in Lenny (DSA-2059-1)
      and Brian Thomason.
    - CVE-2010-0407
 -- Kees Cook <email address hidden>   Tue, 27 Jul 2010 16:20:27 -0700
Superseded in lucid-updates on 2011-04-27
Superseded in lucid-security on 2011-04-27
pcsc-lite (1.5.3-1ubuntu4.1) lucid-security; urgency=low

  * SECURITY UPDATE: fix buffer overflows (LP: #603657)
    - modified src/winscard_svc.c: Fix buffer overflows which allow local
      users to to gain privileges via crafted message data, which is
      improperly demarshalled. Patch provided by Debian in Lenny (DSA-2059-1)
      and Brian Thomason.
    - CVE-2010-0407
 -- Kees Cook <email address hidden>   Tue, 27 Jul 2010 16:19:03 -0700
Superseded in natty-release on 2011-01-27
Obsolete in maverick-release on 2013-03-05
pcsc-lite (1.5.5-3ubuntu2) maverick; urgency=low

  * really add build-dep on libusb-dev
 -- Reinhard Tartler <email address hidden>   Sat, 24 Jul 2010 17:16:40 +0200

Available diffs

Superseded in maverick-release on 2010-07-24
pcsc-lite (1.5.5-3ubuntu1) maverick; urgency=low

  * Merge from debian testing.  Remaining changes:
    - Move runtime libraries to /lib, for the benefit of wpasupplicant.
    - disable hal support. LP: #506908
    - add build-dep on libusb-dev, fixes FTBFS

Available diffs

Superseded in maverick-release on 2010-07-10
Obsolete in lucid-release on 2016-10-26
pcsc-lite (1.5.3-1ubuntu4) lucid; urgency=low

  * add build-dep on libusb-dev, fixes FTBFS
 -- Reinhard Tartler <email address hidden>   Sun, 07 Mar 2010 22:59:03 +0100

Available diffs

Superseded in lucid-release on 2010-03-07
pcsc-lite (1.5.3-1ubuntu3) lucid; urgency=low

  * disable hal support. LP: #506908
 -- Reinhard Tartler <email address hidden>   Sun, 07 Mar 2010 21:32:18 +0100

Available diffs

Superseded in lucid-release on 2010-03-07
pcsc-lite (1.5.3-1ubuntu2) lucid; urgency=low

  * rebuild rest of main for armel armv7/thumb2 optimization;
    UbuntuSpec:mobile-lucid-arm-gcc-v7-thumb2
 -- Alexander Sack <email address hidden>   Sun, 07 Mar 2010 01:00:55 +0100

Available diffs

Superseded in lucid-release on 2010-03-07
Obsolete in karmic-release on 2013-03-04
pcsc-lite (1.5.3-1ubuntu1) karmic; urgency=low

  * Resynchronise with Debian (LP: #378309). Remaining changes:
    - Move runtime libraries to /lib, for the benefit of wpasupplicant.
  * Drop /var/run/pcscd creation in init script; the daemon seems to take
    care of this itself and I can't reproduce the original problem that
    prompted this Ubuntu-specific change (LP: #240195).

Available diffs

Superseded in karmic-release on 2009-06-02
Obsolete in jaunty-release on 2013-02-28
pcsc-lite (1.4.102-1ubuntu2) jaunty; urgency=low

  * Move runtime libraries to /lib, for the benefit of wpasupplicant
    (LP: #44194).

 -- Colin Watson <email address hidden>   Wed, 18 Mar 2009 16:34:28 +0000
Superseded in jaunty-release on 2009-03-18
Obsolete in intrepid-release on 2013-02-20
Superseded in intrepid-release on 2008-07-25
pcsc-lite (1.4.102-1ubuntu1) intrepid; urgency=low

  * Merge from debian unstable, remaining changes:
    - Check if /var/run/pcscd/ directory exists, if not
      create it.
  * don't unconditionally update config.{guess,sub}, refactor that out in
    a rule on its own.
  * Drop therefore the build dependency on autotools-dev.

Superseded in intrepid-release on 2008-07-12
pcsc-lite (1.4.101-2ubuntu1) intrepid; urgency=low

  * Merge from debian unstable, remaining changes:
    - Check if /var/run/pcscd/ directory exists, if not
      create it.

Superseded in intrepid-release on 2008-05-13
Obsolete in hardy-release on 2015-04-24
pcsc-lite (1.4.99-1ubuntu1) hardy; urgency=low

  * debian/pcscd.init: (LP: #183498)
    - Check if /var/run/pcscd/ directory exists, if not
      create it.

 -- Stephan Hermann <email address hidden>   Sat, 19 Jan 2008 11:58:34 +0100
Superseded in hardy-release on 2008-01-19
pcsc-lite (1.4.99-1) unstable; urgency=low

  * New upstream release
  * debian/pcscd.init: pid file is now in /var/run/pcscd/
  * debian/control
   - Standards-Version: 3.7.2.0 -> 3.7.3. no change needed
  * debian/pcscd.postinst: remove very old commented code to clean /tmp/pcsc
    and also remove debian/pcscd.postinst.lintian_override
  * debian/lintian-override: ignore package-contains-empty-directory for
    usr/lib/pcsc/{drivers,services}/

 -- Marco Rodrigues <email address hidden>   Tue,  15 Jan 2008 15:15:42 +0000
Superseded in hardy-release on 2008-01-15
pcsc-lite (1.4.4-3) unstable; urgency=low

  * debian/pcscd.init: use the correct pidfile so that "stop" works
  Closes: #451704 "Latest version takes a lot to shut down"

 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  30 Nov 2007 13:11:55 +0000
Superseded in hardy-release on 2007-11-30
pcsc-lite (1.4.4-2) unstable; urgency=low

  * debian/watch: update URL to make it work again. Closes: #449679:
    "pcsc-lite: debian/watch fails to report upstream's version"
  * debian/control: use Homepage: field

 -- Ubuntu Archive Auto-Sync <email address hidden>   Thu,  15 Nov 2007 14:07:26 +0000
Superseded in hardy-release on 2007-11-15
pcsc-lite (1.4.4-1) unstable; urgency=low

  * New upstream release
    - Closes: #430492 "pcscd: daemon freezes when USB reader inserted or
    removed"

 -- Ubuntu Archive Auto-Sync <email address hidden>   Tue,  23 Oct 2007 18:16:03 +0100
Superseded in hardy-release on 2007-10-23
Obsolete in gutsy-release on 2011-09-16
pcsc-lite (1.4.3-1) unstable; urgency=low

  * New upstream release

 -- Ubuntu Archive Auto-Sync <email address hidden>   Wed,  20 Jun 2007 10:18:58 +0100
Superseded in gutsy-release on 2007-06-20
pcsc-lite (1.4.2-1) unstable; urgency=low

  * New upstream release

 -- Ubuntu Archive Auto-Sync <email address hidden>   Thu,  24 May 2007 12:55:19 +0100
Superseded in gutsy-release on 2007-05-24
pcsc-lite (1.4.1-1) unstable; urgency=low

  * New upstream release
  * debian/control: Standards-Version: 3.6.2.0 -> 3.7.2.0. No change needed
  * debian/libpcsclite-dev.docs: no PDF to distribute. Use the online HTML
    documentation instead

 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  18 May 2007 09:38:04 +0100
Superseded in gutsy-release on 2007-05-18
pcsc-lite (1.4.0-1) unstable; urgency=low

  * New upstream version

 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  27 Apr 2007 01:02:20 +0100
Superseded in gutsy-release on 2007-04-27
Obsolete in feisty-release on 2009-08-20
pcsc-lite (1.3.3-1) unstable; urgency=low

  * New upstream version

Superseded in feisty-release on 2007-01-26
pcsc-lite (1.3.2-3) unstable; urgency=high

  * urgency high to correct a RC bug
  * debian/pcscd.init: really commit a local patch that should already be in
    1.3.2-2.  Closes: #392357 "fails to stop; postinst goes into infinite
    loop"

Superseded in feisty-release on 2006-11-08
Obsolete in edgy-release on 2008-06-19
pcsc-lite (1.3.1-2) unstable; urgency=low

  * debian/control: add Conflicts: libccid (<= 1.0.0-1) since
    LTPBundleFindValueWithKey() is no more exported by pcscd but used buy
    libccid before version 1.0.1

Superseded in edgy-release on 2006-06-15
Obsolete in dapper-release on 2011-09-06
Superseded in dapper-release on 2006-02-03
pcsc-lite (1.2.9-beta9-1) unstable; urgency=low


  * New upstream version
  * debian/compat: change from 3 to 4

 -- Ludovic Rousseau <email address hidden>  Sun, 27 Nov 2005 18:04:59 +0100
Obsolete in breezy-release on 2008-03-25
pcsc-lite (1.2.9-beta7-5) unstable; urgency=low


  * debian/pcscd.install: add usr/sbin/update-reader.conf in pcscd package

 -- Ludovic Rousseau <email address hidden>  Thu, 24 Mar 2005 12:54:43 +0100
Obsolete in hoary-release on 2008-03-19
pcsc-lite (1.2.9-beta6-1) unstable; urgency=medium


  * New upstream release
   - urgency=medium since this version corrects an important bug in the server
     that crashes after 256 client connections.
     This version should be released with Debian sarge.
  * debian/update-reader.conf: use a safe way to generate a temporary filename

 -- Ludovic Rousseau <email address hidden>  Sun, 15 Aug 2004 19:07:24 +0200
Obsolete in warty-release on 2008-01-09
pcsc-lite (1.2.9-beta2-2) unstable; urgency=low


  * debian/rules: add -lpthread to LDFLAGS so that pthread_* symbols are
    included in the library (problem only seen on mips and mipsel).
    Closes: #253629
  * debian/control: make libpcsclite-dev and libpcsclite1 at Priority:
    optional so that other packages at Priority: optional can use them.
    Closes: #249374

 -- Ludovic Rousseau <email address hidden>  Sun, 13 Jun 2004 21:45:56 +0200
156 of 56 results