perl 5.12.4-4 source package in Ubuntu

Changelog

perl (5.12.4-4) unstable; urgency=medium


  * Fix decode_xs n-byte heap-overflow security bug in Unicode.xs
    (Closes: #637376)

 -- Dominic Hargreaves <email address hidden>  Wed, 10 Aug 2011 19:25:23 +0100

Upload details

Uploaded by:
Niko Tyni
Uploaded to:
Sid
Original maintainer:
Niko Tyni
Architectures:
any
Section:
perl
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size SHA-256 Checksum
perl_5.12.4-4.dsc 1.4 KiB 38cd5dc53c1025ea0fa0cf064678de4ab16299a750f02d1d4c37426d230c03fd
perl_5.12.4.orig.tar.bz2 11.8 MiB c920fa01a34b7752e8cbbc99c6921b908df60611d84a29c4377e4a798604767e
perl_5.12.4-4.debian.tar.gz 97.4 KiB 52d8c2fd11706f41f62065b80e0f7d72a4a16be90f651d9b1718264539b73b1f

No changes file available.

Binary packages built by this source

libcgi-fast-perl: No summary available for libcgi-fast-perl in ubuntu oneiric.

No description available for libcgi-fast-perl in ubuntu oneiric.

libperl-dev: No summary available for libperl-dev in ubuntu oneiric.

No description available for libperl-dev in ubuntu oneiric.

libperl5.12: No summary available for libperl5.12 in ubuntu oneiric.

No description available for libperl5.12 in ubuntu oneiric.

perl: No summary available for perl in ubuntu oneiric.

No description available for perl in ubuntu oneiric.

perl-base: No summary available for perl-base in ubuntu oneiric.

No description available for perl-base in ubuntu oneiric.

perl-debug: debug-enabled Perl interpreter

 debugperl provides a debug-enabled version of Perl which can produce
 extensive information about the interpreter as it compiles and executes
 a program (see the -D switch in perlrun(1)).
 .
 Note that this package is primarily of use in debugging *Perl* rather
 than perl programs, which may be traced/debugged using the standard
 perl binary using the -d switch (see perldebug(1)).

perl-doc: Perl documentation

 Perl manual pages, POD documentation and the `perldoc' program. If you are
 writing Perl programs, you almost certainly need this.

perl-modules: Core Perl modules

 Architecture independent Perl modules. These modules are part of Perl and
 required if the `perl' package is installed.
 .
 Note that this package only exists to save archive space and should be
 considered an internal implementation detail of the `perl' package.
 Other packages should not depend on `perl-modules' directly, they
 should use `perl' (which depends on `perl-modules') instead.