php4 4:4.4.4-7 source package in Ubuntu

Changelog

php4 (4:4.4.4-7) unstable; urgency=high

  [ sean finney ]
  * Add a bit of support in upgrade scripts to avoid unnecessary
    ucf prompting during upgrades.
  * loosen the the depends of libapache2-mod-php4 to allow using
    apache2-mpm-itk as an alternative to apache2-mpm-prefork. 
    Closes: #398581.
  * updated standards-version.

  [ Steve Langasek ]
  * Grammarize the changes to php.ini and README.Debian.security.
    Closes: #398097.
  * Re-enable LFS support in PHP4, this time with a fixed libapr API that
    is invariant with respect to -D_FILE_OFFSET_BITS=64
  * Add a versioned build-dependency on libapr1-dev (>= 1.2.7-8) for
    the above.
  * Also change the exported phpapi virtual package to mention LFS --
    changing the data type sizes with -D_FILE_OFFSET_BITS=64 *does*
    change the PHP extension ABI as well, and we *want* it to do this,
    so make sure we don't get subtly broken extensions in the process.
  * Export LFS_CFLAGS as part of the php-config --includes interface,
    otherwise we could again have segfaults with third-party modules
    built against the wrong API (isn't LFS great?)

 -- Ubuntu Archive Auto-Sync <email address hidden>   Wed,  22 Nov 2006 11:41:32 +0000

Upload details

Uploaded by:
Ubuntu Archive Auto-Sync on 2006-11-22
Uploaded to:
Feisty
Original maintainer:
Debian PHP Maintainers
Architectures:
any
Section:
web
Urgency:
Very Urgent

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size SHA-256 Checksum
php4_4.4.4.orig.tar.gz 5.3 MiB a6b856c131b1a5a1a3621bbe489d33d0d7710e15bf7c7ab04c7ebf9b72bb40db
php4_4.4.4-7.diff.gz 90.0 KiB 5754b6289029d3c38cdbc0c7b332088a2cdd093bf69846d522ae88fe375f7306
php4_4.4.4-7.dsc 1.8 KiB 3cd412bd8c3e8395fdaf3475f157f77104d929ca90a2dfc3b31ba1e68ce32d93

View changes file

Binary packages built by this source