Ubuntu

“php5” 5.2.0-7ubuntu1 source package in Ubuntu

Changelog

php5 (5.2.0-7ubuntu1) feisty; urgency=low

  * Merge to Debian unstable; remaining Ubuntu changes:
    - debian/control, debian/rules: Disable apache-dev build dependency and
      remove libapache-mod-php5 package, since we do not support apache 1.3.
    - debian/control: Build with db4.3, as long as our apache needs it.
    - debian/changelog: Add some missing CVEs.
  * debian/control:
    - Remove firebird2-dev build dependency and php5-interbase package, since
      we don't support Firebird and keep the separate php-interbase source.
    - Remove libc-client-dev build dependency and php5-imap package, since
      uw-imapd is in universe and we keep the separate php-imap source.
    - Remove libmcrypt-dev build dependency and php5-mcrypt package, since
      it is in universe and we keep the separate php-mcrypt source.
    - libapr1-dev -> libapr0-dev, as long as we still have Apache 2.0.
  * debian/rules: Disable above modules, and fix up dependency generation for
    Apache 2.0 instead of 2.2.

php5 (5.2.0-7) unstable; urgency=high

  [ Steve Langasek ]
  * Also disable firebird in the PDO config for archs other than
    i386/amd64.

php5 (5.2.0-6) unstable; urgency=high

  [ sean finney ]
  * firebird2-dev (and thus php5-interbase) is only available on
    i386/amd64, so update the control/rules information accordingly.
    thanks to Bastian Blank for reporting this (closes: #399558).

php5 (5.2.0-5) unstable; urgency=high

  [ sean finney ]
  * bring some of the mainline php4 modules back into the php source
    package instead of distributing them in independant source packages:
    - php5-imap
    - php5-interbase
    - php5-mcrypt
    - php5-pspell
    - php5-tidy
    these modules are still provided in the same binary packages as
    before, but will now be built in tandem with the core php packages.
  * fix for pdo.so duplicate loading warnings, thanks to Jan Wagner
    (closes: #398367, #399248).

php5 (5.2.0-4) unstable; urgency=high

  * Re-re-enable LFS support, forward-porting vorlon's fixes in
    the php4 tree.
  * Add a bit of support in upgrade scripts to avoid unnecessary
    ucf prompting during upgrades (closes: #398363).
  * Update build-dependencies to reflect that libpcre3-dev >= 6.6
    is required.  Thanks to Jan Wagner for pointing this out.
  * loosen dependencys for libapache2-mod-php5 to allow usage with
    apache2-mpm-itk as an alternative to prefork.
    Closes: #398580, #398481.

php5 (5.2.0-3) unstable; urgency=high

  * Unify PHP options for pear binaries to:
    -d output_buffering=1 -d open_basedir="" -d safe_mode=0 -d memory_limit="-1"
    (Closes: #397625)
  * [debian/rules]: Enable PDO building only in apache2 build.

php5 (5.2.0-2) unstable; urgency=high

  [ Ondřej Surý ]
  * Revert Large File Support for this moment.  We will try to found
    root of the problem for etch, but we do not promise anything.
    (Closes: #397465)

php5 (5.2.0-1) unstable; urgency=high

  [ sean finney ]
  * new upstream release.  since this means the 5.1 series is deadware
    in the eyes of its developers, we better get on this train before
    it's too late.  Note: this also fixes the htmlentities() exploit.
    Reference: 	CVE-2006-5465.
    Closes: #396766.
  * s/postinst/postrm/ on one critical line in debian/rules.  whoops.
    Thanks to Bart Martens for finding this (closes: #396873).
  * as a pennance i've enabled LFS support (closes: #359686).
  * new version now includes all mbstring headers (closes: #391368).
  * enable new built-in zip support.
  * enable pdo support for currently supported db types, and place the
    extensions in the respective extension packages.  future db
    types will be added, but probably post-etch as they will probably
    introduce new packages/dependencies (closes: #348882).
  * move the mysqli module into the mysql module's package, and remove
    the no longer necessary mysqli package.
  * massaging/removal of various patches to upstream changes:
    D      patches/106-strptime_xopen.patch
    D      patches/110-CVE-2006-4812_zend_alloc.patch
    M      patches/006-debian_quirks.patch
    D      patches/111-mbstring-headers.patch
    M      patches/053-extension_api.patch

  [ Ondřej Surý ]
  * Package checked, upload to unstable.

php5 (5.1.6-6) unstable; urgency=high

  [ sean finney ]
  * add notes to php.ini(-dist) about "unsupported" security features.
    patch: 113-php.ini_securitynotes.patch

  [ Ondřej Surý ]
  * SECURITY: include patch for html buffer overflows in ext/standard/html.c
    Reference: CVE-2006-5465
    Patch: 114-CVE-2006-5465_htmlentities.patch
    Closes: #396766

php5 (5.1.6-5) unstable; urgency=high

  [sean finney]
  * add a README.Debian.security to clarify how we handle/respond
    to security problems in stable releases.
  * SECURITY: include patch for integer overflow in zend_alloc.c.
    Reference: CVE-2006-04812 (closes: #391586).
    patch: 110-CVE-2006-4812_zend_alloc.patch
  * bump the debhelper compatibility level to 4.
  * remove cyclic depends for mysql/mysqli.
  * the long overdue rework of configuration file handling.  this also
    removes the need for debconf and template translations
    (closes: #361211, #393788, #388697).
  * start using ucf to manage the the various SAPI php.ini files.
  * cleanup and consolidation of a few things in the ./debian dir
  * bump the memory limit to 32M for the cli API (closes: #375070, #340586).
  * include a fix for missing mbstring headers reported by Jan Wagner
    (closes: #391368).
    patch: 111-mbstring-headers.patch.
  * include support for PTY's in proc_open, as reported by Eike Dehling.
    according to php's BTS (http://bugs.php.net/bug.php?id=39224) the
    feature was disabled only because the configure script couldn't
    accurately determine whether the feature was available, and we know
    it is :) (closes: #381438).
    patch: 112-proc_open.patch.
  * update standards-version to 3.7.2

php5 (5.1.6-4) unstable; urgency=high

  [sean finney]
  * no longer build against GPL'd gdbm library (closes: #390452).
  * updated apache2 module dependencies to build against and coexist
    with apache2.2 (closes: #390455).

php5 (5.1.6-3) unstable; urgency=low

  [ sean finney ]
  * php5 was building against db4.3 even though db4.4 headers were
    installed.  fix applied to ./ext/dba/config.m4 while we wait
    for a real fix from upstream (closes: #388601).

php5 (5.1.6-2) unstable; urgency=low

  [ sean finney ]
  * enable the mysqli extension (closes: #320835).

 -- Martin Pitt <email address hidden>   Wed,  6 Dec 2006 12:55:44 +0100

Upload details

Uploaded by:
Martin Pitt on 2006-12-06
Uploaded to:
Feisty
Original maintainer:
Debian PHP Maintainers
Component:
main
Architectures:
any
Section:
web
Urgency:
Very Urgent

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size MD5 Checksum
php5_5.2.0.orig.tar.gz 8.2 MiB 52d7e8b3d8d7573e75c97340f131f988
php5_5.2.0-7ubuntu1.diff.gz 92.2 KiB aeeedb6748d40edb679bb3ec1a2f6598
php5_5.2.0-7ubuntu1.dsc 1.8 KiB ac08f358e3b66a5a89ecd2f7b4d2b521

Binary packages built by this source