php5 5.2.3-1ubuntu6.4 source package in Ubuntu

Changelog

php5 (5.2.3-1ubuntu6.4) gutsy-security; urgency=low

  * debian/patches/SECURITY_CVE-2008-2050.patch: possible stack overflow and
    sending of unitialized paddings
  * debian/patches/SECURITY_CVE-2008-2051.patch: properly address incomplete
    multibyte chars inside escapeshellcmd()
  * debian/patches/SECURITY_CVE-2008-0599.patch: properly consider operator
    precedence when calculating length of PATH_TRANSLATED
  * debian/patches/SECURITY_CVE-2007-4850.patch: fixed a safe_mode bypass in
    cURL
  * Add debian/patches/SECURITY_CVE-2008-2829.patch: unsafe usage of
    deprecated imap functions (patch from Debian)
  * Add debian/patches/SECURITY_CVE-2008-1384.patch: integer overflow in
    printf() (patch from Debian)
  * Add debian/patches/SECURITY_CVE-2008-2107+2108.patch: weak random number
    seed.
  * Add debian/patches/SECURITY_CVE-2007-4782.patch: DoS via long string in
    the fnmatch functions
  * debian/patches/SECURITY_526-pcre_compile.patch: avoid stack overflow (fix
    from pcre 7.6)
  * Update debian/patches/207-htmlentity-utf8-fix.patch: fail on improperly
    finished UTF sequence
  * Add debian/patches/SECURITY_CVE-2008-2371.patch: buffer overflow.
    Backported upstream patches.
  * References
    CVE-2008-2050
    CVE-2008-2051
    CVE-2008-0599
    CVE-2007-4850
    CVE-2008-2829
    CVE-2008-1384
    CVE-2008-2107
    CVE-2008-2108
    CVE-2007-4782
    CVE-2007-5898
    CVE-2008-2371
    LP: #227464

 -- Jamie Strandboge <email address hidden>   Tue, 22 Jul 2008 16:32:16 -0400

Upload details

Uploaded by:
Jamie Strandboge on 2008-07-23
Uploaded to:
Gutsy
Original maintainer:
Ubuntu Development Team
Architectures:
any
Section:
web
Urgency:
Low Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size SHA-256 Checksum
php5_5.2.3.orig.tar.gz 8.9 MiB 5aa265e6003a0442b959bc85f3439c48620f647c37e7afeac0a85fa9d5881576
php5_5.2.3-1ubuntu6.4.diff.gz 128.6 KiB e5d1b67c90faabeaebd78436d2e1b521779acf525693405a348d9176d11d3a4a
php5_5.2.3-1ubuntu6.4.dsc 1.9 KiB bcfe6fef82ab792044dd0a715c6c5f9c01245c0d65a67639e734c9f935f50db7

View changes file

Binary packages built by this source

libapache2-mod-php5: No summary available for libapache2-mod-php5 in ubuntu gutsy.

No description available for libapache2-mod-php5 in ubuntu gutsy.

php-pear: No summary available for php-pear in ubuntu gutsy.

No description available for php-pear in ubuntu gutsy.

php5: No summary available for php5 in ubuntu gutsy.

No description available for php5 in ubuntu gutsy.

php5-cgi: No summary available for php5-cgi in ubuntu gutsy.

No description available for php5-cgi in ubuntu gutsy.

php5-cli: No summary available for php5-cli in ubuntu gutsy.

No description available for php5-cli in ubuntu gutsy.

php5-common: No summary available for php5-common in ubuntu gutsy.

No description available for php5-common in ubuntu gutsy.

php5-curl: No summary available for php5-curl in ubuntu gutsy.

No description available for php5-curl in ubuntu gutsy.

php5-dev: No summary available for php5-dev in ubuntu gutsy.

No description available for php5-dev in ubuntu gutsy.

php5-gd: No summary available for php5-gd in ubuntu gutsy.

No description available for php5-gd in ubuntu gutsy.

php5-ldap: No summary available for php5-ldap in ubuntu gutsy.

No description available for php5-ldap in ubuntu gutsy.

php5-mhash: No summary available for php5-mhash in ubuntu gutsy.

No description available for php5-mhash in ubuntu gutsy.

php5-mysql: No summary available for php5-mysql in ubuntu gutsy.

No description available for php5-mysql in ubuntu gutsy.

php5-odbc: No summary available for php5-odbc in ubuntu gutsy.

No description available for php5-odbc in ubuntu gutsy.

php5-pgsql: No summary available for php5-pgsql in ubuntu gutsy.

No description available for php5-pgsql in ubuntu gutsy.

php5-pspell: No summary available for php5-pspell in ubuntu gutsy.

No description available for php5-pspell in ubuntu gutsy.

php5-recode: No summary available for php5-recode in ubuntu gutsy.

No description available for php5-recode in ubuntu gutsy.

php5-snmp: No summary available for php5-snmp in ubuntu gutsy.

No description available for php5-snmp in ubuntu gutsy.

php5-sqlite: No summary available for php5-sqlite in ubuntu gutsy.

No description available for php5-sqlite in ubuntu gutsy.

php5-sybase: No summary available for php5-sybase in ubuntu gutsy.

No description available for php5-sybase in ubuntu gutsy.

php5-tidy: No summary available for php5-tidy in ubuntu gutsy.

No description available for php5-tidy in ubuntu gutsy.

php5-xmlrpc: No summary available for php5-xmlrpc in ubuntu gutsy.

No description available for php5-xmlrpc in ubuntu gutsy.

php5-xsl: No summary available for php5-xsl in ubuntu gutsy.

No description available for php5-xsl in ubuntu gutsy.