Pornview segfaults at startup

Bug #2397 reported by Stian Jordet
10
Affects Status Importance Assigned to Milestone
pornview (Ubuntu)
Medium
MOTU

Bug Description

For quite a while now, pornview in Ubuntu Breezy has started to segfault at startup. Console output is this:

stianj@chevrolet:~$ pornview
xine_thread: init threads
xine_thread: open display
gtkxine: auto-detecting video driver...
Minnesegmentsfeil
stianj@chevrolet:~$

I would really like this fixed before Breezy.

Best regards,
Stian

Changed in pornview:
assignee: nobody → motu
Revision history for this message
Trent Lloyd (lathiat) wrote :

Confirmed, not sure whats causing it tho, will look closer later (a simple rebuild didn't help)

Revision history for this message
Kristian Vlaardingerbroek (kristianv) wrote :

Here's a backtrace of what happens.

Starting program: /usr/bin/pornview
[Thread debugging using libthread_db enabled]
[New Thread -1217698112 (LWP 16677)]
[New Thread -1225552976 (LWP 16681)]
xine_thread: init threads
xine_thread: open display
gtkxine: auto-detecting video driver...
[New Thread -1238406224 (LWP 16682)]
[New Thread -1246835792 (LWP 16685)]
[New Thread -1255498832 (LWP 16686)]
[New Thread -1267991632 (LWP 16687)]
[New Thread -1278272592 (LWP 16688)]
[New Thread -1286665296 (LWP 16689)]
[New Thread -1295058000 (LWP 16690)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1217698112 (LWP 16677)]
0xb78acea4 in pthread_mutex_lock () from /lib/tls/i686/cmov/libpthread.so.0

Thread 9 (Thread -1295058000 (LWP 16690)):
#0 0xb7834bc8 in clone () from /lib/tls/i686/cmov/libc.so.6
#1 0x007d0f00 in ?? ()
#2 0x00000000 in ?? ()
#3 0xb78ab2e0 in __free_tcb () from /lib/tls/i686/cmov/libpthread.so.0
#4 0x00000000 in ?? ()
#5 0x00000000 in ?? ()
.... <snip lot of the same>
#431 0x00000000 in ?? ()
#432 0x00000000 in ?? ()
#433 0xb7896480 in __check_rhosts_file () from /lib/tls/i686/cmov/libc.so.6
#434 0xb7898fe0 in __curbrk () from /lib/tls/i686/cmov/libc.so.6
#435 0x00000000 in ?? ()
#436 0x00000000 in ?? ()
.... <snip lot of the same>
#458 0x00000000 in ?? ()
#459 0xb34f0bf0 in ?? ()
#460 0xb78b5538 in stack_cache_maxsize ()
   from /lib/tls/i686/cmov/libpthread.so.0
#461 0x00004132 in ?? ()
#462 0x00004125 in ?? ()
#463 0x00000000 in ?? ()
#464 0x00000000 in ?? ()
.... <snip lot of the same>
#570 0x00000000 in ?? ()
#571 0x00000000 in ?? ()
#572 0x080840fd in load_audio_out_driver (this=0xb2cefbb0) at gtkxine.c:331
Previous frame inner to this frame (corrupt stack?)
#0 0xb78acea4 in pthread_mutex_lock () from /lib/tls/i686/cmov/libpthread.so.0

Revision history for this message
djiss (jc.bertin) wrote :

Better stack frame:

GNU gdb 6.3-debian
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB. Type "show warranty" for details.
This GDB was configured as "i486-linux-gnu"...Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".

(gdb) run
Starting program: /home/jc/Ubuntu/pornview-0.2pre1/src/pornview
[Thread debugging using libthread_db enabled]
[New Thread -1217538368 (LWP 11947)]
[New Thread -1226069072 (LWP 11950)]
xine_thread: init threads
xine_thread: open display
gtkxine: auto-detecting video driver...
[New Thread -1238926416 (LWP 11951)]
[New Thread -1247319120 (LWP 11954)]
[New Thread -1255982160 (LWP 11955)]
[New Thread -1268474960 (LWP 11956)]
[New Thread -1278755920 (LWP 11957)]
[New Thread -1287148624 (LWP 11958)]
[New Thread -1295541328 (LWP 11964)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1217538368 (LWP 11947)]
0xb78d3ea4 in pthread_mutex_lock () from /lib/tls/i686/cmov/libpthread.so.0
(gdb) bt
#0 0xb78d3ea4 in pthread_mutex_lock () from /lib/tls/i686/cmov/libpthread.so.0
#1 0xb7a5fc4c in XUnlockDisplay () from /usr/lib/libX11.so.6
#2 0xb7a7d141 in XrmQGetResource () from /usr/lib/libX11.so.6
#3 0xb7a5742a in XGetDefault () from /usr/lib/libX11.so.6
#4 0xb7b27dfc in cairo_xlib_surface_set_drawable () from /usr/lib/libcairo.so.2
#5 0xb7b2807f in cairo_xlib_surface_set_drawable () from /usr/lib/libcairo.so.2
#6 0xb7b26014 in cairo_test_xlib_disable_render () from /usr/lib/libcairo.so.2
#7 0xb7c6affd in _gdk_x11_convert_to_format () from /usr/lib/libgdk-x11-2.0.so.0
#8 0xb7c464c9 in _gdk_drawable_ref_cairo_surface () from /usr/lib/libgdk-x11-2.0.so.0
#9 0xb7c4fc71 in gdk_pixmap_get_type () from /usr/lib/libgdk-x11-2.0.so.0
#10 0xb7c464c9 in _gdk_drawable_ref_cairo_surface () from /usr/lib/libgdk-x11-2.0.so.0
#11 0xb7c5acfe in gdk_window_begin_paint_region () from /usr/lib/libgdk-x11-2.0.so.0
#12 0xb7dc9d63 in gtk_main_do_event () from /usr/lib/libgtk-x11-2.0.so.0
#13 0xb7c5bbfa in gdk_window_clear_area_e () from /usr/lib/libgdk-x11-2.0.so.0
#14 0xb7c5c1d6 in gdk_window_process_updates () from /usr/lib/libgdk-x11-2.0.so.0
#15 0xb7d280f0 in gtk_clist_get_selection_info () from /usr/lib/libgtk-x11-2.0.so.0
#16 0xb7a19ab3 in g_cclosure_marshal_VOID__VOID () from /usr/lib/libgobject-2.0.so.0
#17 0xb7a0e3a8 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#18 0xb7a1cb13 in g_signal_stop_emission () from /usr/lib/libgobject-2.0.so.0
#19 0xb7a1e150 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#20 0xb7a1e4c3 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#21 0xb7d01f17 in gtk_adjustment_value_changed () from /usr/lib/libgtk-x11-2.0.so.0
#22 0xb7d02004 in gtk_adjustment_set_value () from /usr/lib/libgtk-x11-2.0.so.0
#23 0x0805f80e in dirview_scroll_center () at dirview.c:977
#24 0x08059696 in browser_create () at browser.c:303
#25 0x08067fa4 in main (argc=1, argv=0xbfea3324) at main.c:47

Revision history for this message
Daniel Holbach (dholbach) wrote :

Hrm, nothing new in upstream CVS for quite a while. maybe a backtrace with debug symbols (http://wiki.ubuntu.com/DebuggingProgramCrash) and -dbg packges for gtk, glib makes an easy fix possible.

Revision history for this message
Yann Rouillard (yann-pleiades) wrote :

I don' t reproduce this bug on dapper drake.
Can you try again under dapper drake ?

Changed in pornview:
status: Unconfirmed → Needs Info
Revision history for this message
Stian Jordet (stian-web) wrote :

Works fine (at least except for the hang at quit, but that's not related).

Thanks.

Revision history for this message
Stian Jordet (stian-web) wrote :

Works with Dapper.

Changed in pornview:
status: Needs Info → Rejected
Revision history for this message
Rocco Stanzione (trappist) wrote :

I am able to reproduce startup segfault on both breezy and dapper. As was mentioned previously, a simple rebuild didn't fix it, but a rebuild with "--with-gtk2" removed from debian/rules (plus an install of libgdk-pixbuf-dev) did fix it. I tried this because ./configure --help showed gtk2 support as experimental and disabled by default.

Changed in pornview:
status: Rejected → Confirmed
Revision history for this message
Reinhard Tartler (siretart) wrote :

seems to be with xine support. according to the linked debian report, we could perhaps disable xine for now

Revision history for this message
Robert Collins (lifeless) wrote :

ajmitch has commented that disabling xine is probably preferrable. I'd really like to see this fixed, so can we try that?

Revision history for this message
Reinhard Tartler (siretart) wrote :

I think this may be a good idea.

Revision history for this message
Robert Collins (lifeless) wrote : interdebdiff-pornview0.2pre1-5ubuntu1

Fix the startup segfault and disable xine to stop nuking X.

Revision history for this message
Martin Meredith (mez) wrote :

Format: 1.7
Date: Thu, 23 Mar 2006 18:26:10 +1100
Source: pornview
Binary: pornview
Architecture: source
Version: 0.2pre1-5ubuntu1
Distribution: dapper
Urgency: low
Maintainer: Debian QA Group <email address hidden>
Changed-By: Robert Collins <email address hidden>
Description:
 pornview - Image and movie viewer/manager
Changes:
 pornview (0.2pre1-5ubuntu1) dapper; urgency=low
 .
   * Fixed segfault bug on startup due to gtk needing the widget shown rather
     than just realized to use xpm calls. (Closes lp: #2397)
   * Disabled xine [temporarily] - the xine opengl plugin was killing X randomly.
Files:
 488275226d93e5a8b0ca0b702b5f87e2 653 utils optional pornview_0.2pre1-5ubuntu1.dsc
 339fde6d7ff0cc1053abe951601373e6 608864 utils optional pornview_0.2pre1.orig.tar.gz
 4335e6fee93d026b0a0afd0fef1bdd44 4736 utils optional pornview_0.2pre1-5ubuntu1.diff.gz

Changed in pornview:
status: Confirmed → Fix Committed
Changed in pornview:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.