Change log for postgis package in Ubuntu

175 of 112 results
Published in focal-proposed on 2020-01-15
postgis (3.0.0+dfsg-6ubuntu1) focal; urgency=low

  * Merge from Debian unstable.  Remaining changes:
    - Also ignore regress results in autopkgtest on s390x, just like it is
      done at build time.

 -- Gianfranco Costamagna <email address hidden>  Wed, 15 Jan 2020 11:39:23 +0100
Superseded in focal-proposed on 2020-01-15
postgis (3.0.0+dfsg-2ubuntu2) focal; urgency=medium

  * No-change rebuild for gdal soname change.

 -- Matthias Klose <email address hidden>  Tue, 14 Jan 2020 14:34:19 +0000
Published in focal-release on 2019-11-23
Deleted in focal-proposed (Reason: moved to Release)
postgis (3.0.0+dfsg-2ubuntu1) focal; urgency=medium

  * Also ignore regress results in autopkgtest on s390x, just like it is
    done at build time.

 -- Dimitri John Ledkov <email address hidden>  Wed, 20 Nov 2019 18:37:26 +0000
Superseded in focal-proposed on 2019-11-20
postgis (3.0.0+dfsg-2) unstable; urgency=medium

  * Move from experimental to unstable.

 -- Bas Couwenberg <email address hidden>  Fri, 01 Nov 2019 07:19:47 +0100
Superseded in focal-proposed on 2019-11-01
postgis (3.0.0+dfsg-1build1) focal; urgency=medium

  * Rebuild against new libproj15.

 -- Gianfranco Costamagna <email address hidden>  Sat, 26 Oct 2019 13:57:09 +0200
Superseded in focal-proposed on 2019-10-26
postgis (3.0.0+dfsg-1) unstable; urgency=medium

  * New upstream release.
  * Move from experimental to unstable.

 -- Bas Couwenberg <email address hidden>  Sun, 20 Oct 2019 07:56:41 +0200

Available diffs

Superseded in focal-proposed on 2019-10-25
postgis (2.5.3+dfsg-2) unstable; urgency=medium

  * Instead of conflicting with older postgresql-*-postgis-*-scripts packages,
    use the alternatives system for managing the extension/*.control files.
    This finally allows us to depend on the -scripts package from the main
    extension package.
  * debian/tests: Run regression tests.
  * regress: Backport fix for oriented-envelope test to be less sensitive.
  * topology: Backport regression test update for geos 3.8 compatibility.
  * Add debian/.gitlab-ci.yml.

 -- Christoph Berg <email address hidden>  Tue, 15 Oct 2019 13:26:11 +0200
Superseded in focal-release on 2019-11-23
Published in eoan-release on 2019-08-11
Deleted in eoan-proposed (Reason: moved to release)
postgis (2.5.3+dfsg-1) unstable; urgency=medium

  * New upstream release.
  * Refresh patches.

 -- Bas Couwenberg <email address hidden>  Sun, 11 Aug 2019 09:18:54 +0200

Available diffs

Superseded in eoan-release on 2019-08-11
Deleted in eoan-proposed on 2019-08-13 (Reason: moved to release)
postgis (2.5.2+dfsg-2) unstable; urgency=medium

  * Merge -arch & -indep targets.
    (closes: #932833)
  * Update PIE hardening conditional, trusty is EOL.
  * Explicitly remove liblwgeom.la before dh_install.
  * Bump Standards-Version to 4.4.0, no changes.

 -- Bas Couwenberg <email address hidden>  Tue, 23 Jul 2019 21:51:23 +0200

Available diffs

Superseded in eoan-release on 2019-07-24
Deleted in eoan-proposed on 2019-07-25 (Reason: moved to release)
postgis (2.5.2+dfsg-1) unstable; urgency=medium

  * Update gbp.conf to use --source-only-changes by default.
  * Move from experimental to unstable.

 -- Bas Couwenberg <email address hidden>  Sun, 07 Jul 2019 13:12:25 +0200
Superseded in eoan-release on 2019-07-11
Deleted in eoan-proposed on 2019-07-13 (Reason: moved to release)
postgis (2.5.1+dfsg-1build1) eoan; urgency=medium

  * Rebuild against new libjson-c4.

 -- Gianfranco Costamagna <email address hidden>  Sat, 29 Jun 2019 13:59:56 +0200
Published in xenial-updates on 2019-02-26
Published in xenial-security on 2019-02-26
postgis (2.2.1+dfsg-2ubuntu0.1) xenial-security; urgency=medium

  * SECURITY UPDATE: An empty argument in a postgis function can cause a DoS
    in PostgreSQL. This fix avoid it.
    - debian/patches/CVE-2017-18359.patch: ST_AsX3D handle empty geometries.
    - CVE-2017-18359

 -- Paulo Flabiano Smorigo <email address hidden>  Wed, 13 Feb 2019 12:07:43 -0200
Published in trusty-updates on 2019-02-26
Published in trusty-security on 2019-02-26
postgis (2.1.2+dfsg-2ubuntu0.2) trusty-security; urgency=medium

  * SECURITY UPDATE: An empty argument in a postgis function can cause a DoS
    in PostgreSQL. This fix avoid it.
    - debian/patches/CVE-2017-18359.patch: ST_AsX3D handle empty geometries.
    - CVE-2017-18359

 -- Paulo Flabiano Smorigo <email address hidden>  Thu, 14 Feb 2019 16:39:36 -0200
Superseded in eoan-release on 2019-07-05
Published in disco-release on 2018-11-24
Deleted in disco-proposed (Reason: moved to release)
postgis (2.5.1+dfsg-1) unstable; urgency=medium

  * New upstream release.
  * Add Build-Depends-Package field to symbols file.

 -- Bas Couwenberg <email address hidden>  Thu, 22 Nov 2018 06:52:52 +0100
Superseded in disco-release on 2018-11-24
Deleted in disco-proposed on 2018-11-26 (Reason: moved to release)
postgis (2.5.0+dfsg-2build1) disco; urgency=medium

  * No-change rebuild against postgresql-11

 -- Jeremy Bicha <email address hidden>  Sun, 11 Nov 2018 17:52:06 -0500
Superseded in disco-proposed on 2018-11-11
postgis (2.5.0+dfsg-2) unstable; urgency=medium

  * Move from experimental to unstable.

 -- Bas Couwenberg <email address hidden>  Sun, 14 Oct 2018 09:04:35 +0200
Superseded in disco-release on 2018-11-23
Published in cosmic-release on 2018-07-06
Deleted in cosmic-proposed (Reason: moved to release)
postgis (2.4.4+dfsg-4) unstable; urgency=medium

  * Add patches to fix parallel build of other extensions.

 -- Bas Couwenberg <email address hidden>  Sun, 10 Jun 2018 00:28:43 +0200
Superseded in cosmic-proposed on 2018-06-10
postgis (2.4.4+dfsg-2) unstable; urgency=medium

  * Drop unnecessary get-orig-source target from rules file.
  * Bump Standards-Version to 4.1.4, changes: get-orig-source target.
  * Enable parallel builds.
  * Don't use parallel for doc, docs-install & man-install targets.
  * Strip trailing whitespace from changelog & control files.
  * Add patch to fix expected test output with GDAL 2.3.0 & PROJ 5.1.0.
    (closes: #901158)

 -- Bas Couwenberg <email address hidden>  Sat, 09 Jun 2018 19:11:01 +0200
Superseded in cosmic-proposed on 2018-06-09
postgis (2.4.4+dfsg-1build1) cosmic; urgency=medium

  * No-change rebuild for proj soname change.

 -- Matthias Klose <email address hidden>  Sat, 12 May 2018 18:43:47 +0000
Superseded in cosmic-proposed on 2018-05-12
postgis (2.4.4+dfsg-1) unstable; urgency=medium

  * New upstream release.
  * Update Vcs-* URLs for Salsa.
  * Drop pkg-config patch, applied upstream.
  * Strip trailing whitespace from README.Debian.

 -- Bas Couwenberg <email address hidden>  Fri, 06 Apr 2018 09:40:25 +0200
Superseded in cosmic-release on 2018-07-06
Published in bionic-release on 2018-02-23
Deleted in bionic-proposed (Reason: moved to release)
postgis (2.4.3+dfsg-4) unstable; urgency=medium

  * Update watch file to use HTTPS.
  * Drop patch to fix FTBFS with proj 5.0.0, fixed in proj 5.0.0-rc4.
  * Build-Depend on postgresql-all in control.in too.

 -- Bas Couwenberg <email address hidden>  Thu, 22 Feb 2018 22:47:48 +0100

Available diffs

Superseded in bionic-release on 2018-02-23
Deleted in bionic-proposed on 2018-02-24 (Reason: moved to release)
postgis (2.4.3+dfsg-3) unstable; urgency=medium

  * Fix deprecated source override location.
  * Add patch to fix FTBFS with proj 5.0.0.
    (closes: #889981)
  * Strip trailing whitespace from changelog file.

 -- Bas Couwenberg <email address hidden>  Sat, 17 Feb 2018 12:24:27 +0100

Available diffs

Superseded in bionic-release on 2018-02-17
Deleted in bionic-proposed on 2018-02-19 (Reason: moved to release)
postgis (2.4.3+dfsg-2) unstable; urgency=medium

  [ Bas Couwenberg ]
  * Merge changes from Christoph Berg.

  [ Christoph Berg ]
  * Build-Depend on postgresql-all, we need server packages for testing.
  * Tests: Install fuzzystrmatch dependency explicitly, not all PostgreSQL
    versions feature CREATE EXTENSION CASCADE yet.

 -- Bas Couwenberg <email address hidden>  Tue, 16 Jan 2018 16:41:25 +0100

Available diffs

Superseded in bionic-release on 2018-01-28
Deleted in bionic-proposed on 2018-01-29 (Reason: moved to release)
postgis (2.4.2+dfsg-3) unstable; urgency=medium

  [ Bas Couwenberg ]
  * Use postgresql-all instead of postgresql-contrib-9.6 in tests/control.
    (closes: #883608)
  * Drop unused lintian overrides.
  * Bump Standards-Version to 4.1.2, no changes.

  [ Christoph Berg ]
  * Test all extensions, not just postgis.

 -- Bas Couwenberg <email address hidden>  Wed, 06 Dec 2017 07:28:09 +0100
Superseded in bionic-release on 2017-12-07
Deleted in bionic-proposed on 2017-12-08 (Reason: moved to release)
postgis (2.4.2+dfsg-2ubuntu2) bionic; urgency=medium

  * Update debian/test/control file to pick up postgresql-contrib-10

 -- Gianfranco Costamagna <email address hidden>  Mon, 04 Dec 2017 20:38:27 +0100
Superseded in bionic-proposed on 2017-12-04
postgis (2.4.2+dfsg-2ubuntu1) bionic; urgency=medium

  * Update debian/test/control file to pick up postgresql-contrib-10.0

 -- Gianfranco Costamagna <email address hidden>  Mon, 04 Dec 2017 20:38:27 +0100
Superseded in bionic-proposed on 2017-12-04
postgis (2.4.2+dfsg-2build1) bionic; urgency=medium

  * Rebuild against new postgresql 10 default

 -- Gianfranco Costamagna <email address hidden>  Mon, 04 Dec 2017 20:23:52 +0100
Superseded in bionic-proposed on 2017-12-04
postgis (2.4.2+dfsg-2) unstable; urgency=medium

  * Disable SFCGAL support, FTBFS with CGAL 4.11. (see: #876521)
  * Add lintian overrides for spelling-error-in-binary false positives.

 -- Bas Couwenberg <email address hidden>  Thu, 30 Nov 2017 21:14:37 +0100

Available diffs

Superseded in bionic-release on 2017-12-05
Deleted in bionic-proposed on 2017-12-06 (Reason: moved to release)
postgis (2.4.2+dfsg-1) unstable; urgency=medium

  * New upstream release.
  * Refresh patches.
  * Strip trailing whitespace from changelog.
  * Drop deprecated autotools_dev helper.

 -- Bas Couwenberg <email address hidden>  Wed, 15 Nov 2017 21:05:04 +0100
Superseded in bionic-proposed on 2017-11-16
postgis (2.4.1+dfsg-1) unstable; urgency=medium

  * New upstream release.
  * Drop postgresql-contrib-10 from Recommends, no longer a separate package
    and provided by postgresql-10 now.
  * Skip tests on powerpc, not a release architecture.
  * Add lintian override for debian-watch-uses-insecure-uri.
  * Mark postgis-doc & -scripts package as Multi-Arch: foreign.
  * Update dh_autoreconf override to run autogen.sh instead of autoconf.
  * Update symbols for 2.4.1.
  * Drop license & copyright for autotools files.

 -- Bas Couwenberg <email address hidden>  Wed, 18 Oct 2017 21:36:00 +0200
Superseded in bionic-release on 2017-11-22
Published in artful-release on 2017-07-02
Deleted in artful-proposed (Reason: moved to release)
postgis (2.3.3+dfsg-1) unstable; urgency=medium

  * New upstream release.
  * Refresh patches.

 -- Bas Couwenberg <email address hidden>  Sat, 01 Jul 2017 20:50:54 +0200

Available diffs

Superseded in artful-release on 2017-07-02
Deleted in artful-proposed on 2017-07-03 (Reason: moved to release)
postgis (2.3.2+dfsg-2) unstable; urgency=medium

  * Enable PIE hardening flags.
    (closes: #865775)
  * Disable PIE on Ubuntu where it's still problematic.
  * Bump Standards-Version to 4.0.0, no changes.
  * Use pkg-info.mk variables instead of dpkg-parsechangelog output.

 -- Bas Couwenberg <email address hidden>  Sun, 25 Jun 2017 10:06:51 +0200

Available diffs

Superseded in artful-release on 2017-06-26
Deleted in artful-proposed on 2017-06-27 (Reason: moved to release)
postgis (2.3.2+dfsg-1) unstable; urgency=medium

  [ Markus Wanner ]
  * Add a trivial autopkgtest to check creation of the extension.

  [ Bas Couwenberg ]
  * Fix test-extension-creation autopkgtest name in control file.
  * Move from experimental to unstable.

 -- Bas Couwenberg <email address hidden>  Sun, 18 Jun 2017 17:09:12 +0200

Available diffs

Superseded in artful-release on 2017-05-27
Deleted in artful-proposed on 2017-05-29 (Reason: moved to release)
postgis (2.3.1+dfsg-2) unstable; urgency=medium

  * Add patch avoid-bashisms.patch to fix the generated sql files.
    Closes: #858610.

 -- Markus Wanner <email address hidden>  Fri, 24 Mar 2017 19:35:00 +0100
Superseded in artful-release on 2017-06-20
Deleted in artful-proposed on 2017-06-21 (Reason: moved to release)
postgis (2.3.2+dfsg-1~exp2) experimental; urgency=medium

  * Add patch avoid-bashisms.patch to fix the generated sql files.
    Closes: #858610.

 -- Markus Wanner <email address hidden>  Fri, 24 Mar 2017 19:46:04 +0100

Available diffs

Superseded in artful-release on 2017-05-01
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed on 2018-06-22 (Reason: moved to release)
postgis (2.3.1+dfsg-1build1) zesty; urgency=medium

  * No-change rebuild against postgresql-9.6

 -- Jeremy Bicha <email address hidden>  Sun, 18 Dec 2016 19:10:05 -0500
Superseded in zesty-release on 2017-03-01
Deleted in zesty-proposed on 2017-03-02 (Reason: moved to release)
postgis (2.3.1+dfsg-1) unstable; urgency=medium

  * New upstream release.
  * Use dh_install -a instead of deprecated -s option.

 -- Bas Couwenberg <email address hidden>  Tue, 29 Nov 2016 00:32:50 +0100
Superseded in zesty-proposed on 2016-11-29
postgis (2.3.0+dfsg-3build1) zesty; urgency=medium

  * Rebuild against new libproj12.

 -- Gianfranco Costamagna <email address hidden>  Thu, 17 Nov 2016 18:49:51 +0100
Superseded in zesty-proposed on 2016-11-17
postgis (2.3.0+dfsg-3) unstable; urgency=medium

  * Restructure control file with cme.
  * Reorder (build) dependencies.
  * Drop explicit liblwgeom-2.3-0 dependency from -postgis-2.3 package,
    already set via ${shlibs:Depends}.
  * Rewrite rules file to use dh sequencer.
  * Rely on dpkg-buildflags instead of including buildflags.mk.
  * Use DEB_BUILD_ARCH instead of DEB_HOST_ARCH.
  * Fix unused substitution variable ${perl:Depends} for -scripts package.

 -- Bas Couwenberg <email address hidden>  Mon, 10 Oct 2016 15:32:04 +0200
Superseded in zesty-release on 2016-12-09
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed on 2018-01-23 (Reason: moved to release)
postgis (2.2.2+dfsg-4) unstable; urgency=medium

  * Don't include desktop file & application icons in scripts package.
  * Skip tests on alpha, has issues with sfcgal support.
  * Drop unneeded build dependency on libssl-dev.
    (closes: #828509)
  * Disable interrupt tests, hang indefinitely.

 -- Bas Couwenberg <email address hidden>  Tue, 05 Jul 2016 01:41:48 +0200

Available diffs

Superseded in yakkety-release on 2016-07-06
Deleted in yakkety-proposed on 2016-07-07 (Reason: moved to release)
postgis (2.2.2+dfsg-3) unstable; urgency=medium

  [ Bas Couwenberg ]
  * Disable tests on ppc64, fails to change owner and permissions.
  * Install desktop file and application icons for shp2pgsql-gui.

  [ Markus Wanner ]
  * Re-rename the -scripts package to include the postgis version
    for easier upgrading.
  * Remove the postgis major.minor version from the generic file
    and add the version from d/rules.
  * Update README.Debian to reflect the renaming.

 -- Markus Wanner <email address hidden>  Fri, 24 Jun 2016 22:11:56 +0200

Available diffs

Superseded in yakkety-release on 2016-06-28
Deleted in yakkety-proposed on 2016-06-29 (Reason: moved to release)
postgis (2.2.2+dfsg-2) unstable; urgency=medium

  * Disable tests on Ubuntu (and derivatives), hanging on their buildds.
  * Move from experimental to unstable.

 -- Bas Couwenberg <email address hidden>  Mon, 23 May 2016 19:30:19 +0200
Superseded in yakkety-release on 2016-06-01
Deleted in yakkety-proposed on 2016-06-02 (Reason: moved to release)
postgis (2.2.2+dfsg-1ubuntu3) yakkety; urgency=medium

  * Disable tests everywhere, hanging on the buildds.

 -- Matthias Klose <email address hidden>  Sat, 30 Apr 2016 17:23:00 +0200
Superseded in yakkety-proposed on 2016-04-30
postgis (2.2.2+dfsg-1ubuntu2) yakkety; urgency=medium

  * Don't run the tests on powerpc, ppc64el, s390x, timing out on the buildds.

 -- Matthias Klose <email address hidden>  Sat, 30 Apr 2016 13:19:24 +0200
Superseded in yakkety-proposed on 2016-04-30
postgis (2.2.2+dfsg-1ubuntu1) yakkety; urgency=medium

  * Ignore test results on armhf, arm64, s390x for now.

 -- Matthias Klose <email address hidden>  Sat, 30 Apr 2016 12:42:49 +0200
Superseded in yakkety-proposed on 2016-04-30
postgis (2.2.2+dfsg-1build2) yakkety; urgency=medium

  * No-change rebuild for libpng soname change.

 -- Matthias Klose <email address hidden>  Fri, 29 Apr 2016 14:14:50 +0000
Superseded in yakkety-proposed on 2016-04-29
postgis (2.2.2+dfsg-1build1) yakkety; urgency=medium

  * Rebuild against libjson-c3.

 -- Gianfranco Costamagna <email address hidden>  Thu, 28 Apr 2016 00:29:58 +0200
Superseded in yakkety-proposed on 2016-04-27
postgis (2.2.2+dfsg-1) unstable; urgency=medium

  * New upstream release.
  * Drop patches applied upstream.
  * Drop hppa.patch, fixed upstream.
  * Update copyright years for Regina Obe & Sandro Santilli.
  * Enable all hardening buildflags except PIE (causes build failure).

 -- Bas Couwenberg <email address hidden>  Wed, 23 Mar 2016 22:09:17 +0100
Superseded in yakkety-release on 2016-05-05
Published in xenial-release on 2016-01-22
Deleted in xenial-proposed (Reason: moved to release)
postgis (2.2.1+dfsg-2) unstable; urgency=medium

  [ Bas Couwenberg ]
  * Add patch by Helge Deller to fix wkb_output test failure on hppa & mips.
    (closes: #810859)
  * Add patch by Sandro Santilli to fix test failure on various architectures.
  * Re-enable tests on arm64, powerpc, ppc64el & s390x.
  * Skip tests on kfreebsd-i386 & mips64el, not release architectures.

  [ Markus Wanner ]
  * Add patch relax-test-timing-constraints.patch to increase chances of
    tests passing on the pgapt infrastructure.

 -- Bas Couwenberg <email address hidden>  Thu, 21 Jan 2016 23:16:46 +0100

Available diffs

Superseded in xenial-release on 2016-01-22
Deleted in xenial-proposed on 2016-01-23 (Reason: moved to release)
postgis (2.2.1+dfsg-1) unstable; urgency=medium

  * Move from experimental to unstable.

 -- Bas Couwenberg <email address hidden>  Tue, 12 Jan 2016 20:59:04 +0100

Available diffs

Superseded in xenial-release on 2016-01-13
Deleted in xenial-proposed on 2016-01-16 (Reason: moved to release)
postgis (2.2.0+dfsg-3) unstable; urgency=medium

  * Fix build with `dpkg-buildpackage -A`. Add dependency on build-arch-stamp
    target to make build-indep-stamp target succeed.
    (closes: #809123)
  * Add patches for new typos.

 -- Bas Couwenberg <email address hidden>  Sun, 27 Dec 2015 16:10:27 +0100
Superseded in xenial-proposed on 2015-12-27
postgis (2.2.0+dfsg-2) unstable; urgency=medium

  * Don't build depend on sfcgal on armel, cgal not available.
  * Disable tests on armel, no sfcgal support and fails interrupt_buffer test.
  * Document libpostgis-java move to postgis-java in README.Debian.

 -- Bas Couwenberg <email address hidden>  Sun, 20 Dec 2015 00:56:07 +0100

Available diffs

Superseded in xenial-release on 2016-01-06
Deleted in xenial-proposed on 2016-01-08 (Reason: moved to release)
postgis (2.2.0+dfsg-1) unstable; urgency=medium

  * Update symbols for 2.2.0.
  * Move from experimental to unstable.

 -- Bas Couwenberg <email address hidden>  Wed, 09 Dec 2015 21:30:54 +0100
Superseded in xenial-release on 2015-12-10
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed on 2018-01-22 (Reason: moved to release)
postgis (2.1.8+dfsg-4) unstable; urgency=medium

  * Bump minimum required libgdal-dev to 1.11.2+dfsg-3~ for spatialite
    with liblwgeom rebuild.

Superseded in wily-proposed on 2015-08-29
postgis (2.1.8+dfsg-1build4) wily; urgency=medium

  * No-change rebuild against libgdal1i

 -- Steve Langasek <email address hidden>  Sun, 23 Aug 2015 01:23:58 +0000
Superseded in wily-release on 2015-08-31
Deleted in wily-proposed on 2015-09-02 (Reason: moved to release)
postgis (2.1.8+dfsg-1build3) wily; urgency=medium

  * Revert the last change.

 -- Matthias Klose <email address hidden>  Wed, 05 Aug 2015 23:06:52 +0200
Superseded in wily-proposed on 2015-08-05
postgis (2.1.8+dfsg-1build2) wily; urgency=medium

  * Build without libgdal / raster support.

 -- Matthias Klose <email address hidden>  Wed, 05 Aug 2015 20:29:45 +0200
Superseded in wily-proposed on 2015-08-05
postgis (2.1.8+dfsg-1build1) wily; urgency=medium

  * No-change rebuild.

 -- Matthias Klose <email address hidden>  Wed, 05 Aug 2015 15:33:21 +0200
Superseded in wily-release on 2015-08-16
Deleted in wily-proposed on 2015-08-18 (Reason: moved to release)
postgis (2.1.8+dfsg-1) unstable; urgency=medium

  [ Markus Wanner ]
  * New upstream version.
  * Re-add libmaven-compiler-plugin-java to the B-D as an alternative, so
    this package remains backward compatible.

  [ Bas Couwenberg ]
  * Update copyright years for autotools files.
  * Update liblwgeom package name for 2.1.8 version.

 -- Markus Wanner <email address hidden>  Fri, 10 Jul 2015 12:51:42 +0200
Superseded in wily-release on 2015-07-16
Deleted in wily-proposed on 2015-07-18 (Reason: moved to release)
postgis (2.1.7+dfsg-2build1) wily; urgency=medium

  * No-change rebuild for libproj9

 -- Iain Lane <email address hidden>  Wed, 24 Jun 2015 12:38:24 +0100
Superseded in wily-proposed on 2015-06-24
postgis (2.1.7+dfsg-2) unstable; urgency=medium

  * Apply patch from Ubuntu to depend on libmaven-compiler-plugin-2.5-java,
    fixes build failure with maven-compiler-plugin 3.x.
    (closes: #788761)
  * Update copyright file, changes:
    - Drop .0 from GPL license shortnames
    - Align copyright holders
    - Group files & copyright by license

 -- Bas Couwenberg <email address hidden>  Sun, 14 Jun 2015 21:55:36 +0200
Superseded in wily-proposed on 2015-06-21
postgis (2.1.7+dfsg-1ubuntu1) wily; urgency=medium

  * Switch libmaven-compiler-plugin-java to libmaven-compiler-plugin-2.5-java
    (Fixes FTBFS); Rebuild for libproj9 transition
    - update debian/control{,.in}

 -- Micah Gersten <email address hidden>  Sun, 14 Jun 2015 14:03:17 -0500
Superseded in wily-proposed on 2015-06-14
postgis (2.1.7+dfsg-1) unstable; urgency=medium

  * Restore get-orig-source target, but use uscan instead of custom script.
  * Move from experimental to unstable.

 -- Bas Couwenberg <email address hidden>  Fri, 01 May 2015 20:10:33 +0200
Superseded in trusty-updates on 2019-02-26
Superseded in trusty-security on 2019-02-26
postgis (2.1.2+dfsg-2ubuntu0.1) trusty-security; urgency=high

  * SECURITY UPDATE: crash of the database backend process when given
    invalid GeoJSON data (LP: #1438875)
    - debian/patches/geojson-fix-3094.patch: back-ported from the 2.1.7
      release, taken from debian patch by Markus Wanner.
    - No CVE number
 -- Johan Van de Wauw <email address hidden>   Wed, 01 Apr 2015 21:29:10 +0200
Obsolete in utopic-updates on 2016-11-03
Obsolete in utopic-security on 2016-11-03
postgis (2.1.3+dfsg-4ubuntu0.1) utopic-security; urgency=high

  * SECURITY UPDATE: crash of the database backend process when given
    invalid GeoJSON data (LP: #1438875)
    - debian/patches/geojson-fix-3094.patch: back-ported from the 2.1.7
      release, taken from debian patch by Markus Wanner.
    - No CVE number
 -- Johan Van de Wauw <email address hidden>   Wed, 01 Apr 2015 19:53:13 +0200
Superseded in wily-release on 2015-06-25
Obsolete in vivid-release on 2018-01-18
Deleted in vivid-proposed on 2018-01-19 (Reason: moved to release)
postgis (2.1.5+dfsg-1~exp2ubuntu1) vivid; urgency=high

  * SECURITY UPDATE: crash of the database backend process when given
    invalid GeoJSON data (LP: #1438875)
    - debian/patches/geojson-fix-3094.patch: back-ported from the 2.1.7
      release, taken from debian patch by Markus Wanner.
    - No CVE number
 -- Johan Van de Wauw <email address hidden>   Wed, 01 Apr 2015 19:53:13 +0200
Superseded in vivid-release on 2015-04-02
Deleted in vivid-proposed on 2015-04-04 (Reason: moved to release)
postgis (2.1.5+dfsg-1~exp2build1) vivid; urgency=medium

  * No-change rebuild for the libgdal-dev 1.11.2 transition.
 -- Adam Conrad <email address hidden>   Wed, 18 Mar 2015 01:06:20 -0600
Superseded in vivid-release on 2015-03-19
Deleted in vivid-proposed on 2015-03-20 (Reason: moved to release)
postgis (2.1.5+dfsg-1~exp2) experimental; urgency=medium


  * Update symbols for liblwgeom-2.1.5.
  * Update Homepage URL from postgis.refractions.net to postgis.net.
  * Update my email to use @debian.org address.
  * Add build dependency on openjdk-7-jdk | java7-sdk required to build
    libpostgis-java. OpenJDK 7 is not yet available on GNU/Hurd.
  * GNU/Hurd doesn't implement semaphores; skip regress tests on hurd-*.

 -- Bas Couwenberg <email address hidden>  Sun, 08 Feb 2015 21:41:31 +0100
Superseded in vivid-release on 2015-02-19
Deleted in vivid-proposed on 2015-02-21 (Reason: moved to release)
postgis (2.1.4+dfsg-2) unstable; urgency=medium


  * Add Dutch translation by Frans Spiesschaert. Closes: #765409.
  * Bump S-V: no changes required.

 -- Markus Wanner <email address hidden>  Wed, 15 Oct 2014 10:58:52 +0200

Available diffs

Superseded in vivid-release on 2014-10-29
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed on 2016-11-03 (Reason: moved to release)
postgis (2.1.3+dfsg-4) unstable; urgency=low


  [ Bas Couwenberg ]
  * Add Czech translation by Michal Šimůnek. Closes: 751426.
  * Add Japanese translation by victory. Closes: 756718.
  * Add Danish translation by Joe Dalton. Closes: 757653.
  * Update for PostgreSQL 9.4.

  [ Jérémy Lal ]
  * Switch Build-Deps back to default-jdk instead of openjdk 7 | 8,
    as gcj-jdk does work now.
  * Backport upstream commits fixing test results with PostgreSQL 9.4.
  
  [ Markus Wanner ]
  * Let postgis recommend the (most up to date) extension, rather than
    only suggesting it.

 -- Markus Wanner <email address hidden>  Thu, 14 Aug 2014 13:40:03 +0200
Superseded in utopic-proposed on 2014-08-16
postgis (2.1.3+dfsg-3) unstable; urgency=high


  * In patch use-debian-maven: Also drop the version requirement for the
    maven-javadoc-plugin.
  * Add Breaks & Replaces against liblwgeom-2.1.2, which shipped
    liblwgeom-2.1.3.so in a package named liblwgeom-2.1.2 due to the
    attempted quick security fix. Closes: #749015.

 -- Markus Wanner <email address hidden>  Thu, 22 May 2014 17:59:05 +0200

Available diffs

Superseded in utopic-proposed on 2014-05-23
postgis (2.1.3+dfsg-2) unstable; urgency=high


  [ Bas Couwenberg ]
  * Bump liblwgeom package name from 2.1.2 to 2.1.3.
    (closes: #748756)

  [ Markus Wanner ]
  * Add NEWS.Debian to warn about a possibly breaking change.
  * Correct patch use-json-c. Drop explicit dependencies, but rely on
    shlibs:Depends, instead. Closes: #748332.
  * Revert parts of the patch use-debian-maven to actually build the
    javadocs. Add a libpostgis-java-doc package carrying the docs.

 -- Markus Wanner <email address hidden>  Wed, 21 May 2014 10:15:57 +0200

Available diffs

Superseded in utopic-proposed on 2014-05-22
postgis (2.1.3+dfsg-1) unstable; urgency=high


  * New upstream release, 2.1.3: strengthens the code to forbid database
    users to trigger opening of arbitrary files or network connections by
    the system user running the PostgreSQL server process.
  * Add B-D-I libmaven-javadoc-plugin-java to support a new plugin in the
    jdbc pom file - supposedly generating java documentation.
  * Adjust the following patches to the new release: debian-versions, and
    use-debian-maven.
  * Refresh line numbers on: honor-build-flags, use-json-c.
  * Drop obsolete patch: java-version-fix.

 -- Markus Wanner <email address hidden>  Wed, 14 May 2014 13:55:46 +0200

Available diffs

Superseded in utopic-proposed on 2014-05-20
postgis (2.1.2+dfsg-3) unstable; urgency=low


  * Also use dh-autoreconf to update libtool.m4. Closes: #744648. Move
    that and dh_autotools-dev above the copying step.
  * Update B-D on libjson-c-dev. Add patch use-josn-c to not only detect,
    but actually use the new directory for its include files.
    Closes: #745010.
  * Allow translations of the debconf notice for postgis-2.0 deprecation.
  * Add a German translation.
  * Add a Russian translation by Yuri Kozlov. Closes: #744268.
  * Add a French translation by Julien Patriarca. Closes: #744749.
  * Add a Polish translation by Michał Kułach. Closes: #745068.
  * Add a Portuguese translation by Américo Monteiro. Closes: #745148.
  * Add a Spanish translation by Matias A. Bellone. Closes: #745785.
  * Add a Italian translation by Beatrice Torracca. Closes: #747587.

 -- Markus Wanner <email address hidden>  Mon, 12 May 2014 18:53:55 +0200
Superseded in utopic-release on 2014-08-18
Deleted in utopic-proposed on 2014-08-20 (Reason: moved to release)
postgis (2.1.2+dfsg-2ubuntu1) utopic; urgency=medium

  * Use dh-autoreconf to get new libtool macros for ppc64el.
  * Disable autoheader to fix FTBFS during autoreconf.
 -- Logan Rosen <email address hidden>   Sat, 10 May 2014 22:37:34 -0400
175 of 112 results