postgresql-9.4 9.4.6-0ubuntu0.15.10 source package in Ubuntu

Changelog

postgresql-9.4 (9.4.6-0ubuntu0.15.10) wily-security; urgency=medium

  * New upstream security/bug fix release: (LP: #1544576)
    - Fix infinite loops and buffer-overrun problems in regular expressions.
      Very large character ranges in bracket expressions could cause infinite
      loops in some cases, and memory overwrites in other cases.
      (CVE-2016-0773)
    - Prevent certain PL/Java parameters from being set by non-superusers.
      This change mitigates a PL/Java security bug (CVE-2016-0766), which was
      fixed in PL/Java by marking these parameters as superuser-only. To fix
      the security hazard for sites that update PostgreSQL more frequently
      than PL/Java, make the core code aware of them also.
    - See release notes for details about other fixes.

 -- Martin Pitt <email address hidden>  Thu, 11 Feb 2016 15:28:06 +0100

Upload details

Uploaded by:
Martin Pitt on 2016-02-11
Sponsored by:
Marc Deslauriers
Uploaded to:
Wily
Original maintainer:
Ubuntu Developers
Architectures:
any all
Section:
database
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size SHA-256 Checksum
postgresql-9.4_9.4.6.orig.tar.bz2 16.9 MiB cbce1f4d01a6142c5d8bebe125623c5198ec04f363da7dd3d3b3a4100b4140a6
postgresql-9.4_9.4.6-0ubuntu0.15.10.debian.tar.xz 21.2 KiB 622538f49db13aafde21502d7dc67f5aa69a4b81570aea2c3e2caeed1071dc68
postgresql-9.4_9.4.6-0ubuntu0.15.10.dsc 3.5 KiB aa22771141567066e40346fdb6c482c41355873b3f3e9cf8dc1551e99b6d7676

View changes file

Binary packages built by this source

libecpg-compat3: No summary available for libecpg-compat3 in ubuntu wily.

No description available for libecpg-compat3 in ubuntu wily.

libecpg-compat3-dbgsym: No summary available for libecpg-compat3-dbgsym in ubuntu wily.

No description available for libecpg-compat3-dbgsym in ubuntu wily.

libecpg-dev: No summary available for libecpg-dev in ubuntu wily.

No description available for libecpg-dev in ubuntu wily.

libecpg-dev-dbgsym: No summary available for libecpg-dev-dbgsym in ubuntu wily.

No description available for libecpg-dev-dbgsym in ubuntu wily.

libecpg6: No summary available for libecpg6 in ubuntu wily.

No description available for libecpg6 in ubuntu wily.

libecpg6-dbgsym: No summary available for libecpg6-dbgsym in ubuntu wily.

No description available for libecpg6-dbgsym in ubuntu wily.

libpgtypes3: No summary available for libpgtypes3 in ubuntu wily.

No description available for libpgtypes3 in ubuntu wily.

libpgtypes3-dbgsym: No summary available for libpgtypes3-dbgsym in ubuntu wily.

No description available for libpgtypes3-dbgsym in ubuntu wily.

libpq-dev: No summary available for libpq-dev in ubuntu wily.

No description available for libpq-dev in ubuntu wily.

libpq-dev-dbgsym: No summary available for libpq-dev-dbgsym in ubuntu wily.

No description available for libpq-dev-dbgsym in ubuntu wily.

libpq5: No summary available for libpq5 in ubuntu wily.

No description available for libpq5 in ubuntu wily.

libpq5-dbgsym: No summary available for libpq5-dbgsym in ubuntu wily.

No description available for libpq5-dbgsym in ubuntu wily.

postgresql-9.4: No summary available for postgresql-9.4 in ubuntu wily.

No description available for postgresql-9.4 in ubuntu wily.

postgresql-9.4-dbg: No summary available for postgresql-9.4-dbg in ubuntu wily.

No description available for postgresql-9.4-dbg in ubuntu wily.

postgresql-9.4-dbgsym: No summary available for postgresql-9.4-dbgsym in ubuntu wily.

No description available for postgresql-9.4-dbgsym in ubuntu wily.

postgresql-client-9.4: No summary available for postgresql-client-9.4 in ubuntu wily.

No description available for postgresql-client-9.4 in ubuntu wily.

postgresql-client-9.4-dbgsym: No summary available for postgresql-client-9.4-dbgsym in ubuntu wily.

No description available for postgresql-client-9.4-dbgsym in ubuntu wily.

postgresql-contrib-9.4: No summary available for postgresql-contrib-9.4 in ubuntu wily.

No description available for postgresql-contrib-9.4 in ubuntu wily.

postgresql-contrib-9.4-dbgsym: No summary available for postgresql-contrib-9.4-dbgsym in ubuntu wily.

No description available for postgresql-contrib-9.4-dbgsym in ubuntu wily.

postgresql-doc-9.4: No summary available for postgresql-doc-9.4 in ubuntu wily.

No description available for postgresql-doc-9.4 in ubuntu wily.

postgresql-plperl-9.4: No summary available for postgresql-plperl-9.4 in ubuntu wily.

No description available for postgresql-plperl-9.4 in ubuntu wily.

postgresql-plperl-9.4-dbgsym: No summary available for postgresql-plperl-9.4-dbgsym in ubuntu wily.

No description available for postgresql-plperl-9.4-dbgsym in ubuntu wily.

postgresql-plpython-9.4: No summary available for postgresql-plpython-9.4 in ubuntu wily.

No description available for postgresql-plpython-9.4 in ubuntu wily.

postgresql-plpython-9.4-dbgsym: No summary available for postgresql-plpython-9.4-dbgsym in ubuntu wily.

No description available for postgresql-plpython-9.4-dbgsym in ubuntu wily.

postgresql-plpython3-9.4: No summary available for postgresql-plpython3-9.4 in ubuntu wily.

No description available for postgresql-plpython3-9.4 in ubuntu wily.

postgresql-plpython3-9.4-dbgsym: No summary available for postgresql-plpython3-9.4-dbgsym in ubuntu wily.

No description available for postgresql-plpython3-9.4-dbgsym in ubuntu wily.

postgresql-pltcl-9.4: No summary available for postgresql-pltcl-9.4 in ubuntu wily.

No description available for postgresql-pltcl-9.4 in ubuntu wily.

postgresql-pltcl-9.4-dbgsym: No summary available for postgresql-pltcl-9.4-dbgsym in ubuntu wily.

No description available for postgresql-pltcl-9.4-dbgsym in ubuntu wily.

postgresql-server-dev-9.4: No summary available for postgresql-server-dev-9.4 in ubuntu wily.

No description available for postgresql-server-dev-9.4 in ubuntu wily.

postgresql-server-dev-9.4-dbgsym: No summary available for postgresql-server-dev-9.4-dbgsym in ubuntu wily.

No description available for postgresql-server-dev-9.4-dbgsym in ubuntu wily.