[SRU] for pouetchess

Bug #72052 reported by Lionel Le Folgoc
8
Affects Status Importance Assigned to Milestone
pouetchess (Ubuntu)
Fix Released
High
Unassigned

Bug Description

Binary package hint: pouetchess

Requesting update for pouetchess in edgy.

Current 0.2.0-0ubuntu1 package is broken (unplayable, always crashes, see Bug 63309). That's a very little patch, and not much risks of regression.

I will edit changelog to add "approved SRU proposal" if it is approved.

diff -u pouetchess-0.2.0/debian/changelog pouetchess-0.2.0/debian/changelog
--- pouetchess-0.2.0/debian/changelog
+++ pouetchess-0.2.0/debian/changelog
@@ -1,3 +1,10 @@
+pouetchess (0.2.0-0ubuntu2~prop1) edgy-proposed; urgency=low
+
+ * debian/patches/04-segfaults_fix.patch: patch from upstream svn to fix
+ segfaults when playing against AI. (Closes Ubuntu #63309)
+
+ -- Lionel Le Folgoc (mr_pouit) <email address hidden> Thu, 16 Nov 2006 14:18:06 +0100
+
 pouetchess (0.2.0-0ubuntu1) edgy; urgency=low

   * Initial release.
only in patch2:
unchanged:
--- pouetchess-0.2.0.orig/debian/patches/04-segfaults_fix.patch
+++ pouetchess-0.2.0/debian/patches/04-segfaults_fix.patch
@@ -0,0 +1,11 @@
+--- src/faile/utils.c.orig 2006-05-28 00:32:00.000000000 +0200
++++ src/faile/utils.c 2006-11-15 23:31:39.000000000 +0100
+@@ -125,7 +125,7 @@
+ rank (target) < 1 || rank (target) > 8 ||
+ file (target) < 1 || file (target) > 8)
+ {
+- sprintf (str, "*** FAILE INTERNAL ERROR ***");
++ sprintf (str, "xxxx");
+ return;
+ }
+

Revision history for this message
Lionel Le Folgoc (mrpouit) wrote :
Revision history for this message
Lionel Le Folgoc (mrpouit) wrote :
Revision history for this message
Lionel Le Folgoc (mrpouit) wrote :
Revision history for this message
StefanPotyra (sistpoty) wrote :

Hi,

looks good, thus +1 from me. Please don't forget to fix feisty as well.

Cheers,
    Stefan.

Revision history for this message
Lionel Le Folgoc (mrpouit) wrote : Re: [Bug 72052] MOTU SRU proposal

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hi,

Thanks for reviewing.

I re-checked https://wiki.ubuntu.com/MOTU/SRU, and it seems I don't need
to edit the changelog to add "Approved", only to subscribe ubuntu-archive.

For feisty, I am going to put it on revu.

Cheers,
 Lionel

 subscribe ubuntu-archive

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.3 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFFXNU98SAVYBK4NxgRAq1UAJ9g9vOnrHmCP4nsAJzrw3C7D9n+DwCgjuM8
UPkQkhAimH1r1PnqpAZNZts=
=RB8Q
-----END PGP SIGNATURE-----

Revision history for this message
StefanPotyra (sistpoty) wrote : Re: MOTU SRU proposal

Hi Lionel,

Erm sorry, please wait to get an ack from two more members of the sru-team.

The next step is then to upload this version to edgy-proposed with an additional changelog entry referring to this SRU-proposal. This upload will then go into the by-hand queue where ubuntu-archive admins need to approve or reject it.
After this follows the testing period and finally an upload to -updates.

Hope this is now a little bit more clear.

Please also note that the policy is still only a proposal, but I'm quite confident that there won't be major changes to it.

Oh, and since you are no MOTU yet, it might be a good idea to find one willing to do the uploading and probably subscribe him/her to this bug report as well.

Cheers,
    Stefan.

Revision history for this message
Steve Kowalik (stevenk) wrote :

This also looks fine to me, so +1. I'd prefer that an MOTU that isn't from SRU team do the uploading, but that's just personal preference.

Revision history for this message
Daniel T Chen (crimsun) wrote :

The version for edgy-proposed (and thus, edgy-updates) needs to be 0.2.0-0ubuntu1.1 .

Revision history for this message
Reinhard Tartler (siretart) wrote : Re: [Bug 72052] MOTU SRU proposal

Lionel Le Folgoc <email address hidden> writes:

> --- pouetchess-0.2.0.orig/debian/patches/04-segfaults_fix.patch
> +++ pouetchess-0.2.0/debian/patches/04-segfaults_fix.patch
> @@ -0,0 +1,11 @@
> +--- src/faile/utils.c.orig 2006-05-28 00:32:00.000000000 +0200
> ++++ src/faile/utils.c 2006-11-15 23:31:39.000000000 +0100
> +@@ -125,7 +125,7 @@
> + rank (target) < 1 || rank (target) > 8 ||
> + file (target) < 1 || file (target) > 8)
> + {
> +- sprintf (str, "*** FAILE INTERNAL ERROR ***");
> ++ sprintf (str, "xxxx");
> + return;
> + }
> +

Could you please explain why replacing one string with a shorter one
fixes your bug?

Looking further, it seems that this bug is reported upstream as
http://sourceforge.net/tracker/index.php?func=detail&aid=1596684&group_id=157043&atid=802212. The
patch attached there is
http://sourceforge.net/tracker/download.php?group_id=157043&atid=802212&file_id=203026&aid=1596684

It looks to me that your patch to utils.c is only one part of what is
needed to fix the bug.

I'll update #63309 shortly.

I agree to uploading pouetchess to edgy-propsed with the complete
patch. Please mention this bug as well in the changelog, so that the
archive admins can see who actually approved the appload.

--
Gruesse/greetings,
Reinhard Tartler, KeyID 945348A4

Changed in pouetchess:
assignee: nobody → motu-sru
importance: Undecided → High
Revision history for this message
StefanPotyra (sistpoty) wrote : Re: MOTU SRU proposal

Reinhard, since I was curious as well, I've been looking at the code yesterday: The target string is most of the time a char[6] (the function is called in several places, I'm not sure if I've found all of them).

Nonetheless I'd prefer a patch by upstream as well.

Cheers,
      Stefan.

Revision history for this message
Lionel Le Folgoc (mrpouit) wrote :

Stefan: ok, that's more clear now, thanks for the explanation.

Steve: ok, I am going to ask a MOTU to sponsor the upload, as soon as it is ready.

Daniel: ok. There is no detail about package version on the wiki page, so I looked at dapper-proposed, and saw packages using "~prop1" suffix.

Reinhart: That's the patch I submitted for reviewing to the developer (after checking svn commits [1]), who answered:
"The patch seems to be correct.
Actually the problem come from :

- sprintf (str, "*** FAILE INTERNAL ERROR ***");
+ sprintf (str, "xxxx");

I'll probably release pouetChess 0.2b with the latest svn version."

That's why I removed the other non-essential parts.
He said that he would release a fixed 0.2b version, so I can wait for this; but I checked the svn, and there are many changes, so the 0.2b version would probably be too different from 0.2 (in this case, is it still suitable for -updates ?).

[1] http://pouetchess.svn.sourceforge.net/viewvc/pouetchess/trunk/src/faile/utils.c?r1=48&r2=47&pathrev=48

Revision history for this message
Lionel Le Folgoc (mrpouit) wrote :

Erm, sorry, I haven't been very clear: this patch wasn't from me (I am not very good at coding ^^); it comes from upstream svn (commit 48 from Aug 27).

Revision history for this message
StefanPotyra (sistpoty) wrote :

Lionel, what about taking the patch Reinhard pointed to?

Revision history for this message
Lionel Le Folgoc (mrpouit) wrote :
Revision history for this message
Lionel Le Folgoc (mrpouit) wrote :
Revision history for this message
Lionel Le Folgoc (mrpouit) wrote :
Revision history for this message
Lionel Le Folgoc (mrpouit) wrote :

I made all needed changes (version number, full patch, changelog entry). :)

Revision history for this message
StefanPotyra (sistpoty) wrote :

+1 for this one.

Revision history for this message
Reinhard Tartler (siretart) wrote :

+1

StefanPotyra (sistpoty)
Changed in pouetchess:
assignee: motu-sru → mrpouit
Revision history for this message
Tollef Fog Heen (tfheen) wrote :

I'd like another member of the motu-sru team to vouch for the upload as well as having this fixed in feisty before accepting it into edgy-proposed. (I've asked StevenK for the former, somebody please do the latter.)

Revision history for this message
Steve Kowalik (stevenk) wrote :

The latest debdiff looks fine, +1

Revision history for this message
Lionel Le Folgoc (mrpouit) wrote :

Tollef Fog Heen > I have already uploaded the fix on REVU for feisty, waiting for a MOTU-reviewer to take a look at it (http://revu.tauware.de/details.py?upid=3747).

Revision history for this message
StefanPotyra (sistpoty) wrote :

Lionel, can you ping a few motu's and ask them to do the upload to feisty? Otherwise the package might sit on revu for quite some time.

Thanks,
      Stefan.

Revision history for this message
Lionel Le Folgoc (mrpouit) wrote :

Fixed version uploaded to feisty.

Revision history for this message
Lionel Le Folgoc (mrpouit) wrote :

What's the status of this bug (fix is already in feisty and uploaded to edgy-proposed, but hasn't shown up yet) ?
Thanks.

Changed in pouetchess:
assignee: mrpouit → nobody
Revision history for this message
Tollef Fog Heen (tfheen) wrote :

Accepted into edgy-proposed. Please solicit testing according to https://wiki.ubuntu.com/MOTU/SRU

Changed in pouetchess:
status: Unconfirmed → Fix Committed
Revision history for this message
ville palo (vi64pa) wrote :

Works for me +1

Revision history for this message
Ralf Nieuwenhuijsen (ralf-nieuwenhuijsen) wrote :

Works for me +1

Revision history for this message
16aR (16ar) wrote :

Ok for me too
+1

Revision history for this message
Cyrille Grosdemange (ze-cyrilou) wrote :

Works for me +1

Revision history for this message
WillSmith (undertakingyou) wrote :

Didn't work, -1

Revision history for this message
WillSmith (undertakingyou) wrote :

OK, it didn't work as an upgrade, but when I removed and then installed new one, it seems to work. +1

Revision history for this message
Daniel T Chen (crimsun) wrote :

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Sun, 4 Mar 2007 00:15:18 -0500
Source: pouetchess
Binary: pouetchess-data pouetchess
Architecture: source
Version: 0.2.0-0ubuntu1.2
Distribution: edgy-updates
Urgency: low
Maintainer: Ubuntu MOTU Developers <email address hidden>
Changed-By: Daniel T Chen <email address hidden>
Description:
 pouetchess - 3D chess game
 pouetchess-data - Data files for the game pouetChess
Launchpad-Bugs-Fixed: 72052
Changes:
 pouetchess (0.2.0-0ubuntu1.2) edgy-updates; urgency=low
 .
   * debian/control: Adhere to DebianMaintainerField.
   * LP: #72052
   * Upload to edgy-updates. Thanks to testing by ville palo,
     Ralf Nieuwenhuijsen, 16aR, Cyrille Grosdemange and WillSmith.
Files:
 bb17cdf9d847abb6b50ef5c936a166f9 759 games optional pouetchess_0.2.0-0ubuntu1.2.dsc
 8489340ec5aa3102dd3e5738bc0eab49 5629 games optional pouetchess_0.2.0-0ubuntu1.2.diff.gz

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFF6lgKe9GwFciKvaMRArvvAJ0WH35i2fXWFGVWfurICTyyfG2nsgCeKHqK
0VD1nLLQ3BNeFLXcVASfrw8=
=UVdH
-----END PGP SIGNATURE-----

Revision history for this message
Martin Pitt (pitti) wrote :

Accepted into edgy-updates. However, in the future, don't change debian/control and use -v for building the source to get a complete changelog in the .changes.

Changed in pouetchess:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers