ppp 2.4.5-5ubuntu1.1 source package in Ubuntu

Changelog

ppp (2.4.5-5ubuntu1.1) precise-security; urgency=medium

  * SECURITY UPDATE: possible privilege escalation via option parsing
    - debian/patches/CVE-2014-3158.patch: fix integer overflow in
      pppd/options.c.
    - CVE-2014-3158
 -- Marc Deslauriers <email address hidden>   Tue, 25 Nov 2014 16:17:49 -0500

Upload details

Uploaded by:
Marc Deslauriers on 2014-11-25
Uploaded to:
Precise
Original maintainer:
Ubuntu Developers
Architectures:
any all
Section:
admin
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size SHA-256 Checksum
ppp_2.4.5.orig.tar.gz 668.3 KiB 43317afec9299f9920b96f840414c977f0385410202d48e56d2fdb8230003505
ppp_2.4.5-5ubuntu1.1.diff.gz 97.4 KiB b6ef562a14121e640b3f1efb2ff31f92429ae5015d9236af42678820c9900dec
ppp_2.4.5-5ubuntu1.1.dsc 1.8 KiB 09da0b3b742b100d0a1e94195ce83a669d44fd474ba58ed29384ecb1d3ae8766

View changes file

Binary packages built by this source

ppp: Point-to-Point Protocol (PPP) - daemon

 The Point-to-Point Protocol provides a standard way to transmit
 datagrams over a serial link, as well as a standard way for the machines
 at either end of the link to negotiate various optional characteristics
 of the link.
 .
 This package is most commonly used to manage a modem for dial-up or
 certain kinds of broadband connections.

ppp-dev: Point-to-Point Protocol (PPP) - development files

 The Point-to-Point Protocol provides a standard way to transmit
 datagrams over a serial link, as well as a standard way for the machines
 at either end of the link to negotiate various optional characteristics
 of the link.
 .
 This package provides files needed to build pppd-related software.

ppp-udeb: Point-to-Point Protocol (PPP) - package for Debian Installer

 The Point-to-Point Protocol provides a standard way to transmit
 datagrams over a serial link, as well as a standard way for the machines
 at either end of the link to negotiate various optional characteristics
 of the link.
 .
 This package is a minimal ppp package used by the Debian Installer.