Change log for prayer package in Ubuntu

130 of 30 results
Published in eoan-release 19 hours ago
Published in disco-release on 2018-12-17
Deleted in disco-proposed (Reason: moved to release)
prayer (1.3.5-dfsg1-6) unstable; urgency=medium

  * Merge changes from Ubuntu (Closes: #913848).

 -- Magnus Holmgren <email address hidden>  Sun, 16 Dec 2018 22:27:47 +0100
Superseded in disco-release on 2018-12-17
Deleted in disco-proposed on 2018-12-18 (Reason: moved to release)
prayer (1.3.5-dfsg1-5ubuntu1) disco; urgency=medium

  * debian/patches/glibc-2.28.patch: drop wrong prototype for crypt().

 -- Steve Langasek <email address hidden>  Thu, 15 Nov 2018 22:34:06 +0000
Superseded in disco-proposed on 2018-11-15
prayer (1.3.5-dfsg1-5) unstable; urgency=medium

  * [SECURITY] CVE-2018-18655 (information disclosure) no-referrer.patch:
    Add no-referrer meta header to templates (Closes: #911842).
  * Replace exim4 dependency with default-mta.
  * Install init script initially disabled instead of using an ENABLED
    flag in /etc/default/prayer to prevent premature start (note: also
    affects prayer-accountd).
  * Upgrade Standards-Version to 4.2.1 with the preceding change.

 -- Magnus Holmgren <email address hidden>  Sat, 27 Oct 2018 22:08:08 +0200
Superseded in disco-release on 2018-11-23
Published in cosmic-release on 2018-05-01
Published in bionic-release on 2018-02-08
Deleted in bionic-proposed (Reason: moved to release)
prayer (1.3.5-dfsg1-4build1) bionic; urgency=high

  * No change rebuild against openssl1.1.

 -- Dimitri John Ledkov <email address hidden>  Mon, 05 Feb 2018 23:27:14 +0000
Superseded in bionic-release on 2018-02-08
Published in artful-release on 2017-04-20
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed (Reason: moved to release)
prayer (1.3.5-dfsg1-4) unstable; urgency=low

  * Switch from CDBS to dh and debhelper compat level 9.
  * openssl1.1.patch: Support OpenSSL 1.1 API changes (Closes: #828512).
    * Support for Entropy Gathering Daemon removed because it's really old
      and support for it is no longer enabled in OpenSSL by default.
  * Add missing lsb-base dependencies.
  * prayer.postrm: remove hard-coded path to deluser.
  * Bump Standards-Version to 3.9.8.

 -- Magnus Holmgren <email address hidden>  Sat, 29 Oct 2016 14:15:05 +0200
Superseded in zesty-release on 2016-11-03
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed on 2018-01-23 (Reason: moved to release)
prayer (1.3.5-dfsg1-3build1) yakkety; urgency=medium

  * No-change rebuild against tidy-html5

 -- Jeremy Bicha <email address hidden>  Tue, 28 Jun 2016 14:49:51 -0400
Superseded in yakkety-release on 2016-07-01
Published in xenial-release on 2015-10-22
Obsolete in wily-release on 2018-01-22
Obsolete in vivid-release on 2018-01-18
Deleted in vivid-proposed (Reason: moved to release)
prayer (1.3.5-dfsg1-3) unstable; urgency=low


  * disable_ssl3.patch (new): Disable SSL 3.0 due to CVE-2014-3566
    (POODLE).
  * debian/Config: Disable ACCOUNTD_SSL_ENABLE since the SSL/TLS support
    in prayer-accountd and prayer-session is incomplete and never was
    functional.

 -- Magnus Holmgren <email address hidden>  Wed, 29 Oct 2014 22:32:18 +0100
Superseded in vivid-release on 2014-10-30
Obsolete in utopic-release on 2016-11-03
Published in trusty-release on 2013-11-02
Deleted in trusty-proposed (Reason: moved to release)
prayer (1.3.5-dfsg1-2build1) trusty; urgency=low

  * No change rebuild against db 5.3.
 -- Dmitrijs Ledkovs <email address hidden>   Sat, 02 Nov 2013 00:24:59 +0000
Superseded in trusty-release on 2013-11-02
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed on 2015-04-28 (Reason: moved to release)
prayer (1.3.5-dfsg1-2) unstable; urgency=high


  * dlopen_templates.patch: Use MYCFLAGS (which is initialized to the
    value of CFLAGS from dpkg-buildflags in the Config file) instead of
    CFLAGS in templates/{src,cam,old}/Makefile (Closes: #715310, LP:
    #1201216). The --defsym options were lost when we let CDBS override
    CFLAGS in the previous upload.

 -- Magnus Holmgren <email address hidden>  Thu, 18 Jul 2013 22:47:08 +0200

Available diffs

Superseded in saucy-release on 2013-07-19
Deleted in saucy-proposed on 2013-07-20 (Reason: moved to release)
prayer (1.3.5-dfsg1-1) unstable; urgency=low


  * New upstream release.
  * Refresh patches.
  * Drop dummy package prayer-templates.
  * No longer override CDBS overriding CFLAGS, thereby allowing hardening
    flags to be properly propagated. I think it caused internal include
    flags to be lost, but since at least 1.3.2 that's no longer the case.
  * Bump Standards-Version to 3.9.4.
  * hurd.patch: Always define HAVE_SHADOW. The test for BSD4_4 seems
    bogus; it is defined on Hurd, but crypt(3) is available there.

 -- Magnus Holmgren <email address hidden>  Wed, 12 Jun 2013 00:09:05 +0200
Superseded in saucy-release on 2013-06-12
Obsolete in raring-release on 2015-04-24
Obsolete in quantal-release on 2015-04-24
Published in precise-release on 2011-10-17
prayer (1.3.4-dfsg1-1) unstable; urgency=low

  * New upstream release.
    - Drop ipv6_v6only.patch; fixed upstream.
    * template_sdk.patch: templates/src/build_index.pl no longer need to
      be patched.
  * Bump Standards-Version to 3.9.2.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  17 Oct 2011 13:46:27 +0000

Available diffs

Superseded in precise-release on 2011-10-17
Obsolete in oneiric-release on 2015-04-24
prayer (1.3.3-dfsg1-4) unstable; urgency=low

  * Merge ld-as-needed.diff from Ubuntu into dlopen_templates.patch
    (Closes: #607559).
  * dlopen_templates.patch: Add missing #include "dlopen_templates.h" to
    servers/prayer_shared.h.
  * hurd.patch (new): Use the SPT_CHANGEARGV implementation of
    setproctitle() on the Hurd.
  * Add basic manpage for prayer-accountd(8).
  * unbrand_accountd.patch: Remove some Cambridge-specific parts of the
    filter handling.
  * Drop obsolete Build-Depends alternative libc-client2007b-dev.
  * Increase Debhelper compat level to 7.

Superseded in oneiric-release on 2011-05-01
Obsolete in natty-release on 2013-06-04
prayer (1.3.3-dfsg1-3ubuntu1) natty; urgency=low

  * Fix FTBFS with ld --as-needed.
 -- Matthias Klose <email address hidden>   Sun, 19 Dec 2010 19:07:04 +0100
Superseded in natty-release on 2010-12-19
prayer (1.3.3-dfsg1-3) unstable; urgency=high

  * ipv6_v6only.patch (new): Set the IPV6_V6ONLY socket option on
    AF_INET6 sockets; since Prayer by default enumerates available address
    families and calls bind() once for each, conflicts will occur
    otherwise.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  17 Dec 2010 11:01:32 +0000

Available diffs

Superseded in natty-release on 2010-12-17
Obsolete in maverick-release on 2013-03-05
prayer (1.3.3-dfsg1-2) unstable; urgency=high

  * Convert (trivially, since CDBS with quilt was already used) to source
    format 3.0 (quilt).
  * no_db_version_check.patch: Remove unnecessary and incorrect check that
    not only the major and minor version numbers of the current libdb are
    the same as at compile time, but also that the patch number is equal
    or greater, which should not be a concern (Closes: #592119).
 -- Alessio Treglia <email address hidden>   Sat, 07 Aug 2010 21:07:53 +0200

Available diffs

Superseded in maverick-release on 2010-09-05
prayer (1.3.3-dfsg1-1) unstable; urgency=low

  * New upstream release.
    - Dropped kfreebsd.patch, clean_completely.patch, and
      manpage_error.patch; all incorporated upstream.
    * makefile_install_config.patch: Updated; some parts incorporated
      upstream.
  * prayer-templates-dev.install: Only template_structs.h and misc.h
    needed henceforth, since only those files are #included by compiled
    templates.
  * template_sdk.patch: The #include that templates/src/build_index.pl
    generates was not changed, though.
  * debian/Config, debian/control: Enable libtidy for HTML parsing and
    sanitisation, fixing certain XSS problems, which were due to simple
    substring matching being used.
  * prayer.init, prayer-accountd.init: Add $remote_fs to, and move
    $local_fs to, Required-Start.
  * Upgrade to Standards-Version 3.9.0:
    * Use Breaks instead of Conflicts to handle the renaming of
      prayer-templates.
 -- Bhavani Shankar <email address hidden>   Thu, 22 Jul 2010 03:27:52 +0200
Superseded in maverick-release on 2010-07-26
Obsolete in lucid-release on 2016-10-26
prayer (1.3.2-dfsg1-4build1) lucid; urgency=low

  * No-change rebuild for libc-client2007b -> libc-client2007e
    transition.
 -- Ilya Barygin <email address hidden>   Sat, 27 Mar 2010 10:39:51 +0300
Superseded in lucid-release on 2010-03-27
prayer (1.3.2-dfsg1-4) unstable; urgency=low

  * Undo inadvertent inclusion of /usr/include/prayer in
    prayer-templates-src (Closes: #557056).

Available diffs

Superseded in lucid-release on 2009-12-12
prayer (1.3.2-dfsg1-1) unstable; urgency=low

  * New upstream release (Closes: #546918).
    * The set of available template sets has changed and several
      obsolete configuration options are no longer recognized. Please
      see NEWS.Debian for more information.
    - Repacked without University of Cambridge logos with dubious
      copyright/license status (more info in debian/copyright).
    - unbrand_cam_template.patch: Remove said Cambridge-specific graphics
      from 'cam' template set.
    - Drop unlimit_login_username.patch (fixed upstream when replacing
      the old login screen with frontend templates) and
      usernames_with_at.patch (incorporated upstream).
    * clean_completely.patch: Partially implemented upstream.
    * Manpages incorporated upstream.
  * dlopen_templates.patch: Experimental support for dynamically loading
    templates.
  * Update README.Debian.
  * makefile_install_config.patch(share/config.c): Change default
    template_set to "old".
  * makefile_install_config.patch(files/Makefile): Fix permissions on
    icons and static files.
  * manpage_error.patch: Fix missing .El in prayer-session(8).

Available diffs

Superseded in lucid-release on 2009-11-06
Obsolete in karmic-release on 2013-03-04
prayer (1.2.3-1) unstable; urgency=low

  * New upstream release.
    - Drop repair_ssl_session_db_on_version_mismatch.patch,
      remove_old_db_logfiles_from_prayer-ssl-prune.patch,
      welcome_is_template.patch, template_find_bug.patch; all incorporated
      upstream.
    - Update makefile_install_config.patch after welcome.html gone.
  * kfreebsd.patch (new): Try to get Prayer to work on Debian
    GNU/kFreeBSD.
  * Add ${misc:Depends} to Depends for prayer-templates.
  * Upgrade to Standards-Version 3.8.1.
    + Add debian/README.source.
  * clean_completely.patch (new): Fix a few makefiles that didn't remove
    their build targets in the clean target (Closes: #521369). Thanks to
    Simon McVittie.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Wed,  29 Apr 2009 12:08:42 +0100

Available diffs

Superseded in karmic-release on 2009-04-29
Obsolete in jaunty-release on 2013-02-28
prayer (1.2.2.1-7) unstable; urgency=high

  * Since /var/run can be a tmpfs filesystem, don't ship /var/run/prayer
    as part of the package but create it in the init script (LP: 304071).
  	Also, var_prefix, pid_dir and prayer_user will by default be overriden
  	from the command line to make sure that they get the values expected by
  	the init script.

 -- Devid Antonio Filoni <email address hidden>   Tue,  17 Feb 2009 17:54:28 +0000

Available diffs

Superseded in jaunty-release on 2009-02-17
prayer (1.2.2.1-6ubuntu2) jaunty; urgency=low

  * Build-depend against libc-client2007b-dev.

 -- Luca Falavigna <email address hidden>   Mon, 22 Dec 2008 10:14:07 +0000
Superseded in jaunty-release on 2008-12-22
prayer (1.2.2.1-6ubuntu1) jaunty; urgency=low

  * Switch to libc-client2007d-dev build-dependency.

 -- Luca Falavigna <email address hidden>   Fri, 14 Nov 2008 20:51:27 +0100

Available diffs

Superseded in jaunty-release on 2008-11-14
prayer (1.2.2.1-6) unstable; urgency=low

  * prayer.init: Correctly check for the presence of the executables.
  * Split out templates to a separate arch-indep package.
  * Change the default value of the tmp_dir option back to
    ${var_prefix}/tmp (/var/run/prayer/tmp) because using /tmp may not be
    secure.
  * usernames_with_at.patch (new, from upstream CVS): If a username
    contains an @, it will be assumed to be a valid email address and be
    used as envelope sender address and default "From" address when
    sending mail (Closes: #497016).

 -- Luca Falavigna <email address hidden>   Fri,  14 Nov 2008 11:49:23 +0000

Available diffs

Superseded in jaunty-release on 2008-11-14
Obsolete in intrepid-release on 2013-02-20
prayer (1.2.2.1-5aubuntu1) intrepid; urgency=low

  * Resync with Debian unstable.
  * Remove libc-client2007-dev from Build-depends field.

Superseded in intrepid-release on 2008-08-18
prayer (1.2.2.1-3ubuntu1) intrepid; urgency=low

  * Merge from Debian unstable, remaining Ubuntu changes:
    - debian/patches/makefile_fix_ftbfs.patch

Superseded in intrepid-release on 2008-08-13
prayer (1.2.2.1-1ubuntu1) intrepid; urgency=low

  * makefile_fix_ftbfs.patch: Add patch to stop FTBFS (LP: #256220)

 -- David Futcher <email address hidden>   Fri, 08 Aug 2008 22:47:11 +0100

Available diffs

Superseded in intrepid-release on 2008-08-08
prayer (1.2.2.1-1) unstable; urgency=low

  * New upstream release featuring XHTML templates and fixes to various
    bugs created by the reorganisation.
    - Drop accountd_makefile_typo.patch; fixed upstream.
  * makefile_install_config.patch: Changes to the default config: 
    - Disable SSL session caching.  
    - Clean out "direct connection stuff". Remove lock_dir since we use
      SysV semaphores.
    * Point login_prefix_path, motd_path, and login_suffix_path towards
      /etc/prayer.
    * Change postponed-mail and sent-mail to Drafts and Sent.
  * Improve SSL/TLS configuration:
    * makefile_install_config.patch: Point ssl_cert_file and
      ssl_privatekey_file to /etc/ssl/*/ssl-cert-snakeoil.*.
    + Add dependency on ssl-cert (>= 1.0.11).  
    + prayer.postinst: Add prayer to group ssl-cert on fresh install or
      when upgrading from versions prior to this one.
  * welcome_is_template.patch (new): Although the welcome screen is now a
    template among others, cmd_welcome.c still tried to read the file
    specified by welcome_path (welcome.html by default) and wouldn't show
    the welcome screen if the option was unset or the file couldn't be
    read. This patch removes that check as well as the welcome_path and
    help_path options from prayer.cf.
  * No longer install welcome.html (see above) and motd.html (no real
    content) in /etc/prayer. Install login_prefix.html, login_suffix.html,
    and motd.html (the versions found in files/etc.hermes in the
    distribution tarball) in /usr/share/doc/prayer/examples instead.
  * Do not install prayer-chroot (too experimental, hardcoded chroot path)
    or prayer-sem-prune (does nothing that ipcrm cannot do).
  * templates_fallback_to_compiled.patch (new): If the
    template_use_compiled option is false, nevertheless use compiled-in
    templates in template_expand.c if the requested template cannot be
    found on disk. Change default template_path to /etc/prayer/templates.
    Install said directory as well as subdirectories for available
    template sets.
  * Update and improve README.Debian.
  * Add logrotate dependency.
  * makefile_install_config.patch: Remove call to install.sh from
    files/Makefile and replace it with single tar pipeline; thus
    install.sh no longer needs to be patched.
  * remove_old_db_logfiles_from_prayer-ssl-prune.patch (new): Patch
    myarchive() in lib/mydb_db3.c so that it only deletes obsolete
    transaction logs if dirname = NULL, then call it (via DB->archive())
    from ssl_prune_sessions() in lib/ssl.c.
    - prayer-db-prune thus unnecessary.
  * template_find_bug.patch (new): Fix segfault in template_find() when
    template_set specifies a non-existing set. Also update default set.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Tue,  24 Jun 2008 13:49:13 +0100

Available diffs

Superseded in intrepid-release on 2008-06-24
prayer (1.2.0-1) unstable; urgency=low

  * New upstream release featuring a major code reorganisation and a new
    template system.
    - Drop obsolete folder_list_cosmetics.patch and includes.patch.
    - Note: SSL support has been removed from prayer-accountd for now.
  * Changed defaults (manual intervention may be needed):
    - Let prayer-accountd.pid reside in /var/run; letting the two packages
      share /var/run/prayer caused too much trouble.
    - prayer.cf (makefile_install_config.patch and debian/Config):
      var_prefix set to /var/run/prayer and referred to in other
      settings. socket_split_dir disabled by default and default sockets
      directory changed to /var/run/prayer/sockets.
  * debian/control:
    + Build-depend on latest Berkley DB library (libdb-dev).
    + Add Homepage field.
  * repair_ssl_session_db_on_version_mismatch.patch: Recreate session DB
    environment when upgrading from a version of Prayer that used an older
    BDB library.
  * prayer.postinst: Set HOME of prayer user to /var/run/prayer.
  * prayer.postrm: Simply remove /var/run/prayer (since accountd doesn't use it)
    on remove or disappear and correctly remove statoverrides (Closes: #483176).
    Also check that deluser exists; it may be gone at purge time.
  * Package build details:
    - Reduce makefile_install_config.patch by not changing BROOT into DESTDIR.
    - Override CDBS overriding CFLAGS.
  * debian/patches/accountd_makefile_typo.patch: Fix typo that caused PAM
    not to be used.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Sun,  01 Jun 2008 14:13:16 +0100

Available diffs

Superseded in intrepid-release on 2008-06-01
prayer (1.1.0-2) unstable; urgency=low

  * Define LDAP_DEPRECATED so that the deprecated LDAP interfaces can be
    used.
  * makefile_install_config.patch: Modify prayer/Makefile so that the
    above definition isn't lost if CFLAGS is overridden.
  * Improve prayer.postrm to clean /var/run/prayer on removal and
    disappearence.
  * Use dpkg-override to allow the administrator to change mode of
    /var/run/prayer and /var/log/prayer.
  * Add postinst and postrm scripts for prayer-accountd.
  * makefile_install_config.patch: Set authtype = pam in accountd.cf so
    that accountd will start.
  * Bump Standards-Version to 3.7.3. No changes necessary.
  * Override Lintian warnings about GPL code linked with OpenSSL. Special
    exception has been granted.
  * Don't require cdbs 0.4.27-1. Oldstable has 0.4.28-1.

130 of 30 results