2.6.15-15.21_i686 does not boot (depmod not found)

Bug #31347 reported by Luka Renko on 2006-02-13
10
Affects Status Importance Assigned to Milestone
Ubuntu
Medium
Unassigned
prelink (Ubuntu)
Medium
Unassigned
ubuntu-docs (Ubuntu)
Dapper
Medium
Unassigned

Bug Description

I am using Kubuntu Dapper on HP nw8240 notebook since Flight 3. I have installed 686 kernel and removed 386 version. When I have recently performed regular upgrade, Dapper did not boot again and reported several errors regarding depmod, modprobe and similar command not found. First reported error was something like this:

/init: 83 - depmod: not found.

Since I did not have other kernels available, I had to boot into Breezy and downgrade linux-image and initramfs to last know good version:

 sudo chroot /media/dapper
 cd /var/cache/apt/archives
 dpkg -i linux-image-2.6.15-15-686_2.6.15-15.20_i386.deb
 dpkg -i initramfs-tools_0.40ubuntu20_all.deb

There was some discussion about this issue in Ubuntu Forums:
http://www.ubuntuforums.org/showthread.php?t=127996

Some people suggest that this problem does not exist with 386 package.

Andrew Waldram (andrew-waldram) wrote :

I have the same issue the suggested fixes mentioned on the forum donot resolve this issue for me.
2.6.15-20 is fine

Changed in linux-meta:
status: Unconfirmed → Confirmed
Luka Renko (lure) wrote :

I have also tried to downgrade only linux-image and it seems to be enough (initramfs can be latest/current Dapper version).

Chris Peterman (kyral) wrote :

Same thing with the -k7 package. However, chrooting in via a LiveCD and running update-grub fixes it for some reason

Ben Collins (ben-collins) wrote :

This is all with initramfs. Kernel doesn't have anything to do with depmod directly.

Luka Renko (lure) wrote :

But why downgrading only linux-image package solves this issue for me?
I do not need to do anything with initramfs package...

Andrew Waldram (andrew-waldram) wrote :

Yes just booting an earlier kernel with no changes is fine

i.e 2.6.15-20

But supprisingly I re-ran the fix posted in the thread and this time it worked (very strange)

sudo apt-get --reinstall install linux-image-2.6.15-15-686 initramfs-tools

Actually i've been trying to between kernel 2.6.15-14 and 2.6.15-15. After deinstalling and reinstallling several times kernel 2.6.15-14, I ended up with my kernel 2.6.15-15 broken in the same way :)

This is non sense ...

Luka Renko (lure) wrote :

I did fresh install of Kubuntu Flight 4 today and this problem is gone! Now both 386 and 686 kernel work as expected.
Is it possible that something on my older install cause it (it was from Flight 3 times)?

Adam Conrad (adconrad) wrote :

Do any of the people who've commented on this bug report still have the initrd.img-2.6.15-15-686 image in /boot that was failing to boot?

If you have that (and can confirm it's still failing), a copy of that would go a long way in me tracking down what really happened here (and if it will happen again).

If not, based on recent feedback that it's not currently a problem, I'll probably just close the bug.

Changed in initramfs-tools:
assignee: nobody → adconrad
Luka Renko (lure) wrote :

Sorry, I don't as I reformatted my Flight 3 install (where the problem was). You may want to ask on forums, as there were more users having same problem (I doubth they follow launchpad). One thread is up, but there were multiple threads discussig that.

I never rebuild so do have a failing initrd.

supplied as requested.

not had an issue with 2.6.15-16

I did manage to get 2.6.15-15 working after multiple re-install of that kernel then it bust again. suspect some update rebuilt initrd---date changed.

motyR (moty-rahamim) wrote :

i had the same problem and i found out that prelink was the reason, look at the prelink bug report in here...

Luka Renko (lure) wrote :

I can confirm that I was testing prelink at the time, therefore it could be it.

Michael Gratton (mjog) wrote :

Confirming that I had prelink installed and that removing it and reinstalling the kernel image and initramfs-tools fixed it. See bug #31135.

Changed in ubuntu-docs:
status: Unconfirmed → Rejected
Matt Zimmerman (mdz) on 2006-04-17
Changed in prelink:
assignee: adconrad → nobody
Adam Niedling (krychek) wrote :

Dapper alpha is not supported. Do you still have this issue in updated Dapper or in a later version of Ubuntu?

Changed in prelink:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers