Change log for psychopy package in Ubuntu

122 of 22 results
Deleted in eoan-release (Reason: Depends on osolete python-imaging, python2 only, removed ...)
Published in disco-release on 2018-10-30
Published in cosmic-release on 2018-05-01
Published in bionic-release on 2018-02-01
Deleted in bionic-proposed (Reason: moved to release)
Deleted in bionic-proposed on 2018-02-01 (Reason: LP: #1746406 remove packages depending on python-imaging ...)
Deleted in bionic-release on 2018-02-01 (Reason: lp: #1746406, demote package still depending on python-im...)
Deleted in bionic-proposed on 2018-02-01 (Reason: moved to release)
psychopy (1.85.3.dfsg-1build1) bionic; urgency=medium

  * No-change rebuild against OpenCV 3.2.

 -- Mattia Rizzolo <email address hidden>  Sun, 29 Oct 2017 13:05:26 +0100
Superseded in bionic-release on 2017-10-29
Deleted in bionic-proposed on 2017-10-30 (Reason: moved to release)
psychopy (1.85.3.dfsg-1) unstable; urgency=medium

  * New upstream release

 -- Yaroslav Halchenko <email address hidden>  Fri, 13 Oct 2017 00:00:02 -0400

Available diffs

Superseded in bionic-release on 2017-10-27
Published in artful-release on 2017-04-20
Obsolete in zesty-release on 2018-06-22
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed (Reason: moved to release)
psychopy (1.83.04.dfsg-2) unstable; urgency=medium

  * CPed changeset_46fe7ee7a8526a927819e961fbb4404110a87293.diff to overcome
    syntax error during installation.  Thanks Christopher J Markiewicz for the
    report!

 -- Yaroslav Halchenko <email address hidden>  Fri, 19 Feb 2016 13:06:09 -0500

Available diffs

Superseded in yakkety-release on 2016-04-27
Published in xenial-release on 2015-10-24
Deleted in xenial-proposed (Reason: moved to release)
psychopy (1.82.02.dfsg-1) unstable; urgency=medium

  * Fresh upstram bugfix release
  * debian/rules
    - make tests less verbose (removed -v, added -q)

 -- Yaroslav Halchenko <email address hidden>  Mon, 14 Sep 2015 15:41:28 -0400

Available diffs

Superseded in xenial-release on 2015-10-24
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed on 2018-01-22 (Reason: moved to release)
psychopy (1.82.01.dfsg-1) unstable; urgency=medium


  * Fresh upstream bugfix release
  * debian/control
    - python-pandas was added to both Build-depends and Recommends

 -- Yaroslav Halchenko <email address hidden>  Mon, 20 Apr 2015 16:23:01 -0400

Available diffs

Superseded in wily-release on 2015-05-06
Obsolete in vivid-release on 2018-01-18
Deleted in vivid-proposed on 2018-01-19 (Reason: moved to release)
psychopy (1.81.03.dfsg-1) unstable; urgency=medium


  * New upstream bugfix release

 -- Yaroslav Halchenko <email address hidden>  Wed, 03 Dec 2014 11:05:04 -0500

Available diffs

Superseded in vivid-release on 2014-12-06
Deleted in vivid-proposed on 2014-12-07 (Reason: moved to release)
psychopy (1.81.01.dfsg-1) unstable; urgency=medium


  * debian/control
    - Added X-Python-Version: >= 2.7 to avoid problems on older systems
      with unsupported in 2.6 syntax. Also export DEBPYTHON_SUPPORTED in
      debian/rules to solidify such a choice ;-) (Thanks to Mark Hymers)
    - Added Conflicts: libavbin0 (= 7-4+b1) to guarantee that psychopy
      is not installed alongside a broken build of libavbin0.  Presence
      of such a build would impair normal functioning of psychopy.
  * debian/rules
    - fix symlink to demos (now that dh_python doesn't install into
      pyshared)

 -- Yaroslav Halchenko <email address hidden>  Thu, 23 Oct 2014 14:01:44 -0400

Available diffs

Superseded in vivid-release on 2014-10-28
Deleted in vivid-proposed on 2014-10-29 (Reason: moved to release)
psychopy (1.81.00.dfsg-1) unstable; urgency=medium


  * Fresh upstream release
  * debian/patches
    - update_matplotlib_test -- handled upstream
    - wxpython3.0.patch was refactored into wxpython3.0-1.81.00.patch to
      keep residual changes (suppressing debug output, and use FD_ prefixes)
  * debian/control
    - boost policy to 3.9.6
    - remove libavbin0 from build-depends (broken see #750577)
    - adding python-psutil, python-gevent, python-msgpack, python-yaml,
      python-serial into Build-Depends and Recommends
  * debian/rules
    - state that TRAVIS=true while testing under xvfb to skip some tests
      requiring real hardware etc
    - switch away from pysupport to dh_python
    - switch from cdbs to dh, raised compat to 7
    - for now ignore tests failure(s), they do not exit cleanly
      see https://github.com/psychopy/psychopy/issues/708

 -- Yaroslav Halchenko <email address hidden>  Mon, 13 Oct 2014 22:14:30 -0400
Superseded in vivid-release on 2014-10-25
Obsolete in utopic-release on 2016-11-03
Published in trusty-release on 2014-03-28
Deleted in trusty-proposed (Reason: moved to release)
psychopy (1.79.00+git16-g30c9343.dfsg-1) unstable; urgency=low


  * New release (+ post-release fixes)
  * debian/patches
    - deb_no_post_inst -- upstream does it correctly now
    - update_matplotlib_test (from Mike Hymers) to address missing nxutils
  * debian/control
    - add python-pytest to build-depends (thanks Mark again)
  * debian/rules
    - do not install our runner shell script, just use upstream's runner script
    (renamed)

 -- Yaroslav Halchenko <email address hidden>  Sat, 21 Dec 2013 10:54:21 -0500
Superseded in trusty-release on 2014-03-28
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed on 2015-04-28 (Reason: moved to release)
psychopy (1.77.02.dfsg-1) unstable; urgency=low


  * New upstream bugfix release
  * Do not ignore tests failures while building for unstable/sid

 -- Yaroslav Halchenko <email address hidden>  Fri, 12 Jul 2013 12:55:11 -0400

Available diffs

Superseded in saucy-release on 2013-07-18
Deleted in saucy-proposed on 2013-07-20 (Reason: moved to release)
psychopy (1.77.00.dfsg-1) unstable; urgency=low


  * New upstream release
  * Enabling build-time unit-testing under Xvfb, but ignoring failures
    for now (there are few differently persistent ones)
  * debian/control:
    - libxxf86vm1 to Recommends -- needed for XF86VidModeSetGammaRamp

 -- Yaroslav Halchenko <email address hidden>  Fri, 14 Jun 2013 08:37:23 -0400

Available diffs

Superseded in saucy-release on 2013-06-15
Obsolete in raring-release on 2015-04-24
Obsolete in quantal-release on 2015-04-24
psychopy (1.73.06.dfsg-1) unstable; urgency=low


  * New upstream bugfix release (released April 2012)

 -- Yaroslav Halchenko <email address hidden>  Wed, 27 Jun 2012 15:49:15 -0400

Available diffs

Superseded in quantal-release on 2012-06-29
psychopy (1.73.05.dfsg-1) unstable; urgency=low


  * New upstream release
  * Upgraded policy to 3.9.3
    - debian/copyright updated for DEP-5 compliance
  * Removed not any longer needed versioning from build-depends

 -- Yaroslav Halchenko <email address hidden>  Sun, 04 Mar 2012 16:19:21 -0500
Superseded in quantal-release on 2012-05-01
Published in precise-release on 2011-11-13
psychopy (1.71.01.dfsg-1) unstable; urgency=low

  * New upstream release
 -- Ubuntu Archive Auto-Sync <email address hidden>   Sun,  13 Nov 2011 01:31:55 +0000

Available diffs

Superseded in precise-release on 2011-11-13
psychopy (1.71.00.dfsg-1) unstable; urgency=low

  * New upstream release
  * Moved scipy into Depends from Recommends due to imports of scipy at
    core modules (also reformatted *Depends into multilines)

Superseded in precise-release on 2011-10-17
Obsolete in oneiric-release on 2015-04-24
psychopy (1.65.02.dfsg-1) unstable; urgency=low
  * New upstream release -- Yaroslav Halchenko <email address hidden>  Wed, 13 Jul 2011 10:37:23 -0400
Superseded in oneiric-release on 2011-07-27
psychopy (1.64.00.dfsg-1) unstable; urgency=low

  * New upstream release
  * debian/control:
    - added perspective python-pyxid to Suggests
  * debian/copyright:
    - added Jeremey Grey copyright to mseq* code
    - updated years

Available diffs

Superseded in oneiric-release on 2011-04-30
Obsolete in natty-release on 2013-06-04
psychopy (1.61.03.dfsg-1) unstable; urgency=low

  * Upstream bugfix release for 1.61 series + 2 additional commits
    (advised by upstream):
    - rev 1015 - builder: minor bug in trying dlgs trying to access advParams
      that don't exist
    - rev 1018 - coder: fix to reading of unicode scripts
  * This should be the last release in 1.61.xx series, 1.62.0 is in alpha
    testing

Available diffs

Superseded in natty-release on 2010-10-15
Obsolete in maverick-release on 2013-03-05
psychopy (1.61.02.dfsg-1) unstable; urgency=low

  * New upstream release (+ few svn commits getting to rev1004)
    - no string exceptions (Closes: #585272)
    - includes iolab's Python interface
 -- Ubuntu Archive Auto-Sync <email address hidden>   Tue,  22 Jun 2010 08:40:49 +0100

Available diffs

Superseded in maverick-release on 2010-06-22
psychopy (1.61.00.dfsg-1) unstable; urgency=low

  * New upstream release
  * Cherry-picked 2 commits pushed upstream: permissions, and python 2.4
    compatibility
 -- Ubuntu Archive Auto-Sync <email address hidden>   Thu,  13 May 2010 08:12:59 +0100

Available diffs

Superseded in maverick-release on 2010-05-13
psychopy (1.60.00.dfsg-1) unstable; urgency=low

  * New upstream release
  * debian/control: Upgraded policy to 3.8.4 -- no changes are due
  * debian/copyright: years
  * Include changlog modifications done by upstream between 
    announced release and tagging
  * BF: use system-wide installed configobj (Closes: #555341)
 -- Ubuntu Archive Auto-Sync <email address hidden>   Sun,  09 May 2010 14:00:20 +0100

Available diffs

Superseded in maverick-release on 2010-05-09
Obsolete in lucid-release on 2016-10-26
psychopy (1.51.00.dfsg-1) unstable; urgency=low

  * Upstream release: based Debian package on SVN rev 687,
    git sha e829fc97e1a23b342630dd10312c345283c915e5.
  * debian/control:
    * BF: Recommends python-scipy
    * RF: libavbin0 into Recommends from Suggests
    * BF: matplotlib/lxml into Depends
    * BF: Adjusted description (closes: #547255)
    * Upgraded policy to 3.8.3 -- no changes are due
  * Reverted to using wrapper script which invokes psychopy app via runpy

122 of 22 results