Change log for puppet package in Ubuntu

175 of 187 results
Published in focal-release on 2020-03-27
Deleted in focal-proposed (Reason: moved to Release)
puppet (5.5.10-4ubuntu3) focal; urgency=medium

  * d/p/fix-ruby27-warning.patch: Add patch to fix a warning when executed
    with Ruby 2.7. It fixes an autopkgtest regression in ruby-puppet-syntax.
  * d/t/control: Add allow-stderr restriction to puppet master and puppet
    master passenger tests.
  * d/t/control: add 'puppet' to $no_proxy variable in puppet-master-passenger
    test to let tests make requests to puppet master running locally
    (LP: #1869265).

 -- Lucas Kanashiro <email address hidden>  Thu, 26 Mar 2020 18:27:14 -0300
Superseded in focal-proposed on 2020-03-27
puppet (5.5.10-4ubuntu2) focal; urgency=medium

  * d/t/control: generate a certificate for puppet master if it does not
    already exist, as it is needed by the tests (LP: #1869084).

 -- Lucas Kanashiro <email address hidden>  Wed, 25 Mar 2020 18:20:06 -0300

Available diffs

Superseded in focal-proposed on 2020-03-25
puppet (5.5.10-4ubuntu1) focal; urgency=medium

  * Add build and runtime dependency on ruby-sync (LP: #1866417).

 -- Lucas Kanashiro <email address hidden>  Fri, 06 Mar 2020 12:15:40 -0300
Superseded in focal-proposed on 2020-03-07
Deleted in eoan-proposed on 2020-03-08 (Reason: moved to focal-proposed)
puppet (5.5.10-4) unstable; urgency=medium

  * Team upload.
  * Added a puppet-master.NEWS file, as suggested by the release team.

 -- Thomas Goirand <email address hidden>  Mon, 17 Jun 2019 11:44:21 +0200

Available diffs

Superseded in eoan-proposed on 2019-06-17
puppet (5.5.10-3) unstable; urgency=medium

  * Team upload.
  * Add a cron.daily job to clean-up /var/lib/puppet/reports for any report
    that is older than 30 days to avoid filling-up a puppet-master hard drive
    until it's full (Closes: #930033).

 -- Thomas Goirand <email address hidden>  Thu, 06 Jun 2019 10:24:27 +0200

Available diffs

Superseded in eoan-proposed on 2019-06-06
Deleted in disco-proposed on 2019-06-07 (Reason: moved to eoan-proposed)
puppet (5.5.10-2) unstable; urgency=medium

  * Make sure oj does not use BigDecimals on data load (Closes: #923976)

 -- Apollon Oikonomopoulos <email address hidden>  Tue, 12 Mar 2019 12:51:05 +0200

Available diffs

Superseded in disco-proposed on 2019-03-21
puppet (5.5.10-1) unstable; urgency=medium

  * New upstream bugfix release; see
    https://puppet.com/docs/puppet/5.5/release_notes.html#puppet-5510
  * Bump Standards-Version to 4.3.0; no changes needed

 -- Apollon Oikonomopoulos <email address hidden>  Wed, 16 Jan 2019 10:56:17 +0200

Available diffs

Superseded in disco-proposed on 2019-01-16
puppet (5.5.8-1) unstable; urgency=medium

  * New upstream bugfix release; see
    https://puppet.com/docs/puppet/5.5/release_notes.html#puppet-557 and
    https://puppet.com/docs/puppet/5.5/release_notes.html#puppet-558
  * d/watch: only look for Puppet 5 versions for the time being
  * Override the source-contains-prebuilt-windows-binary lintian tag for
    ext/windows/eventlog/puppetres.dll. The DLL source is provided in
    ext/windows/eventlog/puppetres.mc.

 -- Apollon Oikonomopoulos <email address hidden>  Fri, 09 Nov 2018 09:33:05 +0200

Available diffs

Superseded in disco-proposed on 2018-11-09
puppet (5.5.6-1) unstable; urgency=medium

  * New upstream bugfix release; see
    https://puppet.com/docs/puppet/5.5/release_notes.html#puppet-556
  * Bump Standards-Version to 4.2.1; no changes needed
  * Refresh patches

 -- Apollon Oikonomopoulos <email address hidden>  Wed, 29 Aug 2018 09:35:46 +0300

Available diffs

Superseded in disco-proposed on 2018-11-09
Deleted in cosmic-proposed on 2018-11-10 (Reason: Moved to disco-proposed)
puppet (5.5.3-1) unstable; urgency=medium

  * New upstream bugfix release
  * Refresh patches

 -- Apollon Oikonomopoulos <email address hidden>  Mon, 23 Jul 2018 23:39:45 +0300

Available diffs

Superseded in cosmic-proposed on 2018-07-24
puppet (5.5.2-2) unstable; urgency=medium

  * Build-Depend on ronn instead of ruby-ronn (Closes: #903290)

 -- Apollon Oikonomopoulos <email address hidden>  Sun, 08 Jul 2018 22:14:10 +0300
Superseded in focal-release on 2020-03-27
Published in eoan-release on 2019-04-19
Deleted in eoan-release (Reason: moved to eoan-proposed)
Published in disco-release on 2018-10-30
Published in cosmic-release on 2018-05-01
Published in bionic-release on 2018-04-21
Deleted in bionic-proposed (Reason: moved to release)
puppet (5.4.0-2ubuntu3) bionic; urgency=medium

  * Revert:
    - Revert the Ubuntu delta. No changes left.
      + DEP8 tests fail in the Ubuntu autopkgtest environment without
        the delta.
  * d/t/control: fix incorrect merge in 5.4.0-2ubuntu1:
    - Wrong test was generating the certificate.
    - Wrong tests were being run for puppet-master-passenger.

 -- Nishanth Aravamudan <email address hidden>  Thu, 19 Apr 2018 14:06:40 -0700
Superseded in bionic-proposed on 2018-04-19
puppet (5.4.0-2ubuntu2) bionic; urgency=medium

  * Revert the Ubuntu delta. No changes left.

 -- Matthias Klose <email address hidden>  Thu, 05 Apr 2018 00:03:24 +0200

Available diffs

Superseded in bionic-proposed on 2018-04-04
puppet (5.4.0-2ubuntu1) bionic; urgency=medium

  * Merge with Debian; remaining changes:
    - d/t/control: disable sysv-init tests as it does not exist on
      Ubuntu.
    - d/t/spec/puppet-master-passenger/zz_puppet3_compat_spec.rb:
      specify to curl that 'puppet' should not be proxied.
    - d/t/control: generate a certificate for puppet master if it does
      not already exist, as it is needed by the tests.

Superseded in bionic-release on 2018-04-21
Deleted in bionic-proposed on 2018-04-22 (Reason: moved to release)
puppet (4.10.4-2ubuntu3) bionic; urgency=medium

  * Fix duplicate oids, cherrypick upstream patch for OpenSSL 1.1 compat.

 -- Dimitri John Ledkov <email address hidden>  Fri, 16 Mar 2018 16:12:56 +0000
Published in trusty-updates on 2018-02-12
Published in trusty-security on 2018-02-12
puppet (3.4.3-1ubuntu1.3) trusty-security; urgency=medium

  * SECURITY UPDATE: insecure permissions when unpacking tarballs
    - debian/patches/CVE-2017-10689-1.patch: reset permissions when
      unpacking tar in lib/puppet/module_tool/tar/mini.rb, fix test in
      spec/unit/module_tool/tar/mini_spec.rb.
    - debian/patches/CVE-2017-10689-2.patch: use Integer instead of Fixnum
      in lib/puppet/module_tool/tar/mini.rb.
    - CVE-2017-10689

 -- Marc Deslauriers <email address hidden>  Fri, 09 Feb 2018 13:46:46 -0500
Superseded in bionic-release on 2018-03-16
Deleted in bionic-proposed on 2018-03-18 (Reason: moved to release)
puppet (4.10.4-2ubuntu2) bionic; urgency=medium

  * debian/patches/ruby2.3.6_compat.patch: SSL behavior changed in ruby
    2.3.6.

 -- Nishanth Aravamudan <email address hidden>  Thu, 01 Feb 2018 19:30:33 -0800
Superseded in bionic-release on 2018-02-02
Published in artful-release on 2017-07-16
Deleted in artful-proposed (Reason: moved to release)
puppet (4.10.4-2ubuntu1) artful; urgency=medium

  * Merge with Debian unstable (LP: #1702578). Remaining changes:
    - d/t/control: disable sysv-init tests as it does not exist on
      Ubuntu.
    - d/t/spec/puppet-master-passenger/zz_puppet3_compat_spec.rb:
      specify to curl that 'puppet' should not be proxied.
    - d/t/control: generate a certificate for puppet master if it does
      not already exist, as it is needed by the tests.
  * Drop:
    - d/p/0005-use-systemd-as-the-default-service-provider.path: also
      make systemd the default provider on Ubuntu.
      [ Fixed in Debian 4.10.4-1 ]

 -- Nishanth Aravamudan <email address hidden>  Wed, 05 Jul 2017 15:23:47 -0700

Available diffs

Superseded in trusty-updates on 2018-02-12
Superseded in trusty-security on 2018-02-12
puppet (3.4.3-1ubuntu1.2) trusty-security; urgency=medium

  * SECURITY UPDATE: untrusted search path vulnerability
    - debian/patches/CVE-2014-3248.patch: remove current directory from
      load path in bin/puppet.
    - CVE-2014-3248
  * SECURITY UPDATE: code execution via unsafe fact formats
    - debian/patches/CVE-2017-2295.patch: reject all fact formats except
      PSON in lib/puppet/indirector/catalog/compiler.rb, added tests to
      spec/unit/indirector/catalog/compiler_spec.rb.
    - CVE-2017-2295

 -- Marc Deslauriers <email address hidden>  Fri, 02 Jun 2017 10:29:36 -0400
Superseded in artful-release on 2017-07-16
Deleted in artful-proposed on 2017-07-17 (Reason: moved to release)
puppet (4.8.2-5ubuntu1) artful; urgency=medium

  * Merge with Debian unstable. Remaining changes:
    - d/p/0005-use-systemd-as-the-default-service-provider.path: also
      make systemd the default provider on Ubuntu.
    - d/t/control: disable sysv-init tests as it does not exist on
      Ubuntu.
    - d/t/spec/puppet-master-passenger/zz_puppet3_compat_spec.rb:
      specify to curl that 'puppet' should not be proxied.
    - d/t/control: generate a certificate for puppet master if it does
      not already exist, as it is needed by the tests.

 -- Nishanth Aravamudan <email address hidden>  Mon, 29 May 2017 10:55:15 -0700

Available diffs

Superseded in artful-release on 2017-05-29
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed on 2018-06-22 (Reason: moved to release)
puppet (4.8.2-3ubuntu2) zesty; urgency=medium

  * d/t/spec/puppet-master-passenger/zz_puppet3_compat_spec.rb: specify
    to curl that 'puppet' should not be proxied.
  * d/t/control: generate a certificate for puppet master if it does not
    already exist, as it is needed by the tests.
  * Drop:
    - d/t/spec/puppet-master/install_spec.rb: generate host certificate
      before attempting to use it. There is no guarantee the certificate
      exist in the autopkgtest environment.
    [ By generating the certificate if not present in d/t/control, we
      don't need to in the spec ]

 -- Nishanth Aravamudan <email address hidden>  Thu, 23 Feb 2017 17:18:09 -0800
Published in xenial-updates on 2017-03-02
Deleted in xenial-proposed (Reason: moved to -updates)
puppet (3.8.5-2ubuntu0.1) xenial; urgency=medium

  * debian/patches/0008-Default-to-systemd-if-systemd.patch: systemd is
    the default service provider if it is running.  Closes LP: #1570472.

 -- Nishanth Aravamudan <email address hidden>  Fri, 17 Feb 2017 16:28:47 -0800
Obsolete in yakkety-updates on 2018-01-23
Deleted in yakkety-proposed on 2018-01-23 (Reason: moved to -updates)
puppet (4.5.2-1ubuntu1.1) yakkety; urgency=medium

  * debian/patches/0004-update_systemd_default_16.10.patch: Indicate
    systemd is also the default on 16.10.  Closes LP: #1570472.

 -- Nishanth Aravamudan <email address hidden>  Fri, 17 Feb 2017 15:57:21 -0800
Superseded in zesty-proposed on 2017-02-24
puppet (4.8.2-3ubuntu1) zesty; urgency=medium

  * d/p/0005-use-systemd-as-the-default-service-provider.path: also make
    systemd the default provider on Ubuntu. LP: #1570472
  * d/t/control: disable sysv-init tests as it does not exist on Ubuntu.
  * d/t/spec/puppet-master/install_spec.rb: generate host certificate
    before attempting to use it. There is no guarantee the certificate
    exist in the autopkgtest environment.

 -- Nishanth Aravamudan <email address hidden>  Fri, 17 Feb 2017 15:14:52 -0800
Superseded in zesty-proposed on 2017-02-17
puppet (4.8.2-3) unstable; urgency=medium

  * Mark systemd as the default service provider for Debian. If the system is
    not running on systemd, puppet will automatically fall back to the
    "debian" service provider.
  * Again patch the "debian" service provider as in 3.7.2-3, to strip the
    sysv-rc check (Closes: #854680) and use systemctl to enable/disable
    services on systemd-booted systems.
  * Use /usr/sbin/service for starting/stopping/restarting services in the
    debian provider, to ensure the provider works with all init systems and
    does not call the initscripts directly. Patch by Gaudenz Steinlin,
    originally included in 3.7.2-2.
  * Add DEP-8 tests for basic operations on services (enable/disable,
    start/stop) backed by initscripts and/xor systemd units, on both systemd
    and sysvinit, with all applicable providers (default, systemd and debian).

 -- Apollon Oikonomopoulos <email address hidden>  Wed, 15 Feb 2017 14:23:21 +0200

Available diffs

Superseded in zesty-proposed on 2017-02-15
puppet (4.8.2-2) unstable; urgency=high

  * Do not enable the puppet service by default on fresh installs
    (Closes: #854487).
    + Preserve the agent lock on upgrade from 3.x to safeguard upgrades from
      Jessie systems where puppet was installed but never used.
  * Update the DEP-8 tests to check that the service is disabled.
  * Strip the agent locking logic from puppet.preinst now that we disable the
    service by default.
  * Add a debian/NEWS entry documenting the disabled service.
  * Update the information in README.Debian and remove the (now obsolete)
    paragraph about stored configs.

 -- Apollon Oikonomopoulos <email address hidden>  Wed, 08 Feb 2017 15:24:55 +0200

Available diffs

Superseded in zesty-proposed on 2017-02-09
puppet (4.8.2-1) unstable; urgency=medium

  * New upstream bugfix release.

 -- Apollon Oikonomopoulos <email address hidden>  Mon, 23 Jan 2017 14:39:14 +0200

Available diffs

Superseded in zesty-proposed on 2017-01-23
puppet (4.8.1-3) unstable; urgency=medium

  * puppet-master: handle puppetmaster service and conffile rename
    + try to preserve puppetmaster.service's state in puppet-master.service
    + migrate user changes from puppetmaster's config files
  * puppetmaster: drop all configfiles using dpkg-maintscript-helper
  * Drop the puppet-agent package (Closes: #826730, #827867)
    + Rename the puppet-agent service back to puppet and preserve state on
      upgrades
  * puppet-master: point to puppet-master-passenger for Puppet 3 support in
    extended description
  * puppet-master-passenger: migrate the apache2 site from
    puppetmaster-passenger installations
  * puppet: add missing Breaks/Depends against puppetmaster-common
  * puppet: remove extra license file
  * d/copyright: update copyright information

 -- Apollon Oikonomopoulos <email address hidden>  Wed, 18 Jan 2017 21:57:44 +0200

Available diffs

Deleted in zesty-proposed on 2017-02-13 (Reason: NBS)
puppet (4.8.1-2) unstable; urgency=medium

  * Add transitional packages for puppetmaster and puppetmaster-passenger.
  * Add Puppet 3 client compatibility when the master is run under a
    rack server (Closes: #832536). Input by James Cowgill and Christos
    Trochalakis, thanks!
  * Add DEP-8 tests for Puppet 3 client compatibility using serverspec.
  * Add a NEWS entry documenting Puppet 3 client compatibility.

 -- Apollon Oikonomopoulos <email address hidden>  Wed, 11 Jan 2017 20:22:17 +0200

Available diffs

Superseded in zesty-proposed on 2017-01-13
puppet (4.8.1-1) unstable; urgency=medium

  * Imported upstream release 4.8.1 (Closes: #844414)

 -- Stig Sandbeck Mathisen <email address hidden>  Wed, 30 Nov 2016 20:24:55 +0100

Available diffs

Superseded in zesty-proposed on 2016-12-01
puppet (4.8.0-1) unstable; urgency=medium

  * Imported upstream release 4.8.0

 -- Stig Sandbeck Mathisen <email address hidden>  Wed, 02 Nov 2016 21:17:39 +0100
Superseded in zesty-release on 2017-02-24
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed on 2018-01-23 (Reason: moved to release)
puppet (4.5.2-1ubuntu1) yakkety; urgency=medium

  * Drop obsolete sysv-rc | file-rc dependency. (Closes: #829552)

 -- Martin Pitt <email address hidden>  Mon, 04 Jul 2016 10:25:57 +0200
Superseded in yakkety-proposed on 2016-07-04
puppet (4.5.2-1) unstable; urgency=medium

  * Imported upstream release 4.5.2
  * Install missing examples from debian/examples
  * Add transitional package puppet-common
  * Fix missing rewrite in default paths patch (Closes: #826745)

 -- Stig Sandbeck Mathisen <email address hidden>  Fri, 17 Jun 2016 23:50:03 +0200

Available diffs

Superseded in yakkety-proposed on 2016-06-20
puppet (4.5.0-4) unstable; urgency=medium

  * Prevent a purge of puppet-common from deleting /var/lib/puppet
    (Closes: #825719)

 -- Stig Sandbeck Mathisen <email address hidden>  Sun, 29 May 2016 12:53:04 +0200

Available diffs

Superseded in yakkety-proposed on 2016-05-29
puppet (4.5.0-3) unstable; urgency=medium

  * Upload puppet 4.5.0-3 to Debian unstable (Closes: #798636)
  * Summary of changes since puppet 3.8.5-2 (last version in unstable):
    * New package names:
      * "puppet" contains the puppet software.
      * "puppet-agent", "puppet-master" and "puppet-master-passenger" starts
        services.
      * "vim-puppet" and "puppet-el" have been removed, and will be repackaged
        from separate sources.
    * activerecord stored configurations is no longer supported
    * etckeeper integration is no longer installed by default

 -- Stig Sandbeck Mathisen <email address hidden>  Sat, 28 May 2016 13:34:25 +0200
Superseded in yakkety-release on 2016-07-04
Published in xenial-release on 2016-03-17
Deleted in xenial-proposed (Reason: moved to release)
puppet (3.8.5-2) unstable; urgency=medium

  * [7b9bf62] sysvinit: fix service restart.
    Thanks to Martin Pitt (Closes: #818267)

 -- Stig Sandbeck Mathisen <email address hidden>  Tue, 15 Mar 2016 12:28:44 +0100
Superseded in xenial-release on 2016-03-17
Deleted in xenial-proposed on 2016-03-18 (Reason: moved to release)
puppet (3.8.5-1ubuntu1) xenial; urgency=medium

  * Merge with Debian unstable. Remaining Ubuntu changes:
    - debian/puppet{,master}.init: Wait until the puppet and puppetmaster
      daemons are actually stopped before returning. (LP: #1315021)
  * Put back Recommends: for ruby-activerecord and
    ruby-activerecord-deprecated-finders, as puppet is back in universe. (Drop
    Ubuntu delta).

Available diffs

Superseded in xenial-release on 2016-03-15
Deleted in xenial-proposed on 2016-03-16 (Reason: moved to release)
puppet (3.8.4-1ubuntu1) xenial; urgency=medium

  * Merge with Debian unstable. Remaining Ubuntu changes:
    - fix wrong process name match in logrotate script.
    - debian/puppet{,master}.init: Wait until the puppet and puppetmaster
      daemons are actually stopped before returning.
    - puppetmaster-common: Suggest instead of recommending ruby-activerecord
      and ruby-activerecord-deprecated-finders (universe).

Available diffs

Superseded in xenial-release on 2015-11-24
Superseded in xenial-release on 2015-10-24
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed on 2018-01-22 (Reason: moved to release)
puppet (3.7.2-5ubuntu2) wily; urgency=medium

  * puppetmaster-common: Suggest instead of recommending ruby-activerecord
    and ruby-activerecord-deprecated-finders (universe).

 -- Matthias Klose <email address hidden>  Fri, 11 Sep 2015 20:40:13 +0200

Available diffs

Superseded in wily-release on 2015-09-13
Deleted in wily-proposed on 2015-09-14 (Reason: moved to release)
puppet (3.7.2-5ubuntu1) wily; urgency=medium

  * Merge with Debian; remaining changes:
    - fix wrong process name match in logrotate script.
    - Wait until the puppet and puppetmaster daemons are actually stopped
      before returning.

Available diffs

Superseded in trusty-updates on 2017-06-05
Deleted in trusty-proposed on 2017-06-06 (Reason: moved to -updates)
puppet (3.4.3-1ubuntu1.1) trusty; urgency=medium

  * fix wrong process name match in logrotate script (LP: #1410383)
 -- Bartosz Cisek <email address hidden>   Fri, 06 Feb 2015 14:48:16 +0100

Available diffs

Superseded in wily-release on 2015-09-11
Obsolete in vivid-release on 2018-01-18
Deleted in vivid-proposed on 2018-01-19 (Reason: moved to release)
puppet (3.7.2-1ubuntu2) vivid; urgency=medium

  * fix wrong process name match in logrotate script (LP: #1410383)
 -- Bartosz Cisek <email address hidden>   Fri, 20 Mar 2015 15:56:13 +0100

Available diffs

Superseded in trusty-updates on 2015-04-30
Deleted in trusty-proposed on 2015-05-05 (Reason: moved to -updates)
puppet (3.4.3-1ubuntu1) trusty; urgency=medium

  * Wait until the puppet and puppetmaster daemons are actually stopped
    before returning (LP: #1315021)
 -- Felipe Reyes <email address hidden>   Wed, 04 Feb 2015 17:11:00 -0300
Obsolete in utopic-updates on 2016-11-03
Deleted in utopic-proposed on 2016-11-03 (Reason: moved to -updates)
puppet (3.6.1-1ubuntu1) utopic; urgency=medium

  * Wait until the puppet and puppetmaster daemons are actually stopped
    before returning (LP: #1315021)
 -- Felipe Reyes <email address hidden>   Wed, 04 Feb 2015 17:07:53 -0300
Superseded in vivid-release on 2015-03-31
Deleted in vivid-proposed on 2015-04-01 (Reason: moved to release)
puppet (3.7.2-1ubuntu1) vivid; urgency=medium

  * Wait until the puppet and puppetmaster daemons are actually stopped
    before returning (LP: #1315021)
 -- Felipe Reyes <email address hidden>   Wed, 04 Feb 2015 11:36:12 -0300
Superseded in vivid-release on 2015-02-04
Deleted in vivid-proposed on 2015-02-06 (Reason: moved to release)
puppet (3.7.2-1) unstable; urgency=medium


  * Imported upstream release 3.7.2
  * Declare compliance with Debian Policy 3.9.6

 -- Stig Sandbeck Mathisen <email address hidden>  Fri, 24 Oct 2014 13:47:15 +0200

Available diffs

Superseded in vivid-release on 2014-10-25
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed on 2016-11-03 (Reason: moved to release)
puppet (3.6.1-1) unstable; urgency=medium


  * Import upstream release 3.6.1

 -- Stig Sandbeck Mathisen <email address hidden>  Mon, 26 May 2014 09:55:10 +0200

Available diffs

Superseded in utopic-release on 2014-05-26
Deleted in utopic-proposed on 2014-05-27 (Reason: moved to release)
puppet (3.6.0-1) unstable; urgency=medium


  * Import upstream release 3.6.0
  * Remove deprecated global file/template locations
  * Move ruby-selinux from Suggests to Recommends (Closes: #743790)
  * Add build dependency on ruby-hiera
  * puppet-el: match .pp suffix at end of string, not end of line.
    Thanks to Kevin Ryde (Closes: #670330)
  * puppet-el: Conform to emacs policy

 -- Stig Sandbeck Mathisen <email address hidden>  Fri, 16 May 2014 00:14:33 +0200

Available diffs

Superseded in utopic-release on 2014-05-16
Deleted in utopic-proposed on 2014-05-17 (Reason: moved to release)
puppet (3.5.1-1) unstable; urgency=medium


  * Imported upstream release 3.5.1

 -- Stig Sandbeck Mathisen <email address hidden>  Thu, 17 Apr 2014 14:50:28 +0200

Available diffs

Superseded in utopic-release on 2014-04-26
Published in trusty-release on 2014-03-10
Deleted in trusty-proposed (Reason: moved to release)
puppet (3.4.3-1) unstable; urgency=medium


  [ Jonas Genannt ]
  * [57515db] d/control: added ruby-rrd as primary Suggests, left librrd-ruby
    for easy backporting.

  [ Stig Sandbeck Mathisen ]
  * Imported upstream release 3.4.3

 -- Stig Sandbeck Mathisen <email address hidden>  Thu, 20 Feb 2014 11:41:42 +0100

Available diffs

Superseded in trusty-release on 2014-01-22
Deleted in trusty-proposed on 2014-01-23 (Reason: moved to release)
puppet (3.3.1-1ubuntu3) trusty; urgency=low

  * SECURITY REGRESSION: Incorrect default file mode (LP: #1267385)
    - debian/patches/CVE-2013-4969-regression.patch: fix incorrect file
      mode in lib/puppet/type/file.rb, lib/puppet/util.rb,
      spec/unit/type/file_spec.rb.
    - CVE-2013-4969
 -- Marc Deslauriers <email address hidden>   Thu, 09 Jan 2014 10:57:12 -0500

Available diffs

Obsolete in raring-updates on 2015-04-24
Obsolete in raring-security on 2015-04-24
puppet (2.7.18-4ubuntu1.4) raring-security; urgency=low

  * SECURITY REGRESSION: Incorrect default file mode (LP: #1267385)
    - debian/patches/CVE-2013-4969-regression.patch: fix incorrect file
      mode in lib/puppet/type/file.rb, lib/puppet/util.rb,
      spec/unit/type/file_spec.rb.
    - CVE-2013-4969
 -- Marc Deslauriers <email address hidden>   Thu, 09 Jan 2014 07:54:31 -0500
Obsolete in saucy-updates on 2015-04-24
Obsolete in saucy-security on 2015-04-24
puppet (3.2.4-2ubuntu2.3) saucy-security; urgency=low

  * SECURITY REGRESSION: Incorrect default file mode (LP: #1267385)
    - debian/patches/CVE-2013-4969-regression.patch: fix incorrect file
      mode in lib/puppet/type/file.rb, lib/puppet/util.rb,
      spec/unit/type/file_spec.rb.
    - CVE-2013-4969
 -- Marc Deslauriers <email address hidden>   Thu, 09 Jan 2014 07:48:28 -0500
Obsolete in quantal-updates on 2015-04-24
Obsolete in quantal-security on 2015-04-24
puppet (2.7.18-1ubuntu1.5) quantal-security; urgency=low

  * SECURITY REGRESSION: Incorrect default file mode (LP: #1267385)
    - debian/patches/CVE-2013-4969-regression.patch: fix incorrect file
      mode in lib/puppet/type/file.rb, lib/puppet/util.rb,
      spec/unit/type/file_spec.rb.
    - CVE-2013-4969
 -- Marc Deslauriers <email address hidden>   Thu, 09 Jan 2014 07:55:18 -0500
Published in precise-updates on 2014-01-09
Published in precise-security on 2014-01-09
puppet (2.7.11-1ubuntu2.7) precise-security; urgency=low

  * SECURITY REGRESSION: Incorrect default file mode (LP: #1267385)
    - debian/patches/CVE-2013-4969-regression.patch: fix incorrect file
      mode in lib/puppet/type/file.rb, lib/puppet/util.rb,
      spec/unit/type/file_spec.rb.
    - CVE-2013-4969
 -- Marc Deslauriers <email address hidden>   Thu, 09 Jan 2014 07:56:00 -0500
Superseded in trusty-release on 2014-03-10
Deleted in trusty-proposed on 2014-03-11 (Reason: moved to release)
puppet (3.4.2-1) unstable; urgency=medium


  * Imported upstream release 3.4.2

 -- Stig Sandbeck Mathisen <email address hidden>  Tue, 07 Jan 2014 12:04:39 +0100
Superseded in trusty-release on 2014-01-10
Deleted in trusty-proposed on 2014-01-11 (Reason: moved to release)
puppet (3.3.1-1ubuntu2) trusty; urgency=low

  * SECURITY UPDATE: unsafe use of temp files
    - debian/patches/CVE-2013-4969-3.3.x-temp-file.patch: Use replace_file
      to update a file's contents in lib/puppet/type/file.rb,
      lib/puppet/util.rb, updated tests in
      spec/integration/type/file_spec.rb, spec/unit/type/file_spec.rb.
    - CVE-2013-4969
 -- Marc Deslauriers <email address hidden>   Mon, 23 Dec 2013 07:57:52 -0500

Available diffs

Superseded in precise-updates on 2014-01-09
Superseded in precise-security on 2014-01-09
puppet (2.7.11-1ubuntu2.6) precise-security; urgency=low

  * SECURITY UPDATE: unsafe use of temp files
    - debian/patches/update-replace_file.patch: updated replace_file to
      enable Windows support so security patch applies better.
    - debian/patches/CVE-2013-4969-2.7.x-temp-file.patch: Use replace_file
      to update a file's contents in lib/puppet/type/file.rb,
      lib/puppet/util.rb, updated tests in
      spec/integration/type/file_spec.rb, spec/unit/type/file_spec.rb.
    - CVE-2013-4969
 -- Marc Deslauriers <email address hidden>   Mon, 23 Dec 2013 08:27:21 -0500
Superseded in quantal-updates on 2014-01-09
Superseded in quantal-security on 2014-01-09
puppet (2.7.18-1ubuntu1.4) quantal-security; urgency=low

  * SECURITY UPDATE: unsafe use of temp files
    - debian/patches/update-replace_file.patch: updated replace_file to
      enable Windows support so security patch applies better.
    - debian/patches/CVE-2013-4969-2.7.x-temp-file.patch: Use replace_file
      to update a file's contents in lib/puppet/type/file.rb,
      lib/puppet/util.rb, updated tests in
      spec/integration/type/file_spec.rb, spec/unit/type/file_spec.rb.
    - CVE-2013-4969
 -- Marc Deslauriers <email address hidden>   Mon, 23 Dec 2013 08:25:08 -0500
Superseded in raring-updates on 2014-01-09
Superseded in raring-security on 2014-01-09
puppet (2.7.18-4ubuntu1.3) raring-security; urgency=low

  * SECURITY UPDATE: unsafe use of temp files
    - debian/patches/update-replace_file.patch: updated replace_file to
      enable Windows support so security patch applies better.
    - debian/patches/CVE-2013-4969-2.7.x-temp-file.patch: Use replace_file
      to update a file's contents in lib/puppet/type/file.rb,
      lib/puppet/util.rb, updated tests in
      spec/integration/type/file_spec.rb, spec/unit/type/file_spec.rb.
    - CVE-2013-4969
 -- Marc Deslauriers <email address hidden>   Mon, 23 Dec 2013 08:21:22 -0500
Superseded in saucy-updates on 2014-01-09
Superseded in saucy-security on 2014-01-09
puppet (3.2.4-2ubuntu2.2) saucy-security; urgency=low

  * SECURITY UPDATE: unsafe use of temp files
    - debian/patches/CVE-2013-4969-3.3.x-temp-file.patch: Use replace_file
      to update a file's contents in lib/puppet/type/file.rb,
      lib/puppet/util.rb, updated tests in
      spec/integration/type/file_spec.rb, spec/unit/type/file_spec.rb.
    - CVE-2013-4969
 -- Marc Deslauriers <email address hidden>   Mon, 23 Dec 2013 08:11:03 -0500
Superseded in saucy-updates on 2014-01-06
Deleted in saucy-proposed on 2014-01-08 (Reason: moved to -updates)
puppet (3.2.4-2ubuntu2.1) saucy; urgency=low

  * Add required dependency ruby-hiera, without which puppet does not work
    correctly in common cases (LP: #1242363).
  * d/tests/parameterised-class: dep8 test for failure case.
 -- Robie Basak <email address hidden>   Fri, 29 Nov 2013 10:03:09 +0000

Available diffs

Superseded in trusty-release on 2014-01-06
Deleted in trusty-proposed on 2014-01-08 (Reason: moved to release)
puppet (3.3.1-1ubuntu1) trusty; urgency=low

  * Merge from Debian unstable (LP: #1246456).  Remaining changes:
    - debian/control: change dependency back from ruby-augeas to
      libaugeas-ruby as that is what's currently in saucy.

Available diffs

Superseded in precise-updates on 2014-01-06
Deleted in precise-proposed on 2014-01-08 (Reason: moved to -updates)
puppet (2.7.11-1ubuntu2.5) precise-proposed; urgency=low

  * debian/patches/2.7.11-remove-process_name-performance.patch:
    Fixes performance regression caused by a thread that loops forever in
    order to change a process name when told so (LP: #995719)
 -- Adam Stokes <email address hidden>   Tue, 24 Sep 2013 14:58:14 -0400
Superseded in trusty-release on 2013-10-30
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed on 2015-04-28 (Reason: moved to release)
puppet (3.2.4-2ubuntu2) saucy; urgency=low

  * debian/tests/control: invert order of tests, or else puppet-agent runs
    after puppetmaster-passenger has already enabled the service.
 -- Marc Deslauriers <email address hidden>   Tue, 03 Sep 2013 16:39:37 -0400
Superseded in saucy-proposed on 2013-09-03
puppet (3.2.4-2ubuntu1) saucy; urgency=low

  * debian/control: change dependency back from ruby-augeas to
    libaugeas-ruby as that is what's currently in saucy.
 -- Marc Deslauriers <email address hidden>   Tue, 03 Sep 2013 10:33:17 -0400
Superseded in saucy-proposed on 2013-09-03
puppet (3.2.4-2) unstable; urgency=low


  * Include patch from upstream to prevent duplicate nagios_ resources
    (Closes: #721132)
  * Add empty /usr/share/puppet/modules to puppet-common for puppet modules

 -- Stig Sandbeck Mathisen <email address hidden>  Sun, 01 Sep 2013 13:41:51 +0200

Available diffs

Superseded in precise-updates on 2013-10-25
Superseded in precise-security on 2014-01-06
puppet (2.7.11-1ubuntu2.4) precise-security; urgency=low

  * SECURITY UPDATE: August 2013 privilege escalation and code execution
    vulnerabilities
    - debian/patches/ubuntu-2.7.11-puppet-Aug-2013-CVE-fixes.patch:
      upstream patch to resolve security issues.
    - CVE-2013-4956
    - CVE-2013-4761
 -- Marc Deslauriers <email address hidden>   Wed, 14 Aug 2013 20:30:05 -0400
Superseded in raring-updates on 2014-01-06
Superseded in raring-security on 2014-01-06
puppet (2.7.18-4ubuntu1.2) raring-security; urgency=low

  * SECURITY UPDATE: August 2013 privilege escalation and code execution
    vulnerabilities
    - debian/patches/2.7.22-puppet-Aug-2013-CVE-fixes.patch: backport of
      upstream patch to resolve security issues.
    - CVE-2013-4956
    - CVE-2013-4761
 -- Marc Deslauriers <email address hidden>   Wed, 14 Aug 2013 07:59:11 -0400
Superseded in quantal-updates on 2014-01-06
Superseded in quantal-security on 2014-01-06
puppet (2.7.18-1ubuntu1.3) quantal-security; urgency=low

  * SECURITY UPDATE: August 2013 privilege escalation and code execution
    vulnerabilities
    - debian/patches/2.7.22-puppet-Aug-2013-CVE-fixes.patch: backport of
      upstream patch to resolve security issues.
    - CVE-2013-4956
    - CVE-2013-4761
 -- Marc Deslauriers <email address hidden>   Wed, 14 Aug 2013 08:06:26 -0400
Superseded in saucy-release on 2013-09-03
Deleted in saucy-proposed on 2013-09-05 (Reason: moved to release)
puppet (3.2.3-1) unstable; urgency=low


  * Import upstream version 3.2.3
  * Do not use "dpkg-maintscript-helper" on non-conffiles
    (Closes: #713070)
  * Bump standards version (no changes)

 -- Stig Sandbeck Mathisen <email address hidden>  Fri, 02 Aug 2013 23:07:48 +0200

Available diffs

Superseded in saucy-release on 2013-08-14
Deleted in saucy-proposed on 2013-08-15 (Reason: moved to release)
puppet (3.2.2-1) unstable; urgency=high


  * New upstream version (Closes: #712745, CVE-2013-3567)
    - use packaged ruby-safe-yaml instead of the vendored gem
  * Support apache 2.4 (Closes: #675409)
  * Remove dependency on rails (Closes: #709636)
  * Remove build dependency on ruby-rspec
  * add dep8 tests
  * puppetmaster-passenger.postinst: check if puppet.conf can be parsed on
    install.
    Thanks to Ubuntu

 -- Stig Sandbeck Mathisen <email address hidden>  Wed, 19 Jun 2013 11:45:46 +0200
Superseded in precise-updates on 2013-08-15
Superseded in precise-security on 2013-08-15
puppet (2.7.11-1ubuntu2.3) precise-security; urgency=low

  * SECURITY UPDATE: Remote code execution on master from unauthenticated
    clients
    - debian/patches/2.7.21-Patch-for-CVE-2013-3567.patch: upstream patch
      to use safe_yama.
    - CVE-2013-3567
 -- Marc Deslauriers <email address hidden>   Fri, 14 Jun 2013 09:06:22 -0400
Superseded in quantal-updates on 2013-08-15
Superseded in quantal-security on 2013-08-15
puppet (2.7.18-1ubuntu1.2) quantal-security; urgency=low

  * SECURITY UPDATE: Remote code execution on master from unauthenticated
    clients
    - debian/patches/2.7.21-Patch-for-CVE-2013-3567.patch: backport of
      upstream patch to use safe_yama.
    - CVE-2013-3567
 -- Marc Deslauriers <email address hidden>   Fri, 14 Jun 2013 09:08:35 -0400
Superseded in raring-updates on 2013-08-15
Superseded in raring-security on 2013-08-15
puppet (2.7.18-4ubuntu1.1) raring-security; urgency=low

  * SECURITY UPDATE: Remote code execution on master from unauthenticated
    clients
    - debian/patches/2.7.21-Patch-for-CVE-2013-3567.patch: backport of
      upstream patch to use safe_yama.
    - CVE-2013-3567
 -- Marc Deslauriers <email address hidden>   Fri, 14 Jun 2013 09:00:45 -0400
175 of 187 results