puppet 2.7.1-1ubuntu3.2 source package in Ubuntu

Changelog

puppet (2.7.1-1ubuntu3.2) oneiric-security; urgency=low

  * SECURITY UPDATE: puppet master impersonation via incorrect certificates
    - debian/patches/CVE-2011-3872.patch: refactor certificate handling.
    - Thanks to upstream for providing the patch.
    - CVE-2011-3872
 -- Marc Deslauriers <email address hidden>   Mon, 24 Oct 2011 15:05:12 -0400

Upload details

Uploaded by:
Marc Deslauriers on 2011-10-24
Uploaded to:
Oneiric
Original maintainer:
Ubuntu Developers
Architectures:
all
Section:
admin
Urgency:
Low Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Builds

Oneiric: [FULLYBUILT] i386

Downloads

File Size SHA-256 Checksum
puppet_2.7.1.orig.tar.gz 1.7 MiB 19149758a1414f4642b554eca4fc6f1dca9d879e19434a269e7b71ef9b4595df
puppet_2.7.1-1ubuntu3.2.debian.tar.gz 86.5 KiB 2118474ad4d96400c3be1f1564ece3eccad65909708e7f74a572e21a5601728a
puppet_2.7.1-1ubuntu3.2.dsc 2.2 KiB 9954264be9cc2ebcc1e79bdb508d499f155c9a04ee71e91c0b852ecfb8e1717c

View changes file

Binary packages built by this source

puppet: Centralized configuration management - agent startup and compatibility scripts

 This package contains the startup script and compatbility scripts for the
 puppet agent, which is the process responsible for configuring the local node.
 .
 Puppet lets you centrally manage every important aspect of your system
 using a cross-platform specification language that manages all the
 separate elements normally aggregated in different files, like users,
 cron jobs, and hosts, along with obviously discrete elements like
 packages, services, and files.
 .
 Puppet's simple declarative specification language provides powerful
 classing abilities for drawing out the similarities between hosts while
 allowing them to be as specific as necessary, and it handles dependency
 and prerequisite relationships between objects clearly and explicitly.

puppet-common: No summary available for puppet-common in ubuntu oneiric.

No description available for puppet-common in ubuntu oneiric.

puppet-el: No summary available for puppet-el in ubuntu oneiric.

No description available for puppet-el in ubuntu oneiric.

puppet-testsuite: No summary available for puppet-testsuite in ubuntu oneiric.

No description available for puppet-testsuite in ubuntu oneiric.

puppetmaster: No summary available for puppetmaster in ubuntu oneiric.

No description available for puppetmaster in ubuntu oneiric.

puppetmaster-common: No summary available for puppetmaster-common in ubuntu oneiric.

No description available for puppetmaster-common in ubuntu oneiric.

puppetmaster-passenger: No summary available for puppetmaster-passenger in ubuntu oneiric.

No description available for puppetmaster-passenger in ubuntu oneiric.

vim-puppet: syntax highlighting for puppet manifests in vim

 The vim-puppet package provides filetype detection and syntax highlighting for
 puppet manifests (files ending with ".pp").