Change log for pyfai package in Ubuntu

128 of 28 results
Published in eoan-proposed on 2019-04-18
Deleted in disco-proposed (Reason: moved to eoan-proposed)
pyfai (0.17.0+dfsg1-3) unstable; urgency=medium

  [ Alexandre Marie ]
  * d/t/control Changed the command line that run the tests.

 -- Alexandre Marie <email address hidden>  Thu, 10 Jan 2019 10:35:17 +0100

Available diffs

Superseded in disco-proposed on 2019-01-12
pyfai (0.17.0+dfsg1-2) unstable; urgency=medium

  * d/p/0004-Skipped-unittests-for-i386-arch.patch (Closes: #916292).
  * d/rules: Build doc only with python3.
  * d/p/0005-Hid-fvisibility-and-D.patch: Fixed FTBFS on unstable.

 -- Alexandre Marie <email address hidden>  Mon, 07 Jan 2019 16:25:17 +0100

Available diffs

Superseded in disco-proposed on 2019-01-10
pyfai (0.17.0+dfsg1-1) unstable; urgency=medium

  [ Picca Frédéric-Emmanuel ]
  * d/t/control.dep8 -> d/t/control pyfai export the pyFAI module and not
    pyfai as expected by autodep8.
  * Switched pyfai scripts to python3
  * d/control: Removed useless pymca5 dependencies.
  * d/rules: do not run QT tests

  [ Alexandre Marie ]
  * New upstream version 0.17.0+dfsg1

 -- Alexandre Marie <email address hidden>  Thu, 20 Dec 2018 12:06:10 +0100

Available diffs

Published in eoan-release on 2019-04-18
Published in disco-release on 2018-11-16
Deleted in disco-proposed (Reason: moved to release)
pyfai (0.16.0+dfsg1-2) unstable; urgency=medium

  * Exported XDG_CACHE_DIR to store openCL kernels and
    fixed the FTBFS.

 -- Picca Frédéric-Emmanuel <email address hidden>  Sun, 28 Oct 2018 22:07:52 +0100
Deleted in cosmic-release (Reason: LP: #1784105: remove pyopengl from cosmic, and demote rde...)
Published in bionic-release on 2018-04-08
Deleted in bionic-proposed (Reason: moved to release)
pyfai (0.15.0+dfsg1-1) unstable; urgency=medium

  * New upstream version 0.15.0+dfsg1
  * Repacked to deal the new third_party layout (Closes: #889183)
  * d/control
    - Build-Depends:
      - Added pandoc
      - Added python[3]-nbsphinx
  * d/patches
    + 0005-unactive-script-test.patch (Added)
  * d/rules
    - Do not build the documentation with python2-dbg

 -- Picca Frédéric-Emmanuel <email address hidden>  Sat, 03 Feb 2018 09:08:32 +0100
Superseded in bionic-proposed on 2018-02-03
pyfai (0.15.0+dfsg-1) unstable; urgency=medium

  * New upstream version 0.15.0+dfsg
  * d/control
    - Bump Standrad-Version 4.1.3 (nothing)
  * debian/patches
    - refreshed
  * d/watch
    - _src is optional

 -- Picca Frédéric-Emmanuel <email address hidden>  Fri, 02 Feb 2018 22:05:05 +0100

Available diffs

Superseded in bionic-proposed on 2018-02-03
pyfai (0.14.2+dfsg-6) unstable; urgency=medium

  * fix for real the ftbfs

 -- Picca Frédéric-Emmanuel <email address hidden>  Fri, 01 Dec 2017 18:17:32 +0100

Available diffs

Superseded in bionic-proposed on 2017-12-02
pyfai (0.14.2+dfsg-3) unstable; urgency=medium

  * d/patches
    - 0004-instrument-setup-code-to-deal-with-the-buildd-FTBFS.patch (Added)

 -- Picca Frédéric-Emmanuel <email address hidden>  Fri, 01 Dec 2017 13:37:21 +0100

Available diffs

Superseded in bionic-proposed on 2017-12-01
pyfai (0.14.2+dfsg-2) unstable; urgency=medium

  * d/control
    - Bump Standrad-Version 4.1.1 (nothing)
    - Fixed broken dependency python3-pymca-dbg -> python3-pymca5-dbg
    - Added python-numpy-dbg, python3-numpy-dbg

 -- Picca Frédéric-Emmanuel <email address hidden>  Mon, 16 Oct 2017 14:37:48 +0200

Available diffs

Superseded in bionic-proposed on 2017-11-30
pyfai (0.14.2+dfsg-1) unstable; urgency=medium

  * New upstream version 0.14.0+dfsg
  * debian/watch
    - Check the pgp signature via uscan
  * debian/upstream
    - add the upstream keyring
  * debian/control
    - Bump Standrad-Version 4.0.1 (extra -> optional)
    - Build-Depends
      + Fixed with cme
      + Removed python[3]-pil[-dbg]
      + Removed python[3]-lxml[-dbg]
      + Added python[3]-numexpr[-dbg]
      + Added python[3]-pymca5[-dbg]
      + Added python[3]-pyopencl[-dbg]
      + Added help2man in order to generate the manpages.
      + Added xauth, xvfb
  * debian/patches
    - 0003-remove-a-wrong-PYTHONPATH-modification.patch  (Added)
    - 0003-use-the-system-mathjax.patch (Added)
    - 0005-fix-the-setup-dependencies.patch (Added)
  * Debian/rules
    - Run tests with xvfb

 -- Picca Frédéric-Emmanuel <email address hidden>  Mon, 31 Jul 2017 13:40:50 +0200
Deleted in bionic-release (Reason: Debian #876739, pyfail failing to build)
Published in artful-release on 2017-09-16
Deleted in artful-proposed (Reason: moved to release)
pyfai (0.13.0+dfsg-1ubuntu1) artful; urgency=medium

  * Skip the python2 tests on ppc64el for now.

 -- Matthias Klose <email address hidden>  Fri, 15 Sep 2017 20:44:43 +0200
Superseded in artful-proposed on 2017-09-15
pyfai (0.13.0+dfsg-1build4) artful; urgency=medium

  * No-change rebuild against latest h5py.

 -- Gianfranco Costamagna <email address hidden>  Wed, 13 Sep 2017 16:49:36 +0200
Superseded in artful-release on 2017-09-16
Deleted in artful-proposed on 2017-09-17 (Reason: moved to release)
pyfai (0.13.0+dfsg-1build3) artful; urgency=medium

  * No-change rebuild to drop _PyFPE support.

 -- Matthias Klose <email address hidden>  Tue, 05 Sep 2017 08:22:25 +0000
Superseded in artful-release on 2017-09-05
Deleted in artful-proposed on 2017-09-07 (Reason: moved to release)
pyfai (0.13.0+dfsg-1build2) artful; urgency=medium

  * No-change rebuild to build to drop python3.5.

 -- Matthias Klose <email address hidden>  Sat, 05 Aug 2017 18:40:04 +0000
Superseded in artful-release on 2017-08-06
Deleted in artful-proposed on 2017-08-07 (Reason: moved to release)
pyfai (0.13.0+dfsg-1build1) artful; urgency=medium

  * No change rebuild to add Python 3.6 support.

 -- Michael Hudson-Doyle <email address hidden>  Wed, 07 Jun 2017 16:28:28 -0700
Superseded in artful-release on 2017-06-09
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed on 2018-06-22 (Reason: moved to release)
pyfai (0.13.0+dfsg-1) unstable; urgency=medium

  * New upstream version 0.13.0+dfsg

 -- Picca Frédéric-Emmanuel <email address hidden>  Sat, 03 Dec 2016 10:00:18 +0100

Available diffs

Superseded in zesty-release on 2017-01-01
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed on 2018-01-23 (Reason: moved to release)
pyfai (0.12.0+dfsg-5) unstable; urgency=medium

  * Remove python-fftw dependency

 -- Picca Frédéric-Emmanuel <email address hidden>  Sat, 27 Aug 2016 16:59:18 +0200
Superseded in yakkety-proposed on 2016-09-02
pyfai (0.12.0+dfsg-4) unstable; urgency=medium

  * debian/tests/control
    - * Add python-tk-dbg and python3-tk-dbg Depends

 -- Picca Frédéric-Emmanuel <email address hidden>  Thu, 18 Aug 2016 20:57:26 +0200

Available diffs

Superseded in yakkety-proposed on 2016-08-18
pyfai (0.12.0+dfsg-3) unstable; urgency=medium

  * debian/tests/control
    - Add pyfai dependency for all tests

 -- Picca Frédéric-Emmanuel <email address hidden>  Thu, 18 Aug 2016 09:19:00 +0200

Available diffs

Superseded in yakkety-proposed on 2016-08-18
pyfai (0.12.0+dfsg-2) unstable; urgency=medium

  * New Homepage https://github.com/silx-kit/pyFAI
  * debian/control
    - Build-Depends on python3-fabio-x (>= 0.4.0+dfsg-2~)
    - Updated Vcs-x in order to use https
  * debian/patchs
    - 0004-do-not-use-deprecated-sphinx-pngmath-extension.patch (new)
      In order to fix an FTBFS (closes: #831242)

 -- Picca Frédéric-Emmanuel <email address hidden>  Wed, 17 Aug 2016 13:03:44 +0200

Available diffs

Superseded in yakkety-proposed on 2016-08-17
pyfai (0.12.0+dfsg-1) unstable; urgency=medium

  * Imported Upstream version 0.12.0+dfsg
  * Updated Files-Excluded to remove the pre-generated documentation.
  * debian/patchs
    - 0001-fix-pyFAI-when-third_party-is-missing.patch (upstreamed)
    - 0002-fix-from-upstream-python3-installation.patch (upstreamed)
    - 0003-fix-from-upstream-for-fabio-3.x.patch (upstreamed)
    + 0001-remove-useless-logic-in-conf.py.patch (new)
    + 0002-skip-test-if-no-network.patch (new)
    + 0003-use-the-system-mathjax.patch (new)

 -- Picca Frédéric-Emmanuel <email address hidden>  Tue, 07 Jun 2016 14:50:00 +0200

Available diffs

Superseded in yakkety-release on 2016-09-03
Deleted in yakkety-proposed on 2016-09-04 (Reason: moved to release)
pyfai (0.11.0+dfsg-5) unstable; urgency=medium

  * debian/patch
    + 0003-fix-from-upstream-for-fabio-3.x.patch (updated)
      previous patch was wrong.

 -- Picca Frédéric-Emmanuel <email address hidden>  Sun, 27 Mar 2016 15:51:21 +0200
Superseded in yakkety-release on 2016-04-27
Published in xenial-release on 2016-01-19
Deleted in xenial-proposed (Reason: moved to release)
pyfai (0.11.0+dfsg-3build1) xenial; urgency=medium

  * No-change rebuild to drop python3.4 support.

 -- Matthias Klose <email address hidden>  Tue, 19 Jan 2016 13:55:28 +0000
Superseded in xenial-release on 2016-01-19
Deleted in xenial-proposed on 2016-01-21 (Reason: moved to release)
Deleted in wily-proposed on 2016-01-21 (Reason: moved to xenial-proposed)
pyfai (0.11.0+dfsg-3) unstable; urgency=medium

  * debian/path
    + 0002-fix-from-upstream-python3-installation.patch (Closes: #794221)

 -- Picca Frédéric-Emmanuel <email address hidden>  Fri, 11 Sep 2015 14:25:10 +0200
Superseded in wily-proposed on 2015-09-16
pyfai (0.11.0+dfsg-2) unstable; urgency=medium

  * Split pyfai package to follow the Debian modules name policy.
  * Added python-pyfai, python-pyfai-dbg, python3-pyfai,
    python3-pyfai-dbg, python-pyfai-doc

 -- Picca Frédéric-Emmanuel <email address hidden>  Mon, 27 Jul 2015 16:18:27 +0200

Available diffs

Superseded in xenial-release on 2015-10-23
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed on 2018-01-22 (Reason: moved to release)
pyfai (0.11.0+dfsg-1) unstable; urgency=medium

  * Imported Upstream version 0.11.0+dfsg
  * debian/control
    - Added Build-Depends fabio (>= 0.2.2+dfsg~)
  * debian/watch
    - use the pypi redirector
  * debian/copyright
    - use Files-Exclude to repack sources
  * debian/patches
    + 0001-fix-pyFAI-when-third_party-is-missing.patch

 -- Picca Frédéric-Emmanuel <email address hidden>  Fri, 24 Jul 2015 10:57:04 +0200

Available diffs

Superseded in wily-release on 2015-07-24
Obsolete in vivid-release on 2018-01-18
Deleted in vivid-proposed on 2018-01-19 (Reason: moved to release)
pyfai (0.10.2-1) unstable; urgency=medium


  * Import new upstream version (0.10.2)
  * debian/control
    - Bump Standrad-Version 3.9.6 (nothing to do)
    - fix Build-Depends/Depends with cme
    - prepare for Debian-Science team maintenance.
  * debian/copyright
    - use copyright-format/1.0
  * debian/rules
    - cythonize files during the build
    - use dh_numpy for better binary dependency.

 -- Picca Frédéric-Emmanuel <email address hidden>  Fri, 24 Oct 2014 09:01:53 +0100

Available diffs

Superseded in vivid-release on 2014-10-26
Obsolete in utopic-release on 2016-11-03
Published in trusty-release on 2013-10-18
Obsolete in saucy-release on 2015-04-24
Obsolete in raring-release on 2015-04-24
Obsolete in quantal-release on 2015-04-24
pyfai (0.3.5-1) unstable; urgency=low


  * Initial release (Closes: #656633)  

 -- Jerome Kieffer <email address hidden>  Fri, 20 Jan 2012 22:00:20 +0100
128 of 28 results