Change log for pyqt5 package in Ubuntu

175 of 81 results
Published in eoan-release on 2019-07-13
Deleted in eoan-proposed (Reason: moved to release)
pyqt5 (5.12.3+dfsg-1) experimental; urgency=medium

  * New upstream release.
  * Refresh debian/patches/public_sip.diff.
  * Backport upstream patch to fix building with Python 2.

 -- Dmitry Shachnev <email address hidden>  Wed, 03 Jul 2019 21:22:54 +0300

Available diffs

Superseded in eoan-release on 2019-07-13
Deleted in eoan-proposed on 2019-07-15 (Reason: moved to release)
pyqt5 (5.12.2+dfsg-1) experimental; urgency=medium

  * New upstream release.
  * Refresh debian/patches/public_sip.diff.

 -- Dmitry Shachnev <email address hidden>  Fri, 24 May 2019 17:40:13 +0300

Available diffs

Superseded in eoan-release on 2019-06-20
Published in disco-release on 2019-04-05
Deleted in disco-proposed (Reason: moved to release)
pyqt5 (5.12.1+dfsg-1) experimental; urgency=medium

  * New upstream release.
  * Update debian/watch for another upstream change.

 -- Dmitry Shachnev <email address hidden>  Wed, 27 Mar 2019 22:02:10 +0300
Superseded in disco-release on 2019-04-05
Deleted in disco-proposed on 2019-04-10 (Reason: moved to release)
pyqt5 (5.11.3+dfsg-1build1) disco; urgency=medium

  * No-change rebuild against qtbase-abi-5-11-3.

 -- Dmitry Shachnev <email address hidden>  Wed, 02 Jan 2019 12:18:21 +0300
Superseded in disco-proposed on 2018-11-11
pyqt5 (5.11.2+dfsg-1ubuntu5) disco; urgency=medium

  * No-change rebuild against latest Qt

 -- Jeremy Bicha <email address hidden>  Sat, 10 Nov 2018 18:41:00 -0500
Superseded in disco-release on 2018-11-23
Deleted in disco-proposed on 2018-11-24 (Reason: moved to release)
pyqt5 (5.11.2+dfsg-1ubuntu4) disco; urgency=medium

  * No-change rebuild to build without python3.6 support.

 -- Matthias Klose <email address hidden>  Sat, 03 Nov 2018 11:52:12 +0000
Superseded in disco-release on 2018-11-07
Deleted in disco-proposed on 2018-11-08 (Reason: moved to release)
pyqt5 (5.11.2+dfsg-1ubuntu3) disco; urgency=medium

  * No-change rebuild to build for python3.7 as the default.

 -- Matthias Klose <email address hidden>  Tue, 30 Oct 2018 18:18:41 +0000
Superseded in disco-release on 2019-01-08
Deleted in disco-proposed on 2019-01-10 (Reason: moved to release)
pyqt5 (5.11.3+dfsg-1) unstable; urgency=medium

  [ Ondřej Nový ]
  * d/watch: Use https protocol

  [ Dmitry Shachnev ]
  * New upstream release.
  * Update public_sip.diff, revert some more upstream changes.
  * Do not override default dh_builddeb parameters.
  * Install both upstream changelog and NEWS, per Policy 12.7.
  * Bump Standards-Version to 4.2.1, no changes needed.

 -- Dmitry Shachnev <email address hidden>  Fri, 12 Oct 2018 12:35:34 +0300
Superseded in disco-release on 2018-11-02
Published in cosmic-release on 2018-08-21
Deleted in cosmic-proposed (Reason: moved to release)
pyqt5 (5.11.2+dfsg-1ubuntu2) cosmic; urgency=medium

  * No-change rebuild against qtbase-abi-5-11-0.

 -- Simon Quigley <email address hidden>  Tue, 17 Jul 2018 14:05:47 -0500
Superseded in cosmic-release on 2018-08-21
Deleted in cosmic-proposed on 2018-08-23 (Reason: moved to release)
pyqt5 (5.11.2+dfsg-1ubuntu1) cosmic; urgency=medium

  * Do not use QMetaEnumBuilder::setIsScoped() that does not exist in Qt 5.9.

 -- Dmitry Shachnev <email address hidden>  Tue, 10 Jul 2018 13:21:53 +0300
Superseded in cosmic-proposed on 2018-07-10
pyqt5 (5.11.2+dfsg-1) unstable; urgency=medium

  * New upstream release.
  * Bump sip build-dependencies to 4.19.11, following configure.py.
  * Drop cura_crash.diff, applied in the new release.
  * Use the public version of sip module, per Policy § 4.13.
  * Configure with --no-dist-info for now, mk_distinfo.py does not work
    well with DESTDIR yet.
  * Update debhelper compat level to 11.
  * Bump Standards-Version to 4.1.5, no changes needed.
  * Update Homepage field in debian/control.

 -- Dmitry Shachnev <email address hidden>  Fri, 06 Jul 2018 13:09:02 +0300
Superseded in cosmic-release on 2018-07-12
Deleted in cosmic-proposed on 2018-07-13 (Reason: moved to release)
pyqt5 (5.10.1+dfsg-1ubuntu3) cosmic; urgency=medium

  * No-change rebuild to build for python3.7.

 -- Matthias Klose <email address hidden>  Thu, 28 Jun 2018 09:55:00 +0000
Superseded in cosmic-release on 2018-06-29
Published in bionic-release on 2018-04-23
Deleted in bionic-proposed (Reason: moved to release)
pyqt5 (5.10.1+dfsg-1ubuntu2) bionic; urgency=medium

  * Backport three upstream commits to fix crashes when running Cura
    (LP: #1766092).

 -- Dmitry Shachnev <email address hidden>  Mon, 23 Apr 2018 14:17:14 +0300
Superseded in bionic-release on 2018-04-23
Deleted in bionic-proposed on 2018-04-25 (Reason: moved to release)
pyqt5 (5.10.1+dfsg-1ubuntu1) bionic; urgency=medium

  * Add Qt 5.9.4, 5.9.5 and 5.9.6 to the timeline, to make sure they are
    not detected as Qt 5.10.

 -- Dmitry Shachnev <email address hidden>  Sun, 15 Apr 2018 14:03:51 +0300
Superseded in bionic-release on 2018-04-17
Deleted in bionic-proposed on 2018-04-19 (Reason: moved to release)
pyqt5 (5.9.2+dfsg-1build2) bionic; urgency=medium

  * No-change rebuild against Qt 5.9.4.

 -- Simon Quigley <email address hidden>  Sun, 25 Feb 2018 21:46:57 -0600
Superseded in bionic-release on 2018-03-06
Deleted in bionic-proposed on 2018-03-08 (Reason: moved to release)
pyqt5 (5.9.2+dfsg-1build1) bionic; urgency=medium

  * No-change rebuild for qtdeclarative ABI bump.

 -- Simon Quigley <email address hidden>  Sat, 16 Dec 2017 21:02:10 -0600
Superseded in bionic-release on 2017-12-20
Deleted in bionic-proposed on 2017-12-22 (Reason: moved to release)
pyqt5 (5.9.2+dfsg-1) unstable; urgency=medium

  * New upstream release.
  * Bump sip build-dependencies to 4.19.4, following configure.py.
  * Update pyrcc5 manpage for -name option removal.
  * Drop disabled_features.diff, applied upstream.
  * Regenerate the resources with QT_HASH_SEED=0, for reproducibility.
  * Bump Standards-Version to 4.1.2, no changes needed.

 -- Dmitry Shachnev <email address hidden>  Tue, 05 Dec 2017 15:51:35 +0300

Available diffs

Superseded in bionic-release on 2017-12-06
Deleted in bionic-proposed on 2017-12-07 (Reason: moved to release)
pyqt5 (5.9+dfsg-2) unstable; urgency=medium

  * Backport upstream patch to fix handling of disabled features (fixes
    build on architectures with OpenGL ES).
  * Enable Qt WebEngine support on mipsel.
  * Drop Breaks/Replaces on versions that are not even in oldstable.
  * Bump Standards-Version to 4.1.0, stop using deprecated Priority: extra.
  * Upload to unstable.

 -- Dmitry Shachnev <email address hidden>  Sat, 23 Sep 2017 22:18:04 +0300

Available diffs

Superseded in bionic-release on 2017-11-22
Published in artful-release on 2017-08-25
Deleted in artful-proposed (Reason: moved to release)
pyqt5 (5.7+dfsg-6) unstable; urgency=medium

  * Add patches from upstream to support Qt 5.9 (closes: #872892):
    - no_license_check.diff
    - qt59_support.diff
    - opengl_detection.diff
  * Build against Qt 5.9.1.
  * Enable Qt WebEngine support on arm64, armhf and mipsel (closes: #867733).

 -- Dmitry Shachnev <email address hidden>  Tue, 22 Aug 2017 14:41:04 +0300
Superseded in artful-release on 2017-08-25
Deleted in artful-proposed on 2017-08-26 (Reason: moved to release)
pyqt5 (5.7+dfsg-5build3) artful; urgency=medium

  * No-change rebuild to build to drop python3.5.

 -- Matthias Klose <email address hidden>  Sat, 05 Aug 2017 16:27:07 +0000
Superseded in artful-proposed on 2017-08-23
pyqt5 (5.7+dfsg-5ubuntu1) artful; urgency=medium

  * Enable webengine support on arm64 and armhf.
  * Add patches from upstream to support Qt 5.9:
    - no_license_check.diff
    - qt59_support.diff
    - opengl_detection.diff

 -- Dmitry Shachnev <email address hidden>  Sat, 08 Jul 2017 11:36:01 +0300
Superseded in artful-release on 2017-08-06
Deleted in artful-proposed on 2017-08-08 (Reason: moved to release)
pyqt5 (5.7+dfsg-5build2) artful; urgency=medium

  * Rebuild against new python3.6.

 -- Gianfranco Costamagna <email address hidden>  Sun, 23 Jul 2017 09:52:23 +0200
Superseded in artful-release on 2017-07-26
Deleted in artful-proposed on 2017-07-27 (Reason: moved to release)
pyqt5 (5.7+dfsg-5build1) artful; urgency=medium

  * No change rebuild to add Python 3.6 support.

 -- Michael Hudson-Doyle <email address hidden>  Wed, 07 Jun 2017 14:32:55 -0700
Superseded in artful-release on 2017-06-08
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed on 2018-06-22 (Reason: moved to release)
pyqt5 (5.7+dfsg-5) unstable; urgency=medium

  * Make WebEngine packages depend on WebChannel, to avoid import errors.
  * Disable implicit qml_debug option for debug builds (no_qml_debug.diff).
    Patch taken from openSUSE, thanks Hans-Peter Jansen!

 -- Dmitry Shachnev <email address hidden>  Sat, 21 Jan 2017 11:26:05 +0300

Available diffs

Superseded in zesty-release on 2017-02-16
Deleted in zesty-proposed on 2017-02-17 (Reason: moved to release)
pyqt5 (5.7+dfsg-4) unstable; urgency=medium

  * Add Qt WebEngine support for amd64 and i386 (closes: #841830).
  * Add Qt WebChannel support.
  * Upload to unstable.

 -- Dmitry Shachnev <email address hidden>  Mon, 09 Jan 2017 12:47:01 +0300
Superseded in zesty-proposed on 2017-01-10
pyqt5 (5.7+dfsg-2build1~2) zesty; urgency=medium

  * No change rebuild

 -- Timo Jyrinki <email address hidden>  Wed, 04 Jan 2017 09:02:27 +0200
Published in trusty-updates on 2017-02-07
Deleted in trusty-proposed (Reason: moved to -updates)
pyqt5 (5.2.1+dfsg-1ubuntu2) trusty; urgency=medium

  * Backport a change from upstream 5.2-maint branch to fix conversion
    of QStrings with surrogate pairs (fix_qstring_conversion.patch).
    Fixes LP: #1654840.

 -- Dmitry Shachnev <email address hidden>  Sun, 08 Jan 2017 13:56:58 +0300
Superseded in zesty-release on 2017-01-15
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed on 2018-01-23 (Reason: moved to release)
pyqt5 (5.7+dfsg-2) unstable; urgency=medium

  * Backport an upstream change to fix conversion of bytes values
    (bytes_conversion.diff; closes: #834875).
  * Update the pyuic5 and pyrcc5 manpages.
  * Drop obsolete debian/README.source.

 -- Dmitry Shachnev <email address hidden>  Sat, 27 Aug 2016 21:06:10 +0300

Available diffs

Superseded in yakkety-release on 2016-09-03
Deleted in yakkety-proposed on 2016-09-04 (Reason: moved to release)
pyqt5 (5.7+dfsg-1) unstable; urgency=medium

  * New upstream release.
  * Drop 0001-Use-all-D-Bus-include-directories-returned-by-pkg-co.patch,
    applied upstream.
  * Drop rule to remove pycache from orig tarball, it is no longer there.
  * Update debian/copyright.
  * Stop installing Qt.pyi, it is no longer generated.
  * Update for upstream changes to pyrcc5 and pylupdate5:
    - Add new files to debian/pyqt5-dev-tools.install.
    - Fix shebangs in /usr/bin/pylupdate5 and /usr/bin/pyrcc5 files.
    - Call make install to temporary location to be able to run pyrcc5.
    - Call dh_python3 against pyqt5-dev-tools.
  * Use --no-sip-files configure option instead of removing the .sip files
    after they are installed.
  * Only ship files installed by upstream build system in pyqt5-dev.
  * Upload to unstable.

 -- Dmitry Shachnev <email address hidden>  Fri, 12 Aug 2016 10:25:00 +0300
Superseded in yakkety-proposed on 2016-08-12
pyqt5 (5.6+dfsg-1build1~1) yakkety; urgency=medium

  * Rebuild against Qt 5.6.

 -- Timo Jyrinki <email address hidden>  Thu, 21 Jul 2016 07:38:07 +0300
Superseded in yakkety-release on 2016-06-28
Deleted in yakkety-proposed on 2016-06-29 (Reason: moved to release)
pyqt5 (5.5.1+dfsg-3ubuntu5) yakkety; urgency=medium

  * No-change rebuild to fix arm64 failure on calibre
    2.55.0+dfsg-1build2 (missing symbols on pyqt5 library)

 -- Gianfranco Costamagna <email address hidden>  Tue, 21 Jun 2016 07:50:03 +0200
Superseded in yakkety-release on 2016-08-19
Deleted in yakkety-proposed on 2016-08-20 (Reason: moved to release)
pyqt5 (5.6+dfsg-1) unstable; urgency=medium

  [ Dmitry Shachnev ]
  * New upstream release.
  * Add missing newline before clean target in debian/rules.
  * Updated debian/watch for the new tarballs naming scheme.
  * Bump sip build-dependencies to 4.18, following configure.py.
  * Drop custom get-orig-source target, it makes no sense.
  * Bump Standards-Version to 3.9.8, no changes needed.
  * Override Lintian false positive error about tiger.js file.
  * Fix detection of D-Bus include directories.
  * Install Python type hint (*.pyi) files.

  [ Ondřej Nový ]
  * Fixed VCS URL (https)

 -- Dmitry Shachnev <email address hidden>  Tue, 26 Apr 2016 16:02:09 +0300
Superseded in yakkety-release on 2016-06-21
Published in xenial-release on 2016-01-20
Deleted in xenial-proposed (Reason: moved to release)
pyqt5 (5.5.1+dfsg-3ubuntu4) xenial; urgency=medium

  * No-change rebuild to drop python3.4 support.

 -- Matthias Klose <email address hidden>  Tue, 19 Jan 2016 13:33:46 +0000
Superseded in xenial-release on 2016-01-20
Deleted in xenial-proposed on 2016-01-21 (Reason: moved to release)
pyqt5 (5.5.1+dfsg-3ubuntu3) xenial; urgency=medium

  * No-change rebuild against Qt 5.5.1.
  * Re-enable QtLocation library.

 -- Timo Jyrinki <email address hidden>  Tue, 03 Nov 2015 17:10:53 +0200
Superseded in xenial-release on 2015-12-10
Deleted in xenial-proposed on 2015-12-11 (Reason: moved to release)
pyqt5 (5.5.1+dfsg-3ubuntu2) xenial; urgency=medium

  * Temporarily disable installing QtLocation library, it is not built
    when Qt is older than 5.5.

 -- Dmitry Shachnev <email address hidden>  Mon, 26 Oct 2015 13:20:10 +0300
Superseded in xenial-proposed on 2015-10-26
pyqt5 (5.5.1+dfsg-3ubuntu1) xenial; urgency=medium

  * Build against Qt 5.4.

 -- Dmitry Shachnev <email address hidden>  Mon, 26 Oct 2015 11:32:32 +0300
Superseded in xenial-proposed on 2015-10-26
pyqt5 (5.5.1+dfsg-3) unstable; urgency=medium

  * Move pyuic5-related sed call to install-arch target, it should not
    be run during indep builds.

 -- Dmitry Shachnev <email address hidden>  Sun, 25 Oct 2015 23:46:29 +0300
Superseded in xenial-proposed on 2015-10-26
pyqt5 (5.4.2+dfsg-1ubuntu1) xenial; urgency=medium

  * pyuic5: Call the unversioned python3 interpreter.

 -- Matthias Klose <email address hidden>  Fri, 23 Oct 2015 15:31:38 +0200
Superseded in xenial-release on 2015-10-28
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed on 2018-01-22 (Reason: moved to release)
pyqt5 (5.4.2+dfsg-1build3) wily; urgency=medium

  * No-change rebuild for python3.5 transition

 -- Steve Langasek <email address hidden>  Sun, 02 Aug 2015 07:59:54 +0000
Superseded in wily-release on 2015-08-13
Deleted in wily-proposed on 2015-08-15 (Reason: moved to release)
pyqt5 (5.4.2+dfsg-1build2) wily; urgency=medium

  * No-change rebuild with fixed dh-python.  LP: #1477759

 -- Steve Langasek <email address hidden>  Fri, 24 Jul 2015 11:12:51 -0700
Superseded in wily-proposed on 2015-07-24
pyqt5 (5.4.2+dfsg-1build1) wily; urgency=medium

  * No-change rebuild for python3.5 transition

 -- Steve Langasek <email address hidden>  Wed, 22 Jul 2015 21:27:20 +0000
Superseded in wily-release on 2015-07-24
Deleted in wily-proposed on 2015-07-26 (Reason: moved to release)
pyqt5 (5.4.2+dfsg-1) unstable; urgency=medium

  * New upstream release.
  * Drop all patches, applied upstream.
  * Add a temporary hack to use upstream stylesheet when building the
    documentation with Sphinx 1.2.
  * Build-depend on sip 4.16.8+dfsg-2, as the previous upload would
    generate wrong dependencies for Python 3 packages.
  * Upload to unstable.

 -- Dmitry Shachnev <email address hidden>  Thu, 25 Jun 2015 14:30:12 +0300
Superseded in wily-release on 2015-06-27
Deleted in wily-proposed on 2015-06-28 (Reason: moved to release)
pyqt5 (5.4.1+dfsg-2build1) wily; urgency=medium

  * No-change rebuild against Qt 5.4.2.

 -- Timo Jyrinki <email address hidden>  Wed, 10 Jun 2015 10:18:37 +0300
Superseded in wily-release on 2015-06-16
Obsolete in vivid-release on 2018-01-18
Deleted in vivid-proposed on 2018-01-19 (Reason: moved to release)
pyqt5 (5.4.1+dfsg-2) experimental; urgency=medium


  * Backport some fixes to setZOrder() function from upstream
    (uiparser_setzorder_fix.diff).

 -- Dmitry Shachnev <email address hidden>  Thu, 12 Mar 2015 10:49:35 +0300
Superseded in vivid-release on 2015-02-16
Deleted in vivid-proposed on 2015-02-18 (Reason: moved to release)
Superseded in vivid-proposed on 2015-01-27
pyqt5 (5.4+dfsg-1~ubuntu1) vivid; urgency=medium

  * Relax build-dependencies to build against Qt 5.3.
 -- Dmitry Shachnev <email address hidden>   Mon, 29 Dec 2014 13:16:02 +0300
Superseded in vivid-release on 2015-03-18
Deleted in vivid-proposed on 2015-03-19 (Reason: moved to release)
pyqt5 (5.4+dfsg-1) experimental; urgency=medium


  * New upstream release.
  * Drop add_dependency.diff, applied upstream.
  * Bump required sip dependency to 4.16.4.
  * Install QtXml module.
  * Build against Qt 5.4.
  * Fix descriptions of some binary packages (closes: #769468, #771713).
  * Add missing licensing information to debian/copyright.
  * Bump Standards-Version to 3.9.6, no changes needed.

 -- Dmitry Shachnev <email address hidden>  Sun, 28 Dec 2014 19:49:12 +0300
Superseded in vivid-release on 2015-01-28
Superseded in vivid-release on 2015-01-27
Deleted in vivid-proposed on 2015-01-29 (Reason: moved to release)
pyqt5 (5.3.2+dfsg-3build1) vivid; urgency=medium

  * No change rebuild against latest qtbase
 -- Ricardo Salveti de Araujo <email address hidden>   Tue, 11 Nov 2014 17:41:53 -0200
Superseded in vivid-proposed on 2014-11-11
pyqt5 (5.3.2+dfsg-3) unstable; urgency=medium


  * Fix a typo in debian/tests/control.
  * Test Enginio and QtWebSockets modules in autopkgtest.
  * Add a patch from OpenSUSE to make pyqt5 build against Qt 5.3.2.

 -- Dmitry Shachnev <email address hidden>  Wed, 24 Sep 2014 13:21:26 +0400
Superseded in vivid-release on 2014-11-12
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed on 2016-11-03 (Reason: moved to release)
pyqt5 (5.3.2+dfsg-1ubuntu1) utopic; urgency=medium

  * Fix a typo in debian/tests/control.
 -- Dmitry Shachnev <email address hidden>   Tue, 16 Sep 2014 18:43:11 +0400
Superseded in utopic-proposed on 2014-09-17
pyqt5 (5.3.2+dfsg-1) unstable; urgency=medium


  [ Dmitry Shachnev ]
  * New upstream release.
  * Test Python 2 versions in autopkgtest.
  * Set X-Python-Version to >= 2.7 as the current code in debian/rules
    builds only for that version.
  * Remove all strip calls from generated Makefiles.
  * Update my e-mail address.
  * Update debian/copyright.

  [ Scott Kitterman ]
  * Set minimum python3-all-dev version to 3.3.2-5~ due to use of configdir in
    debian/rules (LP: #1365814)

 -- Dmitry Shachnev <email address hidden>  Sat, 13 Sep 2014 14:13:57 +0400

Available diffs

Superseded in utopic-release on 2014-09-17
Deleted in utopic-proposed on 2014-09-18 (Reason: moved to release)
pyqt5 (5.3.1+dfsg-4) unstable; urgency=medium


  * Add support for python in addition to python3 because the upcoming calibre
    2.X series of releases will use PyQt5 with Python and not Python 3
    - Add python build-depends to debian/control
    - Add python-* equivalents of existing python3-* packages to debian/
      control
    - Update debian/rules to account for python as well as python3
    - Set minimum python3 version to 3.3 since the revised debug configure
      rule will not work for 3.2
    - Replicate and update all python3-* .install files as python-*

 -- Scott Kitterman <email address hidden>  Sun, 03 Aug 2014 18:48:21 -0400

Available diffs

Superseded in utopic-release on 2014-08-05
Deleted in utopic-proposed on 2014-08-07 (Reason: moved to release)
pyqt5 (5.3.1+dfsg-3) unstable; urgency=medium


  * debian/tests/import: Redirect stderr to stdout for debug interpreter.

 -- Dmitry Shachnev <email address hidden>  Sat, 26 Jul 2014 21:57:58 +0400
Superseded in utopic-proposed on 2014-07-26
pyqt5 (5.3.1+dfsg-2) unstable; urgency=medium


  * Workaround GCC bug #61918 by replacing -isystem with -I in Makefiles
    (closes: #755767).
  * Test importing from debug interpreters in autopkgtest.

 -- Dmitry Shachnev <email address hidden>  Sat, 26 Jul 2014 09:59:30 +0400

Available diffs

Superseded in utopic-release on 2014-07-27
Deleted in utopic-proposed on 2014-07-28 (Reason: moved to release)
pyqt5 (5.3.1+dfsg-1) unstable; urgency=medium


  * New upstream release
    - Drop debian/patches/fix_implicit_qtablewidget.patch, which had been
      cherry picked from upstream

 -- Scott Kitterman <email address hidden>  Sat, 05 Jul 2014 00:05:42 -0400
Superseded in utopic-release on 2014-07-05
Deleted in utopic-proposed on 2014-07-06 (Reason: moved to release)
pyqt5 (5.3+dfsg-3build2) utopic; urgency=medium

  * No-change rebuild against the new qtbase-opensource-src (armhf build still
    used the older package)
 -- Ricardo Salveti de Araujo <email address hidden>   Fri, 20 Jun 2014 01:08:46 -0300
Superseded in utopic-proposed on 2014-06-20
pyqt5 (5.3+dfsg-3build1) utopic; urgency=medium

  * No-change rebuild against the new qtbase-opensource-src
 -- Ricardo Salveti de Araujo <email address hidden>   Fri, 20 Jun 2014 00:00:36 -0300
Superseded in utopic-proposed on 2014-06-20
pyqt5 (5.3+dfsg-3) unstable; urgency=medium


  * Added debian/patches/fix_implicit_qtablewidget.patch to fixed a pyuic
    regression in the handling of implicit QTableWidget dimensions

 -- Scott Kitterman <email address hidden>  Thu, 19 Jun 2014 00:20:35 -0400

Available diffs

Superseded in utopic-proposed on 2014-06-19
pyqt5 (5.3+dfsg-2) unstable; urgency=medium


  * Bump Qt build-dependencies to 5.3, to make sure headers are in
    correct (multi-arch) locations.
  * Upload to unstable.

 -- Dmitry Shachnev <email address hidden>  Sun, 08 Jun 2014 17:01:30 +0400
Superseded in utopic-release on 2014-06-20
Published in trusty-release on 2014-04-05
Superseded in trusty-release on 2014-04-05
Deleted in trusty-proposed (Reason: moved to release)
pyqt5 (5.2.1+dfsg-1ubuntu1) trusty; urgency=medium

  * Merge with Debian experimental, remaining changes:
    - Add new package for QtPositioning module.
    - Add a patch to build against QtWebKit 5.1.
 -- Dmitry Shachnev <email address hidden>   Fri, 21 Mar 2014 10:56:57 +0400
Superseded in trusty-release on 2014-03-24
Deleted in trusty-proposed on 2014-03-25 (Reason: moved to release)
pyqt5 (5.2+dfsg-4ubuntu3) trusty; urgency=medium

  * debian/patches/build_against_qtwebkit_5_1.patch:
    - Dropping features that are only available in qtwebkit 5.2, so we
      can build it against qtwebkit 5.1 (can be dropped once qtwebkit
      5.2 gets published).
 -- Ricardo Salveti de Araujo <email address hidden>   Fri, 14 Mar 2014 00:25:24 -0300
Superseded in trusty-proposed on 2014-03-14
pyqt5 (5.2+dfsg-4ubuntu2) trusty; urgency=medium

  * No-change rebuild against QtWebkit 5.1.
 -- Colin Watson <email address hidden>   Fri, 14 Mar 2014 01:02:38 +0000
Superseded in trusty-proposed on 2014-03-14
pyqt5 (5.2+dfsg-4ubuntu1) trusty; urgency=medium

  * Add new package for QtPositioning module.
    As a side-effect, this fixes a build failure.
 -- Dmitry Shachnev <email address hidden>   Thu, 06 Mar 2014 17:14:08 +0400
Superseded in trusty-release on 2014-03-14
Deleted in trusty-proposed on 2014-03-15 (Reason: moved to release)
pyqt5 (5.2+dfsg-1ubuntu9) trusty; urgency=medium

  * No-change rebuild for Python 3.4.
 -- Matthias Klose <email address hidden>   Wed, 19 Feb 2014 13:47:15 +0100
Superseded in trusty-release on 2014-02-19
Deleted in trusty-proposed on 2014-02-20 (Reason: moved to release)
pyqt5 (5.2+dfsg-1ubuntu8) trusty; urgency=medium

  * fix_qreal_check.diff: Fix qreal check for Qt 5.2 (LP: #1274128).
  * no_positioning.diff: Disable positioning module until we have 5.2
    in the archive.
 -- Dmitry Shachnev <email address hidden>   Thu, 30 Jan 2014 09:56:39 +0400
Superseded in trusty-release on 2014-01-30
Deleted in trusty-proposed on 2014-01-31 (Reason: moved to release)
pyqt5 (5.2+dfsg-1ubuntu7) trusty; urgency=medium

  * Also enable QList<QPair<int, int>> code that is needed for QtSensors.
 -- Dmitry Shachnev <email address hidden>   Wed, 22 Jan 2014 18:53:52 +0400
Superseded in trusty-proposed on 2014-01-22
pyqt5 (5.2+dfsg-1ubuntu6) trusty; urgency=medium

  * Modify sip files in root directory, not in build directory.
 -- Dmitry Shachnev <email address hidden>   Tue, 21 Jan 2014 21:16:59 +0400
Superseded in trusty-proposed on 2014-01-21
pyqt5 (5.2+dfsg-1ubuntu5) trusty; urgency=medium

  * Make sure QtSensors and QtSerialPort modules are really built,
    re-enable autopkgtest for them.
 -- Dmitry Shachnev <email address hidden>   Sun, 19 Jan 2014 17:02:25 +0400
Superseded in trusty-release on 2014-01-22
Deleted in trusty-proposed on 2014-01-23 (Reason: moved to release)
pyqt5 (5.2+dfsg-1ubuntu4) trusty; urgency=medium

  * Don’t set -x in import autopkgtest.
 -- Dmitry Shachnev <email address hidden>   Sat, 11 Jan 2014 09:46:23 +0400
Superseded in trusty-proposed on 2014-01-11
pyqt5 (5.2+dfsg-1ubuntu3) trusty; urgency=medium

  * Make import autopkgtest depend on python3-all.
 -- Dmitry Shachnev <email address hidden>   Fri, 10 Jan 2014 21:38:34 +0400
Superseded in trusty-proposed on 2014-01-10
pyqt5 (5.2+dfsg-1ubuntu2) trusty; urgency=medium

  * Force build of QtSensors and QtSerialPort modules.
 -- Dmitry Shachnev <email address hidden>   Fri, 10 Jan 2014 14:01:58 +0400
Superseded in trusty-proposed on 2014-01-10
pyqt5 (5.2+dfsg-1ubuntu1) trusty; urgency=medium

  * Disable QtSensors and QtSerialPort imports in autopkgtest,
    these are known failures with Qt versions mix.
 -- Dmitry Shachnev <email address hidden>   Fri, 10 Jan 2014 13:24:55 +0400
Superseded in trusty-proposed on 2014-01-10
pyqt5 (5.1.1+dfsg-3svn2) trusty; urgency=low

  * Rebuild to fix QtSensors and QtSerialPort modules that were broken
    in previous build.
 -- Dmitry Shachnev <email address hidden>   Fri, 03 Jan 2014 18:53:12 +0400
Superseded in trusty-release on 2014-01-11
Deleted in trusty-proposed on 2014-01-12 (Reason: moved to release)
pyqt5 (5.1.1+dfsg-3svn1) trusty; urgency=low

  Upload the current Svn HEAD to add the forgotten XS-Testsuite header.

  * Bump Standards-Version to 3.9.5, no changes needed.
  * Add XS-Testsuite header for autopkgtest.
 -- Dmitry Shachnev <email address hidden>   Mon, 23 Dec 2013 14:19:47 +0400
Superseded in trusty-release on 2014-01-02
Deleted in trusty-proposed on 2014-01-04 (Reason: moved to release)
pyqt5 (5.1.1+dfsg-3) experimental; urgency=low


  * Upload to experimental to build against Qt 5.2.
  * Backport upstream patch (gluint64.sip) to disable GLuint64 on GL ES.
  * Symlink duplicate files in examples using fdupes.
  * Add an autopkgtest to make sure all packages are co-installable
    and all modules are importable.
  * Temporary build-depend on libudev-dev on Linux to workaround qmake
    bug that adds -ludev when building QtSerialPort test code.

 -- Dmitry Shachnev <email address hidden>  Sun, 22 Dec 2013 11:13:52 +0400
Superseded in trusty-release on 2013-12-22
Deleted in trusty-proposed on 2013-12-23 (Reason: moved to release)
pyqt5 (5.1.1+dfsg-2ubuntu1) trusty; urgency=low

  * Backport upstream patch (gluint64.sip) to disable GLuint64 on GL ES.
    Should fix armhf build failure.
 -- Dmitry Shachnev <email address hidden>   Tue, 19 Nov 2013 19:00:14 +0400
175 of 81 results