Change log for python-apsw package in Ubuntu

139 of 39 results
Published in eoan-release on 2019-08-03
Deleted in eoan-proposed (Reason: moved to release)
python-apsw (3.28.0-r1-1) unstable; urgency=medium

  * New upstream release 3.28.0-r1
  * Require libsqlite3-dev 3.28.0 for building

 -- Joel Rosdahl <email address hidden>  Sat, 03 Aug 2019 11:19:06 +0200

Available diffs

Superseded in eoan-release on 2019-08-03
Deleted in eoan-proposed on 2019-08-05 (Reason: moved to release)
python-apsw (3.27.2-r1-1) unstable; urgency=medium

  * New upstream release 3.27.2-r1
  * Update Standards-Version to 4.3.0 with no changes
  * Require libsqlite3-dev 3.27.2 for building
  * Update debian/copyright to match current copyright text

 -- Joel Rosdahl <email address hidden>  Wed, 01 May 2019 22:25:11 +0200

Available diffs

Superseded in disco-release on 2018-11-11
Deleted in disco-proposed on 2018-11-12 (Reason: moved to release)
python-apsw (3.16.2-r1-2build4) disco; urgency=medium

  * No-change rebuild to build without python3.6 support.

 -- Matthias Klose <email address hidden>  Sat, 03 Nov 2018 12:08:39 +0000
Superseded in eoan-release on 2019-05-02
Published in disco-release on 2018-11-11
Deleted in disco-proposed (Reason: moved to release)
python-apsw (3.24.0-r1-1) unstable; urgency=medium

  * New upstream release 3.24.0-r1
  * Require libsqlite3-dev 3.24.0 for building
  * Bump Standards-Version to 4.2.1
  * Remove outdated X-Python3-Version control tag
  * Add bindnow linker flag for hardening
  * Remove deprecated priority extra

 -- Joel Rosdahl <email address hidden>  Wed, 12 Sep 2018 20:40:43 +0200
Superseded in disco-release on 2018-11-05
Published in cosmic-release on 2018-06-29
Deleted in cosmic-proposed (Reason: moved to release)
python-apsw (3.16.2-r1-2build3) cosmic; urgency=medium

  * No-change rebuild to build for python3.7.

 -- Matthias Klose <email address hidden>  Thu, 28 Jun 2018 06:54:31 +0000
Superseded in cosmic-release on 2018-06-29
Published in bionic-release on 2017-10-24
Published in artful-release on 2017-08-04
Deleted in artful-proposed (Reason: moved to release)
python-apsw (3.16.2-r1-2build2) artful; urgency=medium

  * No change rebuild to drop Python 3.5 support.

 -- Michael Hudson-Doyle <email address hidden>  Fri, 04 Aug 2017 16:57:11 +1200
Superseded in artful-release on 2017-08-04
Deleted in artful-proposed on 2017-08-05 (Reason: moved to release)
python-apsw (3.16.2-r1-2build1) artful; urgency=medium

  * No change rebuild to add Python 3.6 support.

 -- Michael Hudson-Doyle <email address hidden>  Fri, 12 May 2017 14:36:19 +1200
Superseded in artful-release on 2017-05-12
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed on 2018-06-22 (Reason: moved to release)
python-apsw (3.16.2-r1-2) unstable; urgency=medium

  * Require libsqlite3-dev 3.16.2 for building

 -- Joel Rosdahl <email address hidden>  Sun, 12 Feb 2017 21:50:39 +0100

Available diffs

Superseded in zesty-release on 2017-02-13
Deleted in zesty-proposed on 2017-02-14 (Reason: moved to release)
python-apsw (3.16.2-r1-1) unstable; urgency=medium

  * New upstream release 3.16.2-r1

 -- Joel Rosdahl <email address hidden>  Sun, 12 Feb 2017 17:35:55 +0100

Available diffs

Superseded in zesty-release on 2017-02-13
Deleted in zesty-proposed on 2017-02-14 (Reason: moved to release)
python-apsw (3.13.0-r1-1) unstable; urgency=medium

  * New upstream release 3.13.0-r1
  * Require libsqlite3-dev 3.13.0 for building
  * Bump Standards-Version to 3.9.8 (no changes)

 -- Joel Rosdahl <email address hidden>  Sun, 28 Aug 2016 15:23:05 +0200
Superseded in zesty-release on 2016-11-03
Obsolete in yakkety-release on 2018-01-23
Published in xenial-release on 2016-01-18
Deleted in xenial-proposed (Reason: moved to release)
python-apsw (3.8.11.1-r1-1build1) xenial; urgency=medium

  * No-change rebuild to drop python3.4 support.

 -- Matthias Klose <email address hidden>  Mon, 18 Jan 2016 19:39:39 +0000
Superseded in xenial-release on 2016-01-19
Deleted in xenial-proposed on 2016-01-20 (Reason: moved to release)
python-apsw (3.8.11.1-r1-1) unstable; urgency=medium

  [ Joel Rosdahl ]
  * New upstream version
  * Use debhelper compat level 9
  * Update debian/watch to new upstream location

  [ Scott Kitterman ]
  * Move dh_python2/3 calls to after dh_install so dependency generation works
    (thanks to Piotr O┼╝arowski for figuring this part out) (closes: #799272)
  * Correct python:Depends to be python3:Depends so proper dependencies are
    generated for python3-apsw
  * Add build-depends on dh-python so current code base is used
  * Remove obsolete provides

 -- Joel Rosdahl <email address hidden>  Thu, 17 Sep 2015 21:16:10 +0200

Available diffs

Superseded in xenial-release on 2015-10-24
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed on 2018-01-22 (Reason: moved to release)
python-apsw (3.8.10.1-r1-1) unstable; urgency=medium

  * New upstream release 3.8.10.1-r1
  * Require libsqlite3-dev >= 3.8.10
  * Bumped Standards-Version to 3.9.6 (no changes)

 -- Joel Rosdahl <email address hidden>  Sun, 21 Jun 2015 16:10:45 +0200

Available diffs

Superseded in wily-release on 2015-06-21
Obsolete in vivid-release on 2018-01-18
Deleted in vivid-proposed on 2018-01-19 (Reason: moved to release)
python-apsw (3.8.6-r1-1) unstable; urgency=medium


  * New upstream release 3.8.6-r1
  * Require libsqlite3-dev >= 3.8.6

 -- Joel Rosdahl <email address hidden>  Mon, 08 Sep 2014 22:31:00 +0200
Superseded in vivid-release on 2014-12-24
Obsolete in utopic-release on 2016-11-03
Published in trusty-release on 2014-01-26
Deleted in trusty-proposed (Reason: moved to release)
python-apsw (3.8.2-r1-1ubuntu1) trusty; urgency=medium

  * Build for Python 3.4.
  * Move the python3 debug extensions into the python3-apsw-dbg package.
 -- Matthias Klose <email address hidden>   Sun, 26 Jan 2014 19:02:44 +0100
Superseded in trusty-release on 2014-01-26
Deleted in trusty-proposed on 2014-01-28 (Reason: moved to release)
python-apsw (3.8.2-r1-1) unstable; urgency=low


  * New upstream release 3.8.2-r1.

 -- Joel Rosdahl <email address hidden>  Wed, 11 Dec 2013 22:05:31 +0100

Available diffs

Superseded in trusty-release on 2013-12-21
Deleted in trusty-proposed on 2013-12-23 (Reason: moved to release)
python-apsw (3.8.1-r1-1) unstable; urgency=low


  * New upstream release 3.8.1-r1.
  * Bump Standards-Version to 3.9.5

 -- Joel Rosdahl <email address hidden>  Sun, 08 Dec 2013 10:30:29 +0100

Available diffs

Superseded in trusty-release on 2013-12-08
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed on 2015-04-28 (Reason: moved to release)
python-apsw (3.7.17-r1-1.1) unstable; urgency=low


  * Non-maintainer upload.
  * Correct dependencies for python/python3-apsw (Closes: #718830)
    - Change python:Depends to python3:depends for python3-apsw
    - Move dh_python2/3 after dh_install in debian/rules so it is invoked
      correctly

 -- Scott Kitterman <email address hidden>  Mon, 05 Aug 2013 16:43:48 -0400

Available diffs

Superseded in saucy-release on 2013-08-11
Deleted in saucy-proposed on 2013-08-12 (Reason: moved to release)
python-apsw (3.7.17-r1-1) unstable; urgency=low


  [Joel Rosdahl]
  * New upstream release 3.7.17-r1.

  [ Nikolaus Rath ]
  * Also build Python 3 package (closes: #706992)
  * Tighten build depends on libsqlite3-dev (closes: #710049)

 -- Joel Rosdahl <email address hidden>  Tue, 18 Jun 2013 22:24:58 +0200

Available diffs

Superseded in saucy-release on 2013-07-01
Deleted in saucy-proposed on 2013-07-02 (Reason: moved to release)
python-apsw (3.7.16.1-r1-1) unstable; urgency=low


  * New upstream release 3.7.16.1-r1

 -- Joel Rosdahl <email address hidden>  Sun, 31 Mar 2013 20:41:13 +0200

Available diffs

Superseded in saucy-release on 2013-06-24
Obsolete in raring-release on 2015-04-24
Deleted in raring-proposed on 2015-04-27 (Reason: moved to release)
python-apsw (3.7.14.1-r1-1) unstable; urgency=low


  * New upstream release 3.7.14.1-r1
  * Add X-Python-Version control field
  * Build with flags from /usr/share/dpkg/buildflags.mk for hardening
  * Don't symlink doc directory for python-apsw-doc to python-apsw

 -- Joel Rosdahl <email address hidden>  Sun, 25 Nov 2012 15:10:34 +0100
Superseded in raring-release on 2012-11-26
Obsolete in quantal-release on 2015-04-24
Published in precise-release on 2011-12-31
python-apsw (3.7.6.3-r1-1build1) precise; urgency=low

  * Rebuild to drop python2.6 dependencies.
 -- Matthias Klose <email address hidden>   Sat, 31 Dec 2011 02:08:54 +0000
Superseded in precise-release on 2011-12-31
Obsolete in oneiric-release on 2015-04-24
python-apsw (3.7.6.3-r1-1) unstable; urgency=low
  * New upstream release  * Convert from dh_pycentral to dh_python2 (closes: #616991)  * Use debhelper compat level 8  * Bump Standards-Version to 3.9.2  * Pass --install-layout=deb to "setup.py install"  * Add build-arch and build-indep targets to debian/rules  * Imported Upstream version 3.7.6.3-r1 -- Joel Rosdahl <email address hidden>  Thu, 30 Jun 2011 22:45:04 +0200
Superseded in oneiric-release on 2011-07-27
python-apsw (3.7.5-r1-1) unstable; urgency=low

  * New upstream version.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Sat,  30 Apr 2011 13:34:25 +0000

Available diffs

Superseded in oneiric-release on 2011-04-30
Obsolete in natty-release on 2013-06-04
python-apsw (3.7.0.1-r1-1build1) natty; urgency=low

  * Rebuild to add support for python 2.7.
 -- Matthias Klose <email address hidden>   Fri, 03 Dec 2010 00:09:31 +0000

Available diffs

Superseded in natty-release on 2010-12-03
python-apsw (3.7.0.1-r1-1) unstable; urgency=low

  * New upstream release.
  * Use correct section for APSW manual in doc-base entry.
  * Updated Standards-Version to 3.9.1.
  * Added debian/watch file.
  * Removed asterisks from NEWS.Debian.
  * The doc-base entry is now actually included in python-apsw-doc.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  15 Oct 2010 09:56:02 +0000

Available diffs

Superseded in natty-release on 2010-10-15
Obsolete in maverick-release on 2013-03-05
python-apsw (3.6.23.1-r1-1) unstable; urgency=low

  * New upstream version.
  * Changed source package format to "3.0 (quilt)".
  * Updated Standards-Version to 3.8.4.
  * Don't compile with debug information in the non-dbg package.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  17 May 2010 13:00:31 +0100

Available diffs

Superseded in maverick-release on 2010-05-17
Obsolete in lucid-release on 2016-10-26
python-apsw (3.6.22-r1-2) unstable; urgency=low

  * Split documentation into a python-apsw-doc package to avoid
    python-apsw depending on libjs-jquery. Closes: #565868.
  * Removed obsolete .doc-base files for python2.4 and python2.5.
  * Added .doc-base file for python-apsw-doc.
  * Build depend on debhelper >= 7.0.0~.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Thu,  04 Feb 2010 17:27:05 +0000

Available diffs

Superseded in lucid-release on 2010-02-04
python-apsw (3.6.22-r1-1) unstable; urgency=low

  * New upstream version.
  * Added ${misc:Depends} for binary packages' requirements.

Available diffs

Superseded in lucid-release on 2010-01-18
Obsolete in karmic-release on 2013-03-04
Obsolete in jaunty-release on 2013-02-28
python-apsw (3.5.9-r2-1ubuntu1) jaunty; urgency=low

  * debian/rules: make package ready for Python 2.6 (LP: #336377):
    - Include /usr/share/python/python.mk.
    - Pass $(py_setup_install_args) macro to setup.py install.

 -- Luca Falavigna <email address hidden>   Thu, 05 Mar 2009 23:52:53 +0000

Available diffs

Superseded in jaunty-release on 2009-03-06
python-apsw (3.5.9-r2-1) unstable; urgency=low

  * New upstream release.
  * Build dependency on libsqlite3-dev 3.5.9.
  * Updated Standards-Version to 3.8.0.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Wed,  05 Nov 2008 10:47:04 +0000

Available diffs

Superseded in jaunty-release on 2008-11-05
Obsolete in intrepid-release on 2013-02-20
Obsolete in hardy-release on 2015-04-24
python-apsw (3.3.13-r1-3) unstable; urgency=low

  * Build python-apsw-dbg package.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Wed,  24 Oct 2007 07:29:24 +0100
Superseded in hardy-release on 2007-10-24
Obsolete in gutsy-release on 2011-09-16
python-apsw (3.3.13-r1-2) unstable; urgency=low

  * Corrected documentation about Unicode strings in apsw.html.
  * Created NEWS.Debian with information about notable changes since
    python-apsw 3.3.5r1.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Thu,  07 Jun 2007 15:50:32 +0100
Superseded in gutsy-release on 2007-06-07
python-apsw (3.3.13-r1-1) unstable; urgency=low

  * New upstream release.
  * Updated build dependencies on debhelper, python-all-dev,
    python-central and libsqlite3-dev.
  * Removed use of dh_python.
  * Added debian/pycompat.
  * Removed XS-Python-Standards-Version field.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  27 Apr 2007 01:12:59 +0100
Superseded in gutsy-release on 2007-04-27
Obsolete in feisty-release on 2009-08-20
python-apsw (3.3.5r1-2build1) feisty; urgency=low

  * Rebuild for python2.5 as the default python version.

 -- Matthias Klose <email address hidden>   Fri, 12 Jan 2007 13:21:01 +0000
Superseded in feisty-release on 2007-01-12
Obsolete in edgy-release on 2008-06-19
python-apsw (3.3.5r1-2) unstable; urgency=low

  * Adapt to new Python policy. Closes: bug#373511.
  * Updated Standards-Version to 3.7.2.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Thu,  22 Jun 2006 08:23:40 +0100
Superseded in edgy-release on 2006-06-22
python-apsw (3.3.5r1-1) unstable; urgency=low

  * New upstream release. Closes: bug#365222.
  * APSW now has more error checking. Closes: bug#329236.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Thu,  15 Jun 2006 15:24:49 +0100
Superseded in edgy-release on 2006-06-15
Obsolete in dapper-release on 2011-09-06
Superseded in dapper-release on 2006-02-03
python-apsw (3.2.7r1-1) unstable; urgency=low


  * New upstream release.
  * Closes: bug#329233 ("segfault on too few argument bindings").

 -- Joel Rosdahl <email address hidden>  Sun,  9 Oct 2005 21:31:13 +0200
Obsolete in breezy-release on 2008-03-25
python-apsw (3.2.1r1-1) unstable; urgency=low


  * New upstream release.

 -- Joel Rosdahl <email address hidden>  Sun,  5 Jun 2005 11:50:41 +0200
139 of 39 results