Change log for python-cogent package in Ubuntu

122 of 22 results
Published in cosmic-proposed on 2018-06-06
python-cogent (1.9-12) unstable; urgency=medium

  * Add registry data
  * Testsuite: autopkgtest-pkg-python
  * honor "nocheck" in DEB_BUILD_OPTIONS
    Closes: #898334
  * debhelper 11
  * Point Vcs fields to salsa.debian.org
  * Standards-Version: 4.1.4
  * Fix suite fails with latest matplotlib
    Closes: #899205
  * Fix privacy issue in doc
  * Drop obsolete file debian/pyversions
  * Drop unneeded get-orig-source target
  * Do not parse d/changelog
  * Rename debian/tests/control to debian/tests/control.autodep8
  * Remove useless doctree files

 -- Andreas Tille <email address hidden>  Wed, 06 Jun 2018 11:10:01 +0200
Published in cosmic-release on 2018-05-01
Published in bionic-release on 2017-10-24
Published in artful-release on 2017-09-06
Deleted in artful-proposed (Reason: moved to release)
python-cogent (1.9-11build1) artful; urgency=medium

  * No-change rebuild to drop _PyFPE support.

 -- Matthias Klose <email address hidden>  Tue, 05 Sep 2017 08:22:58 +0000

Available diffs

Superseded in artful-release on 2017-09-06
Deleted in artful-proposed on 2017-09-07 (Reason: moved to release)
python-cogent (1.9-11) unstable; urgency=medium

  * Exclude test_format.test_pdb_color.PdbColorTests for s390x
    Closes: #864894

 -- Andreas Tille <email address hidden>  Fri, 16 Jun 2017 23:50:35 +0200

Available diffs

Superseded in artful-release on 2017-06-17
Deleted in artful-proposed on 2017-06-18 (Reason: moved to release)
python-cogent (1.9-10) unstable; urgency=medium

  * Team upload.

  [ Nadiya Sitdykova ]
  * Add autopkgtest test-suite (without tests known to fail)
  
  [ Andreas Tille ]
  * Move packaging from SVN to Git
  * Fix test checking path to ls

 -- Naidya Sitdykova <email address hidden>  Thu, 15 Jun 2017 23:26:56 -0400

Available diffs

Superseded in artful-release on 2017-06-16
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed on 2018-06-22 (Reason: moved to release)
python-cogent (1.9-9) unstable; urgency=medium

  * Skip test with incompatibilities to Numpy 1.12.0~b1
    Closes: #848746

 -- Andreas Tille <email address hidden>  Tue, 20 Dec 2016 09:39:12 +0100

Available diffs

Superseded in zesty-release on 2016-12-20
Deleted in zesty-proposed on 2016-12-22 (Reason: moved to release)
python-cogent (1.9-8) unstable; urgency=medium

  * Skip another test to enable build on mips

 -- Andreas Tille <email address hidden>  Tue, 06 Dec 2016 08:26:08 +0100

Available diffs

Superseded in zesty-release on 2016-12-06
Deleted in zesty-proposed on 2016-12-08 (Reason: moved to release)
python-cogent (1.9-7) unstable; urgency=medium

  * Skip more tests to enable build on mips & mips64el
  * Skip tests that are not working any more since ncbi-tools6 >=6.1.20160908-1
    Closes: #847082

 -- Andreas Tille <email address hidden>  Mon, 05 Dec 2016 11:32:17 +0100

Available diffs

Superseded in zesty-release on 2016-12-06
Deleted in zesty-proposed on 2016-12-07 (Reason: moved to release)
python-cogent (1.9-6) unstable; urgency=medium

  * Skip some tests that do not create reproducible results at package
    build time
    Closes: #846078

 -- Andreas Tille <email address hidden>  Wed, 30 Nov 2016 07:46:45 +0100

Available diffs

Superseded in zesty-proposed on 2016-12-01
python-cogent (1.9-5) unstable; urgency=medium

  * Update d/README.Debian with todo list
  * debhelper 10
  * d/watch: version=4
  * add verbosity to unit tests to enable tracking down #846078

 -- Andreas Tille <email address hidden>  Tue, 29 Nov 2016 09:03:40 +0100

Available diffs

Superseded in zesty-release on 2016-12-01
Deleted in zesty-proposed on 2016-12-02 (Reason: moved to release)
python-cogent (1.9-4) unstable; urgency=medium

  * Need to exclude further tests on armhf and mips

 -- Andreas Tille <email address hidden>  Thu, 15 Sep 2016 10:45:44 +0200

Available diffs

Superseded in zesty-release on 2016-11-04
Obsolete in yakkety-release on 2018-01-23
Published in xenial-release on 2016-02-15
Deleted in xenial-proposed (Reason: moved to release)
python-cogent (1.5.3-10) unstable; urgency=medium

  * mothur does not exist on s390x
  * exclude test failed on i386 also on kfreebsd-i386

 -- Andreas Tille <email address hidden>  Wed, 30 Dec 2015 17:43:34 +0100

Available diffs

Superseded in xenial-proposed on 2015-12-30
python-cogent (1.5.3-9) unstable; urgency=medium

  * Different autobuilder seems to fail on different tests - exclude another
    two tests on i386

 -- Andreas Tille <email address hidden>  Sat, 26 Dec 2015 07:41:10 +0100

Available diffs

Superseded in xenial-proposed on 2015-12-26
python-cogent (1.5.3-8) unstable; urgency=medium

  * Ignore some more test issues only on ppc64

 -- Andreas Tille <email address hidden>  Fri, 25 Dec 2015 13:04:33 +0100

Available diffs

Superseded in xenial-proposed on 2015-12-25
python-cogent (1.5.3-7) unstable; urgency=medium

  * Ignore a few test failures on certain architectures to at least
    document the problem debian/README.source was created

 -- Andreas Tille <email address hidden>  Thu, 24 Dec 2015 07:27:11 +0100

Available diffs

Superseded in xenial-proposed on 2015-12-24
python-cogent (1.5.3-6) unstable; urgency=medium

  * Also deal with raxml that only exists on [any-amd64 any-i386]

 -- Andreas Tille <email address hidden>  Wed, 23 Dec 2015 20:56:16 +0100

Available diffs

Superseded in xenial-proposed on 2015-12-24
Deleted in wily-proposed on 2015-12-25 (Reason: moved to xenial-proposed)
python-cogent (1.5.3-3) unstable; urgency=medium

  * cme fix dpkg-control
  * Priority: optional (except for *-dbg)
  * DEP5
  * debian/watch: Adapted to Github
  * DEP3
  * README.source removed since redundant
  * cme fix dpkg-control
  * Adapt to the naming scheme of cd-hit inside Debian
    Closes: #730515
  * Switch from python-support to pybuild
    Closes: #786073

 -- Andreas Tille <email address hidden>  Thu, 21 May 2015 09:29:22 +0200
Superseded in xenial-release on 2016-02-15
Obsolete in wily-release on 2018-01-22
Obsolete in vivid-release on 2018-01-18
Obsolete in utopic-release on 2016-11-03
Published in trusty-release on 2013-10-18
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed (Reason: moved to release)
python-cogent (1.5.3-2) unstable; urgency=low


  * debian/rules: Add -f option to rm statements to not fail if
    files to be remove do not exist
    Closes: #710339

 -- Andreas Tille <email address hidden>  Thu, 30 May 2013 13:02:05 +0200
Superseded in saucy-proposed on 2013-05-30
python-cogent (1.5.3-1) unstable; urgency=low


  * New upstream
  * debian/control: use dh 9
  * debian/control: set standard to 3.9.4 (no changes)
  * debian/rules: add get-orig-source target
  * debian/rules: remove some superfluous files

  [ Tim Booth ]
  * Added back python2 helper and invoked dh_numpy to sort deps
  * Split out docs into separate package
  * Added extra cleanup to dh_clean

 -- Thorsten Alteholz <email address hidden>  Sun, 16 May 2013 18:00:00 +0200
Superseded in saucy-release on 2013-05-30
Obsolete in raring-release on 2015-04-24
Obsolete in quantal-release on 2015-04-24
Published in precise-release on 2012-01-04
Superseded in precise-release on 2012-01-04
python-cogent (1.5.1-2) unstable; urgency=low

  * Explicitly added python-numpy as dependency
    to binary ... where is the dh_shlibdeps?
    Many thanks to Jakub (Closes: #640262).
  * Added build-dependency on cython after look in setup.py
  * Some further formatting in debian/control
  * Added -dbg package
  * Fiddled with debian/*.install to actually install the libraries
    and fill that -dbg package.
  * Added dependency to underscore.js

Available diffs

Superseded in precise-release on 2011-10-17
Obsolete in oneiric-release on 2015-04-24
python-cogent (1.5-3) unstable; urgency=low

  * debian/control:
    - Remove Sri Girish Srinivasa Murthy from Uploaders
    - Standards-Version: 3.9.2 (no changes needed)
    - python-all-dev (>= 2.6) to be able to use dh_python2
  * debhelper 8 (control+compat)
  * debian/rules: dh_python2
    Finally closes: #596540

Available diffs

Superseded in oneiric-release on 2011-04-30
Obsolete in natty-release on 2013-06-04
python-cogent (1.5-1) unstable; urgency=low

  * Bumped standard to 3.9.1, no changes required.
  * New upstream version.
    - major additions to Cookbook
    - added AlleleFreqs attribute to ensembl Variation objects.
    - added getGeneByStableId method to genome objects.
    - added Introns attribute to Transcript objects and an Intron class.
    - added Mann-Whitney test and a Monte-Carlo version
    - exploratory and confirmatory period estimation techniques (suitable for
      symbolic and continuous data)
    - Information theoretic measures (AIC and BIC) added
    - drawing of trees with collapsed nodes
    - progress display indicator support for terminal and GUI apps
    - added parser for illumina HiSeq2000 and GAiix sequence files as 
      cogent.parse.illumina_sequence.MinimalIlluminaSequenceParser.
    - added parser to FASTQ files, one of the output options for illumina's
      workflow, also added cookbook demo.
    - added functionality for parsing of SFF files without the Roche tools in
      cogent.parse.binary_sff
    - thousand fold performance improvement to nmds
    - >10-fold performance improvements to some Table operations
 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  06 Dec 2010 13:59:21 +0000

Available diffs

Superseded in natty-release on 2010-12-06
python-cogent (1.4.1-1.2) unstable; urgency=low

  * Non-maintainer upload.
  * Mark package as auto-buildable

122 of 22 results