Change log for python-defaults package in Ubuntu

175 of 128 results
Published in artful-release on 2017-09-27
Deleted in artful-proposed (Reason: moved to release)
python-defaults (2.7.14-2ubuntu1) artful; urgency=medium

  * pycompile, pyclean, pyversions: Use python2 as the shebang to guard
    against people fiddling around with the python symlink or having a
    python3 installed as python in /usr/local. LP: #1715062.
  * Rename the idle package to idle2. idle is now built for python3.

 -- Matthias Klose <email address hidden>  Sat, 23 Sep 2017 10:18:14 +0200
Superseded in artful-release on 2017-09-27
Deleted in artful-proposed on 2017-09-29 (Reason: moved to release)
python-defaults (2.7.14-1) unstable; urgency=medium

  * Bump version to 2.7.14.
  * python-examples: Fix Multi-Arch warning.
  * Change policy format from debiandoc SGML to DocBook/XML (W. Martin Borgert).
    Closes: #872421.

 -- Matthias Klose <email address hidden>  Mon, 18 Sep 2017 10:17:15 +0200

Available diffs

Superseded in artful-release on 2017-09-23
Published in zesty-release on 2017-02-17
Deleted in zesty-proposed (Reason: moved to release)
python-defaults (2.7.13-2) unstable; urgency=medium

  [ Matthias Klose ]
  * Lower priority of packages from standard to optional.

  [ Scott Kitterman ]
  * Make another attempt at Django specific binary naming

 -- Matthias Klose <email address hidden>  Tue, 24 Jan 2017 14:00:42 +0100
Superseded in zesty-proposed on 2017-01-24
python-defaults (2.7.13-1) unstable; urgency=medium

  [ Matthias Klose ]
  * Bump version to 2.7.13.
  * Mark python-doc as M-A: foreign.
  * Bump debhelper version.

  [ Helmut Grohne ]
  * Fix FTCBFS: Annotate python build dependencies with :any (Closes: #841682)

  [ Chris Lamb ]
  * Consistently order python substvars to support reproducibility (Closes:
    #844111)

  [ Scott Kitterman ]
  * Add Django specific binary naming policy to align to current practice.

 -- Matthias Klose <email address hidden>  Tue, 20 Dec 2016 11:15:12 +0100
Superseded in zesty-release on 2017-02-17
Published in yakkety-release on 2016-06-06
Deleted in yakkety-proposed (Reason: moved to release)
python-defaults (2.7.11-2) unstable; urgency=medium

  [ Scott Kitterman ]
  * Python policy updates for Stretch (Many thanks to Ben Finney for all the
    updates)
    - Change focus in text to python3
    - Remove/deprecate features no longer needed due to only a single Python 2
      version
    - Discuss update process in more detail
    - Revamp tools section to better align to current practice

  [ Matthias Klose ]
  * Update valgrind suppression file. Issue #12612. LP: #1512622.
  * Rebuild to pick up the GNU triplet change on i386 archs. Addresses: #826128.

 -- Matthias Klose <email address hidden>  Fri, 03 Jun 2016 01:29:55 +0200

Available diffs

Superseded in yakkety-release on 2016-06-06
Published in xenial-release on 2015-12-14
Deleted in xenial-proposed (Reason: moved to release)
python-defaults (2.7.11-1) unstable; urgency=medium

  * Bump version to 2.7.11.
  * Stop shipping menu files.
  * Fix some lintian warnings.

 -- Matthias Klose <email address hidden>  Wed, 09 Dec 2015 13:07:35 +0100

Available diffs

Superseded in xenial-release on 2015-12-14
Published in wily-release on 2015-05-04
Published in vivid-release on 2015-03-23
Deleted in vivid-proposed (Reason: moved to release)
python-defaults (2.7.9-1) unstable; urgency=medium


  * Bump version to 2.7.9.

 -- Matthias Klose <email address hidden>  Mon, 16 Mar 2015 23:32:04 +0100

Available diffs

Superseded in vivid-release on 2015-03-23
Deleted in vivid-proposed on 2015-03-24 (Reason: moved to release)
python-defaults (2.7.8-4) unstable; urgency=medium


  [ Barry Warsaw ]
  * Update policy document to clarify the purpose and use of the wheel
    files.  No actual change in policy is made.

 -- Scott Kitterman <email address hidden>  Mon, 02 Mar 2015 15:45:19 -0500

Available diffs

Superseded in vivid-release on 2015-03-09
Deleted in vivid-proposed on 2015-03-10 (Reason: moved to release)
python-defaults (2.7.8-3) unstable; urgency=medium


  [ Michael Gilbert ]
  * Make python-minimal a pre-dependency for python (closes: #769106).

 -- Scott Kitterman <email address hidden>  Mon, 02 Feb 2015 16:12:38 -0500

Available diffs

Superseded in vivid-release on 2015-02-03
Deleted in vivid-proposed on 2015-02-04 (Reason: moved to release)
python-defaults (2.7.8-2) unstable; urgency=medium


  [ Matthias Klose ]
  * Build-depend on python2.7 and dpkg-dev versions to consistently
    generate the i586-* symlinks. Closes: #758301.

  [ Piotr Ożarowski ]
  * dh_python2: add a warning abount missing dh-python in Build-Depends

  [ Scott Kitterman ]
  * Minor updates to python policy
    - Reflect disuse of pyshared directory in favor of /usr/lib/python2.7/
      dist-packages since python2.7 is the last and only python version
      supported (Closes: #763451)
    - Update python-central information to reflect its removal from Jessie

 -- Scott Kitterman <email address hidden>  Fri, 24 Oct 2014 10:58:42 -0400

Available diffs

Superseded in vivid-release on 2014-10-30
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed on 2016-11-03 (Reason: moved to release)
python-defaults (2.7.8-1) unstable; urgency=medium


  [ Barry Warsaw ]
  * Fix typo in policy doc re: wheel package exception list.
  * Add myself to Uploaders.

  [ Scott Kitterman ]
  * Fix error in pydist package relationship regex (Closes: #735163)
    - Thanks to Rafael Laboissiere for the patch
  * Switch from using lsb-release to dpkg-vendor to determine distro and drop
    lsb-release from build-depends (Closes: #751706)
    - Thanks to Peter Pentchev for the patch
  * Drop unused build-depends on libhtml-tree-perl
  * Clarify discussion of requirement to use python:Provides (Closes: #669346)
  * Add clarification of naming requirements for submocules (Closes: #701192)
  * Minor cleanups in debian/pyversions.py
  * Stop automatically regenerating static content (dh_python2 man pages and
    Python FAQ) and drop build-dep on python-docutils to ease bootstrapping
    (Closes: #754060)
    - Add direct build-dep on python-all to replace indirect build-dep
  * Bump version to 2.7.8
  * Drop ancient Breaks on python-csv, python-bz2, and python-email

 -- Scott Kitterman <email address hidden>  Fri, 11 Jul 2014 17:10:37 -0400

Available diffs

Superseded in utopic-release on 2014-07-12
Deleted in utopic-proposed on 2014-07-13 (Reason: moved to release)
python-defaults (2.7.6-2) unstable; urgency=medium


  [ Barry Warsaw ]
  * Add python policy for Python Wheels

 -- Scott Kitterman <email address hidden>  Wed, 21 May 2014 00:04:16 -0400

Available diffs

Superseded in utopic-release on 2014-05-22
Deleted in utopic-proposed on 2014-05-23 (Reason: moved to release)
python-defaults (2.7.6-1) unstable; urgency=medium


  * Bump version to 2.7.6.
  * dh_python2: no longer move files to /usr/share/pyshared, don't create
    /usr/lib/pyshared symlinks for extensions.
  * Use UTF-8 encoding for the python policy in HTML format. Closes: #689931.
  * Add a chapter for the python policy to prefer Python 3 over Python 2.

 -- Matthias Klose <email address hidden>  Mon, 12 May 2014 12:16:34 +0200
Superseded in utopic-release on 2014-05-14
Published in trusty-release on 2013-12-21
Deleted in trusty-proposed (Reason: moved to release)
python-defaults (2.7.5-5ubuntu3) trusty; urgency=medium

  * Don't create extension symlinks in /usr/lib/pyshared/pythonX.Y anymore.
 -- Matthias Klose <email address hidden>   Sat, 21 Dec 2013 15:04:57 +0100
Superseded in trusty-proposed on 2013-12-21
python-defaults (2.7.5-5ubuntu2) trusty; urgency=medium

  * dh_python2: Don't move files to /usr/share/pyshared anymore.
 -- Matthias Klose <email address hidden>   Thu, 19 Dec 2013 23:37:23 +0100

Available diffs

Superseded in trusty-release on 2013-12-21
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed on 2015-04-28 (Reason: moved to release)
python-defaults (2.7.5-5ubuntu1) saucy; urgency=low

  * Merge with Debian unstable, remaining change:
    - Set minimal required python version to 2.7.1.

Available diffs

Superseded in saucy-release on 2013-09-26
Deleted in saucy-proposed on 2013-09-27 (Reason: moved to release)
python-defaults (2.7.5-4ubuntu2) saucy; urgency=low

  * Adjust debpython/depends.py to be multiarch-friendly.  Closes: #722046.
 -- Steve Langasek <email address hidden>   Thu, 12 Sep 2013 13:10:46 -0700

Available diffs

Superseded in saucy-release on 2013-09-18
Deleted in saucy-proposed on 2013-09-19 (Reason: moved to release)
python-defaults (2.7.5-4ubuntu1) saucy; urgency=low

  * Merge with Debian unstable, remaining changes:
    - Set Multi-Arch: allowed attributes.
    - Set minimal required python version to 2.7.1.

Available diffs

Published in precise-updates on 2013-06-21
Deleted in precise-proposed (Reason: moved to -updates)
python-defaults (2.7.3-0ubuntu2.2) precise-proposed; urgency=low

  * Fix the python-dev Replaces to prevent installation regression.
    LP: #1167177

Superseded in saucy-release on 2013-08-23
Deleted in saucy-proposed on 2013-08-24 (Reason: moved to release)
python-defaults (2.7.5-1ubuntu1) saucy; urgency=low

  * Merge with Debian; remaining changes:
    - Set Multi-Arch: allowed attributes.
    - Set minimal required python version to 2.7.1.

Available diffs

Superseded in saucy-release on 2013-06-06
Obsolete in raring-release on 2015-04-24
Deleted in raring-proposed on 2015-04-27 (Reason: moved to release)
python-defaults (2.7.4-0ubuntu1) raring; urgency=low

  * Bump version to 2.7.4.
 -- Matthias Klose <email address hidden>   Sun, 07 Apr 2013 20:40:20 +0200
Obsolete in lucid-updates on 2016-10-26
Deleted in lucid-proposed on 2016-11-01 (Reason: moved to -updates)
python-defaults (2.6.5-0ubuntu1.1) lucid-proposed; urgency=low

  * default to python 2.6 for pycompile. LP: #566441.
 -- Rolf Leggewie <email address hidden>   Sat, 16 Jul 2011 20:17:44 +0900

Available diffs

Superseded in raring-release on 2013-04-07
Deleted in raring-proposed on 2013-04-09 (Reason: moved to release)
python-defaults (2.7.3-13ubuntu1) raring; urgency=low

  * Merge with Debian; remaining changes:
    - python2.7 is the only supported version.
    - Build libpython-stdlib, libpython-all-{dev,dbg} packages.
    - Adjusted intra-package dependencies for the above.
    - -all packages are Multi-Arch: allowed.

Superseded in precise-proposed on 2013-06-18
python-defaults (2.7.3-0ubuntu2.1) precise-proposed; urgency=low

  * Make python{,-minimal,-dbg} Multi-Arch: allowed. LP: #1130709.
  * Provide python2.pc symlinks. LP: #1088771.
 -- Matthias Klose <email address hidden>   Wed, 20 Mar 2013 10:56:21 -0700
Obsolete in quantal-updates on 2015-04-24
Deleted in quantal-proposed on 2015-05-01 (Reason: moved to -updates)
python-defaults (2.7.3-0ubuntu7.1) quantal-proposed; urgency=low

  * Make python{,-minimal,-dbg} Multi-Arch: allowed. LP: #1130709.
 -- Matthias Klose <email address hidden>   Fri, 22 Feb 2013 10:33:41 +0100

Available diffs

Superseded in raring-release on 2013-03-21
Deleted in raring-proposed on 2013-03-23 (Reason: moved to release)
python-defaults (2.7.3-10ubuntu5) raring; urgency=low

  * python-all-{dev,dbg}: Depend on libpython-all-{dev,dbg}.
 -- Matthias Klose <email address hidden>   Sun, 27 Jan 2013 19:59:56 +0100

Available diffs

Superseded in raring-release on 2013-01-27
Deleted in raring-proposed on 2013-01-29 (Reason: moved to release)
python-defaults (2.7.3-10ubuntu4) raring; urgency=low

  * Build libpython-all-{dev,dbg} packages.
 -- Matthias Klose <email address hidden>   Fri, 25 Jan 2013 20:35:02 +0100

Available diffs

Superseded in raring-release on 2013-01-26
Deleted in raring-proposed on 2013-01-27 (Reason: moved to release)
python-defaults (2.7.3-10ubuntu3) raring; urgency=low

  * Move lsb-release to Build-Depends.
 -- Matthias Klose <email address hidden>   Wed, 12 Dec 2012 11:11:11 +0100
Superseded in raring-proposed on 2012-12-12
python-defaults (2.7.3-10ubuntu2) raring; urgency=low

  * Make python3-{all,all-dev,all-dbg} Multi-Arch: allowed.
 -- Matthias Klose <email address hidden>   Wed, 12 Dec 2012 11:02:45 +0100

Available diffs

Superseded in raring-proposed on 2012-12-12
python-defaults (2.7.3-10ubuntu1) raring; urgency=low

  * Merge with Debian; remaining changes:
    - Move python-docutils, and debiandoc-sgml to Build-Depends from B-D-Indep.
      This fixes build failures with --no-arch-all and in the buildds on
      powerpc, armhf, and amd64.
    - debian/control.in: Build depend on lsb-release to set correct
      Maintainer fields when building on Ubuntu.
    - debian/rules: Ignore version check, as our default versions differ
      from Debian's.
    - debian/control.in, debian/debian_defaults: Drop python2.6 support.

Superseded in raring-release on 2012-12-12
Deleted in raring-proposed on 2012-12-13 (Reason: moved to release)
python-defaults (2.7.3-3ubuntu2) raring; urgency=low

  * debian/control.in: move python-docutils, and debiandoc-sgml to
    Build-Depends from B-D-Indep.  This fixes build failures with
    --no-arch-all and in the buildds on powerpc, armhf, and amd64.
 -- Barry Warsaw <email address hidden>   Wed, 28 Nov 2012 17:04:08 -0500
Superseded in raring-proposed on 2012-11-28
python-defaults (2.7.3-3ubuntu1) raring; urgency=low

  * Resynchronize with Debian unstable, remaining Ubuntu changes:
    - debian/control.in: Build depend on lsb-release to set correct
      Maintainer fields when building on Ubuntu.
    - debian/rules: Ignore version check, as our default versions differ
      from Debian's.
    - debian/control.in, debian/debian_defaults: Drop python2.6 support.
    - debian/rules: Provide Python pkgconfig defaults.
    - debian/rules: Re-add the python2 and python2-config symlinks,
      formerly present in the python2.7 packages (see PEP 394).
    - debian/control.in, debian/rules: Build dependency packages as
      architecture dependent packages (for cross-building python
      extension packages, see LP: #934593).
  * debian/rules: in binary-arch section, use -a argument for dh_* commands.

Available diffs

Superseded in raring-release on 2012-11-28
Obsolete in quantal-release on 2015-04-24
python-defaults (2.7.3-0ubuntu7) quantal; urgency=low

  * Avoid TypeError in dh_python when maximum version is specified.
    LP: #1048091
 -- Barry Warsaw <email address hidden>   Wed, 10 Oct 2012 15:45:02 -0400

Available diffs

Superseded in quantal-release on 2012-10-10
python-defaults (2.7.3-0ubuntu6) quantal; urgency=low

  * Remove pyversions.py[co] at purge command too (LP: #1054442)
 -- Mitsuya Shibata <email address hidden>   Sat, 22 Sep 2012 13:12:14 +0900

Available diffs

Superseded in quantal-release on 2012-09-28
python-defaults (2.7.3-0ubuntu5) quantal; urgency=low

  * Remove Essential flag from python-minimal.  We have never intentionally
    relied on this elsewhere in the system, and it's going to impede
    transitioning to future Python 3-only systems.
 -- Colin Watson <email address hidden>   Wed, 23 May 2012 11:51:49 +0100

Available diffs

Superseded in quantal-release on 2012-05-23
python-defaults (2.7.3-0ubuntu4) quantal; urgency=low

  * Revert 2.7.3-0ubuntu3 as this breaks a large number of packages and the
    benefits of it are unclear (LP: #1001912)
 -- Scott Kitterman <email address hidden>   Tue, 22 May 2012 11:23:40 -0400

Available diffs

Superseded in quantal-release on 2012-05-22
python-defaults (2.7.3-0ubuntu3) quantal; urgency=low

  * Stop installing packages and creating symlnks to /usr/share/pyshared.
 -- Matthias Klose <email address hidden>   Mon, 30 Apr 2012 19:39:16 +0200

Available diffs

Superseded in quantal-release on 2012-04-30
Published in precise-release on 2012-04-19
Deleted in precise-proposed (Reason: moved to release)
python-defaults (2.7.3-0ubuntu2) precise-proposed; urgency=low

  * Re-add the python2 and python2-config symlinks, formerly present
    in the python2.7 packages. PEP 394.
  * Build dependency packages as architecture dependent packages again.
    LP: #934593.
  * Move idle.xpm into the idle package.
  * Stop providing python-argparse (also provided by python2.7).
 -- Matthias Klose <email address hidden>   Tue, 17 Apr 2012 15:54:22 +0200

Available diffs

Superseded in precise-release on 2012-04-19
Deleted in precise-proposed on 2012-04-20 (Reason: moved to release)
python-defaults (2.7.3-0ubuntu1) precise; urgency=low

  * Bump version to 2.7.3.
 -- Matthias Klose <email address hidden>   Thu, 12 Apr 2012 23:54:23 +0200

Available diffs

Superseded in precise-release on 2012-04-13
python-defaults (2.7.2-9ubuntu6) precise; urgency=low

  * Revert to 2.7.2-9ubuntu2 as the arch:all -> arch:any change needs to be
    properly bootstrapped
 -- Micah Gersten <email address hidden>   Fri, 16 Mar 2012 01:02:42 -0500

Available diffs

Superseded in precise-release on 2012-03-16
python-defaults (2.7.2-9ubuntu5) precise; urgency=low

  * Build docs on all archs now at least until a better solution is found;
    This temporarily fixes the FTBFS and the inabiity to install python on !i386
    - update debian/rules
 -- Micah Gersten <email address hidden>   Fri, 16 Mar 2012 00:39:49 -0500

Available diffs

Superseded in precise-release on 2012-03-16
python-defaults (2.7.2-9ubuntu4) precise; urgency=low

  * Build dependency packages as architecture dependent packages. LP: #934593.
  * Provide python2 and python2-config symlinks.
 -- Matthias Klose <email address hidden>   Fri, 16 Mar 2012 02:36:04 +0100

Available diffs

Superseded in precise-release on 2012-03-16
python-defaults (2.7.2-9ubuntu3) precise; urgency=low

  * Build dependency packages as architecture dependent packages. LP: #934593.
  * Provide python2 and python2-config symlinks.
 -- Matthias Klose <email address hidden>   Fri, 16 Mar 2012 02:36:04 +0100

Available diffs

Obsolete in natty-updates on 2013-06-04
Deleted in natty-proposed on 2013-06-04 (Reason: moved to -updates)
python-defaults (2.7.1-0ubuntu5.1) natty-proposed; urgency=low

  * Backport patch from 2.6.6-11: (LP: #915167)
    - pycompile: use /usr/bin/pythonX.Y rather than pythonX.Y (to avoid
      /usr/local interpreters)
 -- Stefano Rivera <email address hidden>   Wed, 15 Feb 2012 14:52:26 -0800

Available diffs

Superseded in precise-release on 2012-03-16
python-defaults (2.7.2-9ubuntu2) precise; urgency=low

  * python: Provide python-argparse.
 -- Matthias Klose <email address hidden>   Wed, 21 Dec 2011 22:43:22 +0100

Available diffs

Superseded in precise-release on 2011-12-21
python-defaults (2.7.2-9ubuntu1) precise; urgency=low

  * Merge from Debian testing.  Remaining changes:
    - Build depend on lsb-release
    - Ignore vesion check
    - Drop python2.6 support
    - Package priorities and status.
    - Adjust version numbers in maintainer scripts.
    - Provide Python pkgconfig defaults
 -- Michael Terry <email address hidden>   Tue, 22 Nov 2011 08:54:54 -0500

Available diffs

Superseded in precise-release on 2011-11-22
python-defaults (2.7.2-7ubuntu4) precise; urgency=low

  * Build-depend on lsb-release.
  * Ignore version check.
 -- Matthias Klose <email address hidden>   Thu, 13 Oct 2011 22:39:31 +0200

Available diffs

Superseded in precise-release on 2011-10-13
python-defaults (2.7.2-7ubuntu3) precise; urgency=low

  * Drop python2.6 as a supported python version.
 -- Matthias Klose <email address hidden>   Tue, 11 Oct 2011 16:07:04 +0200

Available diffs

Superseded in precise-release on 2011-10-13
Obsolete in oneiric-release on 2015-04-24
python-defaults (2.7.2-7ubuntu2) oneiric; urgency=low

  * Pull in dh_python2 fixes from Debian 2.7.2-9
    - Generate correct dependencies if private directory supports one Python
      version only (closes: #644573)
 -- Scott Kitterman <email address hidden>   Sat, 08 Oct 2011 12:12:12 -0400

Available diffs

Superseded in oneiric-release on 2011-10-08
python-defaults (2.7.2-7ubuntu1) oneiric; urgency=low

  * Merge from debian unstable.  Remaining changes:
    - Package priorities and status.
    - Adjust version numbers in maintainer scripts.
    - Provide Python pkgconfig defaults

Available diffs

Superseded in oneiric-release on 2011-10-06
python-defaults (2.7.2-5ubuntu3) oneiric; urgency=low

  * Update from Debian to bzr r280.

  [ Piotr Ożarowski ]
  * avoid catching KeyboardInterrupt
  * really fix removing .so.foo symlinks twice issue
 -- Barry Warsaw <email address hidden>   Fri, 23 Sep 2011 19:32:58 -0400

Available diffs

Superseded in oneiric-release on 2011-09-24
python-defaults (2.7.2-5ubuntu2) oneiric; urgency=low

  [ Scott Kitterman ]
  * Update from Debian bzr
  * Fixed typo in python-policy (thanks to Jakub Wilk)

  [ Piotr Ożarowski ]
  * dh_python2:
    - handle private dir paths without leading slash
    - add python to Depends if unversioned python shebang is detected in
      private directory
    - dist_fallback: add /usr/share/python-support/package/ to paths searched
      for Egg metadata; add "wsgiref" and "python" fallbacks
    - do not try to remove .so.foo symlinks twice (if files were listed in an
      unfortunate order)
 -- Scott Kitterman <email address hidden>   Thu, 22 Sep 2011 16:59:15 -0400

Available diffs

Superseded in oneiric-release on 2011-09-23
python-defaults (2.7.2-5ubuntu1) oneiric; urgency=low

  * Merge from Debian Experimental.  Remaining Ubuntu changes:
    - Package priorities and status.
    - Adjust version numbers in maintainer scripts.
    - Provide Python pkgconfig defaults

Available diffs

Superseded in oneiric-release on 2011-08-11
python-defaults (2.7.2-4ubuntu4) oneiric; urgency=low

  * Drop python-all* version requirements changes from Debian for python2.6
    now that python2.6 updated in Ubuntu
 -- Scott Kitterman <email address hidden>   Mon, 01 Aug 2011 01:11:14 -0400

Available diffs

Superseded in oneiric-release on 2011-08-01
python-defaults (2.7.2-4ubuntu3) oneiric; urgency=low

  * Adjust python2.6 dependency requirements to fix installability
 -- Scott Kitterman <email address hidden>   Fri, 29 Jul 2011 18:33:14 -0400

Available diffs

Superseded in oneiric-release on 2011-07-29
python-defaults (2.7.2-4ubuntu2) oneiric; urgency=low

  * Relax the dependency to 2.6.7-2 until 2.6.7-3 is merged from Debian.
 -- Barry Warsaw <email address hidden>   Fri, 29 Jul 2011 17:28:31 -0400

Available diffs

Superseded in oneiric-release on 2011-07-29
python-defaults (2.7.2-4ubuntu1) oneiric; urgency=low

  * Merge from Debian experimental.  Remaining changes:
    - Package priorities and status.
    - Adjust version numbers in maintainer scripts.
 -- Barry Warsaw <email address hidden>   Fri, 29 Jul 2011 13:55:57 -0400

Available diffs

Superseded in oneiric-release on 2011-07-29
python-defaults (2.7.2-1ubuntu2) oneiric; urgency=low

  * Fix FTBFS by adding missing manpages target for pyton-minimal DESTDIR that
    was lost due to a bad merge
 -- Scott Kitterman <email address hidden>   Sat, 04 Jun 2011 21:30:25 -0400

Available diffs

Superseded in oneiric-release on 2011-06-05
python-defaults (2.7.2-1ubuntu1) oneiric; urgency=low

  * Merge from debian experimental.  Remaining changes:
    - Package priorities and status.
    - Adjust version numbers in maintainer scripts.

Available diffs

Superseded in oneiric-release on 2011-06-05
Obsolete in natty-release on 2013-06-04
python-defaults (2.7.1-0ubuntu5) natty; urgency=low

  * Merge changes from 2.6.6-10:
  * dh_python2: fix moving files from old debug locations (due to typo)
  * python-minimal now Breaks python-support << 1.0.10ubuntu2 (Python 2.7
    support was 1.0.10ubuntu2 in Ubuntu (1.0.12 in Debian))
  * pycompile: skip dangling symlinks
 -- Scott Kitterman <email address hidden>   Tue, 11 Jan 2011 14:45:20 -0500

Available diffs

Superseded in natty-release on 2011-01-11
python-defaults (2.7.1-0ubuntu4) natty; urgency=low

  * Merge changes from 2.6.6-9:
  * dh_python2: fix a crash in packages with private extension (closes: 607555)
    - test3 added (to test architecture dependent packages)
 -- Matthias Klose <email address hidden>   Wed, 22 Dec 2010 10:32:32 +0100

Available diffs

Obsolete in maverick-updates on 2013-03-05
Deleted in maverick-proposed on 2013-03-05 (Reason: moved to -updates)
python-defaults (2.6.6-2ubuntu2) maverick-proposed; urgency=low

  * Backport pycompile fixes to allow upgrades to natty. LP: #689615.

  [ Piotr Ożarowski ]
  * pycompile:
    - if installed Python is requested via -V option, use it even if
      it's not in a list of supported Python versions
    - `pycompile $DESTDIR/usr/lib/python*` will recognize public
      site-packages directories and use the right interpreter instead of
      raising KeyError
    - do not try to check if interpreter is present when version range is
      empty (closes: 605356)

  [ Matthias Klose ]
  * pycompile:
    - Don't over-optimize, check the timestamps of byte-code files.
    - Add options -f/--force, -O.
    - Propagate the exit value of the py_compile processes.
    - Update manual page.
  * Bump depends to require the fixed pycompile for dh_python2 based package
    builds.
  * Don't touch the standard python library in rtupdate scripts.
 -- Matthias Klose <email address hidden>   Mon, 13 Dec 2010 12:36:23 +0100

Available diffs

Superseded in natty-release on 2010-12-22
python-defaults (2.7.1-0ubuntu3) natty; urgency=low

  * Ignore errors running the rtupdate install script. Needs
    proper fixes for 11.04.
 -- Matthias Klose <email address hidden>   Mon, 13 Dec 2010 01:41:14 +0100

Available diffs

Superseded in natty-release on 2010-12-13
python-defaults (2.7.1-0ubuntu2) natty; urgency=low

  * Merge changes from 2.6.6-7:

  * pycompile:
    - Don't over-optimize, check the timestamps of byte-code files.
    - Add options -f/--force, -O.
    - Copy stdout/stderr of py_compile processes in case of error.
    - Propagate the exit value of the py_compile processes.
    - Update manual page.
  * Bump depends to require the fixed pycompile for dh_python2 based package
    builds.
  * Don't touch the standard python library in rtupdate scripts.
 -- Matthias Klose <email address hidden>   Mon, 13 Dec 2010 01:05:47 +0100

Available diffs

Superseded in natty-release on 2010-12-13
python-defaults (2.7.1-0ubuntu1) natty; urgency=low

  * Merge from debian unstable.  Remaining changes:
    - Package priorities and status.
    - Python-2.6 is the only supported python2.x version.
    - Adjust version numbers in maintainer scripts.
  * Default to python2.7.
  * python-dev: Provide a python.pc pkgconfig file.

Available diffs

Superseded in natty-release on 2010-12-08
python-defaults (2.6.6-5ubuntu1) natty; urgency=low

  * Merge from debian unstable.  Remaining changes:
    - Package priorities and status.
    - Python-2.6 is the only supported python2.x version.
    - Adjust version numbers in maintainer scripts.

Available diffs

Superseded in natty-release on 2010-10-18
python-defaults (2.6.6-3ubuntu1) natty; urgency=low

  * Merge from debian unstable.  Remaining changes:
    - Package priorities and status.
    - Python-2.6 is the only supported python2.x version.
    - Adjust version numbers in maintainer scripts.

Available diffs

Superseded in natty-release on 2010-10-18
Obsolete in maverick-release on 2013-03-05
python-defaults (2.6.6-2ubuntu1) maverick; urgency=low

  * Merge with Debian; remaining changes:
    - Package priorities and status.
    - Python-2.6 is the only supported python2.x version.
    - Adjust version numbers in maintainer scripts.

Available diffs

Superseded in maverick-release on 2010-09-15
python-defaults (2.6.6-1ubuntu1) maverick; urgency=low

  * Merge from debian unstable.  Remaining changes:
    - Package priorities and status.
    - Python-2.6 is the only supported python2.x version.
    - Adjust version numbers in maintainer scripts.

Superseded in maverick-release on 2010-09-10
python-defaults (2.6.5-13ubuntu1) maverick; urgency=low

  * Merge from debian unstable.  Remaining changes:
    - Package priorities and status.
    - Python-2.6 is the only supported python2.x version.
    - Adjust version numbers in maintainer scripts.

Superseded in maverick-release on 2010-08-24
python-defaults (2.6.5-12ubuntu1) maverick; urgency=low

  * Merge from debian unstable.  Remaining changes:
    - Package priorities and status.
    - Python-2.6 is the only supported python2.x version.
    - Adjust version numbers in maintainer scripts.

Superseded in maverick-release on 2010-08-07
python-defaults (2.6.5-10ubuntu1) maverick; urgency=low

  * Merge from debian unstable.  Remaining changes:
    - Package priorities and status.
    - Python-2.6 is the only supported python2.x version.
    - Adjust version numbers in maintainer scripts.

Superseded in maverick-release on 2010-07-26
python-defaults (2.6.5-9ubuntu1) maverick; urgency=low

  * Merge with Debian; remaining changes:
    - Package priorities and status.
    - Python-2.6 is the only supported python2.x version.
    - Adjust version numbers in maintainer scripts.

Available diffs

Superseded in maverick-release on 2010-07-20
python-defaults (2.6.5-8ubuntu1) maverick; urgency=low

  * Merge with Debian; remaining changes:

Available diffs

Superseded in maverick-release on 2010-07-17
python-defaults (2.6.5-5ubuntu4) maverick; urgency=low

  * Pull updated pycentral upgrade symlink cleaning from Debian bzr
    - Readd fixed autoscripts/preinst-pycentral-clean
    - Call autoscripts/preinst-pycentral-clean from dh_python2
 -- Scott Kitterman <email address hidden>   Fri, 09 Jul 2010 18:14:56 -0400

Available diffs

175 of 128 results