python-defaults 2.7.18-1 source package in Ubuntu

Changelog

python-defaults (2.7.18-1) unstable; urgency=medium

  [ Piotr O┼╝arowski ]
  * Remove deprecated dh_python2. Please add dh-python or
    dh-sequence-python2 to Build-Depends if your package still supports
    Python 2.X.

  [ Matthias Klose ]
  * Correct command-not-found XB-Cnf headers:
    - Drop Extra-Commands headers, not needed
    - Add XB- to ensure Visible-Pkgname actually is included in the binary
      package heders
  * Stop building the python, python-dev, python-dbg, python-doc,
    python-minimal, libpython-dev, libpython-dbg, libpython-stdlib packages.
  * Bump standards version.
  * Bump version to 2.7.18.
  * Bump debhelper version.

 -- Matthias Klose <email address hidden>  Sun, 02 Aug 2020 14:51:22 +0200

Upload details

Uploaded by:
Matthias Klose
Uploaded to:
Sid
Original maintainer:
Matthias Klose
Architectures:
any all
Section:
python
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size SHA-256 Checksum
python-defaults_2.7.18-1.dsc 2.4 KiB 8e9ff850d79501696e0f76b04ab192c61e851c6cf72c9379514c0fc8d8124191
python-defaults_2.7.18-1.tar.gz 43.6 KiB cd68c51c455ceba6d9a1bbd44f1ea991e7d54e5f443ad7d36fe086fbe7cce484

No changes file available.

Binary packages built by this source

libpython-all-dbg: package depending on all supported Python2 debugging packages

 The package currently depends on libpython2.7-dbg, in the
 future, dependencies on jython (Python2 for a JVM) and ironpython (Python2
 for Mono) may be added.
 .
 This package is a dependency package used as a build dependency for other
 packages to avoid hardcoded dependencies on specific Python2 debug packages.

libpython-all-dev: package depending on all supported Python2 development packages

 The package currently depends on libpython2.7-dev, in the
 future, dependencies on jython (Python2 for a JVM) and ironpython (Python2
 for Mono) may be added.
 .
 This package is a dependency package used as a build dependency for other
 packages to avoid hardcoded dependencies on specific Python2 development
 packages.

libpython2-dbg: debug build of the Python2 interpreter (version 2.7)

 Python2 interpreter configured with --pydebug. Dynamically loaded modules
 are searched in /usr/lib/python2.7/lib-dynload/debug first.

libpython2-dev: header files and a static library for Python2

 Header files, a static library and development tools for building
 Python2 modules, extending the Python2 interpreter or embedding Python2
 in applications.
 .
 This package is a dependency package, which depends on Debian's Python2
 version (currently v2.7).

libpython2-stdlib: interactive high-level object-oriented language (Python2)

 Python2, the high-level, interactive object oriented language,
 includes an extensive class library with lots of goodies for
 network programming, system administration, sounds and graphics.
 .
 This package is a dependency package, which depends on Debian's Python2
 version (currently v2.7).

python-all: package depending on all supported Python2 runtime versions

 The package currently depends on python2.7, in the future,
 dependencies on jython (Python2 for a JVM) and ironpython (Python2 for Mono)
 may be added.
 .
 This package is a dependency package used as a build dependency for other
 packages to avoid hardcoded dependencies on specific Python2 runtimes.

python-all-dbg: package depending on all supported Python2 debugging packages

 The package currently depends on python2.7-dbg, in the
 future, dependencies on jython (Python for a JVM) and ironpython (Python2
 for Mono) may be added.
 .
 This package is a dependency package used as a build dependency for other
 packages to avoid hardcoded dependencies on specific Python2 debug packages.

python-all-dev: package depending on all supported Python2 development packages

 The package currently depends on python2.7-dev, in the
 future, dependencies on jython (Python2 for a JVM) and ironpython (Python2
 for Mono) may be added.
 .
 This package is a dependency package used as a build dependency for other
 packages to avoid hardcoded dependencies on specific Python2 development
 packages.

python2: interactive high-level object-oriented language (Python2 version)

 Python2, the high-level, interactive object oriented language,
 includes an extensive class library with lots of goodies for
 network programming, system administration, sounds and graphics.
 .
 This package is a dependency package, which depends on Debian's Python2
 version (currently v2.7).

python2-dbg: debug build of the Python2 interpreter (version 2.7)

 Python2 interpreter configured with --pydebug. Dynamically loaded modules are
 searched in /usr/lib/python2.7/lib-dynload/debug first.

python2-dev: header files and a static library for Python2

 Header files, a static library and development tools for building
 Python2 modules, extending the Python2 interpreter or embedding Python2
 in applications.
 .
 This package is a dependency package, which depends on Debian's Python2
 version (currently v2.7).

python2-doc: documentation for the high-level object-oriented language Python2

 This is the official set of documentation for the interactive high-level
 object-oriented language Python2 (v2.7). All documents are provided
 in HTML format, some in info format. The package consists of nine documents:
 .
   * Tutorial
   * Python Library Reference
   * Macintosh Module Reference
   * Python Language Reference
   * Extending and Embedding Python
   * Python/C API Reference
   * Installing Python Modules
   * Documenting Python
   * Distributing Python Modules
 .
 This package is a dependency package, which depends on Debian's Python2
 version (currently v2.7).

python2-minimal: minimal subset of the Python2 language

 This package contains the interpreter and some essential modules. It's used
 in the boot process for some basic tasks.
 See /usr/share/doc/python2.7-minimal/README.Debian for a list of the modules
 contained in this package.