python-future 0.15.2-4ubuntu1 source package in Ubuntu

Changelog

python-future (0.15.2-4ubuntu1) artful; urgency=medium

  * d/*.postinst: Prefer Python 3 version if both versions installed.

 -- Matthias Klose <email address hidden>  Thu, 27 Jul 2017 14:22:54 +0200

Upload details

Uploaded by:
Matthias Klose
Uploaded to:
Artful
Original maintainer:
Debian Python Modules Team
Architectures:
all
Section:
misc
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Builds

Artful: [FULLYBUILT] amd64

Downloads

File Size SHA-256 Checksum
python-future_0.15.2.orig.tar.gz 1.5 MiB 3d3b193f20ca62ba7d8782589922878820d0a023b885882deec830adbf639b97
python-future_0.15.2-4ubuntu1.debian.tar.xz 10.0 KiB d76c1e28fcd07925b1fdf38065ff526c325d1fbe66a634cc29b7c62d6bbf43c6
python-future_0.15.2-4ubuntu1.dsc 2.4 KiB 3155f48893d5528d415d58d4b57491bcf501460ce1c24e144a2de0383162ffde

View changes file

Binary packages built by this source

python-future: single-source support for Python 3 and 2 - Python 2.x

 Future is the missing compatibility layer between Python 2 and Python 3. It
 allows one to use a single, clean Python 3.x-compatible codebase to support
 both Python 2 and Python 3 with minimal overhead.
 .
 The imports have no effect on Python 3. On Python 2, they shadow the
 corresponding builtins, which normally have different semantics on Python 3
 versus 2, to provide their Python 3 semantics.
 .
 This package contains the Python 2.x module.

python-future-doc: No summary available for python-future-doc in ubuntu artful.

No description available for python-future-doc in ubuntu artful.

python3-future: Clean single-source support for Python 3 and 2 - Python 3.x

 Future is the missing compatibility layer between Python 2 and Python 3. It
 allows one to use a single, clean Python 3.x-compatible codebase to support
 both Python 2 and Python 3 with minimal overhead.
 .
 The imports have no effect on Python 3. On Python 2, they shadow the
 corresponding builtins, which normally have different semantics on Python 3
 versus 2, to provide their Python 3 semantics.
 .
 This package contains the Python 3.x module.