Ubuntu

Change log for “python-httplib2” package in Ubuntu

133 of 33 results
Published in trusty-release on 2014-02-24
Deleted in trusty-proposed (Reason: moved to release)
python-httplib2 (0.8-2build1) trusty; urgency=medium

  * Rebuild to drop files installed into /usr/share/pyshared.
 -- Matthias Klose <email address hidden>   Sun, 23 Feb 2014 13:51:48 +0000

Available diffs

Published in raring-updates on 2013-09-09
Published in raring-security on 2013-09-09
python-httplib2 (0.7.7-1ubuntu0.1) raring-security; urgency=low

  * SECURITY UPDATE: Incorrect SSL certificate checking with multiple
    requests (LP: #1175272)
    - debian/patches/CVE-2013-2037.patch: close connection on cert mismatch
      in python2/httplib2/__init__.py.
    - CVE-2013-2037
 -- Marc Deslauriers <email address hidden>   Fri, 06 Sep 2013 09:54:11 -0400
Published in quantal-updates on 2013-09-09
Published in quantal-security on 2013-09-09
python-httplib2 (0.7.4-2ubuntu0.1) quantal-security; urgency=low

  * SECURITY UPDATE: Incorrect SSL certificate checking with multiple
    requests (LP: #1175272)
    - debian/patches/CVE-2013-2037.patch: close connection on cert mismatch
      in python2/httplib2/__init__.py.
    - CVE-2013-2037
 -- Marc Deslauriers <email address hidden>   Fri, 06 Sep 2013 10:01:59 -0400
Published in precise-updates on 2013-09-09
Published in precise-security on 2013-09-09
python-httplib2 (0.7.2-1ubuntu2.1) precise-security; urgency=low

  * SECURITY UPDATE: Incorrect SSL certificate checking with multiple
    requests (LP: #1175272)
    - debian/patches/CVE-2013-2037.patch: close connection on cert mismatch
      in python2/httplib2/__init__.py.
    - CVE-2013-2037
 -- Marc Deslauriers <email address hidden>   Fri, 06 Sep 2013 10:02:56 -0400
Published in lucid-updates on 2013-09-09
Published in lucid-security on 2013-09-09
python-httplib2 (0.7.2-1ubuntu2~0.10.04.2) lucid-security; urgency=low

  * SECURITY UPDATE: Incorrect SSL certificate checking with multiple
    requests (LP: #1175272)
    - debian/patches/CVE-2013-2037.patch: close connection on cert mismatch
      in python2/httplib2/__init__.py.
    - CVE-2013-2037
 -- Marc Deslauriers <email address hidden>   Fri, 06 Sep 2013 10:03:40 -0400
Superseded in trusty-release on 2014-02-24
Published in saucy-release on 2013-08-19
Deleted in saucy-proposed (Reason: moved to release)
python-httplib2 (0.8-2) unstable; urgency=low


  * Team upload.

  [ Vincent Bernat ]
  * Upload to unstable.
  * Fix CVE-2013-2037 with the appropriate patch. Closes: #706602.

 -- Vincent Bernat <email address hidden>  Fri, 16 Aug 2013 17:53:42 +0200

Available diffs

Superseded in saucy-release on 2013-08-19
Deleted in saucy-proposed on 2013-08-20 (Reason: moved to release)
python-httplib2 (0.8-1) experimental; urgency=low


  * New upstream release.
  * debian/patches/use_system_cacerts.patch:
    - Refresh for new upstream release.

 -- Luca Falavigna <email address hidden>  Mon, 18 Mar 2013 22:41:38 +0100

Available diffs

Superseded in saucy-release on 2013-06-19
Published in raring-release on 2013-01-10
Deleted in raring-proposed (Reason: moved to release)
python-httplib2 (0.7.7-1) experimental; urgency=low


  * New upstream release.
  * debian/patches/use_system_cacerts.patch:
    - Do not ship bundled certificates, package already uses system ones,
      provided by ca-certificates.
  * debian/rules:
    - Remove stale egg-info created during build.

 -- Luca Falavigna <email address hidden>  Sun, 25 Nov 2012 15:24:29 +0100

Available diffs

Superseded in raring-release on 2013-01-10
Published in quantal-release on 2012-05-27
python-httplib2 (0.7.4-2) unstable; urgency=low


  * debian/patches/egg-info.patch:
    - Complete egg-info data with missing details.
  * debian/compat:
    - Bump compatibility level to 9.
  * debian/rules:
    - Delete build directory during clean phase (Closes: #671108).

 -- Luca Falavigna <email address hidden>  Sun, 27 May 2012 12:07:29 +0200

Available diffs

Superseded in quantal-release on 2012-05-27
python-httplib2 (0.7.4-1) unstable; urgency=low


  * New upstream release.
  * debian/patches/use_system_cacerts.patch:
    - Refresh for new upstream release.
  * debian/watch:
    - Use code.google.com to watch for upstream releases.

 -- Luca Falavigna <email address hidden>  Fri, 16 Mar 2012 22:19:04 +0100
Superseded in lucid-updates on 2013-09-09
Superseded in lucid-security on 2013-09-09
Deleted in lucid-proposed on 2013-09-10 (Reason: moved to -updates)
python-httplib2 (0.7.2-1ubuntu2~0.10.04.1) lucid-security; urgency=low

  * SECURITY UPDATE: Incorrect SSL certificate validation (LP: #882030)
    - Backport 0.7.2 as a security update to get proper SSL certificate
      validation support and prevent MITM attacks.
    - debian/control: adjust to work with older dependencies.
    - debian/{control,rules}: get rid of python3 package.
 -- Marc Deslauriers <email address hidden>   Mon, 16 Jan 2012 14:07:20 -0500
Obsolete in maverick-updates on 2013-03-05
Obsolete in maverick-security on 2013-03-05
Deleted in maverick-proposed on 2013-03-05 (Reason: moved to -updates)
python-httplib2 (0.7.2-1ubuntu2~0.10.10.1) maverick-security; urgency=low

  * SECURITY UPDATE: Incorrect SSL certificate validation (LP: #882030)
    - Backport 0.7.2 as a security update to get proper SSL certificate
      validation support and prevent MITM attacks.
    - debian/control: adjust to work with older dependencies.
    - debian/patches/python31-compat.patch: fix compatibility with python3
      version in maverick.
 -- Marc Deslauriers <email address hidden>   Mon, 16 Jan 2012 15:32:42 -0500
Obsolete in natty-updates on 2013-06-04
Obsolete in natty-security on 2013-06-04
Deleted in natty-proposed on 2013-06-04 (Reason: moved to -updates)
python-httplib2 (0.7.2-1ubuntu2~0.11.04.1) natty-security; urgency=low

  * SECURITY UPDATE: Incorrect SSL certificate validation (LP: #882030)
    - Backport 0.7.2 as a security update to get proper SSL certificate
      validation support and prevent MITM attacks.
 -- Marc Deslauriers <email address hidden>   Mon, 16 Jan 2012 13:56:37 -0500
Published in oneiric-updates on 2012-02-27
Published in oneiric-security on 2012-02-27
Deleted in oneiric-proposed (Reason: moved to -updates)
python-httplib2 (0.7.2-1ubuntu2~0.11.10.1) oneiric-security; urgency=low

  * SECURITY UPDATE: Incorrect SSL certificate validation (LP: #882030)
    - Backport 0.7.2 as a security update to get proper SSL certificate
      validation support and prevent MITM attacks.
 -- Marc Deslauriers <email address hidden>   Mon, 16 Jan 2012 13:54:02 -0500
Superseded in quantal-release on 2012-05-24
Published in precise-release on 2011-12-15
python-httplib2 (0.7.2-1ubuntu2) precise; urgency=low

  * debian/patches/use_system_cacerts.patch: Use better patch.
 -- Marc Deslauriers <email address hidden>   Thu, 15 Dec 2011 14:22:29 -0500

Available diffs

Superseded in precise-release on 2011-12-15
python-httplib2 (0.7.2-1ubuntu1) precise; urgency=low

  * debian/patches/use_system_cacerts.patch: Use system ca certificates,
    not the bundled ones (LP: #882027)
 -- Marc Deslauriers <email address hidden>   Wed, 14 Dec 2011 14:28:01 -0500

Available diffs

Superseded in precise-release on 2011-12-14
python-httplib2 (0.7.2-1) unstable; urgency=low

  * New upstream release.
  * debian/patches/ssl-validation.patch:
    - Removed, applied upstream.
  * debian/patches/godaddy-certificate.patch:
    - Removed, applied upstream.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  25 Nov 2011 10:07:07 +0000

Available diffs

Superseded in precise-release on 2011-11-25
python-httplib2 (0.7.1-2) unstable; urgency=low

  * debian/patches/ssl-validation.patch:
    - Cherry-pick patch from upstream hg to fix incorrect checks for
      SSL certificate domain names.
 -- Luca Falavigna <email address hidden>   Mon,  24 Oct 2011 09:45:12 +0000

Available diffs

Superseded in precise-release on 2011-10-24
Published in oneiric-release on 2011-09-12
python-httplib2 (0.7.1-1ubuntu1) oneiric; urgency=low

  * debian/patches/ssl-validation-lp839826.patch:
    - Cherry-pick SSL certificate fix from upstream hg (Closes: #839826).
 -- Roman Yepishev <email address hidden>   Mon, 12 Sep 2011 13:59:31 +0200

Available diffs

Superseded in oneiric-release on 2011-09-12
python-httplib2 (0.7.1-1) unstable; urgency=low

  * New upstream release.
    - Install cacerts.txt file (Closes: #631841).
  * debian/patches/godaddy-certificate.patch:
    - Cherry-pick GoDaddy root certificate from upstream to fix access
      to Launchpad services (Closes: #631164).
 -- St?phane Graber <email address hidden>   Wed,  29 Jun 2011 10:56:36 +0000

Available diffs

Superseded in oneiric-release on 2011-06-29
python-httplib2 (0.7.1-0ubuntu1) oneiric; urgency=low

  * New upstream bugfix release (0.7.1)
    - Add missing cacerts.txt (LP: #802608)
  * Add debian/patches/godaddy-certificate to cherry-pick the
    GoDaddy root certificate from upstream hg
 -- Stephane Graber <email address hidden>   Mon, 27 Jun 2011 17:45:05 +0100

Available diffs

Superseded in oneiric-release on 2011-06-27
python-httplib2 (0.7.0-1) unstable; urgency=low

  * New upstream release.
    - Do not hardcode $Rev$ in the User-Agent field (Closes: #609576).
  * debian/copyright:
    - Update copyright information.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Tue,  14 Jun 2011 10:04:29 +0000

Available diffs

Superseded in oneiric-release on 2011-06-14
python-httplib2 (0.6.0-5) unstable; urgency=low

  * Python transition:
    - Add support for python2.7
    - Drop support for python2.5
  * debian/control:
    - Bump Standards-Version to 3.9.2, no changes required.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Sat,  30 Apr 2011 13:35:13 +0000

Available diffs

Superseded in oneiric-release on 2011-04-30
Obsolete in natty-release on 2013-06-04
python-httplib2 (0.6.0-4build1) natty; urgency=low

  * No-change rebuild to add support for Python 2.7.
 -- Martin Pitt <email address hidden>   Wed, 08 Dec 2010 15:22:49 +0100

Available diffs

Superseded in natty-release on 2010-12-08
python-httplib2 (0.6.0-4) unstable; urgency=low

  * Team upload.

  [ Luca Falavigna ]
  * debian/control:
    - Add Breaks: ${python:Breaks} to generate correct dependencies, this
      also makes lintian override useless now.

  [ Piotr Ożarowski ]
  * Bump minimum required python3-all version to 3.1.2-10
    (and rebuild for /usr/lib/python3/dist-packages transtion)
 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  15 Oct 2010 09:56:21 +0000

Available diffs

Superseded in natty-release on 2010-10-15
Obsolete in maverick-release on 2013-03-05
python-httplib2 (0.6.0-3build1) maverick; urgency=low

  * Rebuild for changed python3 site directory.
 -- Matthias Klose <email address hidden>   Fri, 17 Sep 2010 13:56:12 +0200

Available diffs

Superseded in maverick-release on 2010-09-17
python-httplib2 (0.6.0-3) unstable; urgency=medium

  * debian/control:
    - Depend on ${python3:Depends} for python3-httplib2 to generate
      correct dependencies for Python 3.X (Closes: #591956).
    - Bump Standards-Version to 3.9.1, no changes required.
  * debian/python-httplib2.lintian-overrides:
    - Override old-versioned-python-dependency, needs fixing in Lintian.
 -- Michael Bienia <email address hidden>   Sat, 07 Aug 2010 15:39:46 +0200

Available diffs

Superseded in maverick-release on 2010-08-08
python-httplib2 (0.6.0-2) unstable; urgency=low

  * Switch to format 3.0 (quilt).
  * Switch to dh_python2.
  * debian/control:
    - Add python3-httplib2 package.
    - Bump Standards-Version to 3.8.4, no changes required.
  * debian/rules:
    - Install files for python3-httplib2 package.
  * debian/watch: 
    - Use googlecode.debian.net provider.
 -- Michael Bienia <email address hidden>   Tue,  13 Jul 2010 18:55:23 +0100

Available diffs

Superseded in maverick-release on 2010-07-13
Published in lucid-release on 2010-01-18
python-httplib2 (0.6.0-1) unstable; urgency=low

  * New upstream release.
  * Add new copyright holders.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  18 Jan 2010 07:33:09 +0000

Available diffs

Superseded in lucid-release on 2010-01-18
python-httplib2 (0.5.0-1) unstable; urgency=low

  * New upstream release (Closes: #461200) (LP: #373589).
  * debian/compat:
    - Bump compat level to 7.
  * debian/control:
    - New Maintainer (Closes: #542786).
    - Add Debian Python Modules Team to Uploaders.
    - Switch to python section to match override.
    - Remove cdbs from Build-Depends.
    - Bump debhelper required version to 7.2.18.
    - Do not build-depend on python-all-dev, depend on python instead.
    - Move python-support to Build-Depends-Indep.
    - Bump Standards-Version to 3.8.3.
    - Add Homepage field.
    - Add XS-Python-Version field.
    - Add Vcs-* fields to store Debian packaging.
    - Set Architecture to all.
    - Remove ${shlibs:Depends} from Depends.
    - Fix spelling errors in package description.
  * debian/copyright:
    - Adjust copyright informations.
  * debian/README.Debian:
    - Removed, already provided by upstream README.
  * debian/pycompat:
    - Removed, useless.
  * debian/rules:
    - Switch to debhelper 7.
  * debian/watch:
    - Provide a watch file.
 -- Luca Falavigna <email address hidden>   Wed,  11 Nov 2009 13:01:13 +0000

Available diffs

Superseded in lucid-release on 2009-11-11
Obsolete in karmic-release on 2013-03-04
Superseded in karmic-release on 2009-05-04
Obsolete in jaunty-release on 2013-02-28
python-httplib2 (0.4.0-0ubuntu2) jaunty; urgency=low

  * httplib2/__init__.py: apply upstream patch to fix a deprecation
    warning and a timeout error with Python 2.6. Upstream commit is here:
    http://code.google.com/p/httplib2/source/detail?r=275 (LP: #336067).

 -- Luca Falavigna <email address hidden>   Mon, 02 Mar 2009 23:39:02 +0100

Available diffs

Superseded in jaunty-release on 2009-03-03
Obsolete in intrepid-release on 2013-02-20
python-httplib2 (0.4.0-0ubuntu1) intrepid; urgency=low

  * New upstream release (LP: #239734)

 -- James Westby <email address hidden>   Sun, 31 Aug 2008 19:21:47 +0100

Available diffs

Superseded in intrepid-release on 2008-09-26
Published in hardy-release on 2007-10-18
Obsolete in gutsy-release on 2011-09-16
Obsolete in feisty-release on 2009-08-20
python-httplib2 (0.2.0-2) unstable; urgency=low

  * reformat description closes: #392116
  * add missing-build-dependency python-all-dev

133 of 33 results