Change log for python-latexcodec package in Ubuntu

15 of 5 results
Published in eoan-release on 2019-04-18
Published in disco-release on 2018-10-30
Published in cosmic-release on 2018-05-01
Published in bionic-release on 2017-10-24
Published in artful-release on 2017-07-14
Deleted in artful-proposed (Reason: moved to release)
python-latexcodec (1.0.5-1) unstable; urgency=medium

  * Source tarballs from PyPI
  * Switch from git-dpm to gbp
  * New upstream version 1.0.5
  * Drop the patch queue, no longer required
  * Use secure URI in copyright Format
  * Update Source field to the PyPI URI
  * Downgrade install of -doc package to Suggests
  * Drop Recommends of -doc package
  * Add missing Built-Using metadata
  * Build the docs using the upstream Makefile
  * Build the documentation with Python 3
    - Use the Python 3 version of Sphinx
    - New patch Fix-build-of-docs-with-Python-3.patch
  * Add support for the nodoc build profile
  * Add support for the nocheck build profile
  * Drop superfluous installchangelogs override
  * Bump debhelper version to 10, no changes required
  * Bump standards version to 4.0.0, no changes required
  * Improve the autopkgtest suite
    - Replace individual test scripts by Test-Commands
    - Run tests outside the source tree
    - Run tests for all supported Python versions
  * Adopt the package
    - Add myself to Uploaders
    - Add myself to copyright
    - Remove Daniel Stender from Uploaders (Closes: #840034)

 -- Ghislain Antony Vaillant <email address hidden>  Thu, 13 Jul 2017 16:23:07 +0100

Available diffs

Superseded in artful-release on 2017-07-14
Obsolete in zesty-release on 2018-06-22
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed on 2018-06-22 (Reason: moved to release)
python-latexcodec (1.0.3-4) unstable; urgency=medium

  * deb/rules: set discarded http_proxy for sphinx-build (Closes: #830604).

 -- Daniel Stender <email address hidden>  Sat, 06 Aug 2016 11:12:19 +0200

Available diffs

Superseded in yakkety-release on 2016-08-08
Deleted in yakkety-proposed on 2016-08-09 (Reason: moved to release)
python-latexcodec (1.0.3-3) unstable; urgency=medium

  * deb/rules: added -f- to date for reproducible builds (Closes: #824454).

 -- Daniel Stender <email address hidden>  Sun, 29 May 2016 18:23:46 +0200

Available diffs

Superseded in yakkety-release on 2016-05-30
Deleted in yakkety-proposed on 2016-05-31 (Reason: moved to release)
python-latexcodec (1.0.3-2) unstable; urgency=medium

  * deb/control: corrected X-Python3-version.
  * build docs package:
    + added package description in deb/control.
    + added Recommends to module package description in deb/control,
      removed sphinxdoc:Depends.
    + build HTML documentation into docs package in deb/rules.
    + contribute CHANGELOG into both packages in deb/rules.
    + renamed deb/python3-latexcodec.doc-base accordingly, updated
      paths and Document field.
  * build Python2 package:
    + added package description in deb/control.
    + added Python2 package counterparts to build-deps in deb/control.
    + added X-Python-Version in deb/control.
    + added dh_python2 to Debhelper addons to use in deb/rules.
    + extended DEP-8 tests.

 -- Daniel Stender <email address hidden>  Tue, 10 May 2016 16:11:44 +0200

Available diffs

Superseded in yakkety-release on 2016-05-12
Deleted in yakkety-proposed on 2016-05-13 (Reason: moved to release)
python-latexcodec (1.0.3-1) unstable; urgency=medium

  * Initial release (Closes: #801309).

 -- Daniel Stender <email address hidden>  Mon, 09 May 2016 14:25:08 +0200
15 of 5 results