Change log for python-libdiscid package in Ubuntu

119 of 19 results
Published in eoan-release on 2019-07-16
Deleted in eoan-proposed (Reason: moved to release)
python-libdiscid (1.0-5) unstable; urgency=medium

  [ Dmitry Shachnev ]
  * Remove the python2-all autopkgtest as the Python 2 package was dropped.

 -- Sebastian Ramacher <email address hidden>  Mon, 15 Jul 2019 19:53:59 +0200

Available diffs

Superseded in eoan-release on 2019-07-16
Deleted in eoan-proposed on 2019-07-17 (Reason: moved to release)
python-libdiscid (1.0-4) unstable; urgency=medium

  * debian/:
    - Bump debhelper compat to 12.
    - Drop Python 2 support.
    - Update upstream signing key.
  * debian/control: Bump Standards-Version.

 -- Sebastian Ramacher <email address hidden>  Wed, 10 Jul 2019 22:22:04 +0200

Available diffs

Superseded in eoan-release on 2019-07-12
Published in disco-release on 2018-11-07
Deleted in disco-proposed (Reason: moved to release)
python-libdiscid (1.0-3build2) disco; urgency=medium

  * No-change rebuild to build without python3.6 support.

 -- Matthias Klose <email address hidden>  Sat, 03 Nov 2018 12:09:14 +0000

Available diffs

Superseded in disco-release on 2018-11-07
Published in cosmic-release on 2018-06-29
Deleted in cosmic-proposed (Reason: moved to release)
python-libdiscid (1.0-3build1) cosmic; urgency=medium

  * No-change rebuild to build for python3.7.

 -- Matthias Klose <email address hidden>  Thu, 28 Jun 2018 12:36:53 +0000

Available diffs

Superseded in cosmic-release on 2018-06-29
Deleted in cosmic-proposed on 2018-06-30 (Reason: moved to release)
python-libdiscid (1.0-3) unstable; urgency=medium

  [ Ondřej Nový ]
  * d/tests: Use AUTOPKGTEST_TMP instead of ADTTMP

 -- Sebastian Ramacher <email address hidden>  Mon, 21 May 2018 16:06:02 +0200

Available diffs

Superseded in cosmic-release on 2018-05-22
Published in bionic-release on 2017-10-24
Published in artful-release on 2017-09-06
Deleted in artful-proposed (Reason: moved to release)
python-libdiscid (1.0-1build3) artful; urgency=medium

  * No-change rebuild to drop _PyFPE support.

 -- Matthias Klose <email address hidden>  Tue, 05 Sep 2017 08:23:07 +0000

Available diffs

Superseded in artful-release on 2017-09-06
Deleted in artful-proposed on 2017-09-07 (Reason: moved to release)
python-libdiscid (1.0-1build2) artful; urgency=medium

  * No-change rebuild to build to drop python3.5.

 -- Matthias Klose <email address hidden>  Sat, 05 Aug 2017 16:27:41 +0000

Available diffs

Superseded in artful-release on 2017-08-06
Deleted in artful-proposed on 2017-08-08 (Reason: moved to release)
python-libdiscid (1.0-1build1) artful; urgency=medium

  * Rebuild for python 3.6 support.

 -- Bhavani Shankar <email address hidden>  Fri, 12 May 2017 21:58:18 +0530

Available diffs

Superseded in artful-release on 2017-05-12
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed on 2018-06-22 (Reason: moved to release)
python-libdiscid (1.0-1) unstable; urgency=medium

  * New upstream release.
  * debian/control:
    - Bump Standards-Version.
    - Add Built-Using for sphinx.
    - Update Vcs-*.
    - Add python{,3}-pkgconfig to Build-Depends.
    - Update supported Python versions.
    - Remove obsolete versions in Build-Depends. They are all available in
      stable.
  * debian/{control,compat}: Bump debhelper compat to 10.
  * debian/rules: Drop dh_strip overrides to use -dbgsym package.

 -- Sebastian Ramacher <email address hidden>  Thu, 29 Dec 2016 13:34:28 +0100
Superseded in zesty-release on 2016-12-29
Obsolete in yakkety-release on 2018-01-23
Published in xenial-release on 2016-01-19
Deleted in xenial-proposed (Reason: moved to release)
python-libdiscid (0.4.1-5build1) xenial; urgency=medium

  * No-change rebuild to drop python3.4 support.

 -- Matthias Klose <email address hidden>  Tue, 19 Jan 2016 11:45:46 +0000
Superseded in xenial-release on 2016-01-19
Deleted in xenial-proposed on 2016-01-20 (Reason: moved to release)
python-libdiscid (0.4.1-5) unstable; urgency=medium

  * debian/rules: No longer remove SOURCES.txt by hand (Closes: #805686)

 -- Sebastian Ramacher <email address hidden>  Sun, 22 Nov 2015 21:49:39 +0100

Available diffs

Superseded in xenial-release on 2015-11-23
Deleted in xenial-proposed on 2015-11-24 (Reason: moved to release)
python-libdiscid (0.4.1-4) unstable; urgency=medium

  * debian/patches/cython-0.23-compat.patch: Apply upstream patch to fix
    compat issues with Cython 0.23. (Closes: #799839)

 -- Sebastian Ramacher <email address hidden>  Wed, 23 Sep 2015 19:24:08 +0200

Available diffs

Superseded in xenial-release on 2015-10-27
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed on 2018-01-22 (Reason: moved to release)
python-libdiscid (0.4.1-3) unstable; urgency=medium

  * debian/control:
    - Move to Debian Multimedia team.
    - Bump Standards-Version to 3.9.6.
    - Remove XS-Autotest header. It is now inserted automatically.
  * debian/watch: Use pypi.debian.net redirector.

 -- Sebastian Ramacher <email address hidden>  Thu, 20 Aug 2015 12:16:21 +0200
Superseded in wily-release on 2015-08-20
Deleted in wily-proposed on 2015-08-22 (Reason: moved to release)
python-libdiscid (0.4.1-2build1) wily; urgency=medium

  * No-change rebuild for python3.5 transition

 -- Steve Langasek <email address hidden>  Sat, 25 Jul 2015 10:34:36 +0000
Superseded in wily-release on 2015-07-25
Obsolete in vivid-release on 2018-01-18
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed on 2018-01-19 (Reason: moved to release)
python-libdiscid (0.4.1-2) unstable; urgency=medium


  * Privide DEP-8 tests:
    - debian/tests: Add DEP-8 tests for both the Python 2 and Python 3 packages.
    - debian/patches/tests-relative-imports.patch: Use relative imports to
      make the test suite work with DEP-8 tests.
  * debian/control: Change libdisci0-dev to libdiscid-dev in Build-Depends.

 -- Sebastian Ramacher <email address hidden>  Thu, 03 Jul 2014 20:38:30 +0200
Superseded in utopic-release on 2014-07-04
Published in trusty-release on 2014-04-01
Deleted in trusty-proposed (Reason: moved to release)
python-libdiscid (0.4.1-1build1) trusty; urgency=medium

  * No change rebuild to drop python3.3 compiled extension.
 -- Dimitri John Ledkov <email address hidden>   Tue, 01 Apr 2014 14:42:39 +0100
Superseded in trusty-release on 2014-04-01
Deleted in trusty-proposed on 2014-04-02 (Reason: moved to release)
python-libdiscid (0.4.1-1) unstable; urgency=low


  * New upstream version.
  * debian/{watch,upstream-signing-key.pgp}: Add pgpsigurlmangle and
    upstream's key.
  * debian/control: Bump Standards-Version to 3.9.5.
  * debian/copyright: Update copyright years.

 -- Sebastian Ramacher <email address hidden>  Sat, 04 Jan 2014 01:19:39 +0100

Available diffs

Superseded in trusty-release on 2014-01-04
Deleted in trusty-proposed on 2014-01-05 (Reason: moved to release)
python-libdiscid (0.4-1) unstable; urgency=low


  * New upstream version.
  * debian/patches:
    - skip-read-tests-if-not-available.patch: Removed, no longer needed.
    - sphinx-documentation.patch: Refreshed.
  * debian/control: Bump libdiscid0-dev to >= 0.6 for new features.
  * debian/{rules,python-libdiscid-doc.docs}: Update for new path of the
    documentation.

 -- Sebastian Ramacher <email address hidden>  Thu, 03 Oct 2013 17:32:00 +0200

Available diffs

Superseded in trusty-release on 2013-10-24
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed on 2015-04-28 (Reason: moved to release)
python-libdiscid (0.3-1) unstable; urgency=low


  * Initial release. (Closes: #714950)

 -- Sebastian Ramacher <email address hidden>  Fri, 05 Jul 2013 00:43:36 +0200
119 of 19 results