python-numpy 1:1.12.1-3.1ubuntu1 source package in Ubuntu

Changelog

python-numpy (1:1.12.1-3.1ubuntu1) artful; urgency=medium

  * Merge with Debian unstable, remaining changes:
    - debian/patches/20_disable-plot-extension.patch
       Disable plot_directive extension, and catch ImportErrors when
       matplotlib cannot be imported, which allows us to remove
       python-matplotlib from dependencies.  This is required because
       python-numpy is in main, while python-matplotlib is in universe.
    - Run the distutils autopkg test with allow-stderr restrictions.
    - Add build-essential to the python2 and python3 autopkg tests; tests
      trying to run a compiler.

python-numpy (1:1.12.1-3.1) unstable; urgency=medium

  * Non-maintainer upload.
  * "No-change" upload to rebuild with pythonX.Y not using the _fpectl module.
  * Tighten the build dependencies for the pythonX.Y packages (can be dropped
    again once the pythonX.Y packages are available everywhere).

 -- Matthias Klose <email address hidden>  Fri, 01 Sep 2017 07:43:05 +0200

Upload details

Uploaded by:
Matthias Klose on 2017-09-01
Uploaded to:
Artful
Original maintainer:
Ubuntu Developers
Architectures:
any all
Section:
python
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size SHA-256 Checksum
python-numpy_1.12.1.orig.tar.gz 4.1 MiB c13f5cab98eb75545b211d738588d297d8219deced16bc61593e4e89098a913f
python-numpy_1.12.1-3.1ubuntu1.debian.tar.xz 141.3 KiB 84c0e0b53b77f5ebb180a5586f14f400bd405bf49ca87e94e56a388bca4728ef
python-numpy_1.12.1-3.1ubuntu1.dsc 2.9 KiB 39906fb98379ffcb340d51e0ac78cc06e621aaef16f0b025e44f8614d38362a2

View changes file

Binary packages built by this source

python-numpy: Numerical Python adds a fast array facility to the Python language

 Numpy contains a powerful N-dimensional array object, sophisticated
 (broadcasting) functions, tools for integrating C/C++ and Fortran
 code, and useful linear algebra, Fourier transform, and random number
 capabilities.
 .
 Numpy replaces the python-numeric and python-numarray modules which are
 now deprecated and shouldn't be used except to support older
 software.

python-numpy-dbg: Fast array facility to the Python language (debug extension)

 Numpy contains a powerful N-dimensional array object, sophisticated
 (broadcasting) functions, tools for integrating C/C++ and Fortran
 code, and useful linear algebra, Fourier transform, and random number
 capabilities.
 .
 Numpy replaces the python-numeric and python-numarray modules which
 are now deprecated and shouldn't be used except to support older
 software.
 .
 This package contains the extension built for the Python debug interpreter.

python-numpy-doc: NumPy documentation

 Numpy contains a powerful N-dimensional array object, sophisticated
 (broadcasting) functions, tools for integrating C/C++ and Fortran
 code, and useful linear algebra, Fourier transform, and random number
 capabilities.
 .
 Numpy replaces the python-numeric and python-numarray modules which
 are now deprecated and shouldn't be used except to support older
 software.
 .
 This package contains documentation for Numpy and f2py.

python3-numpy: Fast array facility to the Python 3 language

 Numpy contains a powerful N-dimensional array object, sophisticated
 (broadcasting) functions, tools for integrating C/C++ and Fortran
 code, and useful linear algebra, Fourier transform, and random number
 capabilities.
 .
 Numpy replaces the python-numeric and python-numarray modules which are
 now deprecated and shouldn't be used except to support older
 software.
 .
 This package contains Numpy for Python 3.

python3-numpy-dbg: Fast array facility to the Python 3 language (debug extension)

 Numpy contains a powerful N-dimensional array object, sophisticated
 (broadcasting) functions, tools for integrating C/C++ and Fortran
 code, and useful linear algebra, Fourier transform, and random number
 capabilities.
 .
 Numpy replaces the python-numeric and python-numarray modules which
 are now deprecated and shouldn't be used except to support older
 software.
 .
 This package contains the extension built for the Python 3 debug interpreter.