Change log for python-rsa package in Ubuntu

110 of 10 results
Published in hirsute-release on 2020-10-23
Published in groovy-release on 2020-04-30
Deleted in groovy-proposed (Reason: moved to Release)
python-rsa (4.0-4) unstable; urgency=medium

  [ Debian Janitor ]
  * Bump debhelper from old 9 to 12.
  * Set upstream metadata fields: Bug-Database, Bug-Submit, Repository,
    Repository-Browse.

  [ TANIGUCHI Takaki ]
  * add CI config
  * add manpages (Closes: #926691)

 -- TANIGUCHI Takaki <email address hidden>  Sat, 25 Apr 2020 12:48:56 +0900

Available diffs

Superseded in groovy-release on 2020-04-30
Published in focal-release on 2019-10-27
Deleted in focal-proposed (Reason: moved to Release)
python-rsa (4.0-3) unstable; urgency=medium

  [ Ondřej Nový ]
  * Use debhelper-compat instead of debian/compat.

  [ Sandro Tosi ]
  * Drop python2 support; Closes: #938148

 -- Sandro Tosi <email address hidden>  Thu, 10 Oct 2019 11:36:34 -0400

Available diffs

Superseded in focal-release on 2019-10-27
Obsolete in eoan-release on 2020-12-29
Obsolete in disco-release on 2020-07-14
Deleted in disco-proposed on 2020-12-29 (Reason: moved to release)
python-rsa (4.0-2) unstable; urgency=medium

  [ Julian Andres Klode ]
  * Add missing build-depends on mock module (Closes: #914339)

 -- TANIGUCHI Takaki <email address hidden>  Tue, 04 Dec 2018 15:46:41 +0900

Available diffs

Superseded in disco-proposed on 2018-12-04
python-rsa (4.0-1) unstable; urgency=medium

  [ Ondřej Nový ]
  * d/control: Set Vcs-* to salsa.debian.org
  * d/copyright: Use https protocol in Format field
  * d/watch: Use https protocol
  * d/rules: Remove trailing whitespaces
  * Convert git repository from git-dpm to gbp layout

  [ Piotr Ożarowski ]
  * Add dh-python to Build-Depends

  [ TANIGUCHI Takaki ]
  * New upstream version 4.0
  * Bump Stanrads-Version to 4.2.1

 -- TANIGUCHI Takaki <email address hidden>  Thu, 04 Oct 2018 14:19:18 +0900
Published in trusty-updates on 2018-05-16
Published in trusty-security on 2018-05-16
python-rsa (3.1.2-1ubuntu0.1) trusty-security; urgency=medium

  * SECURITY UPDATE: BERserk attack vulnerability
    - debian/patches/CVE-2016-1494.patch: fix in verify()
      from parsing to comparison in rsa/pkcs1.py.
    - CVE-2016-1494

 -- <email address hidden> (Leonidas S. Barbosa)  Wed, 16 May 2018 14:18:55 -0300
Superseded in disco-release on 2018-12-04
Obsolete in cosmic-release on 2020-07-13
Published in bionic-release on 2017-10-24
Obsolete in artful-release on 2020-07-10
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed (Reason: moved to release)
python-rsa (3.4.2-1) unstable; urgency=medium

  [ Ondřej Nový ]
  * Fixed VCS URL (https)

  [ TANIGUCHI Takaki ]
  * Use pypi.debian.net
  * New upstream version 3.4.2
  * Bump Standard Version.
  * debian/patches: No need.
  * debian/docs: No need.

 -- TANIGUCHI Takaki <email address hidden>  Tue, 11 Oct 2016 13:53:30 +0900

Available diffs

Superseded in zesty-release on 2016-11-02
Obsolete in yakkety-release on 2018-01-23
Published in xenial-release on 2016-02-17
Deleted in xenial-proposed (Reason: moved to release)
python-rsa (3.2.3-1.1) unstable; urgency=medium

  * Non-maintainer upload.
  * CVE-2016-1494: Possible signature forgery using Bleichenbacher'06 attack
    (Closes: #809980)

 -- Salvatore Bonaccorso <email address hidden>  Sun, 07 Feb 2016 07:29:08 +0100

Available diffs

Superseded in xenial-release on 2016-02-17
Deleted in xenial-proposed on 2016-02-19 (Reason: moved to release)
python-rsa (3.2.3-1) unstable; urgency=medium

  [ Dariusz Dwornikowski ]
  * Added python modules to Build-Depends (Closes: #804430)
    - python-unittest2, python3-unittest2
    - python-asn1, python3-asn1
  * Added d/patches/fix_tests.patch fixing imports in tests

  [ TANIGUCHI Takaki ]
  * new upstream version
  * debian/control: python3 modules depends on ${python3:Depends}.
    (Closes: #757827)

 -- TANIGUCHI Takaki <email address hidden>  Wed, 25 Nov 2015 01:10:04 +0900

Available diffs

Superseded in xenial-release on 2015-11-25
Obsolete in wily-release on 2018-01-22
Obsolete in vivid-release on 2018-01-18
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed on 2018-01-22 (Reason: moved to release)
python-rsa (3.1.4-1) unstable; urgency=medium


  * New upstream release

 -- TANIGUCHI Takaki <email address hidden>  Sun, 22 Jun 2014 17:21:45 +0900

Available diffs

Superseded in utopic-release on 2014-06-22
Published in trusty-release on 2014-01-05
Deleted in trusty-proposed (Reason: moved to release)
python-rsa (3.1.2-1) unstable; urgency=low


  * Initial release (Closes: #733216)

 -- TANIGUCHI Takaki <email address hidden>  Fri, 27 Dec 2013 16:47:49 +0900
110 of 10 results