python-rtslib-fb 2.1.73-1ubuntu3 source package in Ubuntu

Changelog

python-rtslib-fb (2.1.73-1ubuntu3) groovy; urgency=medium

  * SECURITY UPDATE: insecure saveconfig.json permissions
    - debian/patches/CVE-2020-14019.patch: keep proper umask when calling
      shutil.copy() in rtslib/root.py.
    - CVE-2020-14019

 -- Marc Deslauriers <email address hidden>  Tue, 18 Aug 2020 10:25:05 -0400

Upload details

Uploaded by:
Marc Deslauriers
Uploaded to:
Groovy
Original maintainer:
Ubuntu Developers
Architectures:
all
Section:
misc
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Builds

Groovy: [FULLYBUILT] amd64

Downloads

File Size SHA-256 Checksum
python-rtslib-fb_2.1.73.orig.tar.gz 48.4 KiB fc4e7f9d4d3558965f1556b8909cd79741bfc412d821b8c4dcdbc7c1b2c6b698
python-rtslib-fb_2.1.73-1ubuntu3.debian.tar.xz 7.2 KiB 99d2a79b5618b979061132c67d3783a1e43f7cf5727570b9b821eda4fee757ba
python-rtslib-fb_2.1.73-1ubuntu3.dsc 2.2 KiB 81fb55721f33aeec72549628f32c60c08b842d90ffed67172d434c27cd327467

View changes file

Binary packages built by this source

python3-rtslib-fb: object API for managing the Linux LIO kernel target - Python 3.x

 The rtslib-fb package is an object-based Python library for configuring the
 LIO generic SCSI target, present in 3.x Linux kernel versions.
 .
 The rtslib-fb package is a fork of the "rtslib" code written by RisingTide
 Systems. The "-fb" differentiates between the original and this version.
 Ensure to use either all "fb" versions of the targetcli components --
 targetcli, rtslib, and configshell, or stick with all non-fb versions,
 since they are no longer strictly compatible.
 .
 This package contains the Python 3.x module.