Change log for python-xarray package in Ubuntu

142 of 42 results
Published in groovy-release on 2020-07-17
Deleted in groovy-proposed (Reason: moved to Release)
python-xarray (0.16.0-1) unstable; urgency=medium

  * New upstream release

 -- Alastair McKinstry <email address hidden>  Thu, 16 Jul 2020 11:17:10 +0100

Available diffs

Superseded in groovy-release on 2020-07-17
Deleted in groovy-proposed on 2020-07-18 (Reason: moved to Release)
python-xarray (0.15.1-4) unstable; urgency=medium

  * silence-warnings.patch: Don't fail tests on warnings, only errors.
    Closes: #963820  
  * Drop merged/obsolete patches:
    - 3430.diff
    - 3431.diff
    - NaT.patch
    - xfail-rasterio.patch

 -- Alastair McKinstry <email address hidden>  Sat, 04 Jul 2020 13:43:18 +0100

Available diffs

Superseded in groovy-release on 2020-07-05
Deleted in groovy-proposed on 2020-07-06 (Reason: moved to Release)
python-xarray (0.15.1-3) unstable; urgency=medium

  * patch: Use sparse.COO or scipy.sparse.coo_matrix for sparse
    matrices, not sparse.SparseArray, which doesn't exist.
    Closes: #960380.

 -- Alastair McKinstry <email address hidden>  Tue, 12 May 2020 17:04:22 +0100

Available diffs

Superseded in groovy-release on 2020-05-14
Deleted in groovy-proposed on 2020-05-15 (Reason: moved to Release)
python-xarray (0.15.1-2) unstable; urgency=medium

  * Drop obsolete sphinx3-build hack which breaks on sphinx 2.4 ;
    Closes: #959595

 -- Alastair McKinstry <email address hidden>  Mon, 04 May 2020 12:05:55 +0100
Superseded in groovy-release on 2020-05-04
Deleted in groovy-proposed on 2020-05-06 (Reason: moved to Release)
python-xarray (0.15.1-1ubuntu1) groovy; urgency=medium

  * Merge from Debian unstable, remaining changes:
    + Allow output to stderr in autopkgtest

Superseded in groovy-proposed on 2020-04-27
python-xarray (0.15.1-1) unstable; urgency=medium

  * New upstream release 
  * Use dh-sequence-* rather than --with *

 -- Alastair McKinstry <email address hidden>  Fri, 27 Mar 2020 10:56:52 +0000
Superseded in groovy-release on 2020-05-02
Published in focal-release on 2020-03-15
Deleted in focal-proposed (Reason: moved to Release)
python-xarray (0.15.0-3ubuntu1) focal; urgency=medium

  * Merge from Debian unstable, remaining changes:
    + Allow output to stderr in autopkgtest
    + Let test_repr_of_dataset pass on big-endian systems

Superseded in focal-proposed on 2020-03-15
python-xarray (0.15.0-3) unstable; urgency=medium

  * Drop obsolete patches from d/patches
  * Mark download tests xfail. Closes: #935455
  * Switch to python3-pip. 
  * pip3.patch: use pip3 instead of pip. Closes: #943226

 -- Alastair McKinstry <email address hidden>  Wed, 11 Mar 2020 10:14:52 +0000
Superseded in focal-release on 2020-03-15
Deleted in focal-proposed on 2020-03-16 (Reason: moved to Release)
python-xarray (0.15.0-2ubuntu2) focal; urgency=medium

  * Let test_repr_of_dataset pass on big-endian systems

 -- Graham Inggs <email address hidden>  Mon, 17 Feb 2020 13:45:20 +0000
Superseded in focal-proposed on 2020-02-17
python-xarray (0.15.0-2ubuntu1) focal; urgency=low

  * Merge from Debian unstable.  Remaining changes:
    - Allow output to stderr in autopkgtest

 -- Gianfranco Costamagna <email address hidden>  Fri, 14 Feb 2020 12:32:35 +0100
Superseded in focal-proposed on 2020-02-14
python-xarray (0.15.0-2) unstable; urgency=medium

  * Build-Depend on python3-h5netcdf , python3-zarr, python3-pandas,
    ipython3, python3-jupyter-console, python3-jupyter-core,
    python3-jupyter-client. Closes: #950828
  * Change setup.py to find, include all subpackages. Closes: #950743 
  * Standards-Version: 4.5.0
  * Update no-installer patch to set nbsphinx_allow_errors = True

 -- Alastair McKinstry <email address hidden>  Thu, 06 Feb 2020 12:54:43 +0000
Superseded in focal-release on 2020-03-02
Deleted in focal-proposed on 2020-03-04 (Reason: moved to Release)
python-xarray (0.14.0-2ubuntu1) focal; urgency=medium

  * Allow output to stderr in autopkgtest

 -- Graham Inggs <email address hidden>  Thu, 21 Nov 2019 20:04:58 +0000
Superseded in focal-proposed on 2019-11-21
python-xarray (0.14.0-2) unstable; urgency=medium

  [ Matthias Klose ] 
  * Fix test failures with new cftime 1.0.4, taken from upstream.
  * _get_scheduler() exception if dask.multiprocessing missing, taken
    from upstream.

  [ Alastair McKinstry ]
  * xfail-dask.patch: Dask version in Debian is < 2.
    Label some functionality XFAIL, set dask='allowed' rather than
    'parallelize' where possible for the rest
  * xfail-rasterio.patch: Disable tests due to issue in rasterio:
    "WarpedVRT does not permit boundless reads".
    Closes: #944044

 -- Alastair McKinstry <email address hidden>  Sun, 17 Nov 2019 18:32:58 +0000
Superseded in focal-release on 2019-11-22
Deleted in focal-proposed on 2019-11-23 (Reason: moved to Release)
python-xarray (0.12.3-1ubuntu2) focal; urgency=medium

  * Refresh ARM_xfail_tests.patch

 -- Graham Inggs <email address hidden>  Tue, 12 Nov 2019 12:34:11 +0000
Superseded in focal-proposed on 2019-11-12
python-xarray (0.12.3-1ubuntu1) focal; urgency=medium

  * Backport the cftime fix.

Superseded in focal-release on 2019-11-12
Deleted in focal-proposed on 2019-11-14 (Reason: moved to Release)
python-xarray (0.12.1-1ubuntu2) focal; urgency=medium

  * Backport the cftime fix.

 -- Matthias Klose <email address hidden>  Wed, 06 Nov 2019 12:38:19 +0100
Deleted in focal-proposed on 2019-11-06 (Reason: remove python-xarray 0.14 from focal-proposed, uploading ...)
python-xarray (0.14.0-1ubuntu3) focal; urgency=medium

  * Just try to build from trunk, which is supposed to be v0.14.1?

 -- Matthias Klose <email address hidden>  Sat, 02 Nov 2019 12:52:58 +0200
Superseded in focal-proposed on 2019-11-02
python-xarray (0.14.0-1ubuntu2) focal; urgency=medium

  * Fix test failures with new cftime 1.0.4, taken from upstream.
  * _get_scheduler() exception if dask.multiprocessing missing, taken
    from upstream.

 -- Matthias Klose <email address hidden>  Fri, 01 Nov 2019 13:54:51 +0100
Superseded in focal-proposed on 2019-11-01
python-xarray (0.14.0-1ubuntu1) focal; urgency=medium

  * Fix test failures with new cftime 1.0.4, taken from upstream.

 -- Matthias Klose <email address hidden>  Fri, 01 Nov 2019 13:54:51 +0100
Superseded in focal-proposed on 2019-11-01
python-xarray (0.14.0-1) unstable; urgency=medium

  * New upstream release
  * Standards-Version: 4.4.1.0

 -- Alastair McKinstry <email address hidden>  Wed, 16 Oct 2019 10:53:11 +0100

Available diffs

Superseded in focal-proposed on 2019-10-25
Deleted in eoan-proposed on 2019-10-27 (Reason: moved to focal-proposed)
python-xarray (0.12.3-1) unstable; urgency=medium

  * New upstream release
  * Move to debhelper-compat (= 12)
  * Standards-Version: 4.4.0
  * Disable testing for this release: 1 test fails due to upstream API change
    in dask

 -- Alastair McKinstry <email address hidden>  Sun, 21 Jul 2019 15:18:52 +0100

Available diffs

Superseded in eoan-proposed on 2019-07-21
python-xarray (0.12.1-2) unstable; urgency=medium

  * Source-only upload for transition. Closes: #931971

 -- Alastair McKinstry <email address hidden>  Sun, 14 Jul 2019 14:13:13 +0100
Superseded in focal-release on 2019-11-06
Published in eoan-release on 2019-07-14
Deleted in eoan-proposed (Reason: moved to release)
python-xarray (0.12.1-1ubuntu1) eoan; urgency=medium

  * Fix failing tests on ARM and big-endian systems

 -- Graham Inggs <email address hidden>  Sun, 14 Jul 2019 16:14:15 +0000
Superseded in eoan-proposed on 2019-07-14
python-xarray (0.12.1-1) unstable; urgency=medium

  * New upstream release
  * Drop python2 support: code and dependencies (contextlib.suppress, etc) 
    no longer work on python < 3.5
  * Add sphinx3-build script to allow python3 -based sphinx build. Helper
    script in debian/, path set in d/rules; patch to doc/Makefile

 -- Alastair McKinstry <email address hidden>  Fri, 19 Apr 2019 12:37:11 +0100
Superseded in eoan-release on 2019-07-14
Obsolete in disco-release on 2020-07-14
Deleted in disco-proposed on 2020-07-14 (Reason: moved to release)
python-xarray (0.11.3-2) unstable; urgency=medium

  * Team upload.
  * Apply fix from upstream for test suite
    Closes: #922515

 -- Andreas Tille <email address hidden>  Wed, 20 Feb 2019 09:21:30 +0100

Available diffs

Superseded in disco-release on 2019-02-21
Deleted in disco-proposed on 2019-02-22 (Reason: moved to release)
python-xarray (0.11.3-1) unstable; urgency=medium

  * New upstream release

 -- Alastair McKinstry <email address hidden>  Tue, 29 Jan 2019 16:25:48 +0000

Available diffs

Superseded in disco-release on 2019-02-01
Deleted in disco-proposed on 2019-02-03 (Reason: moved to release)
python-xarray (0.11.2-2) unstable; urgency=medium

  * Build-Depend on flake8
  * Use sphinx objects from matplotlib-doc. not downloaded
  * Disable use of 'iris' in building docs, as this triggers downloads
    at build-time.  Closes: #920194

 -- Alastair McKinstry <email address hidden>  Wed, 23 Jan 2019 08:48:44 +0000
Superseded in disco-proposed on 2019-01-23
python-xarray (0.11.2-1) unstable; urgency=medium

  * New upstream release
  * NaT.patch: NaT==x is now always False, so mark test XFAIL.
    Closes: #917762
  * Change description from " ... for Python 2" to " ... for Python"
  * Standards-Version: 4.3.0

 -- Alastair McKinstry <email address hidden>  Mon, 07 Jan 2019 16:02:08 +0000

Available diffs

Superseded in disco-release on 2019-01-23
Deleted in disco-proposed on 2019-01-24 (Reason: moved to release)
python-xarray (0.11.0-3) unstable; urgency=medium

  * Fix from Jeremy Bicha for FTBFS with python3.7. Closes: #913952

 -- Alastair McKinstry <email address hidden>  Tue, 20 Nov 2018 05:16:34 +0000

Available diffs

Superseded in disco-proposed on 2018-11-20
python-xarray (0.11.0-2) unstable; urgency=medium

  * Add dependencies on scipy, matlplotlib to debian/tests/control.
    Closes: #913847

 -- Alastair McKinstry <email address hidden>  Fri, 16 Nov 2018 09:19:50 +0000

Available diffs

Superseded in disco-proposed on 2018-11-17
python-xarray (0.11.0-1) unstable; urgency=medium

  * New upstream release
  * Re-enable testing on python3* rather than python3.6 now pandas supports 
    python3.7. Closes: #913521
  * Bug with cftime 1.0.2: mark some affected tests XFAIL. Closes: #913524
  * Don't ship executable data (example) files
  * Don't execute tests id 'nocheck' in DEB_BUILD_OPTIONS
  * Drop deprecated Restrictions: needs-recommends from d/tests/control; 
    add dependencies instead

 -- Alastair McKinstry <email address hidden>  Mon, 12 Nov 2018 11:56:23 +0000

Available diffs

Superseded in disco-proposed on 2018-11-12
python-xarray (0.10.9-1) unstable; urgency=medium

  * New upstream release
  * Standards-Version: 4.2.1
  * Drop hard-coded xz compression

 -- Alastair McKinstry <email address hidden>  Wed, 03 Oct 2018 15:01:31 +0100
Superseded in disco-release on 2018-11-22
Obsolete in cosmic-release on 2020-07-13
Deleted in cosmic-proposed on 2020-07-13 (Reason: moved to release)
python-xarray (0.10.8-2) unstable; urgency=medium

  * Patch from Graham Inggs for expected ARM64 test failure (mark XFAIL).
    Closes:#904785.

 -- Alastair McKinstry <email address hidden>  Tue, 31 Jul 2018 13:38:48 +0100

Available diffs

Superseded in cosmic-release on 2018-07-31
Deleted in cosmic-proposed on 2018-08-02 (Reason: moved to release)
python-xarray (0.10.8-1) unstable; urgency=medium

  * New upstream release
  * Standards-Version: 4.1.5
  * Only run tests for python3.6; tests fail on py3.7 because pandas extensions
    not yet built for py3.7

 -- Alastair McKinstry <email address hidden>  Thu, 26 Jul 2018 13:56:44 +0100

Available diffs

Superseded in cosmic-release on 2018-07-28
Deleted in cosmic-proposed on 2018-07-29 (Reason: moved to release)
python-xarray (0.10.7-1) unstable; urgency=medium

  * New upstream release

 -- Alastair McKinstry <email address hidden>  Sat, 09 Jun 2018 14:36:03 +0100

Available diffs

Superseded in cosmic-proposed on 2018-06-09
python-xarray (0.10.4-1) unstable; urgency=medium

  * New upstream release
  * Use 'xz' compression
  * Require dask >= 0.17.3 to work for
  * Ship python-xarray. Closes: #896954

 -- Alastair McKinstry <email address hidden>  Wed, 23 May 2018 11:52:17 +0100

Available diffs

Superseded in cosmic-proposed on 2018-05-28
python-xarray (0.10.3-1) unstable; urgency=medium

  * New upstream release
  * Standards-Version: 4.1.4
  * Add Anaconda (BSD-like) copyright license for dask components

 -- Alastair McKinstry <email address hidden>  Sat, 21 Apr 2018 10:01:29 +0100
Superseded in cosmic-release on 2018-06-21
Published in bionic-release on 2018-04-13
Deleted in bionic-proposed (Reason: moved to release)
python-xarray (0.10.2-1) unstable; urgency=medium

  * New upstream release
  * Add build-dep on python3-cloudpickle, python3-toolz

 -- Alastair McKinstry <email address hidden>  Thu, 15 Mar 2018 11:12:06 +0000

Available diffs

Superseded in bionic-release on 2018-04-13
Deleted in bionic-proposed on 2018-04-15 (Reason: moved to release)
python-xarray (0.9.6-1) unstable; urgency=medium

  * Source future releases from GitHub
  * Use the recommended gbp configuration
  * New upstream version 0.9.6 (Closes: #882559)
  * Rebase the patch queue
    - Drop Fix-missing-config-errors-when-running-test-suite.patch,
      no longer required
    - Refresh Use-packaged-docs.patch, Use-packaged-MathJax.patch
      and No-privacy-breach.patch
  * Bump the copyright years
  * Update the dependencies
    - Drop distributed, h5netcdf, h5py, pydap and toolz from Build-Depends
    - Add rasterio and sphinx-gallery to Build-Depends
    - Move bottleneck, dask and netcdf4 from Suggests to Recommends
    - Add cartopy and rasterio to Suggests
    - Drop distributed, h5netcdf and h5py from Suggests
  * Fix autopkgtest failures.
    Thanks to Steve Langasek (Closes: #873366)
  * Drop superfluous nocheck guards
  * Ignore the autogenerated version file
  * Fix whitespacing in rules file
  * Bump the debhelper version to 11
  * Bump the standards version to 4.1.3
  * Point the VCS metadata to salsa.d.o
  * Disable Sphinx gallery generation
    - New patch No-sphinx-gallery.patch
  * Cherry-pick upstream fix for a failing test
    - New patch Fix-test-suite-failure.patch
    Thanks to Rebecca N. Plamer (Closes: #871208)

 -- Ghislain Antony Vaillant <email address hidden>  Sat, 03 Feb 2018 13:49:07 +0000
Superseded in bionic-release on 2018-02-05
Deleted in bionic-proposed on 2020-07-10 (Reason: moved to release)
Deleted in bionic-release on 2020-07-10 (Reason: See LP: #1728362)
Obsolete in artful-release on 2020-07-10
Deleted in artful-proposed on 2020-07-10 (Reason: moved to release)
python-xarray (0.9.2-1ubuntu1) artful; urgency=medium

  * Drop python3-pydap from the test dependencies; all this does is turn on
    testing of a non-default backend which does not handle proxy variables
    automatically, tries to access the network, and fails even if the
    network is reachable.  Since python3-pydap is only a suggests: at
    runtime and netcdf is always preferred, we shouldn't care if it works.

 -- Steve Langasek <email address hidden>  Sat, 26 Aug 2017 16:40:53 -0700
Superseded in artful-proposed on 2017-08-26
python-xarray (0.9.2-1) unstable; urgency=medium

  * New upstream version 0.9.2
  * Drop repacking of upstream tarballs, no longer required
  * Cherry-pick upstream fix for test config errors
    - New patch Fix-missing-config-errors-when-running-test-suite.patch
  * Add optional dependencies to the build
    - Added bottleneck, dask, distributed, h5netcdf, h5py, matplotlib,
      netcdf4, pydap, scipy, seaborn, toolz to the list of b-deps and
      suggested i-deps
    - Test without distributed and pydap since they are known to fail
      upstream
  * Run DEP-8 tests with all optional dependencies
  * Increase verbosity of DEP-8 tests
  * Discard egg-info dir using extend-diff-ignore
  * Add the documentation package
    - Add cartopy, ipython, numpydoc, sphinx, sphinx-rtd-theme to the list
      of b-deps
    - Mark the dask, matplotlib, netcdf4, numpy, pandas, scipy, seaborn
      b-deps as !nodoc
    - Do not build the documentation if the nodoc b-prof is requested
  * Use the packaged documentation
    - Add numpy-doc, pandas-doc, python3-doc to the list of b-deps
    - Patch the intersphinx configuration to use the packaged docs (new
      patch Use-packaged-docs.patch)
  * Use the packaged MathJax
    - Add MathJax to the i-deps of the documentation package
    - Patch the docs configuration to use the packaged MathJax
  * Remove privacy breaching content from the docs
    - New patch No-privacy-breach.patch

 -- Ghislain Antony Vaillant <email address hidden>  Sat, 15 Apr 2017 21:28:16 +0100
Superseded in artful-release on 2017-08-27
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed on 2018-06-22 (Reason: moved to release)
python-xarray (0.9.1+ds1-1) unstable; urgency=low

  * Initial release. (Closes: #851444)

 -- Ghislain Antony Vaillant <email address hidden>  Thu, 23 Feb 2017 14:14:08 +0000
142 of 42 results