python3.9 3.9.5-3~20.10.1 source package in Ubuntu

Changelog

python3.9 (3.9.5-3~20.10.1) groovy; urgency=medium

  * SRU: LP: #1899159: Backport Python 3.9.5 to 20.10.
  * Adjust python3-tk autopkg test dependency to the version found
    in the release.

python3.9 (3.9.5-3) experimental; urgency=medium

  * Tighten python3-tk autopkg test dependency.
  * Try to detect whether python3-venv is missing (Stefano Rivera).
    Closes: #977887.

python3.9 (3.9.5-2) experimental; urgency=medium

  * Re-add the dependency on libdb-dev.  With Python 3.10, building
    the _dbm extension using libgdbm-compat-dev, and moving the _dbm
    extension into the python3-gdbm package.
  * Call python with -S when checking the minimal set of modules.

python3.9 (3.9.5-1) experimental; urgency=medium

  * Python 3.9.5 release.
  * Refresh patches.
  * Drop the unused build dependency on libdb-dev.

python3.9 (3.9.4-1) experimental; urgency=medium

  * Python 3.9.4 release.

python3.9 (3.9.3-2) experimental; urgency=high

  * Fix flags substitutions for _sysconfigdata.
  * Revert the fix for issue #42500, breaking ABI on 32bit architectures.

python3.9 (3.9.3-1) experimental; urgency=medium

  * Python 3.9.3 release.
    - Fix issue #42988: CVE-2021-3426: Remove the getfile feature of the
      pydoc module which could be abused to read arbitrary files on the
      disk (directory traversal vulnerability).
    - Other security issues without a CVE.
    - Other fixes. See the NEWS file.
  * Move zlib1g-dev dependency to libpython3.9-dev. Closes: #984580.
  * Configure with --libdir=/usr/lib/$(DEB_HOST_MULTIARCH), recording the
    correct LIBDIR in _sysconfigdata.  Also adjust DESTSHARED to install
    lib-dynload into the same location as before the configure change.
    See issue #43229.

python3.9 (3.9.2-1) unstable; urgency=medium

  * Python 3.9.2 release. No changes since 3.9.2~rc1-1.
  * Build idlelib/help.html from source, don't ship the pre-generated file.
  * Autopkg tests:
    - Run testsuite{,-dbg} autopkg tests with allow-stderr. Closes: #983305.
    - Run again in testsuite instead of failing-tests: test_ftplib,
      test_httplib test_imaplib test_nntplib test_poplib test_ssl.
    - Run test_distutils and test_site tests again.

python3.9 (3.9.2~rc1-1) experimental; urgency=medium

  * Python 3.9.2 release candidate 1. Changes since 3.9.1-4:
    - Fix issue #42967, web cache poisoning vulnerability.
    - Fix issue #42938, explicitly disable bracketed paste in the interactive
      interpreter. Closes: #979154.
  * Fix permissions and group for local directories. Closes: #962422.
  * Build a python3.9-full package.
  * idle-python3.9: Drop dependency on libjs-mathjax, unused in 3.8 and 3.9.
  * python3.9-doc: Fix links to the documentation in /usr/share/doc/python3.9.
  * Refresh patches.

python3.9 (3.9.1-4) unstable; urgency=medium

  * Update to the 3.9 branch 2021-02-04.
  * Fix issue #43030, compiler warning in Py_UNICODE_ISSPACE with
    signed wchar_t. Closes: #961396.
  * Depend on media-types instead of mime-support. Closes: #981016.
  * Fix permissions and group for local directories. Closes: #962422.

python3.9 (3.9.1-3) unstable; urgency=medium

  * Update to the 3.9 branch 2021-01-20.
  * Configure again --with-system-libmpdec.
  * Update symbols files.

python3.9 (3.9.1-2) unstable; urgency=medium

  * Update to the 3.9 branch 2021-01-10.

python3.9 (3.9.1-1) unstable; urgency=medium

  * Python 3.9.1 release.

python3.9 (3.9.1~rc1-2) unstable; urgency=medium

  * Don't expect the test_ttk_textonly test to pass.

python3.9 (3.9.1~rc1-1) unstable; urgency=medium

  * Python 3.9.1 release candidate 1.
  * libpython3.9-stdlib: Depend on tzdata, recommend ca-certificates.
  * libpython3.9-stdlib: Depend on media-types | mime-support instead of
    mime-support.
  * Update VCS attributes.
  * Add python3-tk test dependency for the failing-tests* autopkg tests.
  * Bump standards version.
  * Add build conflict with git, or else the git information of the packaging
    is encoded in the upstream version information.
  * Build with -fno-inline-small-functions on hppa and sh4.
    Closes: #972458, #972202.

 -- Matthias Klose <email address hidden>  Wed, 19 May 2021 13:32:47 +0200

Upload details

Uploaded by:
Matthias Klose
Uploaded to:
Groovy
Original maintainer:
Matthias Klose
Architectures:
any all
Section:
python
Urgency:
Very Urgent

See full publishing history Publishing

Series Pocket Published Component Section
Groovy security universe python
Groovy updates universe python

Downloads

File Size SHA-256 Checksum
python3.9_3.9.5.orig.tar.xz 18.2 MiB 0c5a140665436ec3dbfbb79e2dfb6d192655f26ef4a29aeffcb6d1820d716d83
python3.9_3.9.5-3~20.10.1.debian.tar.xz 207.1 KiB d495974c54523b56292bfa2f46d4892283874830fdb667e126528f668ffd66cc
python3.9_3.9.5-3~20.10.1.dsc 3.4 KiB 7c976877e825f164aa339e0bb35ca5b0c6dc7656475fde896ef29dacd7535a0e

Available diffs

View changes file

Binary packages built by this source

idle-python3.9: IDE for Python (v3.9) using Tkinter

 IDLE is an Integrated Development Environment for Python (v3.9).
 IDLE is written using Tkinter and therefore quite platform-independent.

libpython3.9: Shared Python runtime library (version 3.9)

 Python is a high-level, interactive, object-oriented language. Its 3.9 version
 includes an extensive class library with lots of goodies for
 network programming, system administration, sounds and graphics.
 .
 This package contains the shared runtime library, normally not needed
 for programs using the statically linked interpreter.

libpython3.9-dbg: Debug Build of the Python Interpreter (version 3.9)

 The package holds two things:
 .
 - Extensions for a Python interpreter configured with --pydebug.
 - Debug information for standard python extensions.
 .
 See the README.debug for more information.

libpython3.9-dev: Header files and a static library for Python (v3.9)

 Header files, a static library and development tools for building
 Python (v3.9) modules, extending the Python interpreter or embedding
 Python (v3.9) in applications.
 .
 Maintainers of Python packages should read README.maintainers.
 .
 This package contains development files. It is normally not
 used on it's own, but as a dependency of python3.9-dev.

libpython3.9-minimal: Minimal subset of the Python language (version 3.9)

 This package contains some essential modules. It is normally not
 used on it's own, but as a dependency of python3.9-minimal.

libpython3.9-stdlib: Interactive high-level object-oriented language (standard library, version 3.9)

 Python is a high-level, interactive, object-oriented language. Its 3.9 version
 includes an extensive class library with lots of goodies for
 network programming, system administration, sounds and graphics.
 .
 This package contains Python 3.9's standard library. It is normally not
 used on its own, but as a dependency of python3.9.

libpython3.9-testsuite: Testsuite for the Python standard library (v3.9)

 The complete testsuite for the Python standard library. Note that
 a subset is found in the libpython3.9-stdlib package, which should
 be enough for other packages to use (please do not build-depend
 on this package, but file a bug report to include additional
 testsuite files in the libpython3.9-stdlib package).

python3.9: Interactive high-level object-oriented language (version 3.9)

 Python is a high-level, interactive, object-oriented language. Its 3.9 version
 includes an extensive class library with lots of goodies for
 network programming, system administration, sounds and graphics.

python3.9-dbg: Debug Build of the Python Interpreter (version 3.9)

 The package holds two things:
 .
 - A Python interpreter configured with --pydebug. Dynamically loaded modules
   are searched as <foo>_d.so first. Third party extensions need a separate
   build to be used by this interpreter.
 - Debug information for standard python interpreter and extensions.
 .
 See the README.debug for more information.

python3.9-dev: Header files and a static library for Python (v3.9)

 Header files, a static library and development tools for building
 Python (v3.9) modules, extending the Python interpreter or embedding
 Python (v3.9) in applications.
 .
 Maintainers of Python packages should read README.maintainers.

python3.9-doc: Documentation for the high-level object-oriented language Python (v3.9)

 These is the official set of documentation for the interactive high-level
 object-oriented language Python (v3.9). All documents are provided
 in HTML format. The package consists of ten documents:
 .
   * What's New in Python3.9
   * Tutorial
   * Python Library Reference
   * Macintosh Module Reference
   * Python Language Reference
   * Extending and Embedding Python
   * Python/C API Reference
   * Installing Python Modules
   * Documenting Python
   * Distributing Python Modules

python3.9-examples: Examples for the Python language (v3.9)

 Examples, Demos and Tools for Python (v3.9). These are files included in
 the upstream Python distribution (v3.9).

python3.9-full: Python Interpreter with complete class library (version 3.9)

 Python, the high-level, interactive object oriented language,
 includes an extensive class library with lots of goodies for
 network programming, system administration, sounds and graphics.
 .
 This package is a dependency package, which depends on the full
 standard library of Python for Python developers. Including modules
 used only at build-time, such as venv and distutils, and modules with
 complex dependencies, such as tk and IDLE. All batteries included.
 .
 According to the Debian Python policy, this package must not be used in
 build dependencies, dependencies and recommendations.

python3.9-minimal: Minimal subset of the Python language (version 3.9)

 This package contains the interpreter and some essential modules. It can
 be used in the boot process for some basic tasks.
 See /usr/share/doc/python3.9-minimal/README.Debian for a list of the modules
 contained in this package.

python3.9-venv: Interactive high-level object-oriented language (pyvenv binary, version 3.9)

 Python is a high-level, interactive, object-oriented language. Its 3.9 version
 includes an extensive class library with lots of goodies for
 network programming, system administration, sounds and graphics.
 .
 This package contains the pyvenv-3.9 binary.