Change log for pywps package in Ubuntu

110 of 10 results
Published in cosmic-release on 2018-08-01
Deleted in cosmic-proposed (Reason: moved to release)
pywps (4.0.0-6) unstable; urgency=medium

  * Drop ancient X-Python-Version field.
  * Strip trailing whitespace from control & rules files.
  * Disable PIE only on older Ubuntu releases.
  * Bump Standards-Version to 4.1.5, no changes.
  * Drop autopkgtest to test installability.
  * Add lintian override for testsuite-autopkgtest-missing.
  * Add patch to use Python 2 version of Sphinx explicitly.
  * Add override for package-contains-documentation-outside-usr-share-doc.

 -- Bas Couwenberg <email address hidden>  Wed, 01 Aug 2018 18:23:12 +0200

Available diffs

Superseded in cosmic-release on 2018-08-01
Published in bionic-release on 2018-04-23
Deleted in bionic-proposed (Reason: moved to release)
pywps (4.0.0-5) unstable; urgency=medium

  * Add python3-sphinx to build dependencies.
  * Bump Standards-Version to 4.1.4, no changes.
  * Update copyright-format URL to use HTTPS.
  * Update Vcs-* URLs for Salsa.
  * Add patch fix SyntaxError in demobuffer.py.
    (closes: #896612)
  * Add lintian override for python-foo-but-no-python3-foo.

 -- Bas Couwenberg <email address hidden>  Sun, 22 Apr 2018 22:09:16 +0200

Available diffs

Superseded in bionic-release on 2018-04-23
Published in artful-release on 2017-06-27
Deleted in artful-proposed (Reason: moved to release)
pywps (4.0.0-4) unstable; urgency=medium

  * Bump Standards-Version to 4.0.0, no changes.
  * Add autopkgtest to test installability.
  * Enable PIE hardening buildflags.
  * Disable PIE on Ubuntu where it's still problematic.
  * Add patch to disable Sphinx theme options causing privacy breach issues.

 -- Bas Couwenberg <email address hidden>  Mon, 26 Jun 2017 12:03:07 +0200
Superseded in artful-release on 2017-06-27
Deleted in artful-proposed on 2017-06-28 (Reason: moved to release)
pywps (4.0.0-3build1) artful; urgency=medium

  * No-change rebuild for sqlalchemy 1.1.x.

 -- James Page <email address hidden>  Fri, 28 Apr 2017 10:39:47 +0100
Superseded in artful-release on 2017-04-29
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed on 2018-06-22 (Reason: moved to release)
pywps (4.0.0-3) unstable; urgency=medium

  * Add Breaks/Replaces to pywps-wsgi for moved processes.

 -- Bas Couwenberg <email address hidden>  Sun, 22 Jan 2017 11:29:58 +0100

Available diffs

Superseded in zesty-release on 2017-01-22
Deleted in zesty-proposed on 2017-01-24 (Reason: moved to release)
pywps (4.0.0-2) unstable; urgency=medium

  * Update WSGI example for PyWPS 4.

 -- Bas Couwenberg <email address hidden>  Sat, 21 Jan 2017 19:31:25 +0100

Available diffs

Superseded in zesty-release on 2017-01-22
Deleted in zesty-proposed on 2017-01-23 (Reason: moved to release)
pywps (4.0.0-1) unstable; urgency=medium

  * New upstream release.
  * Drop fix-sphinx-failure.patch, applied upstream.
  * Move from experimental to unstable.

 -- Bas Couwenberg <email address hidden>  Thu, 08 Dec 2016 07:50:57 +0100

Available diffs

Superseded in zesty-release on 2016-12-08
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed on 2018-01-23 (Reason: moved to release)
pywps (3.2.6-1) unstable; urgency=medium

  * New upstream release.

 -- Bas Couwenberg <email address hidden>  Thu, 30 Jun 2016 19:24:31 +0200

Available diffs

Superseded in yakkety-release on 2016-07-01
Deleted in yakkety-proposed on 2016-07-02 (Reason: moved to release)
pywps (3.2.5-2) unstable; urgency=medium

  * Install copy of usr/bin/pywps as usr/lib/cgi-bin/wps.py instead of symlink.
  * Drop pywps dependency from pywps-cgi to break circular dependency.
    (closes: #827307)

 -- Bas Couwenberg <email address hidden>  Tue, 14 Jun 2016 23:13:09 +0200

Available diffs

Superseded in yakkety-release on 2016-06-15
Deleted in yakkety-proposed on 2016-06-16 (Reason: moved to release)
pywps (3.2.5-1) unstable; urgency=medium

  * Import pywps packaging from OSGeo-Live.
    (closes: #610181)
  * Restructure control file with cme.
  * Move Homepage field to Source section.
  * Change maintainer to Debian GIS team.
  * Update Vcs-* fields for repository on Alioth.
  * Update copyright file using copyright-format 1.0.
  * Add watch file for GitHub releases.
  * Add upstream metadata.
  * Add dh-python to build dependencies.
  * Enable parallel builds.
  * Override dh_install to use --list-missing.
  * Enable all hardening buildflags, except PIE (causes build failure).
  * Add gbp.conf to use pristine-tar by default.
  * Install AUTHORS & README files in docs.
  * Remove compiled templates with dh_clean.
  * Rename /usr/bin/wps.py to /usr/bin/pywps.
  * Move pywps executable, CGI & WSGI scripts to separate binary packages.
    - Add python-gdal & python-lxml to python-pywps Depends
    - Add python-mapscript & python-pyproj to python-pywps Recommends
    - Update python-pywps Suggests to use grass-core instead of grass
    - Add r-base to python-pywps Suggest
    - Add cgi-mapserver to pywps Suggests
    - Use dh-apache2 for Apache configuration
  * Install pywps manpage.
  * Build & install documentation.
  * Install pywps.cfg-template, webclient & webservices examples.
  * Override dh_auto_test to run soap_tests.py.
  * Bump Standards-Version to 3.9.8, changes:
    - Vcs-* fields in control file
    - copyright-format 1.0
  * Add Angelos Tzotsos to Uploaders.

 -- Bas Couwenberg <email address hidden>  Fri, 10 Jun 2016 19:21:10 +0200
110 of 10 results