Change log for qca2 package in Ubuntu

129 of 29 results
Published in eoan-release on 2019-04-18
Published in disco-release on 2018-10-30
Published in cosmic-release on 2018-05-01
Published in bionic-release on 2018-02-10
Deleted in bionic-proposed (Reason: moved to release)
qca2 (2.1.3-2ubuntu2) bionic; urgency=high

  * No change rebuild against openssl1.1.

 -- Dimitri John Ledkov <email address hidden>  Tue, 06 Feb 2018 17:55:11 +0000
Superseded in bionic-proposed on 2018-02-06
qca2 (2.1.3-2ubuntu1) bionic; urgency=medium

  * Sync from Debian Sid. Remaining changes:
    - Conflicts/Replaces libqca2v5 because of the GCC transition.

 -- Simon Quigley <email address hidden>  Sat, 27 Jan 2018 21:51:22 -0600

Available diffs

Superseded in bionic-release on 2018-02-10
Published in artful-release on 2017-06-18
Deleted in artful-proposed (Reason: moved to release)
qca2 (2.1.3-1ubuntu1) artful; urgency=medium

  * Merge from Debian unstable.  Remaining changes:
    - Add debian/meta/upstream_scm.json.
    - Add kubuntu_mkspecs-dir.diff to install mkspecs to correct place.
    - Don't build the -doc package.
    - Rename back libqca2v5 to libqca2.
    - Don't build the packages for Qt5 (built from the qca-qt5 source).

Available diffs

Superseded in artful-release on 2017-06-18
Deleted in artful-proposed on 2017-06-19 (Reason: moved to release)
qca2 (2.1.1-4ubuntu1) artful; urgency=medium

  * Merge from Debian unstable.  Remaining changes:
    - Add debian/meta/upstream_scm.json.
    - Add kubuntu_mkspecs-dir.diff to install mkspecs to correct place.
    - Don't build the -doc package.
    - Rename back libqca2v5 to libqca2.
    - Don't build the packages for Qt5 (built from the qca-qt5 source).

Available diffs

Superseded in artful-release on 2017-05-11
Obsolete in zesty-release on 2018-06-22
Obsolete in yakkety-release on 2018-01-23
Published in xenial-release on 2016-04-08
Superseded in xenial-release on 2016-04-08
Deleted in xenial-proposed (Reason: moved to release)
qca2 (2.1.1-2ubuntu1) xenial; urgency=medium

  * Merge with Debian; remaining changes:
    - Add debian/meta/upstream_scm.json.
    - Add kubuntu_mkspecs-dir.diff to install mkspecs to correct place.
    - Don't build the -doc package.
  * Rename back libqca2v5 to libqca2.
  * Don't build the packages for Qt5 (built from the qca-qt5 source).

Available diffs

Superseded in xenial-release on 2016-01-15
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed on 2018-01-22 (Reason: moved to release)
qca2 (2.1.0-0ubuntu10) wily; urgency=medium

  * qca2-utils: Fix dependency on libqca2v5.

 -- Matthias Klose <email address hidden>  Sat, 01 Aug 2015 10:25:42 +0200
Superseded in wily-proposed on 2015-08-01
qca2 (2.1.0-0ubuntu9) wily; urgency=medium

  * Rename libqca2 to libqca2v5, follow-up to the libstdc++6 ABI
    transition. Addresses: #791253.
  * Add Breaks/Replaces to the old library package.

 -- Matthias Klose <email address hidden>  Thu, 30 Jul 2015 19:13:15 +0200
Superseded in wily-release on 2015-08-16
Obsolete in vivid-release on 2018-01-18
Deleted in vivid-proposed on 2018-01-19 (Reason: moved to release)
qca2 (2.1.0-0ubuntu6) vivid; urgency=medium

  * Mark armhf and ppc64el specific symbols as optional.
 -- Matthias Klose <email address hidden>   Mon, 09 Mar 2015 19:43:21 +0100
Superseded in vivid-proposed on 2015-03-09
qca2 (2.1.0-0ubuntu5) vivid; urgency=medium

  * Replace non-existing version 2.1.0+git20141126.2258 in the symbols
    file with 2.1.0.
  * Mark more symbols optional with GCC 5.
 -- Matthias Klose <email address hidden>   Mon, 09 Mar 2015 18:38:48 +0100

Available diffs

Superseded in vivid-proposed on 2015-03-09
qca2 (2.1.0-0ubuntu4) vivid; urgency=medium

  * Replace non-existing version 2.1.0+git20141126.2258 in the symbols
    file with 2.1.0.
  * Mark more symbols optional with GCC 5.
 -- Matthias Klose <email address hidden>   Mon, 09 Mar 2015 18:38:48 +0100

Available diffs

Superseded in vivid-release on 2015-03-09
Deleted in vivid-proposed on 2015-03-11 (Reason: moved to release)
qca2 (2.1.0-0ubuntu3) vivid; urgency=medium

  * Update symbols file
 -- Jonathan Riddell <email address hidden>   Wed, 14 Jan 2015 18:32:16 +0100
Superseded in vivid-proposed on 2015-01-14
qca2 (2.1.0-0ubuntu2) vivid; urgency=medium

  * New upstream release
    + This release merges the official plugins into the main package.
    + Deprecating these sources and their binaries:
      - qca2-plugin-gnupg
      - qca2-plugin-ossl
      - qca-cyrus-sasl
    + Build system was changed to git
    + Docs packages was removed as the source does not build documentation
    + New binary packages:
      - libqca2-plugins containing all plugins
      - libqca2-plugin-ossl
      - libqca2-plugin-gnupg
      - libqca2-plugin-cyrus-sasl
    + Added transitional packages for old plugins
  * Add kubuntu_ignore_filewatch_test.diff to ignore a test which fails in
    buildds but not for local build
  * Add kubuntu_mkspecs-dir.diff to install mkspecs to correct place
 -- Harald Sitter <email address hidden>   Sat, 22 Nov 2014 15:46:56 +0100

Available diffs

Deleted in vivid-proposed on 2015-01-14 (Reason: separate qt5 build)
qca2 (2.1.0-0ubuntu1) vivid; urgency=medium

  * New upstream release
    + This release merges the official plugins into the main package.
    + Deprecating these sources and their binaries:
      - qca2-plugin-gnupg
      - qca2-plugin-ossl
      - qca-cyrus-sasl
    + Build system was changed to git
    + Docs packages was removed as the source does not build documentation
    + Introduces qt5 build.
      - All packages have a qt5 version.
      - The qt5 build uses a differnet suffix to lead to a different
        soname
      - Since the qt5 artifacts partially conflict with the qt4 bits
        additional measures were taken to make sure dh_install and dh_strip
        work on the resepectively correct package set
    + New binary packages (excluding qt5):
      - libqca2-plugins containing all plugins
      - libqca2-plugin-ossl
      - libqca2-plugin-gnupg
      - libqca2-plugin-cyrus-sasl
    + Added transitional packages for old plugins
  * Add kubuntu_ignore_filewatch_test.diff to ignore a test which fails in
    buildds but not for local build
  * Add kubuntu_mkspecs-dir.diff to install mkspecs to correct place
 -- Harald Sitter <email address hidden>   Sat, 22 Nov 2014 15:46:56 +0100
Superseded in vivid-release on 2015-01-14
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed on 2016-11-03 (Reason: moved to release)
qca2 (2.0.3-6) unstable; urgency=medium


  * Update the symbols file for gcc 4.9. Thanks to Sphinx Jiang for the
    initial patch. (Closes: #746895)

 -- Felix Geyer <email address hidden>  Wed, 11 Jun 2014 16:54:40 +0200

Available diffs

Superseded in utopic-release on 2014-06-12
Published in trusty-release on 2013-12-09
Deleted in trusty-proposed (Reason: moved to release)
qca2 (2.0.3-5) unstable; urgency=low


  * Team upload.
  * Change the section of qca2-utils from libs to utils.
  * Bump Standards-Version to 3.9.5, no changes required.
  * Update symbols file.

 -- Pino Toscano <email address hidden>  Sun, 08 Dec 2013 22:54:54 +0100

Available diffs

Superseded in trusty-release on 2013-12-09
Obsolete in saucy-release on 2015-04-24
Obsolete in raring-release on 2015-04-24
Obsolete in quantal-release on 2015-04-24
qca2 (2.0.3-4) unstable; urgency=low


  * Team upload.
  * Fix the symbols file.
  * Add pipeunittest_more_wait.diff to increase times of qWait() in the
    pipeunittest test (helps with Hurd).
  * Add patch hurd_msync.diff to temporarly ignore ENOSYS errors for Hurd's
    msync().

 -- Pino Toscano <email address hidden>  Mon, 04 Jun 2012 11:49:16 +0200

Available diffs

Superseded in quantal-release on 2012-06-04
qca2 (2.0.3-3) unstable; urgency=low


  [ Felix Geyer ]
  * Modify CFLAGS and CXXFLAGS after including debian-qt-kde.mk so the
    changes are not overwritten.
  * Pass $CPPFLAGS to the build system.
  * Update symbols file.
  * Fix FTBFS with gcc 4.7. (Closes: #667339)
    - Add fix_build_gcc4.7.diff, cherry-picked from upstream.
  * Bump Standards-Version to 3.9.3, no changes needed.
  * Convert to multiarch.
    - Bump debhelper compat level to v9.
    - Move qcatool2 into the new binary package qca2-utils.
    - Mark libqca2 and libqca2-dbg as Multi-Arch: same.
  * Fix passing $LDFLAGS to the build system.
  * Pass build flags to qcatool2.
  * Remove confapp.pri in clean target.

 -- Debian Qt/KDE Maintainers <email address hidden>  Sat, 26 May 2012 18:30:41 +0200

Available diffs

Superseded in quantal-release on 2012-06-04
Published in precise-release on 2011-10-13
Obsolete in oneiric-release on 2015-04-24
qca2 (2.0.3-2) unstable; urgency=low

  [ Felix Geyer ]
  * Add Vcs-* fields.
  * Fix versioned dependency on arch-any package.

  [ Modestas Vainius ]
  * Add myself to Uploaders.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  24 Jun 2011 09:07:47 +0000

Available diffs

Superseded in oneiric-release on 2011-06-24
qca2 (2.0.3-1) unstable; urgency=low

  * New upstream release.

  [ Felix Geyer ]
  * Switch to source format 3.0 (quilt).
  * Switch debian/rules engine to dhmk.
  * Pass --no-separate-debug-info to configure and let dh_strip handle
    the debug symbol seperation.
  * Switch to debhelper compat level 7.
  * Simplify install files.
  * Don't install the TODO file.
  * Bump Standards-Version to 3.9.2.
    - Drop ancient Conflicts.
  * libqca2: don't suggest libqca2-plugin-pkcs11 as it doesn't exist.
  * Add myself as uploader.
  * Fix short description of libqca2-dbg.
  * Add missing ${misc:Depends}.
  * libqca2-dbg: recommend libqt4-dbg.
  * Build with -fvisibility=hidden -fvisibility-inlines-hidden.
    - Add define_qca_export.diff to define QCA_EXPORT as Q_DECL_EXPORT.
  * Disable broken unit test that fails if two subsequent random numbers are
    the same.
    - Add disable_randomunittest.diff
  * Add a symbols file.

  [ Modestas Vainius ]
  * Remove Matthew Rosewarne from Uploaders, R.I.P.
 -- Felix Geyer <email address hidden>   Mon, 30 May 2011 00:33:07 +0300

Available diffs

Superseded in oneiric-release on 2011-05-30
Obsolete in natty-release on 2013-06-04
Obsolete in maverick-release on 2013-03-05
Obsolete in lucid-release on 2016-10-26
qca2 (2.0.2-1ubuntu2) lucid; urgency=low

  * rebuild rest of main for armel armv7/thumb2 optimization;
    UbuntuSpec:mobile-lucid-arm-gcc-v7-thumb2
 -- Alexander Sack <email address hidden>   Sun, 07 Mar 2010 01:02:25 +0100

Available diffs

Superseded in lucid-release on 2010-03-07
Obsolete in karmic-release on 2013-03-04
qca2 (2.0.2-1ubuntu1) karmic; urgency=low

  * Drop the -dbg package since the package FTBFS when making it and we have
    -dbgsym packages in Ubuntu

 -- Scott Kitterman <email address hidden>   Fri, 04 Sep 2009 00:04:13 -0400

Available diffs

Superseded in karmic-release on 2009-09-04
qca2 (2.0.2-1) unstable; urgency=low

  * New Upstream Version (Closes: Bug#529532)
  * Remove out-of-date VCS fields from debian/control
  * Move -dbg package to section 'debug'

Available diffs

Superseded in karmic-release on 2009-06-01
Obsolete in jaunty-release on 2013-02-28
Obsolete in intrepid-release on 2013-02-20
Superseded in intrepid-release on 2008-06-17
qca2 (2.0.0-4) unstable; urgency=low

  +++ Changes by Matthew Rosewarne:

  * Switch rules to CDBS.
  * Create API documentation package.
  * Install qmake data files in libqca2-dev.
  * Bump compat to 6.
  * Bump Standards-Version to 3.7.3.
  * Tweak package descriptions.
  * Add Homepage: to control.
  * Suggest qca2 plugins.
  * Add watch file.

  +++ Changes by Ana Beatriz Guerrero Lopez:

  * Update FSF address in the copyright file.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  02 May 2008 02:23:52 +0100
Obsolete in gutsy-backports on 2011-09-16
qca2 (2.0.0-3~gutsy1) gutsy-backports; urgency=low

  * Automated backport upload; no source changes.

Superseded in intrepid-release on 2008-05-03
Obsolete in hardy-release on 2015-04-24
qca2 (2.0.0-3) unstable; urgency=low

  * Disable compilation of unit tests. As the plugins necessary to actually
    execute the tests are not available at compile time, and the compiled
    tests are not included in the packages, it's not actually useful to
    compile them in the first place. Additionally, some of the files need
    a huge amount of memory to compile and therefore take excessively long
    to compile on buildds with little memory.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Wed,  21 Nov 2007 09:52:49 +0000
Superseded in hardy-release on 2007-11-21
qca2 (2.0.0-2) unstable; urgency=low

  * Upload to unstable

Superseded in hardy-release on 2007-11-05
Obsolete in gutsy-release on 2011-09-16
qca2 (2.0.0~beta7-1ubuntu1) gutsy; urgency=low

  * Ubuntu upload
  * Rename source package to qca2

 -- Jonathan Riddell <email address hidden>   Sat, 11 Aug 2007 00:54:53 +0100
Superseded in gutsy-release on 2007-08-11
qca2 (2.0~beta2+svn20070709-0ubuntu3) gutsy; urgency=low

  * Remove non existant gnupg file from libqca2.install

 -- Jonathan Riddell <email address hidden>   Fri, 27 Jul 2007 15:53:27 +0100
Superseded in gutsy-release on 2007-07-27
qca2 (2.0~beta2+svn20070709-0ubuntu2) gutsy; urgency=low

  * Update debian/copyright

129 of 29 results