qiv fails to start: Gdk-ERROR **: BadMatch (invalid parameter attributes)

Bug #41056 reported by manatlan on 2006-04-24
18
Affects Status Importance Assigned to Milestone
qiv (Ubuntu)
Medium
Unassigned

Bug Description

qiv fails to start up with the following error:

Gdk-ERROR **: BadMatch (invalid parameter attributes)

Vassilis Pandis (pandisv) wrote :

Hello and thank you for your bug report. I was unable to reproduce the crashing on several images with qiv 2.0-4ubuntu1. Could you attatch an image that causes it to crash? Could you please try to obtain a backtrace following http://wiki.ubuntu.com/DebuggingProgramCrash ? Thanks

Changed in qiv:
status: Unconfirmed → Needs Info

thanks for your quick reply ...

I will send you back all the infos you need tonight (because i'm at work
now)

On 4/24/06, Vassilis Pandis <email address hidden> wrote:
>
> Hello and thank you for your bug report. I was unable to reproduce the
> crashing on several images with qiv 2.0-4ubuntu1. Could you attatch an
> image that causes it to crash? Could you please try to obtain a
> backtrace following http://wiki.ubuntu.com/DebuggingProgramCrash ?
> Thanks
>
> ** Changed in: qiv (Ubuntu)
> Status: Unconfirmed => Needs Info
>
> --
> qiv crash on dapper
> https://launchpad.net/bugs/41056
>

--
"Oui, oui."
                -- Shakespeare (Richard III, Acte I, Scène IV)

when i launch "qiv" (with any image, but i send you one of mine by email):

i've got the same version as you
$ dpkg -l | grep qiv
ii qiv 2.0-4ubuntu1 A quick image viewer for X

$ qiv Desktop/Capture.png
Gdk-ERROR **: BadMatch (invalid parameter attributes)
 serial 112 error_code 8 request_code 2 minor_code 0

with gdb (after compiling/installing debug version of qiv):
(gdb) run Desktop/Capture.png
Starting program: /usr/bin/qiv Desktop/Capture.png
Gdk-ERROR **: BadMatch (invalid parameter attributes)
 serial 112 error_code 8 request_code 2 minor_code 0
Program exited with code 01.

hope it helps ...

i'm pretty sure the trouble sits in the "gdk-imlib1" package, it seems strange

(i've posted directly thru launchpad website, because i've sent 2 emails which seem unable to reach launchpad)

manatlan (manatlan) wrote :

there is a workaround !
thanx to nicolas314 !!
http://ubuntuforums.org/showpost.php?p=960171&postcount=2

just do that, before running qiv ...
export XLIB_SKIP_ARGB_VISUALS=1

Vassilis Pandis (pandisv) wrote :

Can someone that can reproduce it please provide a backtrace following http://wiki.ubuntu.com/DebuggingProgramCrash ? Thanks

Matt Zimmerman (mdz) wrote :

Interesting; qiv had been working fine for me for ages, on warty, hoary, breezy, dapper and edgy, but recently stopped working with the same symptoms described by manatlan (Gdk-ERROR **: BadMatch (invalid parameter attributes)).

XLIB_SKIP_ARGB_VISUALS does indeed work around the problem.

manatlan, in your original description you said that you saw a segmentation fault, but later a Gdk-ERROR, which is not the same thing. Were you experiencing a different problem before?

Matt Zimmerman (mdz) wrote :

(If there was a segmentation fault earlier, the Gdk-ERROR issue should be filed separately; if not, the original description should be corrected)

hi matt

Interesting; qiv had been working fine for me for ages, on warty, hoary,
> breezy, dapper and edgy,

i use qiv since the beginning, and it's started to fail with my fresh dapper
upgrade. (one week before the final release)

but recently stopped working with the same
> symptoms described by manatlan (Gdk-ERROR **: BadMatch (invalid
> parameter attributes)).
>
> XLIB_SKIP_ARGB_VISUALS does indeed work around the problem.
>
> manatlan, in your original description you said that you saw a
> segmentation fault, but later a Gdk-ERROR, which is not the same thing.
> Were you experiencing a different problem before?

now, i still have the gdk-error, but i'm pretty sure it made a "seg fault"
in the past (because it was a copy/paste of the error)
Sorry for this response, i can't reproduce the segfault ... now i still have
the gdk-error, but i use the workaround to bypass the trouble ...
sorry i can't help more

--
> qiv crash on dapper
> https://launchpad.net/bugs/41056
>

--
"Oui, oui."
                -- Shakespeare (Richard III, Acte I, Scène IV)

Matt Zimmerman (mdz) on 2006-09-27
description: updated
Changed in qiv:
status: Needs Info → Confirmed
Martin Pool (mbp) wrote :

Still failing for me with 2.0-4.2ubuntu1

BernardB (b-launchpad) wrote :

AFAICT, it's a bug with imlib1 and the X compositing extension. (see http://xorg.freedesktop.org/archive/X11R6.8.0/doc/RELNOTES5.html#40)

A temporary workaround might be to always force the environment variable, ala the attached patch. (works for me(tm)).

Karl Palsson (ubuntu-tweak) wrote :

This is the same "workaround" that fixes flashplugin-nonfree in firefox, and also fixes the doublesize xmms bug.

Can this sort of thing be bumped up a bit in priority? This is a full on regression from dapper.

BernardB (b-launchpad) wrote :

I just filed Bug #70367 with a patch for imlib, which I believe is the root cause of this qiv bug.

It doesn't look like the xmms or the flashplugin-nonfree bugs are caused by imlib though. However the imlib fix should hopefully resolve other bugs that haven't been reported yet.

Vassilis Pandis (pandisv) wrote :

Can somebody please test the patch and report success or failure? Thanks.

Matt Zimmerman (mdz) wrote :

I can no longer reproduce this with current Feisty:

ii gdk-imlib11 1.9.14-32ubuntu1 imaging library for use with gtk
ii qiv 2.0-7 A quick image viewer for X

Martin Pool (mbp) wrote :

Works for me too with the same feisty versions that mdz mentions. I think we can call it closed in Feisty.

Matt Zimmerman (mdz) wrote :

Marking as fixed; please reopen if this is still reproducible for someone on current Feisty.

Changed in qiv:
status: Confirmed → Fix Released
paul fox (pgf-launchpad) wrote :

i can reproduce this, running qiv on feisty, and displaying to a remote X11 server that's running gutsy.

let me know what i can do to help.

the workaround (setting XLIB_SKIP_ARGB_VISUALS before running qiv) works for me.

(i'm not sure how to "reopen" the bug. i'm happy to do so -- it's just not obvious where in the UI i should look.

paul

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers