Change log for qpdf package in Ubuntu

158 of 58 results
Published in disco-release on 2018-10-30
Published in cosmic-release on 2018-08-19
Deleted in cosmic-proposed (Reason: moved to release)
qpdf (8.2.1-1) unstable; urgency=medium

  * New upstream release.
  * Change interpreter path for fix-qdf to not use /usr/bin/env
  * Update standards version to 4.2.0

 -- Jay Berkenbilt <email address hidden>  Sat, 18 Aug 2018 11:21:48 -0400

Available diffs

Superseded in cosmic-release on 2018-08-19
Deleted in cosmic-proposed on 2018-08-20 (Reason: moved to release)
qpdf (8.2.0-1) unstable; urgency=medium

  * New upstream release.
  * Includes documentation fixes reported as debian bug. (Closes: #902642)

 -- Jay Berkenbilt <email address hidden>  Fri, 17 Aug 2018 21:32:53 -0400

Available diffs

Superseded in cosmic-release on 2018-08-18
Deleted in cosmic-proposed on 2018-08-19 (Reason: moved to release)
qpdf (8.1.0-1) unstable; urgency=medium

  * New upstream release.
  * Includes fix for CVE-2018-9918

 -- Jay Berkenbilt <email address hidden>  Sat, 23 Jun 2018 09:17:28 -0400

Available diffs

Published in trusty-updates on 2018-05-07
Published in trusty-security on 2018-05-07
qpdf (8.0.2-3~14.04.1) trusty-security; urgency=medium

  * SECURITY UPDATE: Updated to 8.0.2 to fix security issues.
    - CVE-2015-9252, CVE-2017-9208, CVE-2017-9209, CVE-2017-9210,
      CVE-2017-11624, CVE-2017-11625, CVE-2017-11626, CVE-2017-11627,
      CVE-2017-12595, CVE-2017-18183, CVE-2017-18184, CVE-2017-18185,
      CVE-2017-18186, CVE-2018-9918
  * Revert to debhelper 9:
    - debian/compat, debian/control: revert to 9.
    - debian/rules: remove dh_missing.
  * debian/patches/fix_pkgconfig.patch: libjpeg in trusty doesn't have
    pkgconfig support, remove it from libqpdf.pc.in.

 -- Marc Deslauriers <email address hidden>  Tue, 01 May 2018 13:52:40 -0400
Published in xenial-updates on 2018-05-07
Published in xenial-security on 2018-05-07
qpdf (8.0.2-3~16.04.1) xenial-security; urgency=medium

  * SECURITY UPDATE: Updated to 8.0.2 to fix security issues.
    - CVE-2015-9252, CVE-2017-9208, CVE-2017-9209, CVE-2017-9210,
      CVE-2017-11624, CVE-2017-11625, CVE-2017-11626, CVE-2017-11627,
      CVE-2017-12595, CVE-2017-18183, CVE-2017-18184, CVE-2017-18185,
      CVE-2017-18186, CVE-2018-9918
  * Revert to debhelper 9:
    - debian/compat, debian/control: revert to 9.
    - debian/rules: remove dh_missing.

 -- Marc Deslauriers <email address hidden>  Tue, 01 May 2018 12:40:34 -0400
Published in artful-updates on 2018-05-07
Published in artful-security on 2018-05-07
qpdf (8.0.2-3~17.10.1) artful-security; urgency=medium

  * SECURITY UPDATE: Updated to 8.0.2 to fix security issues.
    - CVE-2018-9918

 -- Marc Deslauriers <email address hidden>  Tue, 01 May 2018 12:37:47 -0400
Superseded in cosmic-release on 2018-06-23
Published in bionic-release on 2018-04-16
Deleted in bionic-proposed (Reason: moved to release)
qpdf (8.0.2-3) unstable; urgency=medium

  * Add patch for CVE-2018-9918 from upstream commit
    b4d6cf6836ce025ba1811b7bbec52680c7204223. (Closes: #895443)

 -- Jay Berkenbilt <email address hidden>  Sun, 15 Apr 2018 16:24:12 -0400

Available diffs

Superseded in bionic-release on 2018-04-16
Deleted in bionic-proposed on 2018-04-17 (Reason: moved to release)
qpdf (8.0.2-1) unstable; urgency=medium

  * New upstream release.

 -- Jay Berkenbilt <email address hidden>  Tue, 06 Mar 2018 11:54:54 -0500

Available diffs

Superseded in bionic-release on 2018-03-07
Deleted in bionic-proposed on 2018-03-08 (Reason: moved to release)
qpdf (8.0.1-1) unstable; urgency=medium

  * New upstream release.

 -- Jay Berkenbilt <email address hidden>  Sun, 04 Mar 2018 08:40:53 -0500

Available diffs

Superseded in bionic-release on 2018-03-06
Deleted in bionic-proposed on 2018-03-07 (Reason: moved to release)
qpdf (8.0.0-1) unstable; urgency=medium

  * New upstream release.

 -- Jay Berkenbilt <email address hidden>  Sun, 25 Feb 2018 16:55:10 -0500

Available diffs

Superseded in bionic-release on 2018-03-06
Deleted in bionic-proposed on 2018-03-08 (Reason: moved to release)
qpdf (7.1.1-1) unstable; urgency=medium

  * New upstream release.

 -- Jay Berkenbilt <email address hidden>  Sun, 04 Feb 2018 19:05:20 -0500

Available diffs

Superseded in bionic-release on 2018-02-05
Deleted in bionic-proposed on 2018-02-06 (Reason: moved to release)
qpdf (7.1.0-1) unstable; urgency=medium

  * New upstream release.
  * Update standards to 4.1.3. No changes required.

 -- Jay Berkenbilt <email address hidden>  Sun, 14 Jan 2018 22:22:11 -0500

Available diffs

Superseded in bionic-release on 2018-01-27
Published in artful-release on 2017-09-17
Deleted in artful-proposed (Reason: moved to release)
qpdf (7.0.0-1) unstable; urgency=medium

  * New upstream release.

 -- Jay Berkenbilt <email address hidden>  Fri, 15 Sep 2017 23:12:59 -0400

Available diffs

Superseded in artful-release on 2017-09-17
Deleted in artful-proposed on 2017-09-18 (Reason: moved to release)
qpdf (7.0~b1-3) experimental; urgency=medium

  * Redo debian rules to use dh over cdbs.
  * 7.0~b1 closes several bugs. (Closes: #863390, #871320, #825246)

 -- Jay Berkenbilt <email address hidden>  Thu, 24 Aug 2017 21:40:57 -0400
Superseded in artful-release on 2017-09-15
Deleted in artful-proposed on 2017-09-16 (Reason: moved to release)
qpdf (7.0~b1-0ubuntu1) artful; urgency=medium

  * New upstream release. Includes soname bump.
    - Adds support for PCLm output (to print on Mopria and Wi-Fi Direct
      driverless printers).
    - Tons of fixes for possible security vulnerabilities: CVE-2017-11624,
      CVE-2017-11625, CVE-2017-11626, CVE-2017-11627, CVE-2017-9208,
      CVE-2017-9209, CVE-2017-9210.

 -- Till Kamppeter <email address hidden>  Tue, 22 Aug 2017 18:56:00 -0300
Superseded in artful-release on 2017-08-25
Deleted in artful-proposed on 2017-08-26 (Reason: moved to release)
qpdf (6.0.0-2ubuntu1) artful; urgency=medium

  * Fixed zlib data error handling (LP: #1670730, Upstream Issue #106).

 -- Till Kamppeter <email address hidden>  Fri, 18 Aug 2017 11:06:00 -0300
Superseded in artful-release on 2017-08-18
Obsolete in zesty-release on 2018-06-22
Obsolete in yakkety-release on 2018-01-23
Published in xenial-release on 2015-11-20
Deleted in xenial-proposed (Reason: moved to release)
qpdf (6.0.0-2) unstable; urgency=medium

  * Upload to unstable.

 -- Jay Berkenbilt <email address hidden>  Mon, 16 Nov 2015 14:10:13 -0500

Available diffs

Superseded in xenial-release on 2015-11-20
Deleted in xenial-proposed on 2015-11-24 (Reason: moved to release)
qpdf (5.2.0-2) unstable; urgency=medium

  * Revert ABI change. This is reverts the deterministic ID change
    introduced in 5.2.0 but retains the other fix. 6.0.0 will be released
    imminently with the new functionality. This version is compatible with
    5.1.3. (Closes: #804706)

 -- Jay Berkenbilt <email address hidden>  Tue, 10 Nov 2015 13:08:28 -0500

Available diffs

Superseded in xenial-release on 2015-11-11
Deleted in xenial-proposed on 2015-11-12 (Reason: moved to release)
qpdf (5.2.0-1) unstable; urgency=medium

  * New upstream release.

 -- Jay Berkenbilt <email address hidden>  Sun, 01 Nov 2015 16:48:58 -0500

Available diffs

Superseded in xenial-release on 2015-11-08
Deleted in xenial-proposed on 2015-11-09 (Reason: moved to release)
qpdf (5.1.3-3) unstable; urgency=high

  * Update copyright to include a few files that had separate copyrights
    from the rest of the software. (Closes: #794555)

 -- Jay Berkenbilt <email address hidden>  Sun, 06 Sep 2015 18:37:40 -0400

Available diffs

Superseded in xenial-release on 2015-10-24
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed on 2018-01-22 (Reason: moved to release)
qpdf (5.1.3-2) unstable; urgency=medium

  * Upload for gcc5 transition. Rename libqpdf13 to libqpdf13v5.
    (Closes: #791255)

 -- Jay Berkenbilt <email address hidden>  Mon, 03 Aug 2015 09:39:26 -0400

Available diffs

Superseded in wily-release on 2015-08-11
Deleted in wily-proposed on 2015-08-13 (Reason: moved to release)
qpdf (5.1.3-1) unstable; urgency=medium

  * New upstream release. Includes all previous patches.
  * Update standards to 3.9.6. No changes required.
  * Fix typo in package description. (Closes: #779192)

 -- Jay Berkenbilt <email address hidden>  Sun, 24 May 2015 17:47:05 -0400

Available diffs

Superseded in wily-release on 2015-05-25
Obsolete in vivid-release on 2018-01-18
Deleted in vivid-proposed on 2018-01-19 (Reason: moved to release)
qpdf (5.1.2-3) experimental; urgency=medium


  * Handle broken PDF files with missing /Type keys in their page
    dictionary nodes. (Uploaded to experimental during debian freeze --
    this is production-ready.)

 -- Jay Berkenbilt <email address hidden>  Mon, 29 Dec 2014 10:27:12 -0500

Available diffs

Superseded in vivid-release on 2015-01-02
Deleted in vivid-proposed on 2015-01-03 (Reason: moved to release)
qpdf (5.1.2-2) unstable; urgency=medium


  * Properly handle pages with no /Content in the page dictionary,
    enabling printing of files with blank pages as produced by some
    software. (Closes: #769599)

 -- Jay Berkenbilt <email address hidden>  Fri, 14 Nov 2014 21:07:25 -0500

Available diffs

Superseded in vivid-release on 2014-11-15
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed on 2016-11-03 (Reason: moved to release)
qpdf (5.1.2-1) unstable; urgency=medium


  * New upstream release.

 -- Jay Berkenbilt <email address hidden>  Sat, 07 Jun 2014 17:13:43 -0400

Available diffs

Superseded in utopic-release on 2014-06-08
Published in trusty-release on 2014-01-15
Deleted in trusty-proposed (Reason: moved to release)
qpdf (5.1.1-1) unstable; urgency=medium


  * New upstream release.

 -- Jay Berkenbilt <email address hidden>  Tue, 14 Jan 2014 15:51:35 -0500

Available diffs

Superseded in trusty-release on 2014-01-15
Deleted in trusty-proposed on 2014-01-16 (Reason: moved to release)
qpdf (5.1.0-1) unstable; urgency=medium


  * New upstream release
  * Use dh-autoreconf (Closes: #732093)
  * Update stanards to 3.9.5.  No changes required.

 -- Jay Berkenbilt <email address hidden>  Tue, 17 Dec 2013 15:50:11 -0500
Superseded in trusty-release on 2013-12-19
Deleted in trusty-proposed on 2013-12-21 (Reason: moved to release)
qpdf (5.0.1-1ubuntu1) trusty; urgency=low

  * Use dh-autoreconf in order to update libtool.m4 for new ports.
 -- Colin Watson <email address hidden>   Fri, 13 Dec 2013 20:35:36 +0000
Superseded in trusty-release on 2013-12-13
Deleted in trusty-proposed on 2013-12-15 (Reason: moved to release)
qpdf (5.0.1-1) unstable; urgency=low


  * New upstream release

 -- Jay Berkenbilt <email address hidden>  Fri, 18 Oct 2013 12:53:02 -0400

Available diffs

Superseded in trusty-release on 2013-10-24
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed on 2015-04-28 (Reason: moved to release)
qpdf (4.2.0-2) unstable; urgency=low


  * Revert ABI change caused by bug fix.  The bug fix will be re-released
    in qpdf 5.0.0.  (Closes: #715448)

 -- Jay Berkenbilt <email address hidden>  Wed, 10 Jul 2013 13:00:43 -0400

Available diffs

Superseded in saucy-release on 2013-07-11
Deleted in saucy-proposed on 2013-07-12 (Reason: moved to release)
qpdf (4.2.0-1) unstable; urgency=low


  * New upstream release

 -- Jay Berkenbilt <email address hidden>  Sun, 07 Jul 2013 19:05:03 -0400

Available diffs

Superseded in saucy-release on 2013-07-08
Deleted in saucy-proposed on 2013-07-09 (Reason: moved to release)
qpdf (4.1.0-2) unstable; urgency=low


  * Re-upload to unstable.
  * Build depend on autotools-dev to always get latest config.sub and
    config.guess
  * Update standards version to 3.9.4.  No changes made.  (qpdf is a C++
    library with versioned symbols that version "*", so we continue to use
    a shlibs file instead of a symbols file.)

 -- Jay Berkenbilt <email address hidden>  Tue, 07 May 2013 14:15:47 -0400

Available diffs

Superseded in saucy-release on 2013-05-08
Obsolete in raring-release on 2015-04-24
Deleted in raring-proposed on 2015-04-27 (Reason: moved to release)
qpdf (4.0.1-2) experimental; urgency=low


  * Bug fix: proper handling of overridden compressed objects.  This fix
    is backported from upstream and will be part of 4.1.0.

 -- Jay Berkenbilt <email address hidden>  Sat, 23 Feb 2013 18:11:56 -0500

Available diffs

Superseded in raring-release on 2013-03-11
Obsolete in quantal-release on 2015-04-24
qpdf (3.0.2-1) experimental; urgency=low


  * New upstream release

 -- Jay Berkenbilt <email address hidden>  Thu, 06 Sep 2012 16:42:48 -0400

Available diffs

Superseded in quantal-release on 2012-09-07
Superseded in quantal-release on 2012-08-20
qpdf (3.0.1-1) experimental; urgency=low


  * New upstream release

 -- Jay Berkenbilt <email address hidden>  Sat, 11 Aug 2012 13:58:29 -0400

Available diffs

Superseded in quantal-release on 2012-08-14
qpdf (3.0.0-2) experimental; urgency=low


  * Package .pc file in dev package.

 -- Jay Berkenbilt <email address hidden>  Thu, 09 Aug 2012 21:20:22 -0400

Available diffs

Superseded in quantal-release on 2012-08-13
qpdf (3.0.0-1) experimental; urgency=low


  * New upstream release
  * Note: this release is fully production-ready.  It has been uploaded to
    debian experimental only because of the Wheezy freeze in effect at the
    time of upload.

 -- Jay Berkenbilt <email address hidden>  Thu, 02 Aug 2012 06:36:49 -0400

Available diffs

Superseded in quantal-release on 2012-08-02
qpdf (2.3.1-4) unstable; urgency=low


  * Work around portability issues exposed by upgrading to gcc 4.7.  The
    next upstream version of qpdf will handle these properly.  (Closes:
    #673404)

 -- Jay Berkenbilt <email address hidden>  Sat, 19 May 2012 09:21:52 -0400

Available diffs

Superseded in quantal-release on 2012-05-21
qpdf (2.3.1-3) unstable; urgency=low


  * Enable hardening and multiarch.

 -- Jay Berkenbilt <email address hidden>  Sun, 22 Apr 2012 10:51:21 -0400

Available diffs

Superseded in quantal-release on 2012-05-03
qpdf (2.3.1-2) unstable; urgency=low


  * Fix to work with pcre 8.30.  (Closes: #666308)
  * Update standards to 3.9.3.
  * Fix typo in zlib-flate manual page.  Thanks A. Costa.  (Closes:
    #666983)

 -- Jay Berkenbilt <email address hidden>  Fri, 06 Apr 2012 21:45:43 -0400

Available diffs

Superseded in quantal-release on 2012-05-01
Published in precise-release on 2012-01-08
qpdf (2.3.1-1) unstable; urgency=low


  * New upstream release
  * Release includes documentation fixes reported in debian bug reports.
    (Closes: #638038, #636931)

 -- Jay Berkenbilt <email address hidden>  Wed, 28 Dec 2011 17:38:56 -0500
Superseded in precise-release on 2012-01-08
qpdf (2.3.0-1build1) precise; urgency=low

  * No-change rebuild to drop spurious libsfgcc1 dependency on armhf.
 -- Adam Conrad <adconrad@0c3.net>   Fri, 02 Dec 2011 21:05:45 -0700

Available diffs

Superseded in precise-release on 2011-12-03
qpdf (2.3.0-1) unstable; urgency=low

  * New upstream release
 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  17 Oct 2011 15:30:47 +0000

Available diffs

Superseded in precise-release on 2011-10-17
Obsolete in oneiric-release on 2015-04-24
qpdf (2.2.4-1) unstable; urgency=low

  * New upstream release.
  * -Werror is now disabled by default, so it is no longer disabled
    explicitly in debian/rules.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  27 Jun 2011 08:07:52 +0000

Available diffs

Superseded in oneiric-release on 2011-06-27
qpdf (2.2.3-2) unstable; urgency=low

  * Disable -Werror for debian builds. (Closes: #625420)
 -- Ubuntu Archive Auto-Sync <email address hidden>   Sun,  08 May 2011 07:36:40 +0000

Available diffs

Superseded in oneiric-release on 2011-05-08
qpdf (2.2.3-1) unstable; urgency=low

  * New upstream release
  * Updated standards to 3.9.2.  No changes required.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Sun,  01 May 2011 08:02:07 +0000

Available diffs

Superseded in oneiric-release on 2011-05-01
Obsolete in natty-release on 2013-06-04
qpdf (2.2.2-1) unstable; urgency=low

  * New upstream release

Available diffs

Superseded in natty-release on 2010-10-15
Obsolete in maverick-release on 2013-03-05
qpdf (2.1.5-1) unstable; urgency=low

  * New upstream release

Available diffs

Superseded in maverick-release on 2010-05-09
Obsolete in lucid-release on 2016-10-26
qpdf (2.1.2-1) unstable; urgency=low

  * New upstream release
 -- Ubuntu Archive Auto-Sync <email address hidden>   Thu,  04 Feb 2010 17:27:09 +0000

Available diffs

Superseded in lucid-release on 2010-02-04
qpdf (2.1.1-1) unstable; urgency=low

  * New upstream release
  * Updated source format to '3.0 (quilt)'
  * Upstream release builds with gcc 4.4. (Closes: #559877)
 -- Bhavani Shankar <email address hidden>   Mon,  11 Jan 2010 05:53:08 +0000

Available diffs

Superseded in lucid-release on 2010-01-11
qpdf (2.1-1ubuntu1) lucid; urgency=low

  * libqpdf/qpdf/Pl_AES_PDF.hh: Add missing "#include <stdint.h>".
 -- Michael Bienia <email address hidden>   Mon, 07 Dec 2009 11:09:45 +0100

Available diffs

Superseded in lucid-release on 2009-12-07
qpdf (2.1-1) unstable; urgency=low

  * New upstream release

Available diffs

Superseded in lucid-release on 2009-11-23
Obsolete in karmic-release on 2013-03-04
qpdf (2.0.6-1) unstable; urgency=low

  * New upstream release
  * New release includes a fix for streams with decode parameters that
    qpdf doesn't understand.  (It ignores them and leaves the streams
    unfiltered instead of giving an error message.)
  * Updated standards version to 3.8.1.  No changes required.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  04 May 2009 08:23:15 +0100

Available diffs

Superseded in karmic-release on 2009-05-04
qpdf (2.0.5-1) unstable; urgency=low

  * New upstream release
  * New release includes fixes to LZW decoder and improved features for
    handling files with damaged streams.

Available diffs

Superseded in karmic-release on 2009-04-29
Obsolete in jaunty-release on 2013-02-28
Obsolete in intrepid-release on 2013-02-20
qpdf (2.0.2-1) unstable; urgency=low

  * New upstream release.  All debian changes incorporated.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  04 Jul 2008 08:45:00 +0100

Available diffs

Superseded in intrepid-release on 2008-07-04
qpdf (2.0.1-3) unstable; urgency=low

  * Fix bashism in test suite.  (Closes: #485047)
  * Update standards version to 3.8.0 by adding a debian/README.source
    file.  NO other changes were required.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Sun,  08 Jun 2008 21:02:39 +0100

Available diffs

Superseded in intrepid-release on 2008-06-09
qpdf (2.0.1-2) unstable; urgency=low

  * Increase timeout in test driver to be more tolerant of slow build
    systems.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Thu,  08 May 2008 11:59:05 +0100
Superseded in intrepid-release on 2008-05-08
qpdf (2.0.1-1) unstable; urgency=low

  * New upstream release
  * All debian patches incorporated.

158 of 58 results