qt-x11-free 3:3.3.5-1ubuntu11 causes xim failure

Bug #6606 reported by atie on 2006-01-10
8
Affects Status Importance Assigned to Milestone
qt-x11-free (Ubuntu)
Medium
Unassigned

Bug Description

After installation of qt-x11-free 3:3.3.5-1ubuntu11, my xim (nabi) is out of order - not activated by it's activatation key. It's fine with GNOME applications. So, I strongly suspect because of this,

"Applied patch for the immodule which has problems with KeyRelease events
and preventing some applications from working properly (e.g. Katapult,
Opera)"

atie (atie-at-matrix) wrote :

Installed 3.3.5-1ubuntu12 and 13, no luck.

Could someone explain this,
"Added kubuntu_04_immodule_quietxi.,dpatch, but not applied yet. Will be
enabled just before release, to make the immodule added patches a bit more
 silent."
Does it mean this bug will be fixed just before release?

Stephan Ruegamer (sadig) wrote :

It means, that it will make the noisy and not well written debug code silent.

Ming Hua (minghua) wrote :

I have similar problem with scim in XIM mode. I can't say this is a regression though since that's the first time I installed KDE (to test scim, doh). In my case, scim can be started but Ctrl-space can't activate the input method. GTK+ applications can use scim's GTK IM mode in KDE just fine.

The versions of related packages:
libqt3-mt 3.3.5-1ubuntu13
kdelibs4c2a 3.5.0-0ubuntu4
scim 1.4.2-1

I don't have skim or scim-qtimm installed.

Stephan Ruegamer (sadig) wrote :

Ok,

if you want to help me to track down this problem..could you please explain what do I have to do, to enable this input method.

Anyways, we only have to ways: 1. remove the immodule patch from qt completly, or 2. we try to fix it, which is quite difficult, because nobody fixed the other issues in more then 1 1/2 years time :(

So, I need a small workflow how to get everything installed and configured, and how I can use it.

Please put it into the bugreport here, or send me an email to <email address hidden>.

thx,

\sh

Ming Hua (minghua) wrote :

Okay, since many developers are not familar with input methods at all, I'll give some background introduction.

SCIM supports three input method mode: XIM mode, GTK IM mode, and Qt IM mode. XIM mode is an old and established protocol, implemented by XFree86/Xorg (I don't know exactly which part). Both GTK and Qt IM mode are rather new. GTK IM mode is implemented by GTK+ 2.x, and Qt IM mode is implemented by said patch to Qt 3 and (according to what I heard) Qt 4 upstream.

SCIM has XIM mode support by default. The GTK IM mode support is in scim-gtk2-immodule package. The Qt IM mode is in scim-qtimm package.

GTK+/Qt apps can also use XIM mode _in additional to_ the GTK/Qt IM mode. The environment variable GTK_IM_MODULE and QT_IM_MODULE is used to control which mode is used. Non GTK+/Qt apps (such as Motif ones) can only use XIM mode.

This bug is about XIM mode not working in KDE. On IRC freeflying said skim/scim-qtimm works fine, but I suspect that means those Qt applications are using the Qt IM mode, not XIM mode. Also in my testing GTK+ apps works fine with scim in GTK IM mode (but non-GTK apps, including Qt apps, don't have input method).

One thing worth trying is to see if apps using neither GTK nor Qt works in KDE, for example xterm. It works fine for me in GNOME. This really requires someone familar with input methods, though. Or a step-by-step howto by someone familar with IMs.

atie (atie-at-matrix) wrote :

I have currently installed the followings related to this problem,
nabi 0.15-2
im-switch 1.3
libqt3-mt 3.3.5-1ubuntu13
and I use nabi for GNOME and KDE applications within Dapper GNOME.

To Test this problem,
- Install nabi and im-switch
- On command line do "im-switch -s nabi" which creates ~/.xinput.d/en_US if your locale is en_US (I am using en_US)
- Restart X, you can see icon of nabi on the system tray, if not type nabi from mini-command applet or terminal
- Open a GNOME program like as gedit, press shift-space to toggle Hangul/English - icon of nabi is changed to show status.
- With qt-x11-free 3.3.5-1ubuntu11(or above) or without (less than 11), open a KDE program like as kate, press shift-space - you may see this problem - nabi doesn't activate.

atie (atie-at-matrix) wrote :

I concur with what Ming Hua wrote in above, because ~/.xinput.d/en_US has following lines.

XIM=nabi
XIM_PROGRAM=/usr/bin/nabi
XIM_ARGS=
GTK_IM_MODULE=xim

So nabi should work as XIM for KDE applications in this case.

atie (atie-at-matrix) wrote :

OK, the patch is for immodule, but I coudn't find libqxim.so in the plugins directory - there is no inputmethods directory under /usr/lib/qt3/plugins.

SUSE has these in the directory.
/usr/lib/qt3/plugins/inputmethods/libqimsw-multi.so
/usr/lib/qt3/plugins/inputmethods/libqimsw-none.so
/usr/lib/qt3/plugins/inputmethods/libqsimple.so
/usr/lib/qt3/plugins/inputmethods/libqxim.so

Stephan Ruegamer (sadig) wrote :

Right,

see the mistake in the package now. Those files are not installed (missing in action) I will fix this now.

ZhengPeng Hou (zhengpeng-hou) wrote :

1: to: minghua :
   I've said skim can work with grk program but not qt/kde , also scim-qtimm will not work
2 : suzhe , who is the author of scim told me that QT_IM_SWITCHER should be ste for scim-qtimm
3: why can't be activeated ,and there have libscim.so in plugings dir.
4: To : sh:
I'd prefer to remove qtimmodule completely . we'd have a input method in kde firstly .

atie (atie-at-matrix) wrote :

I am not sure that we'd prefer to remove qtimmodule completely because indeed Opera has a problem with XIM which is if I input English in any text box it is OK, but if input Korean my typing goes backward. So I hope the patch may fix this problem and I'd like to test it. And, FYI the problem on Opera happens with 9.0 preview version but not with 8.5 version as far as I know.

atie (atie-at-matrix) wrote :

Thank you, Stephan. 3.3.5-1ubuntu14 fixed the xim failure.

But, the Opera problem with 9.0 preview is worse than before, previously I could type Korean even though it goes backward, but this time no Korean charaters are shown nor spaces. And, even with 8.51 same problem happens now which was OK before so I guess the patch impacts on this.

I will create a separate report if it's required, Stephan could you give me some instructions how I can narrow down this opera problem.

On Sat, Jan 14, 2006 at 08:11:57AM -0000, Stephan Hermann wrote:
>
> see the mistake in the package now. Those files are not installed
> (missing in action) I will fix this now.

With libqt3-mt 3.3.5-1ubuntu14, scim can be activated at XIM mode in KDE
now. So I believe this bug is fixed. I'll leave it open waiting for
atie to confirm the fix for nabi though.

Just for the record, although scim can be activated at XIM mode, it
doesn't work properly (at least not for scim-pinyin). This is not
related to this bug though, as I've see the same problem it in GNOME as
well.

Ming
2006.01.14

Stephan Ruegamer (sadig) wrote :

Ok, Mig Hua told me, that now the XIM works.
That is, first of all, a good message *phew*.

Now we have to address some other issues:

1. the patch I added is to fix KeyRelease events. The original qt-immodule patch is being know, to have issues with it.
The applied patch is a workaround, until upstream of this patch addresses those issues with KeyRelease Events in QT. Means, I don't change it now, because it fixes other troubles with katapult e.g.
(see http://lists.freedesktop.org/archives/immodule-qt/2005-June/000732.html)

2. Opera
It would be nice, if opera was opensource, which is not the case. Is the problem only occuring with the dynamic linked version of opera, or as well with the static linked version?
But this shouldn't be addressed here, better is to file a bug at opera and another one regarding this issue here.
Please put this bug report url as a reminder into your report :)

Thx for reporting the bug, and thx to everybody who was testing.

Changed in qt-x11-free:
status: Unconfirmed → Fix Released
atie (atie-at-matrix) wrote :

Just for the record, I used opera 8.51-20051114.6-shared-qt_en_etch_i386 and 9.0-20051020.6-shared-qt_en_etch_i386.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers