Change log for rakudo package in Ubuntu

145 of 45 results
Published in eoan-release on 2019-04-18
Published in disco-release on 2019-01-10
Deleted in disco-proposed (Reason: moved to release)
rakudo (2018.12-5) unstable; urgency=medium

  * Execute last test run without spesh

 -- Robert Lemmen <email address hidden>  Wed, 09 Jan 2019 18:59:57 +0100

Available diffs

Superseded in disco-proposed on 2019-01-09
rakudo (2018.12-4) unstable; urgency=medium

  * Run tests more often on failures to get data on flappers

 -- Robert Lemmen <email address hidden>  Fri, 04 Jan 2019 20:02:29 +0100

Available diffs

Superseded in disco-proposed on 2019-01-04
rakudo (2018.12-3) unstable; urgency=medium

  * Remove unused libreadline dependency

 -- Robert Lemmen <email address hidden>  Mon, 31 Dec 2018 10:52:35 +0100

Available diffs

Superseded in disco-proposed on 2018-12-31
rakudo (2018.12-2) unstable; urgency=medium

  * No longer fail if precomp files do not exist on removal (closes: #916646)
  * Make vendor/resources explicit in package (closes: #915785)

 -- Robert Lemmen <email address hidden>  Sun, 30 Dec 2018 12:54:52 +0100

Available diffs

Superseded in disco-proposed on 2018-12-30
rakudo (2018.12-1) unstable; urgency=medium

  * New upstream version 2018.12
  * control: update moarvm-dev and nqp dep versions

 -- Robert Lemmen <email address hidden>  Sat, 22 Dec 2018 14:51:21 +0100

Available diffs

Superseded in disco-proposed on 2018-12-22
rakudo (2018.11-1) unstable; urgency=medium

  * New upstream version 2018.11
  * control: update moarvm-dev and nqp dep versions

 -- Robert Lemmen <email address hidden>  Sat, 01 Dec 2018 19:09:33 +0100

Available diffs

Superseded in disco-release on 2019-01-10
Deleted in disco-proposed on 2019-01-11 (Reason: moved to release)
rakudo (2018.10-1) unstable; urgency=medium

  * New upstream version 2018.10
  * control: update moarvm-dev and nqp dep versions

 -- Robert Lemmen <email address hidden>  Thu, 15 Nov 2018 21:15:18 +0100

Available diffs

Superseded in disco-release on 2018-11-26
Deleted in disco-proposed on 2018-11-27 (Reason: moved to release)
rakudo (2018.09-2) unstable; urgency=medium

  * Fix install-dist.p6 location in rakudo-helper.pl (closes: #909698)

 -- Robert Lemmen <email address hidden>  Fri, 28 Sep 2018 10:17:52 +0200

Available diffs

Superseded in disco-release on 2018-11-11
Published in cosmic-release on 2018-06-28
Deleted in cosmic-proposed (Reason: moved to release)
rakudo (2018.06-1) unstable; urgency=medium

  * New upstream version 2018.06
  * control: update moarvm-dev and nqp dep versions
  * postinst script and rakudo-helper to support upgrades
    and module package precompilation and cleanup

 -- Robert Lemmen <email address hidden>  Wed, 27 Jun 2018 19:03:19 +0200
Superseded in cosmic-proposed on 2018-06-27
rakudo (2018.05-1build1) cosmic; urgency=medium

  * No-change rebuild for moarvm soname change.

 -- Matthias Klose <email address hidden>  Wed, 27 Jun 2018 20:02:49 +0200
Superseded in cosmic-release on 2018-06-28
Deleted in cosmic-proposed on 2018-06-29 (Reason: moved to release)
rakudo (2018.05-1) unstable; urgency=medium

  * New upstream version 2018.05
  * control: update moarvm-dev and nqp dep versions
  * add rakudo-helper script

 -- Robert Lemmen <email address hidden>  Sat, 26 May 2018 14:14:12 +0200

Available diffs

Superseded in cosmic-release on 2018-05-26
Deleted in cosmic-proposed on 2018-05-28 (Reason: moved to release)
rakudo (2018.04.1-1) unstable; urgency=medium

  * New upstream version 2018.04.1
  * control: update moarvm-dev and nqp dep versions

 -- Robert Lemmen <email address hidden>  Mon, 30 Apr 2018 09:23:09 +0200

Available diffs

Superseded in cosmic-release on 2018-05-05
Published in bionic-release on 2018-04-07
Deleted in bionic-proposed (Reason: moved to release)
rakudo (2018.03-1) unstable; urgency=medium

  * New upstream version 2018.03
  * control: update moarvm-dev and nqp dep versions (cme)
  * control: update Vcs-Browser and Vcs-Git
  * update copyright info (cme)
  * add instructions about signature file in README.source
  * refreshed patch

 -- Dominique Dumont <email address hidden>  Tue, 03 Apr 2018 19:33:16 +0200
Superseded in bionic-proposed on 2018-04-07
rakudo (2018.02.1-2) unstable; urgency=medium

  * control: breaks and replaces rakudo-lib (Closes: #891693)

 -- Dominique Dumont <email address hidden>  Wed, 28 Feb 2018 17:17:12 +0100

Available diffs

Superseded in bionic-proposed on 2018-02-28
rakudo (2018.02.1-1) unstable; urgency=medium

  * setup gpg check of upstream tarball
  * New upstream version 2018.02.1
  * control: update moarvm-dev and nqp dep versions (cme)

 -- Dominique Dumont <email address hidden>  Sun, 25 Feb 2018 14:32:50 +0100

Available diffs

Superseded in bionic-proposed on 2018-02-25
rakudo (2018.01-1) unstable; urgency=medium

  * New upstream version 2018.01
  * control: update moarvm-dev and nqp dep versions (cme)
  * control: declare compliance with policy 4.1.3
  * refreshed copyright info with cme
  * rules: fix libdir

 -- Dominique Dumont <email address hidden>  Wed, 07 Feb 2018 19:07:06 +0100

Available diffs

Superseded in bionic-proposed on 2018-02-07
rakudo (2017.10-1) unstable; urgency=medium

  * New upstream version 2017.10
  * control: remove rakudo-lib package
  * control: update moarvm-dev and nqp dep versions (cme)
  * control: declare compliance with policy 4.1.1
  * disable obsolete fix-lib-install-dir patch
  * rules: use --libdir=/usr/lib/perl6 option. Many thanks to
    Gerd Pokorra from Fedora for the help.
  * rules: change install dir
  * remove debian/install
  * add link for perl6-lldb-m man page

 -- Dominique Dumont <email address hidden>  Wed, 01 Nov 2017 19:29:28 +0100
Superseded in bionic-release on 2018-04-07
Published in artful-release on 2017-06-28
Deleted in artful-proposed (Reason: moved to release)
rakudo (2017.06-1) unstable; urgency=medium

  [ Daniel Dehennin ]
  * New upstream version 2017.06
  * control: update moarvm-dev and nqp dep versions

  [ Dominique Dumont ]
  * control: Declare compliance with policy 4.0.0

 -- Daniel Dehennin <email address hidden>  Sat, 24 Jun 2017 00:29:57 +0200

Available diffs

Superseded in artful-release on 2017-06-28
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed on 2018-06-22 (Reason: moved to release)
rakudo (2016.12-1) unstable; urgency=medium

  * New upstream version 2016.12
  * refreshed patches
  * control: update moarvm-dev and nqp dep versions (cme)

 -- Dominique Dumont <email address hidden>  Tue, 20 Dec 2016 13:33:04 +0100

Available diffs

Superseded in zesty-release on 2016-12-21
Deleted in zesty-proposed on 2016-12-22 (Reason: moved to release)
rakudo (2016.11-1) unstable; urgency=medium

  * New upstream version 2016.11
  * removed patch (applied upstream)
  * refreshed patch
  * control: update moarvm-dev and nqp dep versions (cme)

 -- Dominique Dumont <email address hidden>  Mon, 28 Nov 2016 13:48:20 +0100

Available diffs

Superseded in zesty-release on 2016-11-28
Deleted in zesty-proposed on 2016-11-30 (Reason: moved to release)
rakudo (2016.10-1) unstable; urgency=medium

  Many thanks to Tobias Leich (FROGGS) who did a terrific job
  porting rakudo on all architectures supported by Debian.
  * New upstream version 2016.10
  * control:
    * updated moarvm-dev and nqp dep versions (cme)
    * enable mips mipsel mips64el (Closes: #841346)
    * enable s390x
  * update patch to tweak pod doc

 -- Dominique Dumont <email address hidden>  Mon, 31 Oct 2016 09:27:45 +0100
Superseded in zesty-release on 2016-11-03
Deleted in zesty-proposed on 2016-11-04 (Reason: moved to release)
Deleted in yakkety-proposed on 2016-11-04 (Reason: Moved to zesty-proposed)
rakudo (2016.07.1-1build1) yakkety; urgency=medium

  * No-change rebuild for updated moarvm.

 -- Matthias Klose <email address hidden>  Fri, 02 Sep 2016 09:44:31 +0200
Superseded in yakkety-proposed on 2016-09-02
rakudo (2016.07.1-1) unstable; urgency=medium

  * Imported Upstream version 2016.07.1
  * Refresh patch
  * control: updated moarvm-dev and nqp dep versions
  * copyright: updated with cme

 -- Daniel Dehennin <email address hidden>  Sat, 23 Jul 2016 15:45:55 +0200

Available diffs

Superseded in zesty-release on 2016-10-22
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed on 2018-01-23 (Reason: moved to release)
rakudo (2016.06-1) unstable; urgency=medium

  * Imported Upstream version 2016.06
  * use cme function in update-control.pl
  * control: updated moarvm-dev and nqp dep versions (cme)
  * use simple BTS url in patch header (cme)
  * copyright: use https for Format parameter (cme)

 -- Dominique Dumont <email address hidden>  Thu, 07 Jul 2016 13:11:00 +0200

Available diffs

Superseded in yakkety-release on 2016-07-08
Deleted in yakkety-proposed on 2016-07-09 (Reason: moved to release)
rakudo (2016.05-2) unstable; urgency=medium

  * added lintian overrides for /usr/share/perl6/site/lib

 -- Dominique Dumont <email address hidden>  Thu, 02 Jun 2016 10:51:24 +0200

Available diffs

Superseded in yakkety-release on 2016-06-03
Deleted in yakkety-proposed on 2016-06-05 (Reason: moved to release)
rakudo (2016.04-1) unstable; urgency=medium

  * Imported Upstream version 2016.04
  * added debian/update-control.pl script...
  * control:
    * updated moarvm-dev and nqp dep versions
    * Standards-Version: '3.9.7' -> '3.9.8'

 -- Dominique Dumont <email address hidden>  Mon, 25 Apr 2016 13:56:27 +0200
Superseded in yakkety-release on 2016-04-28
Published in xenial-release on 2016-02-22
Deleted in xenial-proposed (Reason: moved to release)
rakudo (2015.11-2build1) xenial; urgency=medium

  * No-change rebuild for updated nqb.

 -- Matthias Klose <email address hidden>  Mon, 22 Feb 2016 13:07:04 +0100
Superseded in xenial-release on 2016-02-22
Deleted in xenial-proposed on 2016-02-23 (Reason: moved to release)
rakudo (2015.11-2) unstable; urgency=medium

  * patch to fix lib path (Closes: #809372)
  * control: removed mipsel arch
  * control: updated version of moarvm-dev and nqp build deps
    Dependencies are restricted to current upstream version
    (i.e. 2015.11* for this version)
  * rules: restrict run-time dep on moarvm

 -- Dominique Dumont <email address hidden>  Thu, 07 Jan 2016 18:38:48 +0100

Available diffs

Superseded in xenial-release on 2016-01-08
Deleted in xenial-proposed on 2016-01-09 (Reason: moved to release)
rakudo (2015.11-1) unstable; urgency=medium

  * control: add dep on libkvm-dev and libffi-dev (Closes: #801478)
  * Imported Upstream version 2015.11
  * refreshed fix-lib-install-dir patch

 -- Dominique Dumont <email address hidden>  Sun, 27 Dec 2015 18:34:32 +0100
Superseded in xenial-proposed on 2015-12-27
rakudo (2015.09-2) unstable; urgency=medium

  * rules: fix nqp dependency setup
  * README.source: added explanations on nqp dependency

 -- Dominique Dumont <email address hidden>  Sat, 10 Oct 2015 10:27:39 +0200
Superseded in xenial-release on 2015-12-30
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed on 2018-01-22 (Reason: moved to release)
rakudo (2014.07-4build1) wily; urgency=medium

  * No-change rebuild against libicu55

 -- Steve Langasek <email address hidden>  Fri, 07 Aug 2015 01:31:10 +0000
Superseded in wily-release on 2015-08-12
Obsolete in vivid-release on 2018-01-18
Deleted in vivid-proposed on 2018-01-19 (Reason: moved to release)
rakudo (2014.07-4) unstable; urgency=medium


  * control: reduced supported arch to the ones working with nqp

 -- Dominique Dumont <email address hidden>  Tue, 16 Sep 2014 10:32:55 +0200

Available diffs

Superseded in vivid-release on 2014-12-02
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed on 2016-11-03 (Reason: moved to release)
rakudo (2014.03.01-1) unstable; urgency=low


  [ Alessandro Ghedini ]
  * Remove myself from Uploaders

  [ Dominique Dumont ]
  * Imported Upstream version 2014.03.01
  * copyright: updated years
  * added links for perl-p and perl-debug-p man page
  * control: updated BD on nqp and parrot, added libgmp-dev

 -- Dominique Dumont <email address hidden>  Sat, 12 Apr 2014 12:26:28 +0200

Available diffs

Superseded in utopic-release on 2014-07-16
Published in trusty-release on 2013-12-31
Deleted in trusty-proposed (Reason: moved to release)
rakudo (2013.12-1) unstable; urgency=medium


  * New upstream release
  * Bump versioned Build-Depends on nqp to 2013.12.1
  * Bump Standards-Version to 3.9.5 (no changes needed)

 -- Alessandro Ghedini <email address hidden>  Mon, 23 Dec 2013 12:27:17 +0100
Superseded in trusty-proposed on 2013-12-23
rakudo (2013.11-1) unstable; urgency=low


  * New upstream release
  * Use --prefix instead of --with-nqp in Configure.pl
  * Bump versioned nqp (Build-)Depends

 -- Alessandro Ghedini <email address hidden>  Sun, 24 Nov 2013 17:46:54 +0100

Available diffs

Superseded in trusty-proposed on 2013-11-24
rakudo (2013.10-1) unstable; urgency=low


  * New upstream release
  * Bump versioned nqp and parrot (Build-)Depends
  * Fix vcs-field-not-canonical
  * Do not Depends on parrot-devel anymore

 -- Alessandro Ghedini <email address hidden>  Fri, 01 Nov 2013 16:27:49 +0100
Superseded in trusty-release on 2013-12-31
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed on 2015-04-28 (Reason: moved to release)
rakudo (2013.03-1) unstable; urgency=low


  * New upstream release
  * Bump versioned (Build-)Depends on parrot and nqp

 -- Alessandro Ghedini <email address hidden>  Thu, 04 Apr 2013 17:53:29 +0200
Superseded in saucy-release on 2013-04-29
Obsolete in raring-release on 2015-04-24
Deleted in raring-proposed on 2015-04-27 (Reason: moved to release)
rakudo (2012.10-1build1) raring; urgency=low

  * Rebuild with the current version of the Not Quite Perl compiler.
 -- Adam Conrad <email address hidden>   Thu, 29 Nov 2012 01:00:04 -0700
Superseded in raring-proposed on 2012-11-29
rakudo (2012.10-1) unstable; urgency=low


  * New upstream release
  * Bump parrot and nqp required versions
  * Bump Standards-Version to 3.9.4 (no changes needed)

 -- Alessandro Ghedini <email address hidden>  Sun, 28 Oct 2012 13:22:43 +0100
Superseded in raring-release on 2012-11-29
Obsolete in quantal-release on 2015-04-24
rakudo (0.1~2012.04.1-2build1) quantal; urgency=low

  * No-change rebuild to update dependency on nqp.
 -- Ilya Barygin <email address hidden>   Sun, 23 Sep 2012 12:20:55 +0400
Superseded in quantal-release on 2012-09-23
rakudo (0.1~2012.04.1-2) unstable; urgency=low


  * Dynamically generate versioned depends on nqp during build
    to fix 'Missing or wrong version of dependency ...' errors
  * Remove not needed source/options file

 -- Alessandro Ghedini <email address hidden>  Tue, 12 Jun 2012 15:20:12 +0200
Superseded in quantal-release on 2012-06-13
rakudo (0.1~2012.04.1-1) unstable; urgency=low


  * New upstream release
  * Bump required nqp and parrot version
  * Explicitly set nqp path during configure
  * Re-word long description
  * Use dh_parrot debhelper plugin

 -- Alessandro Ghedini <email address hidden>  Fri, 08 Jun 2012 15:50:16 +0200

Available diffs

Superseded in quantal-release on 2012-06-12
rakudo (0.1~2012.01-1) unstable; urgency=low


  * New upstream release
  * Depends on versioned parrot too (Closes: #653240)
  * Bump debhelper compat level to 9
  * Update debian/copyright format as in Debian Policy 3.9.3
  * Bump Standards-Version to 3.9.3
  * Update upstream copyright years
  * (Build) depend on nqp too, update parrot version
  * Build depend on libicu-dev (Closes: #669499)
  * Email change: Alessandro Ghedini -> <email address hidden>
  * Manually depend on parrotapi-X.Y.Z

 -- Alessandro Ghedini <email address hidden>  Tue, 24 Apr 2012 17:04:08 +0200
Superseded in quantal-release on 2012-05-10
Published in precise-release on 2011-12-03
rakudo (0.1~2011.07-1build1) precise; urgency=low

  * No-change rebuild to drop spurious libsfgcc1 dependency on armhf.
 -- Adam Conrad <adconrad@0c3.net>   Fri, 02 Dec 2011 21:17:25 -0700
Superseded in precise-release on 2011-12-03
rakudo (0.1~2011.07-1) unstable; urgency=low

  [ Alessandro Ghedini ]
  * New upstream release
  * Bump debhelper compat level to 8
  * Update Dominique's email address
  * Bump (Build-)Depends on parrot to 3.6.0
  * Add Provides: perl6 field

  [ Dominique Dumont ]
  * debian/copyright: reformatted with config-edit
  + debian/source/option: Build process creates a config.status
    file. This option ignores it when checking source changes
  * debian/control:
    + added (Build-)Depends on libparrot3.6.0
    * Slightly changed synopsis
    * reformatted with config-edit

145 of 45 results