please enable daap

Bug #24860 reported by joe on 2005-10-31
28
Affects Status Importance Assigned to Milestone
rhythmbox (Ubuntu)
Wishlist
Sebastien Bacher

Bug Description

This is a unique feature in the new Rhythmbox 0.9.1
So that's what's around in the newspapers and it lacks
in dapper I know avahi and howl are not promotet, but
it would be fine to promote one of these because it's
a must for today's Desktops and to compete with OSX...

joe (joerg-unglaub) wrote :

No real bug but an enhancement.

Sebastien Bacher (seb128) wrote :

Thanks for your bug. If you want to track new changes reading changelog is
usually quite useful. Speaking about this wishlist:

rhythmbox (0.9.1-1ubuntu2) dapper; urgency=low

  * debian/control.in, debian/rules:
    - don't use avahi for now, it's not promoted yet.

 -- Sebastien Bacher <email address hidden> Fri, 28 Oct 2005 12:17:46 -0400

I'm closing is a NOTABUG because this is planned anyway and we don't need to
keep extra bugs for that. Feel free to reopen if you disagree.

joe (joerg-unglaub) wrote :

Thats ok
Just to notice I recompiled latest rhythmbox with daap enabled + avahi
and it worked like a charme

Sebastien Bacher (seb128) wrote :

*** Bug 24932 has been marked as a duplicate of this bug. ***

Joakim (jryden) wrote :

Why was this closed out? 0.9.2 was just pushed out in dapper today and it still
has no DAAP support compiled in... Functionality wise I'd say that DAAP has a
bit more value than say... audio scrobbler, heh.

Sebastien Bacher (seb128) wrote :

there is a comment explaning why it's closed. Avahi need to be promoted first

James "Doc" Livingston (jrl) wrote :

As an additional note: DAAP support is still marked as an "experimental" feature
in Rhythmbox, because there are a few nasty issues that can occur (although it
mostly works). In particular, you will want to ensure libsoup has the patch from
http://bugzilla.gnome.org/show_bug.cgi?id=319305.

joe (joerg-unglaub) wrote :

(In reply to comment #7)
> http://bugzilla.gnome.org/show_bug.cgi?id=319305.
this seems to be fixed in dapper for now.
recompiled and workes

@ Joakim it no problem to recompile rhythmbox by yourself with daap
  DEB_CONFIGURE_EXTRA_FLAGS += --with-ipod=yes --with-mdns=avahi --enable-daap
  tis line in debian/rules will make you happy

Sebastien Bacher (seb128) wrote :

*** Bug 27329 has been marked as a duplicate of this bug. ***

Celso Pinto (cpinto) wrote :

There are more some packages more unstable than Avahi in the main repository.
Heck, check Rhythmbox. The latest package is somewhat broken
(http://bugzilla.ubuntu.com/show_bug.cgi?id=21242) and the Podcast functionality
also doesn't work.

I've been using avahi since version 0.4.1 came out and most of the stuff is ok
(I think I recall some issues with the laptop coming up from suspend-to-ram and
avahi not detecting the NIC). I think it's more than time that avahi gets moved
to main and let applications take advantage of it.

joe (joerg-unglaub) wrote :

Ok its not a bug but an improvement.

It seems that Avahi is promoted now (the little ubuntu-circle before the packeges).

So please reconsider to enable daap in rhythmbox

thanks ...

Celso Pinto (cpinto) wrote :

The latest rhythmbox depends on gstreamer-0.10 and apparently doesn't support
DAAP sharing.

Sebastien Bacher (seb128) wrote :

(In reply to comment #11)

> It seems that Avahi is promoted now (the little ubuntu-circle before the
packeges).
>
> So please reconsider to enable daap in rhythmbox
>
> thanks ...

We appreciate your enthusiasm on that but sending new comments now and then will
not make it changed faster, we are working on it and will build rhythmbox with
it when possible. rhythmbox has been switched to gstreamer0.10 and the daap
feature hasn't been ported yet as said by a previous comment. Upstream have a
patch to bugzilla beeing worked and that should be fixed soon

Celso Pinto (cpinto) wrote :

I just tried with the latest rhythmbox update and daap is working out of the box. Thanks!

Sebastien Bacher (seb128) wrote :

Nice, closing the bug as fixed

Changed in rhythmbox:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.