Ubuntu

busyspheres screensaver crashes gdm

Reported by Colin Cooper on 2006-10-04
8
Affects Status Importance Assigned to Milestone
rss-glx (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: rss-glx

For some time my system has been crashing mysteriously -- but only overnight or when I leave it alone. I'd come back to find it sitting at the gdm login window. All of my running programs would have stopped.

I believe it is caused by the "busyspheres" screensaver. If I select it in the screensaver preferences, the display crashes. My screensaver was set to random, so this would come up at some point and crash the display.

Display is nVidia GeForce FX 5200, with TwinView, running XGL and Beryl.

I've removed this screensaver for the moment ( and checked that none of the others crash). Conatact me if you need more info - I can replicate the crash at will.

syslog:

Oct 4 09:02:44 localhost kernel: [17256291.864000] NVRM: Xid (0001:00): 1, Channel 00000002 Method 00000000 Data 44a00000
Oct 4 09:02:44 localhost kernel: [17256291.864000] NVRM: Xid (0001:00): 28, L1 -> L0
Oct 4 09:02:44 localhost kernel: [17256291.980000] NVRM: Xid (0001:00): 6, PE0002 0000 2d66c4bb 00000000 2d66c4bb 00ea024c
Oct 4 09:02:44 localhost kernel: [17256291.980000] NVRM: Xid (0001:00): 28, L1 -> L0
Oct 4 09:02:44 localhost kernel: [17256292.124000] NVRM: Xid (0001:00): 6, PE0002 0000 3f800000 00074930 00000000 00ea024c
Oct 4 09:02:44 localhost kernel: [17256292.124000] NVRM: Xid (0001:00): 28, L1 -> L0
Oct 4 09:02:45 localhost kernel: [17256292.436000] NVRM: Xid (0001:00): 6, PE0002 0000 43c0bcf1 000ccc7c 00000000 00ea024c
Oct 4 09:02:45 localhost kernel: [17256292.436000] NVRM: Xid (0001:00): 28, L1 -> L0
Oct 4 09:02:45 localhost kernel: [17256292.516000] NVRM: Xid (0001:00): 6, PE0002 0000 8d961071 00111574 00000000 00ea024c
Oct 4 09:02:45 localhost kernel: [17256292.516000] NVRM: Xid (0001:00): 28, L1 -> L0
Oct 4 09:02:45 localhost kernel: [17256292.544000] NVRM: Xid (0001:00): 6, PE0002 0000 30eaefd6 00111574 00000000 00ea024c
Oct 4 09:02:45 localhost kernel: [17256292.544000] NVRM: Xid (0001:00): 28, L1 -> L0
Oct 4 09:02:45 localhost kernel: [17256292.628000] NVRM: Xid (0001:00): 6, PE0002 0000 8d96108f 00000000 8d96108f 00ea024c
Oct 4 09:02:45 localhost kernel: [17256292.628000] NVRM: Xid (0001:00): 28, L1 -> L0
Oct 4 09:02:45 localhost kernel: [17256292.656000] NVRM: Xid (0001:00): 6, PE0002 0000 30eaefe5 00111574 00000000 00ea024c
Oct 4 09:02:45 localhost kernel: [17256292.656000] NVRM: Xid (0001:00): 28, L1 -> L0
Oct 4 09:02:49 localhost gdm[6904]: Error reinitilizing server

description: updated
description: updated
description: updated
Zingo Andersen (zingo) wrote :
Download full text (3.8 KiB)

I see the similar output from Planeshift on Edgy AMD64 X2
My Planeshift do not crash is just freezes up the whole computer for long periods.

Warning: Keep in mind that the both my Planeshift and the Nvidia driver below is not part of Edgy so I just post this to maybe give more clues the puzzle. Ill see if I can downgrade nvidia driver and get the problem in ppracer.

I tried to fix it by switching to later NVidia driver from http://albertomilone.com/driver.html
But I still have the same problem but the output below is NOT from the stock Edgy drivers

I got the same problem from PPracer also, but it don't start now since my driver upgrade
Ill try to downgrade NVidia drivers and see if I can compare the output. PPracer and Planeshift is the only 3d stuff I execute (well glxgears also :) And I just tried so this might have been broken in my setup for a long time.

---------------- uname -a

Linux dual 2.6.17-10-generic #2 SMP Fri Oct 13 15:34:39 UTC 2006 x86_64 GNU/Linux

--------------- glxgears -info (Driver and GFX Card part)

GL_RENDERER = GeForce 7600 GS/PCI/SSE2
GL_VERSION = 2.1.0 NVIDIA 96.29

----------------dmesg (after a planeshift run)

[80029.615236] NVRM: Xid (0005:00): 8, Channel 00000002
[80029.615782] NVRM: Xid (0005:00): 29, L1 -> L0
[80041.610574] NVRM: Xid (0005:00): 8, Channel 00000002
[80041.611114] NVRM: Xid (0005:00): 29, L1 -> L0
[80090.323869] BUG: soft lockup detected on CPU#0!
[80090.323875]
[80090.323876] Call Trace: <IRQ> <ffffffff802b5faa>{softlockup_tick+250}
[80090.323905] <ffffffff80299d47>{update_process_times+87} <ffffffff8027d563>{smp_local_timer_interrupt+35}
[80090.323918] <ffffffff8027dcd1>{smp_apic_timer_interrupt+65} <ffffffff8026634e>{apic_timer_interrupt+98}
[80090.323932] <ffffffff882b6467>{:nvidia:_nv002718rm+15} <ffffffff88431455>{:nvidia:_nv005705rm+125}
[80090.324202] <ffffffff884fe101>{:nvidia:_nv001077rm+25} <ffffffff884fcaa0>{:nvidia:_nv001095rm+214}
[80090.324417] <ffffffff884339e0>{:nvidia:_nv006026rm+132} <ffffffff8842adf8>{:nvidia:_nv007709rm+288}
[80090.324662] <ffffffff8842b197>{:nvidia:_nv006668rm+231} <ffffffff88412acc>{:nvidia:_nv006381rm+322}
[80090.324901] <ffffffff884c70ce>{:nvidia:_nv002451rm+0} <ffffffff884fd015>{:nvidia:_nv001071rm+319}
[80090.325117] <ffffffff884c70ce>{:nvidia:_nv002451rm+0} <ffffffff884fd115>{:nvidia:_nv001063rm+175}
[80090.325326] <ffffffff882a3cd3>{:nvidia:_nv002933rm+39} <ffffffff88431455>{:nvidia:_nv005705rm+125}
[80090.325526] <ffffffff884fe220>{:nvidia:_nv001078rm+58} <ffffffff882a3cd3>{:nvidia:_nv002933rm+39}
[80090.325713] <ffffffff88431aa8>{:nvidia:_nv005905rm+38} <ffffffff88498a7a>{:nvidia:_nv003994rm+710}
[80090.325956] <ffffffff8848ed37>{:nvidia:_nv004002rm+139} <ffffffff882b899b>{:nvidia:_nv001993rm+153}
[80090.326157] <ffffffff882bd163>{:nvidia:rm_isr_bh+83} <ffffffff885305c6>{:nvidia:nv_kern_isr_bh+22}
[80090.326332] <ffffffff802958a6>{tasklet_action+102} <ffffffff8021195f>{__do_softirq+95}
[80090.326347] <ffffffff802669aa>{call_softirq+30} <ffffffff802733ec>{do_softirq+44}
[80090.326358] <ffffffff802737e7>{do_IRQ+71} <fffffff...

Read more...

Zingo Andersen (zingo) wrote :

Ok now I have stock nvidia (Edgy) and the problem in PPRacer (Also Edgy)

The problem description is that PPRacer/whole machine freezes in the "race" while much 3d gfx
is used. It seems to have to do with the nvidia driver using 3d stuff...

Here is some info from my machine (still AMD64 X2)
-----------------------------------------------
zingo@dual:~$ glxgears -info
GL_RENDERER = GeForce 7600 GS/PCI/SSE2
GL_VERSION = 2.0.2 NVIDIA 87.76
...
-----------------------------------------------
zingo@dual:~$ dmesg
[ 0.000000] Bootdata ok (command line is root=/dev/mapper/harddisk-root ro quiet splash)
[ 0.000000] Linux version 2.6.17-10-generic (root@crested) (gcc version 4.1.2 20060928 (prerelease) (Ubuntu 4.1.1-13ubuntu5)) #2 SMP Fri Oct 13 15:34:39 UTC 2006 (Ubuntu 2.6.17-10.33-generic)
...
[ 296.060742] NVRM: Xid (0005:00): 8, Channel 00000002
[ 296.061305] NVRM: Xid (0005:00): 28, L1 -> L0
[ 308.056388] NVRM: Xid (0005:00): 8, Channel 00000002
[ 308.056950] NVRM: Xid (0005:00): 28, L1 -> L0
[ 320.052036] NVRM: Xid (0005:00): 8, Channel 00000002
[ 320.052600] NVRM: Xid (0005:00): 28, L1 -> L0
[ 332.055680] NVRM: Xid (0005:00): 8, Channel 00000002
[ 332.056246] NVRM: Xid (0005:00): 28, L1 -> L0
-----------------------------------------------
planeshift (not from ubuntu) Adds this to dmesg

[ 623.965073] NVRM: Xid (0005:00): 8, Channel 00000002
[ 623.965643] NVRM: Xid (0005:00): 28, L1 -> L0
[ 648.959895] NVRM: Xid (0005:00): 8, Channel 00000002
[ 648.960463] NVRM: Xid (0005:00): 28, L1 -> L0
-----------------------------------------------
Tuxcart (some carting racer I found)

[ 1004.853456] NVRM: Xid (0005:00): 8, Channel 00000002
[ 1004.854019] NVRM: Xid (0005:00): 28, L1 -> L0

Zingo Andersen (zingo) wrote :

Hello
I reported the new driver (GL_VERSION = 2.1.0 NVIDIA 96.29)
on nvnews here is the reference:

http://www.nvnews.net/vbulletin/showthread.php?t=80310

Zingo Andersen (zingo) wrote :

My Problem dissapeard after I upgraded my BIOS and resetted the settings, in the process I also upgraded to latest Nvidia Beta 9742. My problem in planeshift seems gone after an hour and a half of gameplay (my old problem appared after a few sec/minutes.

My progress can be viewed at
http://www.nvnews.net/vbulletin/showthread.php?t=80310

Since I don't have the first error I can't say much about that problem.

Daniel T Chen (crimsun) wrote :

Likely, we need to open a task on nvidia-glx-* in 8.10, too. Is this symptom still reproducible there?

Changed in rss-glx:
status: New → Incomplete
Daniel T Chen (crimsun) on 2008-09-18
Changed in rss-glx:
importance: Undecided → Medium
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to New. Thanks again!.

Changed in rss-glx:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers