Change log for ruby-bunny package in Ubuntu

19 of 9 results
Published in hirsute-release on 2020-10-23
Published in groovy-release on 2020-08-24
Deleted in groovy-proposed (Reason: moved to Release)
ruby-bunny (2.14.4-4) unstable; urgency=medium

  * Team upload.

  [ Lucas Kanashiro ]
  * d/ruby-tests.rake: add a reminder to revisit the blacklisted spec file
  * d/control: update the Homepage url, the former does not work

  [ Sergio Durigan Junior ]
  * Adjust test infrastructure to use a customized rabbitmq-server.
    In order to perform our tests, we have to install the rabbitmq-server
    package.  This means that when we build the package outside a chroot,
    the systemd service of rabbitmq-server is started automatically.  This
    is expected behaviour, but it conflicts with what the setup step of
    our tests does: it tries to start its own instance of rabbitmq-server
    using a customized configuration file.
    In order to overcome this problem, it is possible to start another
    instance of rabbitmq-server listening at a different port.  This is
    what this commit does, which ultimately fixes a FTBFS that happens
    when building ruby-bunny outside a chroot.  Unfortunately, the
    solution here is a bit hacky and prone to failures, but it works
    reasonably well enough that I think it's safe to adopt it into
    package.
    - d/ruby-tests.rake: Use Socket.gethostname to compose the pidfile
      name.
    - d/rules: On override_dh_auto_install, adjust the local rabbitmq.conf
      file and instruct it to listen on localhost:16688; adjust several
      environment variables needed to properly start rabbitmq-server and
      ruby-bunny at the customized port; adjust the tests inside spec/ and
      make sure they explicitly connect to the rabbitmq-server instance
      running on the customized port. (Closes: #968420) (LP: #1891842)

 -- Sergio Durigan Junior <email address hidden>  Thu, 20 Aug 2020 10:55:09 -0400

Available diffs

Superseded in groovy-release on 2020-08-24
Published in focal-release on 2020-04-15
Deleted in focal-proposed (Reason: moved to Release)
ruby-bunny (2.14.4-3) unstable; urgency=medium

  * Team upload
  * d/ruby-tests.rake: skip a test consistently failing in s390x
  * d/control: use secure url in Homepage field

 -- Lucas Kanashiro <email address hidden>  Wed, 15 Apr 2020 10:04:15 -0300

Available diffs

Superseded in focal-proposed on 2020-04-15
ruby-bunny (2.14.4-2) unstable; urgency=medium

  * Team upload
  * debian/ruby-tests.rake: backport to work on ruby2.5
  * debian/ruby-tests.rake: skip tests that consistently fail under ruby2.5

 -- Antonio Terceiro <email address hidden>  Sat, 28 Mar 2020 06:48:32 -0300

Available diffs

Superseded in focal-release on 2020-04-15
Deleted in focal-proposed on 2020-04-17 (Reason: moved to Release)
ruby-bunny (2.9.2-2) unstable; urgency=medium

  * Team upload

  [ Utkarsh Gupta ]
  * Add salsa-ci.yml

  [ Antonio Terceiro ]
  * autopkgtest: replace default Ruby tests with smoke test (Closes: #901552)
  * Bump Standards-Version to 4.4.0; no changes needed otherwise

 -- Antonio Terceiro <email address hidden>  Wed, 28 Aug 2019 20:11:10 -0300

Available diffs

Superseded in focal-release on 2019-10-27
Published in eoan-release on 2019-04-18
Obsolete in disco-release on 2020-07-14
Obsolete in cosmic-release on 2020-07-13
Deleted in cosmic-proposed (Reason: moved to release)
ruby-bunny (2.9.2-1) unstable; urgency=medium

  * Team upload.
  * New upstream version 2.9.2
  * Update years of upstream copyright
  * Update Debian packaging copyright
  * Declare compliance with Debian Policy 4.1.4
  * Depends on ruby-amq-protocol >= 2.2.0
  * Bump debhelper compatibility level to 11
  * debian/copyright: use https:// in Format and Source fields
  * Update VCS urls to point to salsa
  * debian/control: use https:// in Homepage field
  * Refresh patch
  * debian/watch: use https:// instead of http://

 -- Lucas Kanashiro <email address hidden>  Fri, 27 Apr 2018 14:11:38 -0300

Available diffs

Superseded in cosmic-release on 2018-05-06
Published in bionic-release on 2017-10-24
Obsolete in artful-release on 2020-07-10
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed (Reason: moved to release)
ruby-bunny (2.6.1-2) unstable; urgency=medium

  * debian/ruby-tests.rake: wait for rabbitmq-server to be online before
    starting the tests (Closes: #847741)

 -- Antonio Terceiro <email address hidden>  Sun, 11 Dec 2016 14:10:15 -0200

Available diffs

Superseded in zesty-release on 2016-12-12
Deleted in zesty-proposed on 2016-12-13 (Reason: moved to release)
ruby-bunny (2.6.1-1) unstable; urgency=medium

  * Team upload

  [ Cédric Boutillier ]
  * Bump debhelper compatibility level to 9
  * Remove version in the gem2deb build-dependency
  * Use https:// in Vcs-* fields

  [ Antonio Terceiro ]
  * New upstream version 2.6.1
  * update packaging with `dh-make-ruby -w`
  * 0001-spec_helper-remove-some-unecessary-or-unavailable-re.patch: remove
    some unecessary or unavailable requirements from the test suite.
  * Run tests during the build. rabbitmq-server is necessary for that.

 -- Antonio Terceiro <email address hidden>  Sat, 10 Dec 2016 13:01:44 -0200

Available diffs

Superseded in zesty-release on 2016-12-11
Obsolete in yakkety-release on 2018-01-23
Published in xenial-release on 2015-10-22
Obsolete in wily-release on 2018-01-22
Obsolete in vivid-release on 2018-01-18
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed (Reason: moved to release)
ruby-bunny (1.1.2-1) unstable; urgency=low


  * Team upload.

  [ Cédric Boutillier ]
  * use canonical URI in Vcs-* fields
  * debian/copyright: use copyright-format/1.0 official URL for Format field

  [ Jonas Genannt ]
  * Imported Upstream version 1.1.2
  * d/control:
    - removed transitional packages (Closes: #735695)
    - bumped standards version to 3.9.5 (no changes needed)
    - added ruby-amq-protocol as depend, 1.9.2-1~
    - wrap-sort
  * d/rules: remove unneeded bin from package
  * install README.md
  * d/ruby-tests.rb: added basic testing
  * d/copyright:
    - updated copyright to format 1.0
    - added myself
    - updated years of copyright

 -- Jonas Genannt <email address hidden>  Fri, 14 Feb 2014 18:14:06 +0100

Available diffs

Superseded in utopic-release on 2014-04-27
Published in trusty-release on 2013-10-18
Obsolete in saucy-release on 2015-04-24
Obsolete in raring-release on 2015-04-24
Obsolete in quantal-release on 2015-04-24
ruby-bunny (0.7.8-1) unstable; urgency=low


  * migrated to gem2deb helper (Closes: #655831)
  * close wrongly filed ITPs (Closes: #624612)
  * new upstream release
  * tests are disabled because it needs network

 -- Praveen Arimbrathodiyil <email address hidden>  Sat, 14 Jan 2012 13:06:29 +0530
19 of 9 results